Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 10/10/2010, à 20:28

SpiKe

VLC saccade en vidéo avec Maverick 10.10

Bonjour,

Ma migration (avec une clean install) vers Ubuntu 10.10 en 64 bits s'est très bien passée... mis à part le cas de VLC.
En lecture de fichiers audio, aucun problème... par contre pour lire un fichier .avi ou un DVD, c'est l'horreur... L'image est très saccadée, ça n'est pas regardable. J'ai installé le pilote proposé par Ubuntu, fglrx, pour la carte graphique ATI.

Cependant, aucun problème pour les jeux vidéo, et GNOME Mplayer lit bien les .avi (tout comme Totem), mais au lancement d'une vidéo en .avi, voici ce que m'affriche Mplayer comme message d'erreur (cela ne l'empêche pas de lire la vidéo) :

"Échec à l'ouverture de VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory"

J'ai bien une carte ATI, pas nVidia... donc je ne comprends pas ce message.

Quelqu'un d'autre est-il concerné ?
Quelqu'un aurait-il une solution ?

Merci !


Intel Core i5 3570 (3,4 Ghz) - nVidia GTX 650 (2 Go) - RAM DDR3 (16 Go) - HDD WD Caviar Black (1 To) - Xubuntu 12.04 LTS
www.xonotic.org --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#2 Le 11/10/2010, à 12:39

James-Marshall-Hendrix

Re : VLC saccade en vidéo avec Maverick 10.10

Explication du message au sujet de nvidia :
http://doc.ubuntu-fr.org/smplayer_mplay … idia_vdpau

Hors ligne

#3 Le 11/10/2010, à 19:27

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour !
Même problème pour moi, certaines vidéos sont très saccadées...
J'explique ma config :
- Installation "propre" (pas de dist-update) de Maverick 64bits.
- Les codecs sont correctement installés (dont le libvdpau1 proposé dans le lien).
- Tentatives de lecture avec vlc, gnome-mplayer, smplayer, le lecteur par défaut.
- Tentatives avec ou sans effets de bureau.
- Tentatives avec ou sans installation du driver propriétaire Nvidia.

Et dans tous les cas mon fichier saccade. C'est un film que j'ai vu sans aucun problème avec le même ordi sous Mint 9 64bits (Linux Mint est basée sur Ubuntu) la semaine dernière ! Je vais repasser à Mint ce soir je pense. Bonne soirée !

Hors ligne

#4 Le 11/10/2010, à 19:41

SpiKe

Re : VLC saccade en vidéo avec Maverick 10.10

Ton problème concerne donc tous les lecteurs vidéo ?
Dans mon cas seul VLC saccade, et MPlayer m'affiche cet étrange message à propos de libvdpau1... Totem marche parfaitement en revanche.

Par contre, comme toi, le problème ne s'arrange pas en désactivant les effets de bureau.

En désinstallant le pilote fglrx, j'ai pu lire correctement une vidéo avec vlc... mais j'ai besoin du pilote proprio pour des jeux 3D et pour la gestion de la ventilation... (j'ai aussi appris que le pilote fglrx était en fait le pilote ATI Catalyst 10.10 bêta, et qui dit bêta dit version pas encore stable a priori).
Je vais donc attendre des mises à jour.


Intel Core i5 3570 (3,4 Ghz) - nVidia GTX 650 (2 Go) - RAM DDR3 (16 Go) - HDD WD Caviar Black (1 To) - Xubuntu 12.04 LTS
www.xonotic.org --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#5 Le 11/10/2010, à 21:34

Philetjosie

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour,
je rencontre le même problème, mes divx saccadent avec tous les lecteurs, et MPlayer me donne le même message d'erreur que Jedediah. Pourtant, je suis sur un Dell Inspiron Portable, avec une carte vidéo Intel intégrée. Donc pas d'ATI ni de Nvidia. J'ai fait une installation propre de 10.10, en reformatant tout, et la semaine dernière, sous Lucid Lynx, les vidéos étaient lues sans problème aucun (donc ce n'est pas un problème matériel).
Je n'ai pas mis Compiz, j'ai essayé toutes les méthodes d'affichage vidéo de VLC, mais rien n'y fait. Je me demande si le problème ne vient pas du décodage de la bande son (décodeur MP3) car j'ai remarqué qu'il y avait aussi des petites saccades quand j'écoute des radios internet encodées en mp3. Est-ce que ce serait une piste ? Savez vous si le décodeur mp3 a été modifié (j'ai coché lors de l'installation pour l'avoir installé automatiquement).
Merci pour toute aide.

Hors ligne

#6 Le 12/10/2010, à 17:14

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

@Philetjosie : intéressant comme remarque, et peut-être qu'on peut trouver plus d'infos en cherchant du côté du son plutôt que de la vidéo. Ou sinon on peut, comme moi, revenir sur Mint 9 (ou Lucid Lynx) en attendant passivement une mise à jour wink

Hors ligne

#7 Le 13/10/2010, à 18:58

Philetjosie

Re : VLC saccade en vidéo avec Maverick 10.10

Il y a peut être une solution sur le forum anglais ici: http://ubuntuforums.org/showpost.php?p= … stcount=29
Chez moi ça à l'air d'améliorer un peu les choses, mais ne résoud pas le problème complètement. En tout cas, ça semble confirmer que c'est lié à un problème de son, pas de vidéo...

Hors ligne

#8 Le 13/10/2010, à 22:17

obidouillekenoby

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour,
j'ai exactement le même problème depuis que je suis en ubuntu 10.10.
Mais pour moi ça le fait ou bout d'un moment et une fois que ça saccade mon ubuntu est un peu dans les choux (oh ça rime)
Les effets compiz rame, je veux taper une commande dans un terminal ça rame aussi.....

Je pense aussi que ça viens du greffon mp3 car quand j'écoute des mp3 avec audacious, ça me fait la même chose......
Bien embêtant!! sad

Hors ligne

#9 Le 13/10/2010, à 23:45

eddydg

Re : VLC saccade en vidéo avec Maverick 10.10

Ayant moi aussi le son saccadé avec VLC et une soudaine accélération suivie de saccades avec Totem je suis tombé ici. Puis j'ai remarqué l'icône rouge de redémarrage pour compléter une mise à jour.
Je redémarre donc et... Tadaa ! Les vidéos sont lues normalement smile

Dernière modification par eddydg (Le 13/10/2010, à 23:45)

Hors ligne

#10 Le 14/10/2010, à 10:46

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

Ah si le problème était résolu ce serait honorable : sortie officielle le dimanche, correction le mercredi.

Hors ligne

#11 Le 17/10/2010, à 22:34

krisofe

Re : VLC saccade en vidéo avec Maverick 10.10

Contournement en attendant un nouveau VLC même si celui-là avait l'option d'utiliser le hardware pour décompresser la vidéo.
Pour moi ça fonctionne parfaitement avec en sortie son SPDIF pour envoyer les flux
DTS AC3 à l'ampli.
Smplayer fonctionne à merveille pour peu de forcer le SPDIF en désactivant toutes les options softs dans les préférences audio et d'utiliser la sortie alsa spécifique au device digital.

Hors ligne

#12 Le 21/10/2010, à 02:43

Merle

Re : VLC saccade en vidéo avec Maverick 10.10

J'ai le même problème avec Gnome-mplayer, vlc et Totem fonctionnent parfaitement ... et je n'ai aucun problème de saccade.


Logithéque d'applications web très complète : Waah.info

Hors ligne

#13 Le 24/10/2010, à 20:17

VinyMusic

Re : VLC saccade en vidéo avec Maverick 10.10

Tout simplement bluffant ! Mon pb venait effectivement d'un mauvais décodage du son... Je me suis compliqué la vie en cherchant à installer tous les pilotes graphiques possibles pour mon chipset vidéo GMA 4500HD... et c'était le décodage du son !!! Merci Philetjosie pour cette subtile solution !
http://ubuntuforums.org/showpost.php?p= … stcount=29


- Linux Mint 13 "Maya", Intel E5200, 2048 Go, ATI radeon X300, Soundblaster xtrem audio
- Ubuntu 12.04 "Precise", PC by surcourf (CLEVO) 13,3'', SU2300, 2048 Go, GMA 4500HD

Hors ligne

#14 Le 25/10/2010, à 11:24

Apollonox

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour,

Je suis exactement dans le même cas de figure avec une lecture vidéo qui saccade quel que soit le lecteur utilisé. Cependant j'ai remarqué que si on maintient la souris en mouvement pendant la lecture, la vidéo reste fluide. Bien sûr ce n'est absolument pas satisfaisant comme rustine mais ça peut orienter sur la solution, on sait jamais...

Hors ligne

#15 Le 27/10/2010, à 14:24

Franpoule

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour à vous,

Je me permets de remonter le poste car VinyMusic, ton lien est mort... La solution était pourtant à portée de clic mad

(j'ai moi aussi le même problème de saccades avec VLC et Gnome MPlayer en lecture de fichiers .avi et en 720p et 1080p c'est tout simplement infâme)

Dernière modification par Franpoule (Le 27/10/2010, à 14:26)

Hors ligne

#16 Le 27/10/2010, à 18:28

VinyMusic

Re : VLC saccade en vidéo avec Maverick 10.10

http://ubuntuforums.org/showpost.php?p= … stcount=29
C'était en fait le lien proposé un peu plus haut ;-))


- Linux Mint 13 "Maya", Intel E5200, 2048 Go, ATI radeon X300, Soundblaster xtrem audio
- Ubuntu 12.04 "Precise", PC by surcourf (CLEVO) 13,3'', SU2300, 2048 Go, GMA 4500HD

Hors ligne

#17 Le 27/10/2010, à 18:55

Franpoule

Re : VLC saccade en vidéo avec Maverick 10.10

J'avais bien compris mais je n'arrive pas à accéder à ton lien, il doit être mort.

Est-ce que c'est cette solution dont il s'agit ?
http://ubuntuforums.org/showthread.php? … hlight=VLC

Hors ligne

#18 Le 30/10/2010, à 11:46

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

Touours le même problème de mon côté. Les mises à jour n'y ont rien changé.
Ce genre de problème est très décevant :
1 - La plupart des gens lisent des vidéos et écoutent de la musique avec leur ordinateur, c'est un des usages principaux du particulier. Pour une distribution "grand public", ne pas avoir ces fonctions dès l'installation, et être obligé de creuser et bricoler pour les avoir c'est plus que gênant : c'est un motif d'abandon.
2 - En ce qui concerne ma machine, le problème n'a jamais existé, j'y ai installé Ubuntu depuis la 8.10 et les médias y étaient lus correctement (excepté un problème de "tearing" à cause de Compiz+Nvidia, qui subsiste encore d'ailleurs).

Pour l'instant je reste en Mint 9 car Mint 10 RC a elle-aussi ce problème (rien d'étonnant car elle est basée sur Maverick).

Hors ligne

#19 Le 30/10/2010, à 12:13

shakipu

Re : VLC saccade en vidéo avec Maverick 10.10

J'avais le même message avec gnome-mplayer. Je l'ai résolu en allant dans les préférences et en mettant "x11" pour sortie vidéo. J'ai pas essayé avec les autres mais au moins j'ai plus le message.


Nous sommes tous des pécheurs face à l'Ethernet...

Hors ligne

#20 Le 30/10/2010, à 12:58

Nebula

Re : VLC saccade en vidéo avec Maverick 10.10

Bonjour,

J'avais le même problème avec VLC: saccade du son, saccade dans les vidéos.
En essayant la solution de Philetjosie, c'est à dire (traduction très rapide):

Editer le fichier /etc/pulse/default.pa:

sudo gedit /etc/pulse/default.pa

Dans ce fichier, recherchez la ligne suivante:

load-module module-udev-detect

Et ajoutez: 'tsched=0' à la fin de la ligne.
Ce qui devrait donner:

load-module module-udev-detect tsched=0

Sauvegarder le fichier et redémarrer.

Cette manipulation n'a pas fonctionner.

J'ai résolut le problème en mettant à jour Ubuntu:

sudo apt-get update && sudo apt-get dist-upgrade

Amicalement,
Nebula

Hors ligne

#21 Le 30/10/2010, à 20:43

VinyMusic

Re : VLC saccade en vidéo avec Maverick 10.10

Tout comme pareil sauf que au lieu d'essayer vainement de copier/coller un lien qui ne marche pas, Nebula a repris chaque point en traduisant en plus, chapeau.
En tous cas, après cette manip', ça fonctionne parfaitement chez moi.
PS : d'accord avec EK1, ça fait désordre ce genre de bug pour une distribution qui se veut "grand public"


- Linux Mint 13 "Maya", Intel E5200, 2048 Go, ATI radeon X300, Soundblaster xtrem audio
- Ubuntu 12.04 "Precise", PC by surcourf (CLEVO) 13,3'', SU2300, 2048 Go, GMA 4500HD

Hors ligne

#22 Le 06/11/2010, à 00:19

krisofe

Re : VLC saccade en vidéo avec Maverick 10.10

Bonsoir,

Comme pour Google Earth, VLC ne saccade absolument plus avec un son AC3 ou DTS parfait tout simplement en désactivant compiz.

- Créer un fichier stop-compiz contenant le script ci-dessous dans le répertoire /home/votreutilisateur :

#!/bin/bash
if [ "`ps -ef |grep 'compiz' |grep -v grep`" != "" ]; then
metacity --replace&
#killall cairo-dock
$@
#décommentez la ligne suivante si compiz se relance avant le début du jeu.
#zenity --info --text='cliquez moi quand le jeu est fini' 
compiz --replace&
#cairo-dock
else
$@
fi


J'ai repiqué ce script mais je ne sais plus où pour le citer hmm

- Créer un lanceur en tant qu'application et lui mettre en commande :
stop-compiz vlc

Quand vous fermerez vlc, compiz reviendra.


note : la case à cocher pour la prise en charge décodage vidéo par ma carte vidéo ATI HD4500
permet une très grande fluidité dans l'ensemble alors que si elle n'est pas cochée, la saccade revient, dans une moindre mesure.
Cependant, sous ubuntu 10.04, la décompression soft était aussi fluide même si évidemment elle chargeait davantage les CPU.

Dernière modification par krisofe (Le 06/11/2010, à 00:28)

Hors ligne

#23 Le 08/11/2010, à 21:24

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

@krisofe : Merci pour ce script, c'est pratique. J'ai aussi ce problème de Compiz (déchirement horizontal de l'image, surtout quand l'image change beaucoup).
Mais ce problème, qui s'appelle "tearing", n'est rien ou presque à côté du problème de saccade dont nous parlons ici et qui survient (pour ma part) indifféremment avec ou sans Compiz.

Hors ligne

#24 Le 09/11/2010, à 22:16

steve

Re : VLC saccade en vidéo avec Maverick 10.10

Salut,

Je remercie Nebula, ça a résolu mon gros problème de saccade vidéo ! wink


Ubuntu  10.10 sur un Fujitsu Siemens Amilo
Accès Internet par le routeur LiveBox....

Hors ligne

#25 Le 13/11/2010, à 01:01

EK1

Re : VLC saccade en vidéo avec Maverick 10.10

Bonsoir tout le monde.
Après avoir essayé tout un tas de versions de pilotes Nvidia sans succès, je suis arrivé à une solution qui semble fonctionner. Le résultat n'est peut-être pas parfait, mais s'il ne l'est pas il est au moins acceptable :

  1. Utiliser smplayer (paquet du même nom)

  2. Aller dans "Options / Préférences" (Ctrl+P)

  3. Onglet "Vidéo", Pilote de sortie = vdpau

  4. Onglet "Audio", Pilote de sortie = alsa

Chez moi, l'une des deux options sans l'autre n'a pas d'efficacité, ou faible. Mais les deux options ensemble fonctionnent.

Dernière modification par EK1 (Le 13/11/2010, à 01:02)

Hors ligne

Haut de page ↑