Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 06/06/2006, à 10:58

DEoT

[Howto] Sagem fast 800 sous dapper

Je remercie tout ceux qui ont participé à ce tuto. (Cathou, Teofifil et j'en oublie tongue )
Devant le nombre de problème rencontré avec le sagem fast 800 nous avons décidé de faire un tuto


Pour faire marcher votre modem Ueagle APRES UNE INSTALLATION FRAICHE DE DAPPER


J'ai repris les posts de Teofifil et de Cathou entre autres et j'essai que ce soit clair
ATTENTION: si votre modem est un sagem fast 800 E4 (regardez au dos)
alors il ne fonctionnera pas avec ueagle-atm (même avec ce tuto hmm )
mais il reste de l'espoir
regardez ce lien http://forum.eagle-usb.org/viewtopic.php?p=24549&sid=7c5c4c8afc0b1d076f2fea4d792b63ed

(il est conseiller d'imprimer ce tuto avant de vous lancer dans l'aventure)
à télécharger avant sur un pc ayant internet
vous les copierez dans le dossier /home/"nom d'utilisateur"/ueagle-atm/
(il faut donc créer le dossier)
aller à cette adresse et enregistrer les 5 fichiers qui y sont présents http://svn.gna.org/svn/ueagleatm/trunk/ueagle-atm/

télécharger ça aussi
http://eagle-usb.org/ueagle-atm/non-free/ueagle-data-1.1.tar.gz
(il existe une version 1.2 qui ne semble pas marcher http://eagle-usb.org/ueagle-atm/non-free/ueagle-data-1.2-not-working.tar.gz )

POUR TROUVER LES KERNEL HEADERS
En cas de problème de "kernel-headers not found"
allez là http://packages.ubuntulinux.org/dapper/virtual/linux-image-2.6
et télécharger le package correspondant à votre noyau
(pour connaître la version de votre noyau tapez uname -r sous ubuntu dans une console)

aller sur ce lien et copier les valeurs VP et VC de votre FAI
http://faq.eagle-usb.org/wakka.php?wiki=ListConfigADSL

Maintenant sous votre dapper
Mettez le cd de dapper dans le lecteur!! (note les headers doivent être sur le cd sinon c'est une mise à jour voir post suivant) et soyez sur qu'il est monté
Les lignes de commande sont à taper en console

sudo apt-get install build-essential linux-headers-`uname -r`
sudo modprobe -r eagle-usb
sudo killall pppd
sudo modprobe -r pppoatm

(note vous pouvez accéder au caractère "`" avec la combinaison de touche Alt Gr+ "7")

sudo rm /lib/modules/`uname -r`/kernel/drivers/usb/atm/usbatm.ko
sudo rm /lib/modules/`uname -r`/kernel/drivers/usb/net/eagle/eagle-usb.ko

débrancher (attendre 5 secondes)  et rebrancher le modem

puis

cd ~/ueagle-atm
make
sudo make install
cd ~/ueagle-atm
tar xzf ueagle-data-1.1.tar.gz
cd ueagle-data-1.1
sudo mkdir /lib/firmware/ueagle-atm
sudo cp -a * /lib/firmware/ueagle-atm
sudo modprobe ueagle-atm

Chez free on s'arrête ici (voir post #3 de ce sujet)

sudo gedit /etc/ppp/peers/ueagle-atm

écrivez ceci dans le fichier

user "myusername"
plugin pppoatm.so VP.VC
noipdefault
usepeerdns
defaultroute
persist
noauth

!!!!Attention vous devez remplacer myusername par votre identifiant (laissez les guillemets)
et VP et VC par les valeurs de votre fai
De même attention si votre fai n'utilise pas pppoa mais pppoe les infos sont différentes!!
regarder ici
http://atm.eagle-usb.org/wakka.php?wiki=UeagleAtmDoc
par exemple moi c'est tiscali france -> 8.35

puis (c'est presque fini)

sudo gedit /etc/ppp/chap-secrets

mettez dans ce fichier

"myusername"  "*"  "mypassword"  "*"

pareil laissez bien les guillemets et remplacez myusername par votre identifiant
et mypassword par votre mot de passe

sudo modprobe pppoatm
sudo pppd call ueagle-atm
ifconfig

vous devez avoir

pppX      Lien encap:Protocole Point-à-Point
          inet adr:XX.XXX.XXX.XXX  P-t-P:XXX.XXX.X.XX  Masque:XXX.XXX.XXX.XXX
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:XXXX  Metric:X
          Packets reçus:XXXX erreurs:0 :0 overruns:0 frame:0
          TX packets:XXXX errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:X
          Octets reçus:XXXXXX (X.X MiB) Octets transmis:XXXXXX (XXX.X KiB)

SI VOUS NAVEZ PAS CECI REDEMARREZ ET REPRENEZ A L'ETAPE #####
(ici quoi tongue)
##### UNIQUEMENT POUR CEUX QUI ONT DU REDEMARRER

sudo modprobe ueagle-atm
sudo modprobe pppoatm
sudo pppd call ueagle-atm

vous devriez avoir pppX ..... en tapant ifconfig dans une console #####

Reprise pour tous le monde wink


Lancer la connexion au démarrage

sudo gedit /usr/bin/depart_adsl

mettez ceci dans le fichier

#!/bin/bash
pppd call ueagle-atm

Par prudence on fait

sudo gedit /etc/modprobe.d/blacklist

et on rajoute

# interdire le chargement du module eagle-usb
blacklist eagle-usb

(Merci Cathou)
puis enfin

sudo gedit /etc/modules

rajouter pppoatm dans le fichier
moi j'ai dans ce fichier

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
psmouse
pppoatm

puis

sudo chmod +x /usr/bin/depart_adsl

rajouter le fichier /usr/bin/depart_adsl à votre liste de démarrage (sous gnome système préférence/session/programmes au démarrage sous kde créer un script dans  ~/.kde/autostart
de la forme

#!/bin/bash
/usr/bin/depart_adsl

EDIT MISE A JOUR DU 12/11/2006

Dernière modification par DEoT (Le 12/11/2006, à 20:52)


"Les jeux vidéos n'affectent pas les enfants : je veux dire si Pac-Man nous avait influencé étant enfant, nous devrions tous courrir en rond dans des pièces sombres, en gobant des pillules magiques tout en écoutant de la musique répétitive."

Hors ligne

#2 Le 06/06/2006, à 10:59

DEoT

Re : [Howto] Sagem fast 800 sous dapper

Pour faire marcher votre modem avec ueagle APRES UNE MISE A JOUR DE NOYAU

bon puisqu'il y a eu une mise à jour de noyau je reposte la marche à suivre après les mises à jour de noyau
Les lignes de commande sont à taper en console

sudo apt-get update
sudo apt-get upgrade

on suppose qu'il y a eu une mise à jour du noyau

Donc là vous avez internet
(recupération de la derniere version de ueagle, si la version 1.3 a marché la première fois , reprenez la version 1.3 (moi elle ne marchait pas mais le svn oui, donc selon votre cas))
et n'oubliez de déplacer le dossier /home/"nom d'utilisateur"/ueagle-atm POUR NE PAS interférer avec la mise à jour.

sudo apt-get install subversion build-essential linux-headers-(nouvelle version du noyau)
cd ~
svn co svn://svn.gna.org/svn/ueagleatm/trunk/ueagle-atm ueagle-atm

(vous êtes encore sous votre ancien noyau et vous devez telechargement les nouveaux HEADERS)

redémarrage avec le nouveau noyau

(suppression des ancien modules et de ceux du nouveau kernel)

sudo modprobe -r eagle-usb
sudo modprobe -r ueagle-atm      #inutile normallement
sudo killall pppd
sudo modprobe -r pppoatm
sudo rm /lib/modules/`uname -r`/kernel/drivers/usb/atm/usbatm.ko
sudo rm /lib/modules/`uname -r`/kernel/drivers/usb/net/eagle/eagle-usb.ko

(installation des nouveaux modules)

cd ~/ueagle-atm
make
sudo make install
sudo modprobe ueagle-atm
dmesg|grep ueagle 
sudo modprobe pppoatm
sudo pppd call ueagle-atm

(là on a à nouveau internet normallement)

ifconfig

on obtient normallement quelque chose du genre
(Il se peut que vous ayez à redémarrer pour que cela marche)

pppX      Lien encap:Protocole Point-à-Point
          inet adr:XX.XXX.XXX.XXX  P-t-P:XXX.XXX.X.XX  Masque:XXX.XXX.XXX.XXX
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:XXXX  Metric:X
          Packets reçus:XXXX erreurs:0 :0 overruns:0 frame:0
          TX packets:XXXX errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:X
          Octets reçus:XXXXXX (X.X MiB) Octets transmis:XXXXXX (XXX.X KiB)

Dernière modification par DEoT (Le 12/11/2006, à 18:35)


"Les jeux vidéos n'affectent pas les enfants : je veux dire si Pac-Man nous avait influencé étant enfant, nous devrions tous courrir en rond dans des pièces sombres, en gobant des pillules magiques tout en écoutant de la musique répétitive."

Hors ligne

#3 Le 06/06/2006, à 10:59

DEoT

Re : [Howto] Sagem fast 800 sous dapper

nouveau lien pour les free dégroupés!!


http://forum.ubuntu-fr.org/viewtopic.php?id=43971

Dernière modification par DEoT (Le 15/11/2006, à 14:17)


"Les jeux vidéos n'affectent pas les enfants : je veux dire si Pac-Man nous avait influencé étant enfant, nous devrions tous courrir en rond dans des pièces sombres, en gobant des pillules magiques tout en écoutant de la musique répétitive."

Hors ligne

#4 Le 06/06/2006, à 23:12

gene69

Re : [Howto] Sagem fast 800 sous dapper

migration de Breezy à Dapper, si breezy ok mais modem ne s'initialise pas.

mon fix à moi...

debrancher / rebrancher le modem (sinon ça marche pas sad )

~$ sudo startadsl
Password:

Le modem n'est pas opérationnel!
Vérifiez la sortie de eaglestat pour connaître son état!

Pour une connection Wanadoo moyen haut debit
~$ sudo eaglestat
eagle-usb status display
-------------------------------------------------------------
Driver version 2.3.2     Chipset: Eagle2
Vendor ID : 0x1110     Product ID : 0x9021   Rev: 0x500b
USB Bus : 002    USB Device : 005        Dbg mask: 0x0
Ethernet Interface : <NULL>
MAC: 00:60:4c:3b:e5:6d
Tx Rate           0  Rx Rate           0
FEC               0  Margin            0  Atten             0 dB
VID-CPE           0  VID-CO            0  HEC               0
VPI               0  VCI               0  Delin          GOOD
Cells Tx          0  Cells Rx          0
Pkts Tx           0  Pkts Rx           0
OAM               0  Bad VPI           0  Bad CRC           0
Oversiz.          0

Modem waiting for driver response.
Please send DSP (eaglectrl -d)

~$ eaglectrl -d
CMVs successfully sent to driver.
Options successfully sent to driver.
Using DSP code for POTS line
DSP code successfully loaded.
~$ sudo startadsl
~$

reste à trouver comment automatiser le eaglectrl -d sans se fouler. Mais c'est déjà plus agreable que de faire le reconfigure à chaque fois.
-----------------
EDIT
Quand on éteind alors les diodes restent allumées alors je débranchais le modem.
que je rebranche uniquement lorsque le PC à booté. Je me suis appercu plus tard que cette condition est nécessaire: brancher le modem apres le boot.
ceci n'est qu'une solution provisiore pour télécharger la solution de sus-citée.

Dernière modification par gene69 (Le 30/06/2006, à 21:18)


Quand le berger est lâche, le loup chie de la laine.
A (draft) guide to UFO Alien-Invasion

Hors ligne

#5 Le 08/06/2006, à 18:04

DEoT

Re : [Howto] Sagem fast 800 sous dapper

Encore une fois je déconseille l'utilisation de eagle-usb
qui n'est plus mis à jour, et qui va devenir obsolète


"Les jeux vidéos n'affectent pas les enfants : je veux dire si Pac-Man nous avait influencé étant enfant, nous devrions tous courrir en rond dans des pièces sombres, en gobant des pillules magiques tout en écoutant de la musique répétitive."

Hors ligne

#6 Le 09/06/2006, à 12:46

bernard33

Re : [Howto] Sagem fast 800 sous dapper

salut
je suis chez tiscali non dégroupé noyau 2.6.15-23-686 Sagem fast 800
j'ai suivi ton 'tuto' tout marche super bien !!!
j'ai même un exemple de script
un grand merci à vous tous pour cette aide si précieuse

Hors ligne

#7 Le 09/06/2006, à 14:09

gene69

Re : [Howto] Sagem fast 800 sous dapper

HUMMM

Comment on fait pour régler le MTU à 1492 (de tête)?
parce que si c'est XXXX j'ai peur que ce soit 1500 et 1500 c'est pas optimal vu que ça va générer de la framentation lorsque ça va se faire encapsuler par atm(?) !


Quand le berger est lâche, le loup chie de la laine.
A (draft) guide to UFO Alien-Invasion

Hors ligne

#8 Le 09/06/2006, à 14:50

DEoT

Re : [Howto] Sagem fast 800 sous dapper

gene69 a écrit :

HUMMM

Comment on fait pour régler le MTU à 1492 (de tête)?
parce que si c'est XXXX j'ai peur que ce soit 1500 et 1500 c'est pas optimal vu que ça va générer de la fragmentation lorsque ça va se faire encapsuler par atm(?) !

c'est moi qui ait remplacé par XXXX
je te donne la valeur dans quelques minutes (là je suis pas chez moi)

edit: c'est bien 1500, je vais regarder comment faire ça m'intéresse
je te tiens au courant
(par contre si je trouve ce sera avec ueagle-atm, vu que je suis avec donc peut-être que tu devrais envisager d'y passer wink )

edit2: j'ai pas trouvé dsl, enfin il semble qu'avec 1500 ça fonctionne très bien.

Dernière modification par DEoT (Le 09/06/2006, à 15:13)


"Les jeux vidéos n'affectent pas les enfants : je veux dire si Pac-Man nous avait influencé étant enfant, nous devrions tous courrir en rond dans des pièces sombres, en gobant des pillules magiques tout en écoutant de la musique répétitive."

Hors ligne

#9 Le 09/06/2006, à 21:08

fab56

Re : [Howto] Sagem fast 800 sous dapper

Bonjour, smile
 
Je suis récemment passer de Breezy vers Dapper
http://doc.ubuntu-fr.org/installation/m … ezy_dapper
(Mise à jour en changeant la liste des dépots )
Avant mon modem Sagem USB marchait sans problème avec eagle-usb, donc maintenant je dois passer sous ueagle-atm. neutral
Je suivi tout les étapes du tutoriel, ça marche sans problème
  *  Les diodes sont allumés big_smile
  *  Avec dmesg | $grep ueagle-atm, ça me met Modem Opérationnel big_smile

Mais toujours pas d'internet. sad
J'ai suivi tout les étapes, j'ai mis mes identifiants dans /etc/ppp/peers/ueagle-atm & /etc/ppp/chap-secrets, mais rien y fait.
Après, j'ai fait $ifconfig et là j'ai vu que j'avais eth0 et lo (je crois) mais pas de pppx.

Comment faire pour y remedier.
Merci pour votre réponse.

Hors ligne

#10 Le 10/06/2006, à 09:03

gene69

Re : [Howto] Sagem fast 800 sous dapper

~$ eaglestat
eagle-usb status display
-------------------------------------------------------------
Driver version 2.3.2     Chipset: Eagle2
Vendor ID : 0x1110     Product ID : 0x9021   Rev: 0x500b
USB Bus : 003    USB Device : 003        Dbg mask: 0x0
Ethernet Interface : eth1
MAC: 00:60:4c:3b:e5:6d
Tx Rate         160  Rx Rate         608
FEC               0  Margin           39  Atten            24 dB
VID-CPE           0  VID-CO           28  HEC               0
VPI               8  VCI              35  Delin          GOOD
Cells Tx         44  Cells Rx         17
Pkts Tx          20  Pkts Rx          12
OAM               0  Bad VPI           0  Bad CRC           0
Oversiz.          0

Modem is operational

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:86.194.162.204  P-t-P:193.253.160.3  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          Packets reçus:7 erreurs:0 :0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          Octets reçus:309 (309.0 b) Octets transmis:313 (313.0 b)


Quand le berger est lâche, le loup chie de la laine.
A (draft) guide to UFO Alien-Invasion

Hors ligne

#11 Le 10/06/2006, à 11:23

bapoumba

Re : [Howto] Sagem fast 800 sous dapper

@ DEoT : j'ai déplacé ton sujet dans trucs et astuces (surtout si cela doit alimenter le wiki). D'habitude je ne demande pas, mais si tu préfères qu'il reste dans internet et réseaux, dis-moi smile


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#12 Le 11/06/2006, à 18:46

Bilabo

Re : [Howto] Sagem fast 800 sous dapper

Avant la première étape (sudo apt-get install build-essential linux-headers-`uname -r`) j'ai dû faire reconnaître le CD d'installation de dapper en tant que dépôt (source de paquets pour installation).

Pour ce faire, j'ai entré la ligne suivante dans une fenêtre terminal :

sudo apt-cdrom add

Il est également possible d'accomplir cette tâche avec les outils d'administration graphiques du menu système.

Bisous

#13 Le 12/06/2006, à 18:18

valente

Re : [Howto] Sagem fast 800 sous dapper

Bonjour,

gene69 a écrit :

HUMMM

Comment on fait pour régler le MTU à 1492 (de tête)?
parce que si c'est XXXX j'ai peur que ce soit 1500 et 1500 c'est pas optimal vu que ça va générer de la framentation lorsque ça va se faire encapsuler par atm(?) !

user "loginc@fai"
plugin pppoatm.so 8.35
noipdefault
usepeerdns
defaultroute
persist
noauth
mtu 1492 #<---MTU 1492 :-)

Utilise le "tuto" de DEoT, la version eagle-usb que tu as n'est plus "viable" smile

@+

#14 Le 13/06/2006, à 20:24

J_F

Re : [Howto] Sagem fast 800 sous dapper

Bilabo a écrit :

Avant la première étape (sudo apt-get install build-essential linux-headers-`uname -r`) j'ai dû faire reconnaître le CD d'installation de dapper en tant que dépôt (source de paquets pour installation).

Pour ce faire, j'ai entré la ligne suivante dans une fenêtre terminal :

sudo apt-cdrom add

Il est également possible d'accomplir cette tâche avec les outils d'administration graphiques du menu système.

Bisous

Idem mais sous kubuntu.

Sinon je ne peu que plussoyer DeOT en ce qui concerne l'utilisation du driver ueagle, il est plus fiable et plus stable que l'ancien eagle-usb (qui n'est plus supporté).

Hors ligne

#15 Le 14/06/2006, à 18:24

fafane41

Re : [Howto] Sagem fast 800 sous dapper

Bonjour

c'est peut etre une question c** mais je suis sous dapper amd64 et est ce que cette methode fonctionne aussi pour cette architecture?

merci

Hors ligne

#16 Le 14/06/2006, à 23:28

valente

Re : [Howto] Sagem fast 800 sous dapper

Bonsoir,

fafane41 a écrit :

Bonjour

c'est peut etre une question c** mais je suis sous dapper amd64 et est ce que cette methode fonctionne aussi pour cette architecture?

merci

Le meilleur moyen, c'est que tu essayes :-) et ensuite nous faire un p'tit compte rendu !

C'est peut être une réponse con, mais dans tous les cas bonne chance smile

@+

#17 Le 15/06/2006, à 08:50

fafane41

Re : [Howto] Sagem fast 800 sous dapper

ok je vais voir ca en esperant que ca fonctionne
big_smile
merci

Hors ligne

#18 Le 15/06/2006, à 20:25

fafane41

Re : [Howto] Sagem fast 800 sous dapper

Bon je peux le dire
se post fonctionne impecable
la preuve
j'ecrit avec firefox sous ubuntu

Hors ligne

#19 Le 18/06/2006, à 23:46

uperu1

Re : [Howto] Sagem fast 800 sous dapper

Bien j'ai tout lu et je me situe:
installation sur Breezy avec sagem fasr 800 où j'ai configuré la connexion automatique sans aucun problème puis migration vers Dapper via les dépôts: là la connexion, malgré

sudo dpkg-reconfigure eagle-usb-utils

ne se fait plus automatiquement et je dois passer par:

eaglestat
eaglectrl -d
sudo startadsl

Je veux bien tout changer et installer  ueagle ;il faut ensuite insérer le CD de DApper mais je ne l'ai pas puisque j'ai migré via les dépôts alors comment je fais?
Merci pour votre réponse.

#20 Le 19/06/2006, à 19:18

Ploric

Re : [Howto] Sagem fast 800 sous dapper

Je suis sous Dapper, mise à jour de la version Breezy. J'ai essayé de faire l'installation mais ça ne marche pas... j'ai même fait en sorte que la connexion se lance dès le démarrage d'Ubuntu (avec l'explication donnée dans le sujet), mais non. J'avais fait ça car je ne voyais pas comment me connecter sinon.

Bon, et bien, ça ne fonctionne pas. Je voudrais bien réessayer à partir de zéro mais que faut-il faire pour nettoyer tout ce qui a été fait ? les fichiers crées, les fichiers de configuration, etc...

Désolé hmm

#21 Le 23/06/2006, à 01:25

Iorek

Re : [Howto] Sagem fast 800 sous dapper

Salut

Lorsque je lance le make dans le répertoire ~/ueagle-atm, il me dit que /lib/modules/2.6.15-23-386/build n'existe pas...

Quelqu'un saurait il pourquoi?

#22 Le 24/06/2006, à 00:33

Iorek

Re : [Howto] Sagem fast 800 sous dapper

Mon problème venait du fait que j'avais la mauvaise version du paquet des headers roll

J'ai été cependant ensuite confronté au même problème que fab56 (voir plus haut)
La solution ce trouve là : http://forum.ubuntu-fr.org/viewtopic.php?id=46855
A noter que je n'ai, moi, pas eu du tout à bidouiller pour avoir la connexion au démarrage, l'ajout de l'interface a suffit à lui seul.

#23 Le 25/06/2006, à 17:40

creon

Re : [Howto] Sagem fast 800 sous dapper

Bonjour à tous, et merci pour le tuto...

Je fais des essais pour migrer vers Ubuntu mais j'ai personnellement quelques soucis pour configurer ma connexion internet...

Je suis chez Free en dégroupé, donc j'essaye d'appliquer la méthode de configuration donnée.
Mon problème est à l'étape du "sudo atmarp -s $VOTREPASSERELLE 0.8.36 nul" , parceque le terminal me répond: "atmarp usage: [tous les cas de figure]"... mon problème c'est que je n'y comprends rien...

Apparemment la commande n'est pas la bonne....

Quelqu'un peut-il m'aider?

Hors ligne

#24 Le 25/06/2006, à 18:24

Arrrakis

Re : [Howto] Sagem fast 800 sous dapper

Bonjour,
Comme fab56 je n'ais pas de pppx après un ifconfig neutral je ne sais pas trop quoi faire.
Sinon merci pour ce tuto très bien adapté aux newbies big_smile:D

Hors ligne

#25 Le 26/06/2006, à 08:16

Cathou

Re : [Howto] Sagem fast 800 sous dapper

creon > puisque tu es chez Free en dégroupé, je te conseille d'aller consulter un HowTo spécifique, qui se trouve >> ICI <<

Haut de page ↑