Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/01/2011, à 20:41

TraGiKomiK

Resolution du probleme: No init found. Try passing init= bootarg.

Alors apres avoir vu beaucoup de posts concerant ce probleme voici un "resumé" et les etapes a suivre pour resoudre ce probleme.


1-> Telecharger la version 10.04 live-CD (lien), Ne pas utiliser la version 10.10 sinon vous serez confrontés a une erreur de montage de partition
2-> Graver l'image Cd ou l'installer sur une clé USB (voir documentation live-usb, lien non utilisable a cause de caracteres qui rentrent en conflit)
3-> Booter sur votre Live-cd/usb et attendre d'etre sous le bureau Gnome (session live)
4-> Ouvrir un terminal et lancer la commande sudo fdisk -l afin de reperer sur quel partition est installé Ubuntu (denomination /dev/sd**)
5-> Lancer le commande fsck -y /dev/sd** (** correspondant au repere de l'etape 4)
6-> Rebooter votre Pc (ou mac d'ailleur) en prenant soin d'avoir enlever le live-cd/usb au moment ou celui ci vous le demande (pour booter sur votre disque dur)
7-> Profitez a nouveau de votre Ubuntu prefere big_smile


[EDIT-CAUSE POSSIBLE] Il semblerai (a confirmaer par les utilisateurs) que le bug puisse provenir de la non-execution du test des disques lors de l'install de la distribution 10.10...

Dernière modification par TraGiKomiK (Le 05/01/2011, à 22:13)


Merci de mettre [RESOLU] dans le titre de votre post une fois le  probleme reglé!

GNU/Linux -> \o/

Hors ligne

#2 Le 03/01/2011, à 20:43

helly

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Hop, je déplace !


Archlinux-wmii-dwb.
Un problème résolu ? Faites le savoir en mettant [résolu] à côté du titre de votre topic.
Un problème non résolu ? Faites le savoir en insultant ceux qui cherchent à vous aider.
Un site bleu super remasterised©, un wiki cherchant des volontaires pour traduire un site.

Hors ligne

#3 Le 03/01/2011, à 20:48

TraGiKomiK

Re : Resolution du probleme: No init found. Try passing init= bootarg.

helly a écrit :

Hop, je déplace !

Arf pourtant j'ai bien reflechi avant de choisir la categorie lol


Merci de mettre [RESOLU] dans le titre de votre post une fois le  probleme reglé!

GNU/Linux -> \o/

Hors ligne

#4 Le 05/01/2011, à 21:40

TraGiKomiK

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Merci helly pour "l'epinglage" wink
Je pense que celui ci (je l'espere) ne sera plus necessaire lors de la sortie de la prochaine version wink


Merci de mettre [RESOLU] dans le titre de votre post une fois le  probleme reglé!

GNU/Linux -> \o/

Hors ligne

#5 Le 04/02/2011, à 10:12

6-ril

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Salut,

Merci pour ce résumé, il a résolu mon problème.
Mais j'aimerais ajouter quelques étapes.

Cette méthode fonctionne bien si le problème ne vient pas du disque dur.
Si le disque est abimé, il y a un risque de tous perdre ...

A mon avis, la première chose à faire, c'est de vérifier qu'il n'y ait pas de secteurs défectueux sur le disque.
L' utilitaire de disque peut faire ca ( à partir d'un live cd ou d'une autre machine ). Des outils équivalents existent sur UBCD
Attention, généralement, ces outils permettent aussi de formater ou effacer les disques dur.

L'autre étape qui peut permettre d'éviter de perdre des fichiers, c'est de faire une copie du disque. En ligne de commande il y a dd, mais je peux pas en dire plus, j'ai utilisé G4L sous UBCD. Voici les étapes que j'ai suivi :

[*] brancher un disque USB au moins au grand que mon disque interne. J'ai pris un disque vide ou en tous cas avec rien d'important dessus parce que tous va être effacé.[/*]
[*] booter sur un clef USB UBCD (y'a pas de lecteur CD sur les eeepc)[/*]
[*] lancer G4L[/*]
[*] lister les disques : la commande disks : liste les média branché/ mon disque interne est wd0, mon disque USB est sda[/*]
[*] Vérifier le contenu des disques : parts wd0 ... je vois une partition ext4 
              parts sda ... je vois une partition NTFS[/*]
Il faut être sûr d'avoir bien identifier le disque source et le disque destination avant de lancer la copie sinon, on écrase son disque avec un disque vide

[*]Lancer la copie : copydisk wd0 sda[/*]

Si le disque est "fatigué" ( disque bruyant, il claque et messages d'erreurs pendant la copie) , il vaut mieux continuer à l'aide de la copie.

Dans tous les cas, pour accéder aux fichiers, il faudra réparer le système de fichier à l'aide des bon conseils de TraGiKomiK ci dessus.

Mais attention, un disque dur endommagé se dégrade très vite, il s'use ...

Dernière modification par 6-ril (Le 04/02/2011, à 10:12)

Hors ligne

#6 Le 04/02/2011, à 11:43

TraGiKomiK

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Merci 6-ril pour ce complement d'information wink


Merci de mettre [RESOLU] dans le titre de votre post une fois le  probleme reglé!

GNU/Linux -> \o/

Hors ligne

#7 Le 09/03/2011, à 21:15

Balf

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Salut,
ça fait plus de 3 mois que j'ai ce pbm sous 10.10 et ça devient de plus en plus fréquent, au début je réinstallais carrément mon System hmm
la solution de TraGiKomiK est efficace et ça me permettais de récupérer ma partition et de démarrer normalement Ubuntu smile

Hélas cette solution n'est pas définitive, et a chaque crash ou un redémarrage forcé le problème persiste toujours et donc il fallait encore réutiliser la commande fsck -y /dev/sd** sous le live CD 10.04 hmm

y'a t'il une autre solution plus radicale a ce désagréable bug ? Merci d'avance smile

Hors ligne

#8 Le 15/02/2012, à 09:43

01franz

Re : Resolution du probleme: No init found. Try passing init= bootarg.

bonjour
http://doc.ubuntu-fr.org/verification_de_fichiers

man tune2fs
sudo tune2fs -c 1 /dev/sdaX

je suis pas français sorry pour mon ortogaffe
toujours utile
sudo tail -f /var/log/syslog  pour le nouvelle grub http://doc.ubuntu-fr.org/plymouth
http://doc.ubuntu-fr.org/tutoriel/conso … es_de_base

Hors ligne

#9 Le 24/06/2012, à 20:42

leschapis

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Bonjour à tous,

En laissant un CD gravé de lucid, j'ai chopé ce satané bug.
VArainte quand je fais
fsck -y /dev/sd**
ubuntu 10.04 me répond fsck.ext4:
Device or resource busy lors de la tentative d'ouverture de /dev/sda1.
Système de fichier monté ou ouvert en mode exclusif par un autre
programme ?

J'ai tenté un sudo tune2fs -c 2 /dev/sda1 pour permettre un montage multiple, umount /dev/sda1 qui répond umount: /dev/sda1is not mounted (according to mtab)
J'ai regardé dans man si on peut forcer, mais je n'ai rien pu trouver.

Qq1 a-t-il une idée ?

Merci pour votre aide.

Hors ligne

#10 Le 22/05/2013, à 17:21

filomax

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Un grand merci @TraGiKomiK pour ces infos qui m'ont permis de récupérer mon Ubuntu 10.04 qui  avait choppé le bug "No init found. Try passing init= bootarg".

Tout fonctionne de nouveau.

Super !

Hors ligne

#11 Le 22/05/2013, à 18:00

jeanjd63

Re : Resolution du probleme: No init found. Try passing init= bootarg.

leschapis a écrit :

Bonjour à tous,

En laissant un CD gravé de lucid, j'ai chopé ce satané bug.
VArainte quand je fais
fsck -y /dev/sd**
ubuntu 10.04 me répond fsck.ext4:
Device or resource busy lors de la tentative d'ouverture de /dev/sda1.
Système de fichier monté ou ouvert en mode exclusif par un autre
programme ?

J'ai tenté un sudo tune2fs -c 2 /dev/sda1 pour permettre un montage multiple, umount /dev/sda1 qui répond umount: /dev/sda1is not mounted (according to mtab)
J'ai regardé dans man si on peut forcer, mais je n'ai rien pu trouver.

Qq1 a-t-il une idée ?

Merci pour votre aide.



Salut

Tu peux télécharger le SystemRescueCD qui te permettra de passer la commande :
sudo  fsck -f -y  /dev/sda1

@+

Hors ligne

#12 Le 09/12/2013, à 21:20

cht

Re : Resolution du probleme: No init found. Try passing init= bootarg.

bounsoir,

même soucis que tout le monde ...

Merci pour cette solution efficace !!!!

( ptit détails: cétait mon disk qui avait morflé ... j'ai perdu dans l'histoire quelques éléments de configurations dont ma boite mail :-( )

Cordialement,

                  CHT

Hors ligne

#13 Le 08/02/2014, à 17:58

azerty17

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Bonsoir,

J'ai actuellement ce message avec un Ubuntu 12.04

La solution est-elle toujours d'actualité ?

Merci d'avance

Hors ligne

#14 Le 08/02/2014, à 18:23

jeanjd63

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Y a pas de raison. Il suffit d'avoir un LiveCD et hop.

Hors ligne

#15 Le 08/02/2014, à 21:57

azerty17

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Ça à marcher.

Merci

Hors ligne

#16 Le 10/05/2014, à 13:02

jycé1924

Re : Resolution du probleme: No init found. Try passing init= bootarg.

Bonjour à tous
Eh bien pour moi ,la solution de "TraGiKomiK" ne me permet pas de redémarrer car aprés avoir rentré " fsck -y /dev/sda1" ,j'ai le message :" WARNING !!! the file system is mounted .If you continue you ***WILL*** cause ***severe*** file system damage.
Souhaitez vous réellement continuer (o/n) ?
Je tape (o) et là j'obtiens :    fsck ext2: permission non accordée lors de la tentative d'ouverture de dev/sda1
Vous devez avoir un accès r/w au système de fichier ou être root  .....
Que signifie la dernière phrase  (Vous devez avoir un accès r/w au système de fichier ou être root  .....) ,étant donné que je suis sur un cd live Ubuntu 10.04 et quand je rentre mon code de session ,ça me marche ps ? ;je ne suis pas un" geek " ,l'informatique m'est tombé dessus .Linux Ubuntu a été pour moi une solution salvatrice pour moi après des dommages sur mon xp il y a quelques années ,mais avec Ubuntu je galère trop dès qu'il y des problèmes techniques ;car les" paquets ......" et touts autres subtilités de la technique Linux me dépasse complètement
Alors s'il vous plaît ,répondez moi en bon vieux français avec si possible des lignes de commande toutes prêtes
Merci d'avance
PS : pc portable  Dell 600 avec Ubuntu 10.04LTS sur DD externe ( posait trop de problème de redémarage en interne aprés mise à jour à 2 reprises  alors qu'il redémarait parfaitement connecté en usb ! )

Hors ligne

#17 Le 10/05/2014, à 13:17

jycé1924

Re : Resolution du probleme: No init found. Try passing init= bootarg.

...re bonjour
La preuve que je ne suis pas un "geek" ,c'est que j'ai galéré pour passer le précédent message ( essayé 2 heures auparavant et ne voulait pas s'enregistrer .....)
Alors ,entre temps ,j'ai compris que le problème était que ma partition /dev/sd1 était montée ( ouf !!!!)   ,j'ai donc démonté et relancé la commande et là  ,il semblerait que le système cherche une partition ext2 et ne trouve pas alors que mon disque est en ext4 ....
Est ce que la commande " fsck -y /dev/sda " cherche systématiquement en ext2  et comment lui faire rechercher ma ext4 ?
Désolé ,les "GEEKs" ,vous avez voulu démocratiser linux et vous récoltez des nullités comme moi ! sad:(:(
Merci de votre aide

Hors ligne

Haut de page ↑