Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 08/01/2011, à 00:46

pseudologos

[résolu] pas d'accès après formatage

Bonjour,


Je viens d'essayer de formater en EXT 4, avec gparted sous Lucid, un disque dur interne que je n'utilise que pour des fichiers sauvegardes : sda1. Seulement, je n'arrive pas y créer des dossiers. Le disque apparaît dans poste de travail, je peux y entrer et c'est tout. Un fichier a été crée : lost+found auquel sur lequel  je n'ai aucun droit.


J'ai sans doute oublier quelque chose mais quoi ?


Voici ce que donne fdisk

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1        9638    77417203+  83  Linux
/dev/sda2   *        9639        9964     2618595    5  Etendue


Merci

Dernière modification par pseudologos (Le 08/01/2011, à 20:44)

Hors ligne

#2 Le 08/01/2011, à 01:51

f.x0

Re : [résolu] pas d'accès après formatage

Bonjour pseudologos,

c'est étrange car on voit 2 paritions sur ton disque :
1 primaire  /dev/sda1               1        9638    77417203+  83  Linux
1 étendue /dev/sda2   *        9639        9964     2618595    5  Etendue
et la partition sda2 semble vide.

Si tu as bien 1 AUTRE DISQUE DUR de type sdb sur lequel est installé un linux

tu devrais relancer gparted, supprimer sda1 et sda2, créer 1 seule parttion en format ext4

et cela devrait être bon

A+++
hmm


SOPI

Hors ligne

#3 Le 08/01/2011, à 02:15

pseudologos

Re : [résolu] pas d'accès après formatage

merci pour la réponse,

J'ai eu des problèmes lors de l'installation de Lucid, parce que, et je ne sais pas pourquoi, sdb est en mon disque principal sur lequel est installé Lucid.
En fait, je crois que grub2 se trouve sur sda2. Si j'étais sûr que grub2 soit sur sdb, alors je ne créerais qu'une seule partition sda. Comment savoir ?

En plus, je m'aperçois que sda1 est monté sur /media. Je me demande si ce n'est pas cela qui pose problème.

Voici ma configuration exacte.


Disque /dev/sda: 82.0 Go, 81964302336 octets
255 têtes, 63 secteurs/piste, 9964 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x8ee1e307

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1        9638    77417203+  83  Linux
/dev/sda2   *        9639        9964     2618595    5  Etendue

Disque /dev/sdb: 160.0 Go, 160041885696 octets
255 têtes, 63 secteurs/piste, 19457 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x0004ed91

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1               1       18709   150274048   83  Linux
/dev/sdb2           18709       19458     6013953    5  Etendue
/dev/sdb5           18709       19458     6013952   82  Linux swap / Solaris

Disque /dev/sdc: 320.1 Go, 320072933376 octets
255 têtes, 63 secteurs/piste, 38913 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x1474c751

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1               1       38913   312568641    7  HPFS/NTFS




En fait, les partitions et moi, ca fait 2...

Tant que j'y suis : gparted me dit que sur mon disque externe, il n'y a pas de point de montage. Pourtant, cela fonctionne...



Merci pour ton aide

Dernière modification par pseudologos (Le 08/01/2011, à 02:29)

Hors ligne

#4 Le 08/01/2011, à 12:54

pseudologos

Re : [résolu] pas d'accès après formatage

J'ai eu la confirmation que grub se trouve sur sda... grâce à ces infos :
ici

Merci de m'aider

Hors ligne

#5 Le 08/01/2011, à 13:30

jeanjd63

Re : [résolu] pas d'accès après formatage

Salut

Peux-tu lister le contenu de /etc/fstab :
cat  /etc/fstab
donner le résultat de :
sudo  ls  -l  /dev/disk/by-uuid
et  indiquer quelle est la partition que tu souhaites monter et utiliser.

@+

Hors ligne

#6 Le 08/01/2011, à 13:42

pseudologos

Re : [résolu] pas d'accès après formatage

voilà :

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=a89672b3-b180-41d1-bac1-f5f38e6c0ec2 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb5 during installation
UUID=614e938f-2a86-4bd9-af02-f1b659c978d0 none            swap    sw              0       0

et ensuite


ludovic@ludovic-desktop:~$ sudo  ls  -l  /dev/disk/by-uuid
[sudo] password for ludovic:
total 0
lrwxrwxrwx 1 root root 10 2011-01-08 10:27 1dbed1cf-c7c8-4d23-9150-439a23e3b6c5 -> ../../sda1
lrwxrwxrwx 1 root root 10 2011-01-08 10:28 20580A4B580A2060 -> ../../sdc1
lrwxrwxrwx 1 root root 10 2011-01-08 12:23 6021-1DAE -> ../../sdd1
lrwxrwxrwx 1 root root 10 2011-01-08 10:28 614e938f-2a86-4bd9-af02-f1b659c978d0 -> ../../sdb5
lrwxrwxrwx 1 root root 10 2011-01-08 10:28 a89672b3-b180-41d1-bac1-f5f38e6c0ec2 -> ../../sdb1



Je souhaiter monter et utiliser sda1 ext 4


Merci

Dernière modification par pseudologos (Le 08/01/2011, à 13:51)

Hors ligne

#7 Le 08/01/2011, à 14:14

jeanjd63

Re : [résolu] pas d'accès après formatage

Donc tu édites  /etc/fstab :
sudo  gedit  /etc/fstab
tu ajoutes les lignes suivantes :

# /media/DATA sur /dev/sdA1
UUID=1dbed1cf-c7c8-4d23-9150-439a23e3b6c5   /media/DATA              ext4    defaults   0       2

Tu sauves puis tu crées le point de montage :
sudo  mkdir  /media/DATA
tu montes ta partition :
sudo  umount   /dev/sda1   on commence par démonter
sudo  mount   /dev/sda1    /media/DATA
Et enfin tu te donnes les droits sur cette partition :
sudo  chown  -R ton_user:ton_user  /media/DATA

Et ça devrait "rouler".

@+

Hors ligne

#8 Le 08/01/2011, à 14:31

pseudologos

Re : [résolu] pas d'accès après formatage

cool,



ca marche : en tous ca je peux créer des dossiers. Un grand merci.


toute petite question : dans utilisateurs et groupe, j'étais en mode personnalisé et je me suis mis en administrateurs mais je ne peux plus revenir en arrière. Cela peut-il poser un problème ?

encore merci

Hors ligne

#9 Le 08/01/2011, à 14:34

jeanjd63

Re : [résolu] pas d'accès après formatage

pseudologos a écrit :

cool,



ca marche : en tous ca je peux créer des dossiers. Un grand merci.


toute petite question : dans utilisateurs et groupe, j'étais en mode personnalisé et je me suis mis en administrateurs mais je ne peux plus revenir en arrière. Cela peut-il poser un problème ?

encore merci


A priori non pour vérifier, en ligne de commande tu tapes :
groups  ton_user   et tu indiques ce qui est affiché. 

@+

Hors ligne

#10 Le 08/01/2011, à 14:36

pseudologos

Re : [résolu] pas d'accès après formatage

voilà ce que cela donne :


ludovic adm dialout fax cdrom floppy tape dip video plugdev fuse lpadmin admin sambashare

Hors ligne

#11 Le 08/01/2011, à 17:42

jeanjd63

Re : [résolu] pas d'accès après formatage

pseudologos a écrit :

voilà ce que cela donne :


ludovic adm dialout fax cdrom floppy tape dip video plugdev fuse lpadmin admin sambashare

Super.

Bonne continuation.

Hors ligne

Haut de page ↑