Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 05/02/2011, à 12:58

Spadassin

[Résolu] Lenteur demarrage open office / libre office

Salut à tous

Je trouve que libre office met du temps à se lancer sur mon PC, c'était pareil avec open office précédemment. La fenêtre de lancement s'affiche, et il se passe plus de 10 secondes avant que la barre rouge se remplisse d'un coup. Le disque dur ne tourne pas et le processeur ne semble pas sollicité plus que ça.
Ma config AMD X4 3,2 GHZ 4GO de ram. Open office se lance plus vite sur mon acer aspire one à 1,6 GHZ et 1 go de ram !!
J'ai comme l'impression que java pourrait être la source de ce problème, quelqu'un à une idée ?

Merci d'avance

Dernière modification par Spadassin (Le 04/03/2011, à 18:01)


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#2 Le 05/02/2011, à 13:03

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Ah oui précision, est ce qu'éventuellement le nombre de polices de caractères ou certaines d'entre elles peuvent générer ce problème ?


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#3 Le 05/02/2011, à 13:13

omtux

Re : [Résolu] Lenteur demarrage open office / libre office

Je n'ai pas la solution mais pour accélérer l'ouverture d'une application libreoffice,je laisse une fenêtre ouverte (réduite ou sur un autre bureau).
1 seconde pour en ouvrir une autre ensuite.

Hors ligne

#4 Le 05/02/2011, à 17:15

Papy Octet

Re : [Résolu] Lenteur demarrage open office / libre office

Spadassin a écrit :

... le nombre de polices de caractères ou certaines d'entre elles peuvent générer ce problème ?

Oui, bien entendu, plus il y a de polices à charger et plus cela prend de temps.
Il est vivement conseillé - mais c'est valable pour tous les logiciels bureautiques - de ne conserver que les polices que l'on utilise régulièrement en plus des polices système proposées par défaut.
Les polices système proposées par défaut doivent rester car le logiciel bureautique se sert de ces polices pour remplacer des polices contenues dans des documents et qui ne sont pas fournies avec le document et qui ne sont pas installées sur la machine qui les lit.

J'ai connu des personnes qui avaient plus de 300 polices installées sur leur machine !
Et avec combien travaillent-elles vraiment habituellement ?

Après suppression de 200 d'entre elles, le chargement allait un peu plus vite.

A+


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#5 Le 06/02/2011, à 16:43

gibkristen

Re : [Résolu] Lenteur demarrage open office / libre office

Bonjour
l'idéal si on a vraiment beaucoup de polices est d'utiliser un gestionnaire de polices comme fontmatrix Très efficace

Dernière modification par gibkristen (Le 06/02/2011, à 16:43)


Passage de Windows 98/Vista/XP à Ubuntu le 11 septembre 2008
Actuellement Xubuntu 14.04.1 LTS

Hors ligne

#6 Le 07/02/2011, à 17:39

lolo

Re : [Résolu] Lenteur demarrage open office / libre office

Salut à tous,
Je suis dans le même cas, et je viens de supprimer la plupart de mes fontes, il ne m'en reste qu'une petite centaine d'après font manager.
Libreoffice3.3 est plus rapide sur un win7 monté avec virtualbox (Un comble) roll
Je pense que le problème doit tourner autour de java (Je suis sous ubuntu 10.10 amd64).

Hors ligne

#7 Le 08/02/2011, à 22:18

michcauch

Re : [Résolu] Lenteur demarrage open office / libre office

lolo a écrit :

Je pense que le problème doit tourner autour de java

dans ce cas il suffit de le désactiver (outils -> options) et vérifier si LibO est alors plus rapide.
Pour moi pas de tels problèmes de lenteur mais je n'ai pas une petite centaine de fontes ! au fait à quoi cela sert-il ?

Dernière modification par Michel Cauchois (Le 09/02/2011, à 22:50)


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#8 Le 09/02/2011, à 09:51

Papy Octet

Re : [Résolu] Lenteur demarrage open office / libre office

Michel Cauchois a écrit :

... une petite centaine de fontes ! au fait à quoi cela sert-il ?

En effet, déjà avec 25 polices différentes ...

Surtout qu'avec des polices "folkloriques", la lecture des documents créés risque fort de poser des problèmes sur d'autres machines  à moins d'incorporer ces polices et alors ... bonjour la taille du fichier !!!

Maintenant, lorsque j'ai besoin d'utiliser une police particulière dans mes créations, je l'installe vite-fait (cela prend quelques secondes à peine) puis je la supprime après emploi (encore quelques secondes). Cela me permet de conserver un système normal.

Ceci fonctionne tant pour les suites bureautiques que pour les logiciels graphiques (Blender, Gimp, Inkscape, ...).
Un peu de discipline et d'ordre ... tongue Oooooh ! Et c'est moi qui écrit ça !???:rolleyes:

Avec certains logiciels, Gimp, par exemple, il est possible de placer ses polices sur une clé USB et de ne l'utiliser que quand le besoin s'en fait sentir sans même devoir redémarrer l'application; un simple rafraîchissement des polices à utiliser et l'indication du chemin pour les trouver dans les préférences et les voilà à disposition immédiate.

Pour java : j'ai essayé, mais je vois peu de différence de vitesse avec mes quelques malheureuses polices installées.
Le tout est de se poser sincèrement la question : est-ce que j'ai vraiment BESOIN d'avoir toutes ces polices continuellement installées sur ma bécane ???

A+

Dernière modification par Papy Octet (Le 09/02/2011, à 09:51)


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#9 Le 09/02/2011, à 10:02

marceldo

Re : [Résolu] Lenteur demarrage open office / libre office

Bonjour,

pour accélérer le démarrage il faut aller dans "outils" - "option" "mémoire vive" et cocher la case " "activer le démarrage rapide dans la zone de notification"
le démarrage se fait en moins d'une seconde, mais en réalité c'est lors de l'initialisation du PC que se charge en mémoire une partie des fonctionnalités de libre-office.
Néanmoins l'activation de cette option peut dans certains cas empêcher la fermeture d'Ubuntu, c'est un bug connu, qui devrait pouvoir se résoudre bientôt

Cordialement


Celui qui n'avance pas... recule

Hors ligne

#10 Le 13/02/2011, à 13:04

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Salut

J'ai essayé en virant le dossier .font que j'utilisais, et aucun changement au niveau performances.


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#11 Le 13/02/2011, à 17:54

marceldo

Re : [Résolu] Lenteur demarrage open office / libre office

avez vous essayé le démarrage rapide dans la zone de notification ?

Dernière modification par marceldo (Le 13/02/2011, à 17:54)


Celui qui n'avance pas... recule

Hors ligne

#12 Le 15/02/2011, à 23:24

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Concernant le lancement rapide ça fonctionne, mais c'est surtout la question pourquoi c'est plus rapide sur un PC moins performant. J'ai refait une install propre en 64 Bit cette fois ci et toujours pareil.


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#13 Le 16/02/2011, à 19:19

michcauch

Re : [Résolu] Lenteur demarrage open office / libre office

Qu'appelles-tu lent ?
Chez moi
si le démarrage rapide n'est pas activé 10 s au premier lancement de LibO writer et 3 s les suivants
Si le démarrage rapide est activé alors environ 1 s

Le monstre (:rolleyes:) : Intel Core 2 Duo E7200 2.53 GHz avec 2 Go de mémoire.


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#14 Le 20/02/2011, à 10:55

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Chez moi 10 secondes avant que la barre de progression comme à se remplir normalement en 3 secondes
Les fois d'après pareil, le cache ne change rien. 10 secondes avant de commencer à se remplir.


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#15 Le 21/02/2011, à 09:05

gibkristen

Re : [Résolu] Lenteur demarrage open office / libre office

Michel Cauchois a écrit :

si le démarrage rapide n'est pas activé 10 s au premier lancement de LibO writer et 3 s les suivants
Si le démarrage rapide est activé alors environ 1 s

Le monstre : Intel Core 2 Duo E7200 2.53 GHz avec 2 Go de mémoire.

Salut
8 secondes pour moi et ensuite 2 secondes. Pas de démarrage rapide d'activé. On peut faire surement plus rapide avec des machines plus actuelles mais ces quelques secondes de lancement me permettent de m'installer confortablement.
Ma bête de conurse AMD Athlon 64 dual core 3800 avec 2 Go de mémoire.


Passage de Windows 98/Vista/XP à Ubuntu le 11 septembre 2008
Actuellement Xubuntu 14.04.1 LTS

Hors ligne

#16 Le 04/03/2011, à 10:14

lolo

Re : [Résolu] Lenteur demarrage open office / libre office

J'ai trouvé une méthode qui a bien arrangé la vitesse d'initialisation de LibO:D
1) use Alt-F2 sudo gedit  /etc/hosts
2) notice the old entry:
127.0.0.1 localhost
127.0.1.1 galaxy
4) and add a line so it looks like this:
127.0.0.1 localhost
127.0.1.1 galaxy
127.0.0.1 galaxy localhost galaxy.(none)
5) save
Bien sur "galaxy" correspond au nom de votre machine

Hors ligne

#17 Le 04/03/2011, à 18:00

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Salut

C'est ça le problème, je viens de faire ce que tu as dit et ça démarre très rapidement, c'est donc la solution, très étrange car en wifi ça ne le fait pas sur mon autre PC.

Merci pour l'info, et si tu as l'explication du pourquoi du comment j'aimerais comprendre.


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#18 Le 11/03/2011, à 12:54

Woodstocker

Re : [Résolu] Lenteur demarrage open office / libre office

J'avais le même problème, mais pas sur une bête de course comme Spadassin ou Michauch, mais sur un Pentium 4 2.93 GHz, et le tuyau du post #16 a parfaitement résolu l'ennui  smile
Merci Lolo !

Dernière modification par Woodstocker (Le 11/03/2011, à 12:55)


Overdose de Windows...
Administration du remède en cours : Lucid Lynx
En convalescence (pas booté sur Windows depuis un mois)
Vaccination de rappel : booté sur Windows après deux mois d'Ubuntu : 103 Mo de mises à jour d'antivirus, et il a perdu la souris...

Hors ligne

#19 Le 12/03/2011, à 20:49

omtux

Re : [Résolu] Lenteur demarrage open office / libre office

Super!Merci lolo

Hors ligne

#20 Le 13/04/2011, à 18:47

loicmarot

Re : [Résolu] Lenteur demarrage open office / libre office

Merci
Ca m'a bien aidé aussi.
Ca commençait à être fatiguant
big_smile

Hors ligne

#21 Le 13/04/2011, à 22:15

xanmoo

Re : [Résolu] Lenteur demarrage open office / libre office

Ah oui, ça change !
(hp nx 6110, celeron 32 bits, 1go RAM)

Dernière modification par xanmoo (Le 13/04/2011, à 22:15)


Portable LDLC Saturne: Ubuntu 14.04, CPU i5 Haswell, GPU:Nvidia 740M, Ram 8 Go, SSD 240 Go
Portable IBM Thinkpad R50e : SolydK, CPU intel, GPU: intel 855GM, Ram 2Go, DD  40 Go
http://dip4fish.blogspot.com/

Hors ligne

#22 Le 22/11/2011, à 21:33

Spadassin

Re : [Résolu] Lenteur demarrage open office / libre office

Truc toujours d'actualité sous libreoffice 3.4 et ubuntu 11.10 ! vitesse de démarrage multipliée par 10


Olivier - Ubuntu 12.10 64 bits
AMD X4 3,2 GHZ 8GO DDR3, Asus M4 A87TD evo, MSI ATI R6770 1GO

Hors ligne

#23 Le 17/03/2012, à 10:53

elephant

Re : [Résolu] Lenteur demarrage open office / libre office

bonjour,

j'ai un problème semblable : certains de mes fichiers .doc et .odt mettent plus de 4 minutes à s'ouvrir avec LibreOffice. J'ai voulu appliquer la procédure expliquée par Lolo mais je n'ai pas réussi :
j'ai tapé Alt-F2, entré "sudo gedit  /etc/hosts", mais ensuite je me suis retrouvée coincée, ne sachant comment faire apparaître les lignes de textes suivantes, et maintenant (conséquence je suppose de mes manipulations) mon ordi ne veut plus s'éteindre, je suis obligée de le mettre en hibernation chaque soir au lieu de l'éteindre...

pourriez vous m'aider ?

elephant
2) notice the old entry:

Hors ligne

#24 Le 17/03/2012, à 11:17

Ekel

Re : [Résolu] Lenteur demarrage open office / libre office

Bonjour,

Pourquoi poser une question dans un fil Résolu ?

Sauf à ne pas vouloir  avoir de réponse..... autre...

Ce poste a été ouvert en 2011 avec sans doute une version d'OS et de OO/LibO différente... cela risque fort de ne pas être le même problème.

Ouvre donc un nouveau sujet !

Cordialement.


Ekel
---
Trusty Thar - KUbuntu Utilisateur n°16275
AMD Phenom(tm) II X4 955 3200 GHz | ATI Radeon HD 5770 Series | 12 Go | Double 17"

Hors ligne

#25 Le 18/03/2012, à 11:23

omtux

Re : [Résolu] Lenteur demarrage open office / libre office

Salut,
Peut être que la manière dont c'est présenté ci-dessus prête à confusion pour les nouveaux.
La  manip de Lolo c'est une modification de fichier.
Elle se fait en administrateur, donc attention de ne pas faire de bêtises.

On peut procéder comme suit en ouvrant un terminal et en y collant :

gksudo gedit /etc/hosts

( appuyer sur entrée et donner le mot de passe administrateur.)

On va se retrouver devant la fenêtre gedit.

On modifie le fichier en tenant compte de ce que dit Lolo.

On enregistre, on  quitte et c'est tout.

Dernière modification par omtux (Le 18/03/2012, à 11:24)

Hors ligne

Haut de page ↑