Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 21/02/2011, à 16:13

stonehenge

Erreur grub, partitions disparues!

Bonjour à tous!

Panique totale! J'ai un disque dur avec XP dessus, un autre avec Kubuntu 8.10 et Mint 10... Tout à l'heure, je veux passer de Kubuntu à Mint. Dans l'invite Mint, j'ai la vérification habituelle des disques qui se lance. Je veux l'interrompre car je suis pressé et je clique sur "escape". Il faut normalement cliquer sur "C" pour l'interrompre. Et là, c'est le bazar! Je tombe sur un écran noir avec un message d'erreur du boot qui me dit qu'un de mes disques durs n'existe pas (celui où il y a les distro linux). Je mets mon live-cd de Gparted et là, il trouve le disque avec XP mais affiche une erreur du système de fichier. Pour l'autre disque dur où il y les deux distro linux, Gparted n'affiche aucune partition! Comme si le disque dur était vide! Grub ne s'ouvre plus.

Là, je vous parle depuis un live-cd. Je suis très loin d'être un spécialiste. S'il y a moyen de retrouver mes partitions sans tout perdre, je vous remercie d'avance de m'expliquer dans un langage simple. J'ai des données importantes que je ne souhaiterais pas perdre... (évidemment, groumpff!)

Autre chose, lorsque j'ouvre Gparted depuis le live-cd de Mint 10, il me dit ceci: /dev/sdb: unrecognized disk label

Voici ce que me dit un fdisk -l en console:

mint@mint ~ $ sudo fdisk -l

Disk /dev/sda: 30.8 GB, 30750031872 bytes
255 heads, 63 sectors/track, 3738 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xec52ec52

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3737    30017421    7  HPFS/NTFS

Disk /dev/sdb: 203.9 GB, 203928109056 bytes
255 heads, 63 sectors/track, 24792 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn't contain a valid partition table

Je cherche aussi sur le net, bien sûr. D'avance merci pour votre aide.


Linux Mint 10 Julia, Gnome 2.32, kernel 2.6.35.22
CM : ASRock K8Upgrade-NF3 - CPU: AMD Sempron, 1800 MHz (2 x 900) 3000+
RAM: 1024 Mo  (PC3200 DDR SDRAM)
CG: ATI Radeon 9600 / X1050 Series  (128 Mo)

Hors ligne

#2 Le 21/02/2011, à 16:49

stonehenge

Re : Erreur grub, partitions disparues!

Si cela peut aider, voici ce que me dit testdisk:

TestDisk 6.11, Data Recovery Utility, April 2009
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/sdb - 203 GB / 189 GiB - CHS 24792 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors


Partition sector doesn't have the endmark 0xAA55

Linux Mint 10 Julia, Gnome 2.32, kernel 2.6.35.22
CM : ASRock K8Upgrade-NF3 - CPU: AMD Sempron, 1800 MHz (2 x 900) 3000+
RAM: 1024 Mo  (PC3200 DDR SDRAM)
CG: ATI Radeon 9600 / X1050 Series  (128 Mo)

Hors ligne

#3 Le 21/02/2011, à 20:22

stonehenge

Re : Erreur grub, partitions disparues!

J'ai essayé les différents outils de testdisk sans succès. Notamment la restauration de la MBR.
Voici ce que donne maintenant un fdisk -l :

mint@mint ~ $ sudo fdisk -l

Disk /dev/sda: 30.8 GB, 30750031872 bytes
255 heads, 63 sectors/track, 3738 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xec52ec52

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3737    30017421    7  HPFS/NTFS

Disk /dev/sdb: 203.9 GB, 203928109056 bytes
255 heads, 63 sectors/track, 24792 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?           1        1718    13795328    0  Empty
Partition 1 does not end on cylinder boundary.
/dev/sdb2          151300      151301        9916+   0  Empty
Partition 2 does not end on cylinder boundary.
/dev/sdb3               2        8287    66557264+   f  W95 Ext'd (LBA)
/dev/sdb4            8288       10111    14651280   83  Linux
/dev/sdb5               2        3497    28073745   83  Linux
/dev/sdb6            4464        8287    30716248+   7  HPFS/NTFS
mint@mint ~ $ 

Il me semble que c'est mieux que tantôt mais je ne sais plus que faire... D'avance merci pour toute aide que vous pourrez m'apporter.
Cordialement,


Linux Mint 10 Julia, Gnome 2.32, kernel 2.6.35.22
CM : ASRock K8Upgrade-NF3 - CPU: AMD Sempron, 1800 MHz (2 x 900) 3000+
RAM: 1024 Mo  (PC3200 DDR SDRAM)
CG: ATI Radeon 9600 / X1050 Series  (128 Mo)

Hors ligne

#4 Le 21/02/2011, à 22:01

stonehenge

Re : Erreur grub, partitions disparues!

Rebonsoir,

Voici ce que donne la commande:

mint@mint ~ $ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/sda1: LABEL="Windows" UUID="EC785020784FE7C2" TYPE="ntfs" 
mint@mint ~ $

Il ne trouve pas /dev/sdb

Personne n'a d'idée?

Cordialement,


Linux Mint 10 Julia, Gnome 2.32, kernel 2.6.35.22
CM : ASRock K8Upgrade-NF3 - CPU: AMD Sempron, 1800 MHz (2 x 900) 3000+
RAM: 1024 Mo  (PC3200 DDR SDRAM)
CG: ATI Radeon 9600 / X1050 Series  (128 Mo)

Hors ligne

Haut de page ↑