Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 25/02/2011, à 22:58

Hibou57

[Info] Compiler LinuxSampler

Hello,

Je viens de compiler LinuxSampler successfully,

Pour épargner les messages d'erreur et les déceptions qui les suivent de prêt, aux gens qui voudraient eux aussi compiler un LinuxSampler tout frais sorti de chez le maraicher, voici les étapes à suivre ci-après. Ça reste assez simple, les seuls couacs sont que la documentation et les README sont parfois contradictoires, et que parfois même aucun des deux n'est dans le vrai, et que la documentation n'expose pas toute les dépendances. Certaines dépendances manquantes, peuvent produire des messages d'erreur durant la compilation, sans qu'aucun message n'indique qu'une librairie doit être installée pour corriger l'erreur.

En espérant ne rien avoir oublié


Installez :

  • [1] Optionnel, seulement si vous pensez packager. La procédure de compilation et d'installation après compilation n'installe aucun raccourcis dans les menus ni autre intégration à GNOME.

  • [2] Encore plus optionnel; c'était une dépendance recommandée qui m'a paru utile.

  • [3] Non formellement requis, mais je l'ai installé parce qu'il me semblait étrange d'avoir une dépendance à Bison/Yacc sans dépendance à Flex/Lex (le message d'erreur ne parlait que de Bison/Yacc). Note : Yacc, l'original de l'Université de Berkeley, n'existe pas sous Ubuntu, j'ai donc installé Bison.

  • [4] Il était possible de prendre libaudiofile également, mais tout d'abord libsnd me semble plus portable, supporter un plus grand nombre de formats et de codecs, et ensuite, libaudiofile ne semble pas exister sous Ubuntu. Il est probablement possible de l'installer, mais ça compliquerait tout de suite une procédure de compilation qui peut rester relativement simple.

  • [5] Il était possible d'opter pour MIDIShare, que je ne connais pas (j'imagine que c'est un genre de MIDI-Yok comme sous Windows), ou pour ALSA, mais j'ignore tout des capacités d'ALSA dans le routage MIDI, et comme Jack semble reconnu bon chez les utilisateurs du MIDI, j'ai opté pour Jack. Vous pourrez éventuellement préférer un autre choix, mais charge à vous de déterminer les dépendances spécifiques venant alors avec.

  • [6] Ou autre version plus récente.

  • [7] Ou autre version plus récente.


Créez un répertoire sur votre Bureau, nomez le LinuxSampler.

Ouvrez une console, faites

cd ~/Bureau/LinuxSampler

Lancez tour à tour les commandes suivantes :

CVSSERVER="anonymous@cvs.linuxsampler.org:/var/cvs/linuxsampler"
cvs -z3 -d:pserver:$CVSSERVER co libgig
cvs -z3 -d:pserver:$CVSSERVER co liblscp
cvs -z3 -d:pserver:$CVSSERVER co linuxsampler
cvs -z3 -d:pserver:$CVSSERVER co qsampler
cvs -z3 -d:pserver:$CVSSERVER co gigedit

Avec Geany ou Gedit, créer un fichier dans LinuxSampler, que vous appellerez build-all. Donnez lui l'attribut exectuable (Click-droit -> Propriétés -> Persmissions -> Autoriser l'éxecution).

Copiez/Collez ceci dans ce fichier build-all :

#! /bin/sh

export CXXFLAGS="-O2 -g3" 
export DEBIAN_BUILDARCH="pentium"

check_for_error () {
    if [ ! $?  -eq 0 ]; then
        echo "Failed!">&2
        exit 1
    fi
}

echo "===== Building liggig ==========================================="
cd libgig;                  check_for_error
make -f Makefile.cvs;       check_for_error
./configure;                check_for_error
make;                       check_for_error
sudo su -c "make install";  check_for_error
cd ..
    
echo "===== Building linuxsampler ====================================="
cd linuxsampler;            check_for_error
make -f Makefile.cvs;       check_for_error
./configure;                check_for_error
make;                       check_for_error
sudo su -c "make install";  check_for_error
cd ..

echo "===== Building gigedit =========================================="
cd gigedit;                 check_for_error
./autogen.sh;               check_for_error
./configure;                check_for_error
make;                       check_for_error
sudo su -c "make install";  check_for_error
cd ..

echo "===== Building liblscp =========================================="
cd liblscp;                 check_for_error
make -f Makefile.svn;       check_for_error
./configure;                check_for_error
make;                       check_for_error
sudo su -c "make install";  check_for_error
cd ..

echo "===== Building qsampler ========================================="
cd qsampler;                check_for_error
make -f Makefile.svn;       check_for_error
./configure;                check_for_error
make;                       check_for_error
sudo su -c "make install";  check_for_error
cd ..

Depuis votre console, entrez

./build-all

Quand cela vous est demandé, entrez votre mot de passe, qui est requis pour les "sudo su make install".

Notez bien que pour construire certains répertoires, il faut commencer par "make -f Makefile.svn", tandis que pour d'autres il faut commencer par "make -f Makefile.cvs". Ce n'est pas une erreur dan le script, donc copiez/collez le bien à l'identique.


Vérifications

Depuis une console,  entrez

qsampler

Si tout c'est bien passé, vous devriez voir s'ouvrir la GUI de LinuxSampler.

Cliquez sur l'icône qui représente comme un périphérique avec une petite étincelle jaune ("Add channel"). Dans la liste déroulante nommée "Engine", vérifiez que vous trouvez bien "GIG", "SF2" et "SFZ" [Voir figure ci-dessous]. Si c'est le cas, alors bienvenu au club des privilégiées ayant à leur disposition un LinuxSampler supportant les SoundFont Cheeeeese (en plus de ces GIG bizarres dont je ne connais rien).

Ubuntu ne propose que le paquet QSampler, et pas LinuxSampler. Les paquets *.deb pour LinuxSampler ne sont disponibles que depuis le site de LinuxSampler, et comme vous pouvez le voir, ... ils datent de plus de 3 ans! Il ne supportent pas les SF2 ni les SFZ, seulement les GIG, et en plus, ça plante trois fois sur quatre (des messages SEGFAULT sont visibles depuis la console).

Voilà pour les bonnes raisons de compiler son LinuxSampler. Plus tard, quand je serai plus à l'aise avec tout ce qui tourne autour de Ubuntu, j'essaierai de faire un paquet installable (packager en *.deb), comme ça ce sera encore plus simple, et ça évitera de devoir installer tout le bazar qui ne sert qu'à compiler ce truc.

Ajout d'un canal dans QSampler, avec options GIG, SF2 et SFZ

Dernière modification par Hibou57 (Le 26/02/2011, à 19:50)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#2 Le 26/02/2011, à 05:50

xabilon

Re : [Info] Compiler LinuxSampler

Salut

Balèze, ton tuto smile L'as-tu contrasté avec la page de doc de linuxsampler ?
Elle ne dit rien pour Ubuntu 10.10 (et la section "à partir des sources" fait peur !), peut-être serait-il utile d'y ajouter un lien vers ce sujet, dans la rubrique "installation" ? un petit message sur la ML du wiki pour prévenir de cet ajout sera le bienvenu.

Et merci pour le partage wink


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 26/02/2011, à 05:58

Hibou57

Re : [Info] Compiler LinuxSampler

Aïe, ça m'inquiète que tu dise « balaise », parce que je pensais que c'était simple. Qu'est-ce qui donne l'impression que c'est compliqué ? Peut-être les listes qui sont trop longues ? Mais c'est assez répétitif...

De toutes les manières, je vais retester la procédure depuis un environnement deboostrap / chroot. Je suis en train de lire des choses à ce sujet en ce moment même (je ne connais pas tout ça encore, mais c'est intéressant, c'est bien fait).

Dernière modification par Hibou57 (Le 26/02/2011, à 05:59)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#4 Le 26/02/2011, à 17:42

xabilon

Re : [Info] Compiler LinuxSampler

Balèze (je crois que les deux orthographes sont acceptées) parce qu'il est bien fait, structuré, et clair.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 26/02/2011, à 19:34

bishop

Re : [Info] Compiler LinuxSampler

Salut Hibou57 !
J'ai compilé LinuxSampler juste pour voir de quoi il retourne, compilation effectuée sous Ubuntu Maverick 32 bits.

Complément pour compilation sous Maverick.
Pour les dépendances c'est autotools-dev et pas autotools.
Lors du premier lancement de qsampler j'ai eu un message d'erreur. Il manquait une LIB "liblscp".  Pour faire court j'ai installé liblscp-dev et là... ça roule.

Sinon très bon tuto.


Hibou57... pour info !
Note qu'un PPA propose une version récente de LinuxSampler.

Dernière modification par bishop (Le 26/02/2011, à 19:38)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#6 Le 26/02/2011, à 19:49

Hibou57

Re : [Info] Compiler LinuxSampler

bishop a écrit :

Salut Hibou57 !

Hello!

bishop a écrit :

Complément pour compilation sous Maverick.
Pour les dépendances c'est autotools-dev et pas autotools.

OK, je vais corriger ça dans le post initial (effectivement, après vérification, le paquet autotools n'existe même pas, il n'existe que autotools-dev). Je dois refaire des tests au sujet de cette compilation, mais je les ferai plus tard; pour l'instant je suis occupé à lire des docs (encore, je suis long), et je ne suis plus tout à fait sûr que compiler avec Jack soit le bon choix, je penche actuellement pour ALSA (à défaut d'OSS installé par défaut sous Ubuntu)... choix en attente.

bishop a écrit :

Lors du premier lancement de qsampler j'ai eu un message d'erreur. Il manquait une LIB "liblscp".  Pour faire court j'ai installé liblscp-dev et là... ça roule.

Je ne comprend pas, cette librairie est censée être compilée lors de la procédure que j'indique. Elle figure par exemple dans la liste de ce qui est récupéré sur CVS :

[...]
cvs -z3 -d:pserver:$CVSSERVER co liblscp
[...]
bishop a écrit :

Note qu'un PPA propose une version récente de LinuxSampler.

OK, je vais voir

Dernière modification par Hibou57 (Le 26/02/2011, à 19:52)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#7 Le 26/02/2011, à 21:06

bishop

Re : [Info] Compiler LinuxSampler

Hibou57 écrit :
Je ne comprend pas, cette librairie est censée être compilée lors de la procédure que j'indique. Elle figure par exemple dans la liste de ce qui est récupéré sur CVS :

[...]
cvs -z3 -d:pserver:$CVSSERVER co liblscp
[...]

Oui et la compilation a bien fonctionné :

bishop2@Maverick:~/Bureau/LinuxSampler$ cvs -z3 -d:pserver:$CVSSERVER co liblscp
cvs checkout: CVS password file /home/bishop2/.cvspass does not exist - creating a new file
cvs checkout: Updating liblscp
U liblscp/AUTHORS
U liblscp/COPYING
U liblscp/ChangeLog
U liblscp/INSTALL
U liblscp/Makefile.am
U liblscp/Makefile.svn
U liblscp/NEWS
U liblscp/README
U liblscp/TODO
U liblscp/configure.ac
U liblscp/liblscp.spec.in
U liblscp/lscp.pc.in
cvs checkout: Updating liblscp/debian
U liblscp/debian/README.Debian
U liblscp/debian/changelog
U liblscp/debian/control
U liblscp/debian/copyright
U liblscp/debian/liblscp-dev.doc-base
U liblscp/debian/liblscp-dev.docs
U liblscp/debian/liblscp-dev.install
U liblscp/debian/liblscp6.install
U liblscp/debian/rules
cvs checkout: Updating liblscp/doc
U liblscp/doc/Makefile.am
U liblscp/doc/liblscp.doxygen.in
U liblscp/doc/reference.dox
cvs checkout: Updating liblscp/examples
U liblscp/examples/Makefile.am
U liblscp/examples/example_client.c
U liblscp/examples/example_server.c
U liblscp/examples/parser.c
U liblscp/examples/parser.h
U liblscp/examples/server.c
U liblscp/examples/server.h
cvs checkout: Updating liblscp/lscp
U liblscp/lscp/Makefile.am
U liblscp/lscp/client.h
U liblscp/lscp/device.h
U liblscp/lscp/event.h
U liblscp/lscp/socket.h
U liblscp/lscp/thread.h
U liblscp/lscp/version.h.in
cvs checkout: Updating liblscp/osx
U liblscp/osx/README.osx
U liblscp/osx/autoconf_builder.sh
U liblscp/osx/wrapper.sh
cvs checkout: Updating liblscp/osx/liblscp.xcodeproj
U liblscp/osx/liblscp.xcodeproj/project.pbxproj
cvs checkout: Updating liblscp/src
U liblscp/src/Makefile.am
U liblscp/src/client.c
U liblscp/src/common.c
U liblscp/src/common.h
U liblscp/src/device.c
U liblscp/src/event.c
U liblscp/src/socket.c
U liblscp/src/thread.c
cvs checkout: Updating liblscp/win32
U liblscp/win32/Makefile.bcc32
U liblscp/win32/Makefile.mingw
U liblscp/win32/Makefile.msvc

De plus si je désinstalle les LIB requises lors du premier lancement "liblscp-dev (0.5.5-1+cvs080828) et liblscp2 (0.5.5-1+cvs080828) qsampler démarre sans problème... roll

Dernière modification par bishop (Le 26/02/2011, à 21:07)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#8 Le 26/02/2011, à 22:02

Hibou57

Re : [Info] Compiler LinuxSampler

bishop a écrit :

De plus si je désinstalle les LIB requises lors du premier lancement "liblscp-dev (0.5.5-1+cvs080828) et liblscp2 (0.5.5-1+cvs080828) qsampler démarre sans problème... roll

Ça m'intéresse tout ça, parce que je découvre.

Je vais essayer de reformuler, parce que je ne sais pas si j'ai bien compris, tu me dira si c'est ça :  pour lancer QSampler la première fois, tu as eu besoin de la présence des deux librairies que tu indique, sinon tu avais un message d'erreur, mais pour les lancements suivants, ces librairies provoquaient une erreur et devaient au contraire être absentes ? C'est ça ?

Tu avais fait l'installation d'une autre version de QSampler + LinuxSampler auparavant ? Parce que moi aussi j'ai constaté un petit phénomène qui m'a surpris, mais qui n'était pas une erreur, et je pense que c'était l'effet d'une précédente installation, d'où l'utilité de faire des tests dans un environnement neutre, et c'est pour ça que je m'intéresse en ce moment aux debootstrap, chroot et cie : dans mon cas, au premier démarrage, dans la liste des pilotes diponibles, j'avais ALSA et Jack, alors que la compilation n'avait été effectuée que pour Jack, donc ALSA n'aurait pas dut être disponible, et au deuxième lancement, je n'avais que Jack et plus de ALSA. J'imagine que c'était un effet d'une précédente installation (la version sous forme de paquet obsolète fourni sur le site), alors que pourtant cette précédente installation avait été désinstallée. C'est une faille des procédures de désinstallation; elles n'offrent pas l'option de supprimer les préférences utilisateurs.


C'est ici que j'avais ALSA et Jack, ce qui n'était pas normal, et ALSA a disparu des listes au lancement suivant :
237812NewChannel.png

Dernière modification par Hibou57 (Le 26/02/2011, à 22:03)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#9 Le 26/02/2011, à 22:40

bishop

Re : [Info] Compiler LinuxSampler

Hibou57 écrit :
Je vais essayer de reformuler, parce que je ne sais pas si j'ai bien compris, tu me dira si c'est ça :  pour lancer QSampler la première fois, tu as eu besoin de la présence des deux librairies que tu indique, sinon tu avais un message d'erreur, mais pour les lancements suivants, ces librairies provoquaient une erreur et devaient au contraire être absentes ? C'est ça ?


C'est pas tout à fait cela...
La première fois que j'ai lancé qsampler un message d'erreur me prévenait qu'il manquait la LIB "liblscp.so.6" et, bien entandu, qsampler ne se lançait pas (normalement, pour garder les infos, je copie tous les messages et là j'ai zappé celui-ci).
Pourtant, cette librairie (liblscp.so.6) se trouve dans /usr/local/lib. C'est la LIB issue de la compilation du CVS.

Suite à ton message "post #6" je me suis dit que pour reproduire l'erreur et le message d'erreur il me suffisait de désinstaller liblscp-dev et liblscp2. De cette façon j'allais pouvoir te poster le message.
Que nenni !
J'ai désinstallé les deux lib(s) et QSampler a démarré sans problème et sans message d'erreur.
Installées ou pas ces deux LIB(s) ne gènent pas le fonctionnement de QSampler.


Hibou57 écrit :
Tu avais fait l'installation d'une autre version de QSampler + LinuxSampler auparavant ?

Je n'ai jamais installé LinuxSampler ni QSampler.


Qsampler.mini.jpeg

Dernière modification par bishop (Le 26/02/2011, à 22:55)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#10 Le 26/02/2011, à 23:26

Hibou57

Re : [Info] Compiler LinuxSampler

bishop a écrit :

La première fois que j'ai lancé qsampler un message d'erreur me prévenait qu'il manquait la LIB "liblscp.so.6" et, bien entandu, qsampler ne se lançait pas (normalement, pour garder les infos, je copie tous les messages et là j'ai zappé celui-ci).
Pourtant, cette librairie (liblscp.so.6) se trouve dans /usr/local/lib. C'est la LIB issue de la compilation du CVS.

Les chemins de recherche par défaut et qui ne peuvent pas être supprimés, pour le chargeur dynamique, sont /lib et /usr/lib. /usr/local/lib n'en fait pas partie normalement.

Des chemins de recherche pour le chargeur dynamique peuvent être ajouté via /etc/ld.so.conf. Apparemment sous Ubuntu ce fichier inclus et mixe le contenu d'autres fichiers qui sont dans /etc/ld.so.conf.d (c'est un répertoire).

J'ai testé

cat /etc/ld.so.conf.d/*.conf

et ça donne

/usr/lib/mesa
# Multiarch support
/lib/i686-linux-gnu
/usr/lib/i686-linux-gnu
/usr/lib/alsa-lib
# libc default configuration
/usr/local/lib

OK, /usr/local/lib y est.

Un autre teste :

ldd $(which qsampler)

et ça donne (en version élaguée, parce que la liste est longue) :

    linux-gate.so.1 =>  (0x003b8000)
    liblscp.so.6 => /usr/local/lib/liblscp.so.6 (0x004cb000)
    libgig.so.6 => /usr/local/lib/libgig.so.6 (0x00326000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x006ea000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00807000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x07b36000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00600000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00110000)
    [...]

liblscp.so.6 figure bien dans les dépendances, et c'est bien avec une librairie dans /usr/local/lib que cette dépendance est résolue.



bishop a écrit :

Suite à ton message "post #6" je me suis dit que pour reproduire l'erreur et le message d'erreur il me suffisait de désinstaller liblscp-dev et liblscp2. De cette façon j'allais pouvoir te poster le message.

liblscp-dev ne devrait pas participer au chargement de l'application, car c'est une librairie *-dev. Et effectivement, la liste des fichiers contenu dans liblscp-dev , montre que liblscp.so.6 n'y figure pas :

/usr/include/lscp/client.h
/usr/include/lscp/device.h
/usr/include/lscp/event.h
/usr/include/lscp/socket.h
/usr/include/lscp/thread.h
/usr/include/lscp/version.h
/usr/lib/liblscp.a
/usr/lib/liblscp.la
/usr/lib/liblscp.so
/usr/lib/pkgconfig/lscp.pc
/usr/share/doc-base/liblscp
/usr/share/doc/liblscp-dev/AUTHORS
/usr/share/doc/liblscp-dev/NEWS.gz
/usr/share/doc/liblscp-dev/README
/usr/share/doc/liblscp-dev/README.Debian
/usr/share/doc/liblscp-dev/TODO
/usr/share/doc/liblscp-dev/changelog.Debian.gz
/usr/share/doc/liblscp-dev/changelog.gz
/usr/share/doc/liblscp-dev/copyright

Le paquet liblscp2 ne participe pas non-plus au chargement de QSampler, la liste des fichiers inclus dans la paquet liblscp2, donne ceci :

/usr/lib/liblscp.so.5
/usr/lib/liblscp.so.5.0.0
/usr/share/doc/liblscp2/changelog.Debian.gz
/usr/share/doc/liblscp2/changelog.gz
/usr/share/doc/liblscp2/copyright

La dépendance liblscp.so.6 n'y figure pas non-plus.

En conclusion so far, il est normal que l'installation ou la désinstallation des paquets liblscp-dev et liblscp2, n'aient pas d'influance sur le chargement de QSampler.

Comme QSampler a besoin de liblscp.so.6, si QSampler démarre chez toi, c'est que cette librairie doit toujours y être, et que tu n'a pas supprimé ce que tu croyais avoir supprimé Wink



Peux-tu poster le résultat de

cat /etc/ld.so.conf

et

cat /etc/ld.so.conf.d/*.conf

et de

ldd $(which qsampler)

et encore de

ls -l /usr/local/lib/liblscp.so.6

ce que ça donne chez toi ?



bishop a écrit :

Je n'ai jamais installé LinuxSampler ni QSampler.

Donc la seule installation que tu en ai eu jusque maintenant, c'est bien celle que tu as compilé ? (t'es courageux... tu va directement au plus laborieux Hihi )

Dernière modification par Hibou57 (Le 26/02/2011, à 23:35)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#11 Le 26/02/2011, à 23:38

bishop

Re : [Info] Compiler LinuxSampler

bishop2@Maverick:~/Bureau$ cat /etc/ld.so.conf
include /etc/ld.so.conf.d/*.conf
bishop2@Maverick:~/Bureau$ cat /etc/ld.so.conf.d/*.conf
/usr/lib/nvidia-current
# Multiarch support
/lib/i686-linux-gnu
/usr/lib/i686-linux-gnu
/usr/lib/alsa-lib
# libc default configuration
/usr/local/lib
bishop2@Maverick:~/Bureau$ ldd $(which qsampler)
    linux-gate.so.1 =>  (0x0087e000)
    liblscp.so.6 => /usr/local/lib/liblscp.so.6 (0x00166000)
    libgig.so.6 => /usr/local/lib/libgig.so.6 (0x009ef000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00176000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00a31000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x003cd000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00110000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00293000)
    libm.so.6 => /lib/libm.so.6 (0x0012a000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00909000)
    libc.so.6 => /lib/libc.so.6 (0x00665000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0037e000)
    libdl.so.2 => /lib/libdl.so.2 (0x007e6000)
    libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0x007ea000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x0087f000)
    libaudio.so.2 => /usr/lib/libaudio.so.2 (0x00866000)
    libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x0e0de000)
    libpng12.so.0 => /lib/libpng12.so.0 (0x008af000)
    libz.so.1 => /lib/libz.so.1 (0x00150000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00925000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x0099c000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0x00398000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0x007c2000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x003a1000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x008d4000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x007db000)
    librt.so.1 => /lib/librt.so.1 (0x008e4000)
    /lib/ld-linux.so.2 (0x003af000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x003ab000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x007e0000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0x039bd000)
    libexpat.so.1 => /lib/libexpat.so.1 (0x0d851000)
    libXt.so.6 => /usr/lib/libXt.so.6 (0x0ed76000)
    libpcre.so.3 => /lib/libpcre.so.3 (0x11194000)
    libuuid.so.1 => /lib/libuuid.so.1 (0x008ed000)
bishop2@Maverick:~/Bureau$ ls -l /usr/local/lib/liblscp.so.6
lrwxrwxrwx 1 root root 16 2011-02-26 17:55 /usr/local/lib/liblscp.so.6 -> liblscp.so.6.0.0

Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#12 Le 26/02/2011, à 23:45

bishop

Re : [Info] Compiler LinuxSampler

Hibou57 écrit :
Donc la seule installation que tu en ai eu jusque maintenant, c'est bien celle que tu as compilé ? (t'es courageux... tu va directement au plus laborieux lol )

Je compile des outils, des logiciels, des gestionnaires de fenêtre, etc... depuis 7 ou 8 ans... Des outils comme LinuxSampler ou QSampler ne me sont d'aucune utilité, je les compile par curiosité ainsi que pour aider, le cas échéant, à corriger des erreurs ou pour aider des gens qui débutent et qui ont quelques difficultés à s'y retrouver. wink

Un tuto comme celui que tu proposes facilite grandement la compilation. Il n'y a vraiment rien de bien compliqué. Tout est dit dans la marche à suivre.
J'en ai aussi profité pour voir ce que donnais la compilation de JSampler et Fantasia. Curiosité... quand tu me tiens... roll

Dernière modification par bishop (Le 26/02/2011, à 23:58)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#13 Le 26/02/2011, à 23:54

Hibou57

Re : [Info] Compiler LinuxSampler

Ton avant dernier message confirme bien que la librairie est toujours là, et que c'est bien elle qui résout la dépendance à cette librairie.

Mais alors la raison pour laquelle tu as eu un message d'erreur au premier lancement est mystérieuse. Peut-être un problème de cache du chargeur dynamique ? Peut-être qu'un re-démarrage avant de lancer QSampler la première fois aurait empêché cette erreur ?

Dernière modification par Hibou57 (Le 26/02/2011, à 23:56)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#14 Le 26/02/2011, à 23:59

bishop

Re : [Info] Compiler LinuxSampler

Hibou57
Peut-être qu'un re-démarrage avant de lancer QSampler la première fois aurait empêché cette erreur ?

C'est aussi ce que je pense...


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#15 Le 01/03/2011, à 02:43

Hibou57

Re : [Info] Compiler LinuxSampler

bishop a écrit :

Hibou57... pour info !
Note qu'un PPA propose une version récente de LinuxSampler.

Je viens de l'essayer : première surprise, il ne peut être installé qu'avec Jack1, et pas Jack2.

Soit, j'ai installé jackd de Jack1 au lieu de jackd de Jack2, qui est pourtant le plus recommandé.

Résultat : SEGFAULT, comme avec la version de 2009 que j'avais essayé.

Bon, je vais retourner à mes documentations sur le packaging Debian pour avoir quelque chose d'installable proprement, et les chroot pour créer un environnement de compilation sans interférence avec le reste du système, parce que compiler et installer comme je l'ai fait, c'est bien gentil pour un coup d'essai, mais ce n'est pas gérable.

Finalement je ferai un paquet quand même un de ces jours, ce PPA ne convient pas, et puis il semble obsolète au moins par sa dépendance envers Jack1.

Dernière modification par Hibou57 (Le 01/03/2011, à 02:46)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#16 Le 27/10/2011, à 02:33

Pacifick_FR42

Re : [Info] Compiler LinuxSampler

Bonsoir ! smile
je n'arrive pas à compiler celon ce tuto :

Filter.h:520:11: note: 'const class LinuxSampler::gig::LowpassTurboFilter' has no user-provided default constructor
make[4]: *** [Filter.lo] Erreur 1
make[4]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src/engines/gig »
make[3]: *** [all-recursive] Erreur 1
make[3]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src/engines »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler »
make: *** [all] Erreur 2
Failed!

libjack-jackd2-dev rentre en conflit avec toute ma logithèque  MAO... donc pas installé ... une solution ? je "force" l'installation de libjack-cack2-dev ? (en virant tous mes softs) ?

Dernière modification par Pacifick_FR42 (Le 27/10/2011, à 02:44)


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#17 Le 27/10/2011, à 08:51

Hibou57

Re : [Info] Compiler LinuxSampler

Waw, ça fait un bail ce topic. D’ailleurs j’ai enlevé LinuxSampler et je n’ai plus le temps de m’occuper l'audio et compagnie.

Je me pencherai sur ton erreur un jour prochain, mais peux rien promettre. Ou alors si quelqu'un d’autre sait.


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#18 Le 27/10/2011, à 18:15

Pacifick_FR42

Re : [Info] Compiler LinuxSampler

Bon... en fait c'est la compile de linuxsampler qui plante :

Filter.h:520:11: note: 'const class LinuxSampler::gig::LowpassTurboFilter' has no user-provided default constructor
make[3]: *** [Filter.lo] Erreur 1
make[3]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src/engines/gig »
make[2]: *** [install-recursive] Erreur 1
make[2]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src/engines »
make[1]: *** [install-recursive] Erreur 1
make[1]: quittant le répertoire « /home/radioactif/Musique/linuxsampler/linuxsampler/src »
make: *** [install-recursive] Erreur 1

J'ai pas d'idée...


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#19 Le 28/10/2011, à 01:08

Pacifick_FR42

Re : [Info] Compiler LinuxSampler

Bon... j'y suis arrivé en passant pas les svn, mais... qsampler ne gère que les *.gig, pas les *.sf2, et justement, c'était le but, une idée ? (pour tant au configure, il me le précise bien sur le sf2--->yes !)

Edit : C'est tout bon, j'ai pas tous compris, mais tous fonctionne ! smile En fait, il fallait lancer Qsampler 2 fois... à la 2ème tout y était...

Dernière modification par Pacifick_FR42 (Le 28/10/2011, à 02:18)


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#20 Le 30/10/2011, à 00:47

Gemnoc

Re : [Info] Compiler LinuxSampler

Bonjour,

xabilon a écrit :

Balèze, ton tuto smile L'as-tu contrasté avec la page de doc de linuxsampler ?
Elle ne dit rien pour Ubuntu 10.10 (et la section "à partir des sources" fait peur !), peut-être serait-il utile d'y ajouter un lien vers ce sujet, dans la rubrique "installation" ?

J'avais passé à côté de ce sujet. La méthode de compilation détaillée dans la doc est inutilement compliquée (et fait doublon avec des pages existantes).

Pour l'instant j'ai ajouté une note au début de la rubrique pour pointer vers ce tuto qui est plus simple à suivre, en attendant de refaire complètement la section. Mais si quelqu'un se sent d'attaque, ne vous gênez pas. wink


Pensez à consulter la documentation ! :-)

Hors ligne

#21 Le 30/10/2011, à 00:51

Gemnoc

Re : [Info] Compiler LinuxSampler

@ Pacifick_FR42

Le PPA qui est listé dans la doc linuxsampler contient une version 1.0.0 basée sur le svn et a été compilée cette semaine, le 25 octobre pour toutes les versions d'Ubuntu présentement maintenues. Il ne faisait pas l'affaire ?


Pensez à consulter la documentation ! :-)

Hors ligne

#22 Le 30/10/2011, à 01:29

Pacifick_FR42

Re : [Info] Compiler LinuxSampler

La version que j'avais du PPA (installé en avril dernier) ne gérait pas les *.sf2, mais maintenant si ça le fait... wink


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#23 Le 30/10/2011, à 17:18

bishop

Re : [Info] Compiler LinuxSampler

Première partie.
Compilation sur Ubuntu Natty 11.04, architecture 64 bits (processeur 6 cores "Intel i7 980")
Je n'ai pas pu utilisé le script proposé par Hibou57 dans le premier post car il plante lors de la compilation de liggig et de linuxsampler mais j'ai repris sa méthode (pas à pas) pour trouver les erreurs (détail des erreurs dans la seconde partie de ce post).

1) Dépendances à installées :

sudo apt-get install cvs autotools-dev automake libtool dpkg-dev fakeroot g++ pentium-builder bison flex intltool libglib2.0-dev libsndfile1-dev libjack-jackd2-dev libcairomm-1.0-dev libgtkmm-2.4-dev libqt4-dev uuid-dev

2) Création d'un dossier :

cd && mkdir LinuxSampler
cd ~/LinuxSampler

3) Téléchargement :

CVSSERVER="anonymous@cvs.linuxsampler.org:/var/cvs/linuxsampler"
cvs -z3 -d:pserver:$CVSSERVER co libgig
cvs -z3 -d:pserver:$CVSSERVER co liblscp
cvs -z3 -d:pserver:$CVSSERVER co linuxsampler
cvs -z3 -d:pserver:$CVSSERVER co qsampler
cvs -z3 -d:pserver:$CVSSERVER co gigedit

4) Compilation :

cd libgig;                  
make -f Makefile.cvs      
./configure               
make                      
sudo make install 
cd ..

   

cd linuxsampler           
make -f Makefile.cvs      
./configure              
make
sudo ln -s /usr/local/lib/libgig.so.6.4.0 /usr/lib/libgig.so.6                   
sudo make install
cd ..
cd gigedit                
./autogen.sh            
./configure              
make                      
sudo make install
cd ..
cd liblscp                 
make -f Makefile.svn     
./configure               
make                  
sudo make install  
cd ..
cd qsampler               
make -f Makefile.svn     
./configure              
make                       
sudo make install 
cd

5) Lancez qsampler.

qsampler

Si cette erreur est affichée lors du premier lancement de qsampler.:

qsampler: error while loading shared libraries: liblscp.so.6: cannot open shared object file: No such file or directory

Installez liblscp6 :

sudo apt-get install liblscp6

Seconde partie.
Infos sur les dépendances, les modifications et la correction des erreurs de compilation.

Note sur les dépendances à installées :
     libcairomm-1.0-dev remplace cairomm-1.0-dev.
     libgtkmm-2.4-dev remplace gtkmm-2.4-dev.
     uuid-dev requis pour la compilation de libgig.


Compilation de libgig.
Installation de uuid-dev suite à une erreur pendant la compilation (./configure) de libgig.

Erreur lors du ./configure :

... ... ...
checking uuid/uuid.h usability... no
checking uuid/uuid.h presence... no
checking for uuid/uuid.h... no
checking for library containing uuid_generate... no
checking for uuid_generate... no
checking for CFUUIDCreate... no
configure: WARNING: No UUID generate function found.
*** libgig will not be able to create DLSIDs in DLS and gig files.
*** Install libuuid from e2fsprogs to solve this. Package might be called
*** uuid-dev, libext2fs2-devel or e2fsprogs-devel.
... ... ...


Compilation de linuxsampler.
Création d'un lien symbolique pour corriger une erreur (sudo make install) :

sudo ln -s /usr/local/lib/libgig.so.6.4.0 /usr/lib/libgig.so.6

Erreur lors de sudo make install :

... ... ...
*** LinuxSampler was compiled with instruments DB support and
*** /var/lib/linuxsampler/instruments.db
*** doesn't exist yet, creating it now:
/home/bishop1104/LinuxSampler/linuxsampler/src/.libs/lt-linuxsampler: error while loading shared libraries: libgig.so.6: cannot open shared object file: No such file or directory
make[2]: *** [install-data-local] Erreur 127
make[2]: quittant le répertoire « /home/bishop1104/LinuxSampler/linuxsampler »
make[1]: *** [install-am] Erreur 2
make[1]: quittant le répertoire « /home/bishop1104/LinuxSampler/linuxsampler »
make: *** [install-recursive] Erreur 1

Dernière modification par bishop (Le 10/02/2014, à 18:54)


Mon blog L'effet Papy Ion - | - Éditeur BBCode - | - Ma Bécane
Ma Bécane alimentée par Trusty 14.04 + additif VirtualBox (Elementary OS Luna)  | Portable LDLC Aurore : Trusty 14.04

Hors ligne

#24 Le 10/02/2014, à 18:24

Flo_

Re : [Info] Compiler LinuxSampler

Petit complément pour ceux que ça intéresserait toujours :

- Pour télécharger les sources, ce n'est pas CVS mais Subversion. Il faut donc lancer les commandes :

svn co https://svn.linuxsampler.org/svn/libgig/trunk libgig
svn co https://svn.linuxsampler.org/svn/liblscp/trunk liblscp
svn co https://svn.linuxsampler.org/svn/linuxsampler/trunk linuxsampler
svn co https://svn.linuxsampler.org/svn/qsampler/trunk qsampler
svn co https://svn.linuxsampler.org/svn/jlscp/trunk jlscp
svn co https://svn.linuxsampler.org/svn/jsampler/trunk jsampler
svn co https://svn.linuxsampler.org/svn/gigedit/trunk gigedit

- Pour avoir le support d'alsa-midi, il faut installer le paquet libasound2-dev avant de compiler linuxsampler.

Hors ligne

Haut de page ↑