Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 28/02/2011, à 17:59

bapesio

Problème avec une ATI RV280 Radeon 9200 Pro

Bonjour à tous,

Comme le topic, http://forum.ubuntu-fr.org/viewtopic.php?id=114772
j'ai un problème avec ma carte ATI RV280. Je n'arrive rendre compatible à 100% ma carte graphique.
Mon accélération 3D est pourtant activée (vérifié et revérifié).

Mon ancien sujet, pour plus de détail : http://forum.ubuntu-fr.org/viewtopic.php?id=444157
Il a un tant soit peu avancé et s'est orienté ici...

Pour ma carte et drivers associé, voici le résultat de la commande lspci -v | grep -A 12 VGA

bapesio@ordi:~$ lspci -v | grep -A 12 VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. Device 9522
    Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
    Memory at e8000000 (32-bit, prefetchable) [size=128M]
    I/O ports at b800 [size=256]
    Memory at ff4f0000 (32-bit, non-prefetchable) [size=64K]
    Expansion ROM at ff4c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon, radeonfb

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
    Subsystem: Micro-Star International Co., Ltd. Device 9523

Je n'ai pas de fichier xorg.conf, je suis sous Ubuntu 10.10 en 32bits (récemment changé, dans l'autre topic j'ai peut-être indiqué 64bits mais j'ai réinstaller pour une version 32bits)

Merci pour votre aide qui me sera très précieuse.

J'ajoute, que ayant commencé sous Débian, puis évolué vers ubuntu 8 puis 9.04 et enfin ubuntu 10.10, je trouve cela invraisemblable que ma CG soit tout à coup incompatible et devrais être changé... Je cherche la solution et je sais qu'elle existe ! Encore merci pour l'aide que vous pourrez m'apporter.

Dernière modification par bapesio (Le 28/02/2011, à 18:04)

Hors ligne

#2 Le 28/02/2011, à 18:14

f.x0

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Bonjour bapesio,

Peux-tu installer, si ce n'est pas déjà fait, le driver propriétaire de ta carte graphique (dans le menu Système=>Administration=>Pilotes supplémentaires) ?


SOPI

Hors ligne

#3 Le 01/03/2011, à 10:02

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Bonjour f.x0,
Merci pour ta réponse vraiment très rapide, j'ai déjà vérifié plusieurs fois dans le menu Système=>Administration=>Pilotes supplémentaires et il n'y a rien à chaque fois (je viens de revérifié).
D'ailleurs, je ne sais pas si c'est réellement normal...
J'ai aussi essayé en installant fglrx mais cela donne un résultat pire encore que quand il n'y est pas.

PS: je ne sais pas si je l'ai déjà dit mais mon accélération graphique est pourtant bien activée

Hors ligne

#4 Le 01/03/2011, à 10:10

atichu

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Ta carte n'est officiellement plus supporté par ATI.seul le drivers libre peux la faire marché..


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#5 Le 01/03/2011, à 10:34

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Arf, il n'y a donc aucun moyen? Ma carte est donc unitilisable?
Merci bien pour ta réponse, je vais voir ce que je peux faire...
En attendant, j'ai trouvé ce site : http://support.amd.com/us/gpudownload/P … er200.aspx où ATI proposerai un pilote pour ma carte...

Hors ligne

#6 Le 01/03/2011, à 10:51

Compte anonymisé

Re : Problème avec une ATI RV280 Radeon 9200 Pro

ATI RV280 Radeon 9200 Pro

Cette carte fonctionne sans problème dans ubuntu ou Debian, à condition de limiter tous les effets kisscool.
Que donne le retour de ces commandes:

lsmod |grep radeon
grep r200 /var/log/Xorg.0.log
bapesio a écrit :

En attendant, j'ai trouvé ce site : http://support.amd.com/us/gpudownload/P … er200.aspx où ATI proposerai un pilote pour ma carte...

NON NON NON ! Surtout pas.

Dernière modification par Compte anonymisé (Le 01/03/2011, à 11:00)

#7 Le 01/03/2011, à 16:37

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Ok, de toute façon j'arrivai pas à le faire fonctionné

φlip a écrit :

Que donne le retour de ces commandes:

lsmod |grep radeon
grep r200 /var/log/Xorg.0.log

Voila le résultat :

 bapesio@ordi:~$ lsmod |grep radeon
radeon                829447  2 
ttm                    56633  1 radeon
drm_kms_helper         30200  1 radeon
drm                   168092  4 radeon,ttm,drm_kms_helper
i2c_algo_bit            5168  2 bttv,radeon
bapesio@ordi:~$ grep r200 /var/log/Xorg.0.log
[    45.819] (II) RADEON(0): [DRI2]   DRI driver: r200
[    45.856] (II) AIGLX: Loaded and initialized /usr/lib/dri/r200_dri.so

Hors ligne

#8 Le 01/03/2011, à 16:52

Compte anonymisé

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Rien d'anormal pourtant.
Qu'est-ce qui ne "fonctionne pas" ?

Cette radeon 9200 fonctionne très bien dans KDE, à condition de désactiver tous les effets graphiques. (pas un problème je pense).
Si tu utilises gnome et compiz, je ne peux rien te dire de plus, mais ta configuration driver radeon me semble normale.

!! important: => ne pas utiliser OpenGL, mais xrender pour le compositing. => voir réglage compiz, ça doit être dans le coin.

As-tu un fichier /etc/X11/xorg.conf ???
Si oui, supprime le et reboot.

Mais si tu cherches une carte pour jouer, ce n'est ps une radeon 9200 qu'il te faut.
Le gros avantage de la radeon 9200  => pas de ventilo !!!!

Dernière modification par Compte anonymisé (Le 01/03/2011, à 17:05)

#9 Le 01/03/2011, à 18:06

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Okkkk,
Merci pour les points obscur que tu m'écclaires
j'ai en effet désactivé les effets graphiques
J'utilise bien gnome et compiz (enfin pas compiz)
Je n'est pas fichier /etc/X11/xorg.conf comme dit ci-dessus !

Par contre, tu dis qu'il faut utilisé xrender et non opengl???
Comment se servir de xrender? Il faut mettre -xrender au lieu de -opengl?

Hors ligne

#10 Le 01/03/2011, à 22:12

Compte anonymisé

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Je ne connais pas gnome. Désolé.
Par contre, pas compris ce qui ne fonctionne pas chez toi, sauf si tu as pour objectif est de jouer à travers wine (...).

#11 Le 01/03/2011, à 22:34

f.x0

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Dans ce post similaire au tien avec la même carte graphique
(d'ailleurs ton post y est cité)

j'ai apporté une solution qui, SI TU LE SOUHAITES, peut être essayée
http://forum.ubuntu-fr.org/viewtopic.ph … 9#p4020739


SOPI

Hors ligne

#12 Le 01/03/2011, à 23:07

Haleth

Re : Problème avec une ATI RV280 Radeon 9200 Pro

φlip a écrit :

Je ne connais pas gnome. Désolé.
Par contre, pas compris ce qui ne fonctionne pas chez toi, sauf si tu as pour objectif est de jouer à travers wine (...).

J'ai l'impression que tout fonctionne, il veut juste jouer via wine avec un trop petit PC.


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#13 Le 02/03/2011, à 00:01

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

φlip a écrit :

Je ne connais pas gnome. Désolé.
Par contre, pas compris ce qui ne fonctionne pas chez toi, sauf si tu as pour objectif est de jouer à travers wine (...).

En effet, mon objectif est de jouer via Wine (à World of Warcraft pour être plus précis)
Ce qui ne fonctionne pas très bien par ailleurs (il est vrai que je n'en ai pas parler plus haut) ce sont les écrans de veille, l'hibernation et aussi la multiconnection de session sur l'ordinateur (pour ce dernier, je ne sais pas si c'est lié ou non à la CG)

Haleth a écrit :

φlip a écrit :

    Je ne connais pas gnome. Désolé.
    Par contre, pas compris ce qui ne fonctionne pas chez toi, sauf si tu as pour objectif est de jouer à travers wine (...).

J'ai l'impression que tout fonctionne, il veut juste jouer via wine avec un trop petit PC.

Voir réponse ci-dessus, autre point au niveau du PC trop petit : je suis conscient qu'il est vieux, mais je me suis permit quand même de poster un topic car j'ai déjà joué au jeu en question sur ce même PC (il y a un an de demi) et qu'il n'y avait aucun problème... Je cherche donc pourquoi maintenant ça ne fonctionne plus.

Hors ligne

#14 Le 02/03/2011, à 00:05

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

f.x0 a écrit :

Dans ce post similaire au tien avec la même carte graphique
(d'ailleurs ton post y est cité)

j'ai apporté une solution qui, SI TU LE SOUHAITES, peut être essayée
http://forum.ubuntu-fr.org/viewtopic.ph … 9#p4020739

Merci bien, je lis ça tout de suite

PS : désolé pour le double post

Edit: La technique d'ajout des sources pour ajouter les pilotes par les dépots officiel a fonctionnait pour moi smile
J'ai redémarré l'ordinateur comme demander, mais comment peut-on savoir si les pilotes sont bien installé?

Dernière modification par bapesio (Le 02/03/2011, à 00:27)

Hors ligne

#15 Le 07/03/2011, à 18:38

bapesio

Re : Problème avec une ATI RV280 Radeon 9200 Pro

Up !

Hors ligne