Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 13/05/2005, à 18:35

Gou

[Résolu] Version trop vieille de libc6

Bonjour!

Je suis un petit nouveau sous Ubuntu (et sous linux en général roll ) et je rencontre un problème assez récurant en voulant installer ou mettre à jour des logiciels (dernier en date: avidemux ), j'ai dans mes dépots une version trop vieille de libc6 et Synaptic me renvoie alors le message d'erreur suivant:

The following packages have unresolvable dependencies. Make sure that all required repositories are added and
 enabled in the preferences

nomprogramme:
  Depends: libc6 (>=2.3.2.ds1-21) but 2.3.2.ds1-20ubuntu13 is to be installed

Visiblement, il aime pas la version que j'ai. Mais où en trouver une qui lui plaise? hmm
Voici la liste de mes dépots: (obtenant en faisant un cat /etc/apt/sources.list)

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe multiverse 

deb http://archive.ubuntu.com/ubuntu/ warty-updates main restricted universe multiverse

deb ftp://ftp.nerim.net/debian-marillat/ stable main
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
deb ftp://ftp.nerim.net/debian-marillat/ testing main

# pour passer le la version stable (Warty) à  la version en developpement (Hoary)
# attention, très déconseillé !! (décochez pour passer néamoins en Hoary)
deb http://archive.ubuntu.com/ubuntu/ hoary main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb http://www.stud.uni-karlsruhe.de/~ut8g/ubuntu/ warty-updates main universe 

deb http://rarewares.soniccompression.com/debian/packages/unstable/ ./

#geexbox
deb http://www.geexbox.org/debian/ unstable main
deb-src http://www.geexbox.org/debian/ unstable main

Si quelqu'un avait une idée pour me dire ce qui va pas ou sur quel dépot je pourrai je pourrait trouver la libc6 de mes rêves ce serait vraiment génial! big_smile Merci d'avance donc wink

Dernière modification par Gou (Le 17/05/2005, à 11:37)

Hors ligne

#2 Le 13/05/2005, à 18:41

dawar

Re : [Résolu] Version trop vieille de libc6

T'as du warty, du hoary, du debian et que sais-je encore dans tes sources apt ? A mon avis tes problèmes viennent de la...


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#3 Le 13/05/2005, à 18:43

laurent

Re : [Résolu] Version trop vieille de libc6

Mets uniquement du hoary et tout ira bien...


Laurent, petit belge explorant la banquise

Hors ligne

#4 Le 14/05/2005, à 13:03

Gou

Re : [Résolu] Version trop vieille de libc6

OK merci! je vais essayer ça... Je vous tiens au courant

Hors ligne

#5 Le 14/05/2005, à 13:21

Gou

Re : [Résolu] Version trop vieille de libc6

Bon alors voici ce que j'ai fait:

J'ai remis les dépots que le guide non officiel recommande (http://www.ubuntu-fr.org/articles/ubunt … positories) et effacé tous les autres...

J'ai alors eu pleins de mises à jour pour ma Hoary, ce qui est plutôt une bonne nouvelle mais la mauvaise nouvelle c'est qu'il ne trouve toujours pas de version plus récente de libc6... sad

Auriez-vous une autre idée svp? wink

Dernière modification par Gou (Le 14/05/2005, à 13:21)

Hors ligne

#6 Le 14/05/2005, à 13:22

laurent

Re : [Résolu] Version trop vieille de libc6

Salut, quand tu cliques sur le paquet de libc6, et que tu fais "Paquet" -> Forcer la version , tu sais pas choisir la version hoary?


Laurent, petit belge explorant la banquise

Hors ligne

#7 Le 14/05/2005, à 17:13

Gou

Re : [Résolu] Version trop vieille de libc6

Non malheureusement: c'est grisé et je ne peux pas y accéder... sad

Il y a peut être moyen de le forcer à faire ça en ligne de commande mais je ne sais pas comment... roll

Dernière modification par Gou (Le 14/05/2005, à 20:47)

Hors ligne

#8 Le 16/05/2005, à 14:22

Gou

Re : [Résolu] Version trop vieille de libc6

Personne pour m'aider? c'est que j'en ai besoin de cette libc6 moi... sad Même un début de piste serait le bienvenu wink

Hors ligne

#9 Le 17/05/2005, à 00:35

hamham

Re : [Résolu] Version trop vieille de libc6

Tu vas sur ce lien

Tu le télécharges
http://packages.debian.org/cgi-bin/download.pl?arch=i386&file=pool%2Fmain%2Fg%2Fglibc%2Flibc6_2.3.2.ds1-21_i386.deb&md5sum=f85258f6f37716e0243659f74d5e6af9&arch=i386&type=main

Tu te place dans le répertoire où tu l'as téléchargé

$ dpkg -i lenomdupaquet.deb

Si tu auras besoin de le désinstaller, tu trouveras le paquet dans synaptic

Hors ligne

#10 Le 17/05/2005, à 11:37

Gou

Re : [Résolu] Version trop vieille de libc6

Merci hamham!! ça marche nickel!! big_smile

Juste une dernière petite question: est-ce que je peux effacer le .deb une fois que j'ai fait "dpkg -i" ? (dsl si ça paraît con mais je suis pas super familier de ce système... hmm)

Merci encore en tout cas! big_smile

Hors ligne

#11 Le 17/05/2005, à 18:41

Gou

Re : [Résolu] Version trop vieille de libc6

En fait, depuis que j'ai installé ton .deb, hamham, à chaque fois que je veux installer un logiciel (j'en ai installé 3 ou 4 cet aprèm' ), je vois apparaitre ça quand je demande à synaptic d'installer mes paquets (c'est dans le terminal qui s'ouvre alors...):

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr_FR"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Visiblement ça a un rapport avec Perl et les problèmes de langues mais j'en sais pas plus...

Le bon côté de la chose c'est que ça n'a pas l'air d'empécher le bon fonctionnement des logiciels installés... Mais ça m'inquiète un peu quand même... quelqu'un sait à quoi c'est lié? Merci big_smile

Hors ligne

#12 Le 17/05/2005, à 22:53

hamham

Re : [Résolu] Version trop vieille de libc6

1)
> Juste une dernière petite question: est-ce que je peux effacer le .deb une fois que j'ai fait "dpkg -i" ? (dsl si ça paraît con mais je suis pas super familier de ce système... hmm)

Bien sur que tu peux l'effacer

2)
> En fait, depuis que j'ai installé ton .deb, hamham, à chaque fois que je veux installer un logiciel (j'en ai installé 3 ou 4 cet aprèm' ), je vois apparaitre ça quand je demande à synaptic d'installer mes paquets (c'est dans le terminal qui s'ouvre alors...):

Euh alors la je ne connais pas trop ce type de message, cherche sur google qui est ton ami.

Hors ligne

#13 Le 18/05/2005, à 10:56

Gou

Re : [Résolu] Version trop vieille de libc6

Merci pour tes réponses hamham big_smile

Je vais donc me retourner vers Google wink

Hors ligne

#14 Le 18/05/2005, à 11:03

ZeBob

Re : [Résolu] Version trop vieille de libc6

je crois qu'il faut faire
localedef -f ISO-8859-15 -i fr_FR fr

Hors ligne

#15 Le 18/05/2005, à 20:17

Gou

Re : [Résolu] Version trop vieille de libc6

ZeBob a écrit :

je crois qu'il faut faire
localedef -f ISO-8859-15 -i fr_FR fr

Merci! big_smile Mais est ce que tu pourrais expliciter un peu plus le pourquoi de la manip stp? J'aime bien savoir un peu pourquoi je fais les choses wink

Hors ligne

#16 Le 18/05/2005, à 20:42

ZeBob

Re : [Résolu] Version trop vieille de libc6

ben...j'avais le même problème avec un programme Perl utilisé via transcode, j'ai cherché et trouvé.
Mais pour expliquer...je sais que c'est à cause d'un problème de langue défini en utf8 et Perl il aime pas.
Ah voilà j'ai trouvé c'était sur Léa : http://lea-linux.org/trucs/item.200.html

Hors ligne

#17 Le 18/05/2005, à 22:13

Gou

Re : [Résolu] Version trop vieille de libc6

J'avais pas trouvé cette page sad ... Merci pour l'info! Je teste ça dès que j'ai 5 minutes! big_smile

Hors ligne

#18 Le 08/12/2005, à 20:08

Belz

Re : [Résolu] Version trop vieille de libc6

Ben moi, j'ai testé, rien ! Par contre, je sais pas si il faut relance X, je ne l'ai pas fais !
Mais j'ai quand même trouvé comment régler ce problème :

$ export LANG=fr_FR.ISO-8859-15
$ export LANGUAGE=fr_FR.ISO-8859-15
$ dvdrip

Et les accents apparaissent bien.

Dernière modification par Belz (Le 08/12/2005, à 20:08)

Hors ligne

Haut de page ↑