Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 14/05/2005, à 01:58

bodha

tout va bien ,sauf la souris..............minou...minou

1116025360-capture11.png
bonjour,
J'etais ravie que l'installation se passe tres bien, le boot sur lilo , nickel........l'image, le son, la connection, les peripheriques, tout est la, sauf que la souris n'y est pas......... '' gros minet serai t il passé par la''
J'avais déja essayé un cd live unbutu warty. ou la souris ne marchait pas non plus, mais comme sur le live cd d'unbutu 5.4, ca marchait je pensais que par l'instal ce serai pareil.............bin non, au dessus; la fiche  de la souris capturée dans mdk.

que dois je faire.............pas trop compliqué
merci

ps je precise que la souris integrée a l'ordi, ne fonctionne pas non plus. c'est un portable clevo.


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#2 Le 14/05/2005, à 02:02

coffee

Re : tout va bien ,sauf la souris..............minou...minou

peux-tu nous donner ton xorg.conf?

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#3 Le 14/05/2005, à 02:54

bodha

Re : tout va bien ,sauf la souris..............minou...minou

oui, je ne demande que ca, mais je ne sais pas ce qu'est  xorg
peux tu me dire  ou,
comment, puisque pas de souris,
je suis presentement sous mdk.

et m'expliquer comment faire, je suis tres debutante:)

Dernière modification par bodha (Le 14/05/2005, à 17:07)


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#4 Le 14/05/2005, à 08:03

tigrou

Re : tout va bien ,sauf la souris..............minou...minou

regarde dans le fichier /etc/X11/xorg.conf c'est là que se trouve la configuration de Xorg et regarde en particulier la/les sections dédiées à la configuration de la souris.

Hors ligne

#5 Le 14/05/2005, à 15:53

bodha

Re : tout va bien ,sauf la souris..............minou...minou

merci, mais je ne sais pas comment faire, j'ai essayé hier soir d'avoir une console par les ; f1,,f2  et toute la ligne, je n'ai eu qu'une execution de commande, ou j'ai ecrit dedans xorg.conf, qui n'a rien donné .
je viens d'essayer en console,dans mandrake en root, et utilisateur rien, peut t on m'expliquer comment faire pour donner l'info que demande coffee, merci


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#6 Le 14/05/2005, à 17:04

bodha

Re : tout va bien ,sauf la souris..............minou...minou

ouf, j'ai trouvé grace au poste en dessous (merci)
voila xorg,config de mandrake. en caracteres gras ce qui concerne la souris.
si je dois faire la meme chose dans ubuntu, merci de me dire comment faire.:)


# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "synaptics"
    Load "glx" # 3D layer
    Load "/usr/X11R6/lib/modules/extensions/libglx.a"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "ca_enhanced"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection


Section "InputDevice"
    Identifier "SynapticsMouse1"
    Driver "synaptics"
    Option "Protocol" "auto-dev"
    Option "Device" "/dev/input/mice"
    Option "EdgeMotionMinSpeed" "200"
    Option "MinSpeed" "0.8"
    Option "MaxSpeed" "1.00"
    Option "BottomEdge" "650"
    Option "EdgeMotionMaxSpeed" "200"
    Option "UpDownScrolling" "0"
    Option "CircScrollTrigger" "2"
    Option "SHMConfig" "on"
    Option "EmulateMidButtonTime" "75"
    Option "CircScrollDelta" "0.1"
    Option "LeftEdge" "120"
    Option "FingerLow" "14"
    Option "HorizScrollDelta" "20"
    Option "MaxTapMove" "110"
    Option "MaxTapTime" "180"
    Option "FingerHigh" "15"
    Option "VertScrollDelta" "20"
    Option "CircularScrolling" "1"
    Option "AccelFactor" "0.015"
    Option "RightEdge" "830"
    Option "TopEdge" "120"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "Flat Panel 1024x768"
    HorizSync 31.5-48.5
    VertRefresh 40-70
EndSection

Section "Device"
    Identifier "device1"
    VendorName "Silicon Integrated System"
    BoardName "SiS 650"
    Driver "sis"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
   
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "SynapticsMouse1" "AlwaysCore"
    Screen "screen1"
EndSection


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#7 Le 15/05/2005, à 08:44

cep

Re : tout va bien ,sauf la souris..............minou...minou

Bonjour bodha,

Si ton problème de souris n'est pas résolu, tu pourrais donner maintenant une copie de ton /etc/xorg/xorg.conf établi par ubuntu en faisant en console :

sudo gedit /etc/Xorg.conf (pour simplifier) afin de comparer avec celui généré par mandrake.

Ensuite éventuellement modifier la section "InputDevice" par les valeurs données par coffee.

Mais avant toute modification, faire une sauvegarde :

sudo cp /etc/Xorg.conf /etc/Xorg.conf_backup

Après toute modification, après enrégistrement, clore la session gnome ( ctrl + alt + back space) et se reloguer.

Si ça ne fonctionne toujours pas après avoir relancé ta session, tu pourrais essayer les valeurs suivantes :

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ExplorerPS/2"
    Option        "ZAxisMapping"        "6 7"
EndSection

Si toujours pas de résultat, on pourra essayer  /dev/psaux pour forcer ps2 ou les paramètres donnés par mandrake.

Bonne chasse au mulot smile

Hors ligne

#8 Le 15/05/2005, à 13:54

bodha

Re : tout va bien ,sauf la souris..............minou...minou

salut cep

super , tu me guides vraiment bien, je n'ai toujours pas de souris (ni de mulot), mais j'avance, hier soir j'ai trouvé comment ouvrir la console, et pour le reste tu me donnes bien la main, (merci a toi), est ce que je dois ecrire dans la console tout ce que tu as ecrit ou seulement ce qui est entre parentheses?;
comme

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ExplorerPS/2"
    Option        "ZAxisMapping"        "6 7"
EndSection

et ecrire backup a la fin ou _backup
apres bien sur avoir edité mon xorg.conf et comparé avec mandrake.
parce qu'hier j'ai entrée les valeurs données par coffee, mais ne savais pas terminer .
donc quand on entre des modifs en console pour les sauvegarder a la fin on ecrit backup, c'est bien ça?
big_smile


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#9 Le 15/05/2005, à 19:52

bodha

Re : tout va bien ,sauf la souris..............minou...minou

le monde etrange de ubuntu, me surprend encore une fois...........la souris fonctionne, mais plus de connexion ni de son?
alors que tout ça marchait hier........je suis en connexion a travers un reseau local . Silicon integated System|sis701356k modem. eth0:realtek|RTL-8139, materiel network _ethernet

Dernière modification par bodha (Le 15/05/2005, à 19:56)


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#10 Le 15/05/2005, à 21:39

cep

Re : tout va bien ,sauf la souris..............minou...minou

bodha a écrit :

donc quand on entre des modifs en console pour les sauvegarder a la fin on ecrit backup, c'est bien ça?
big_smile

Ben non, perdu big_smile

Bon, en me relisant, je me rends compte que j'ai été un peu "bref". Donc pour éviter tout malentendu, je décompose :

sudo gedit /etc/Xorg.conf

"sudo" c'est pour avoir les droits root
"gedit" est l'éditeur de texte (par exemple l'équivalent de wordpad, mais en mieux smile )
"/etc/Xorg.conf" signifie que gedit va ouvrir le fichier Xorg.conf qui est dans le répertoire /etc/

Maintenant pour "sudo cp /etc/Xorg.conf /etc/Xorg.conf_backup"
cp est l'ordre de copier le fichier Xorg.conf qui est dans /etc/ et la copie s'appellera Xorg.conf_backup (ou Xorg.conf_copie ou tout ce que l'on veut)

Donc faire une copie du fichier de configuration, par précaution, puis faire
sudo gedit /etc/Xorg.conf pour éditer le fichier original et faire les modifications préconnisées, c a dire modifier uniquement les parties interessées.
Ensuite enrégistrer le fichier qui gardera bien sûr le même nom de Xorg.conf et relancer la session gnome pour que les modifications soient prises en compte.
Ce principe est le même quel que soit le fichier que l'on modifie (en principe...)

Mais en fin de compte, tout cela n'est plus nécessaire puisque la souris ne joue plus au chat smile

Bonne continuation.

Cep

Hors ligne

#11 Le 15/05/2005, à 22:30

bodha

Re : tout va bien ,sauf la souris..............minou...minou

merci cep
avec ubuntu, j'ai vraiment l'impression de jouer au chat et a la souris, effectivement, car j'ai refais une installation, a cause de l'internet et du son, qui sont revenus et la souris a disparue.
et je ne me souviens plus quels touches utiliser pour avoir acces a la console.
je verrai ça demain.
@ +

bodha


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#12 Le 16/05/2005, à 11:00

cep

Re : tout va bien ,sauf la souris..............minou...minou

bodha a écrit :

et je ne me souviens plus quels touches utiliser pour avoir acces a la console.

On sent pointer l'exaspération smile

Pour les touches de raccourci :

alt + f2

et dans la boite de dialogue, comme application à lancer, marquer :
gnome-terminal

Ou, autre solution, lancer une autre console par les touches alt + ctrl + f2 et se loguer avec le login habituel et le mot de passe (on sera ainsi en console texte).

Pour revenir à l'ancienne console, qui elle est sous X, il faudra faire alt + ctrl + f7

Hors ligne

#13 Le 06/06/2005, à 17:54

forficule

Re : tout va bien ,sauf la souris..............minou...minou

bonjour
j'ai le même problème de souris... yikes
Voici en résumé l'historique de pb : sur un portable avec touchpad synaptics et port ps2 souris/clavier sur lequel je branche ma souris optique ps2, je n'ai pas de soucis avec la version live hoary (avec la warty ça bloquait même avec le lve cd), par contre ça bloque avec la version installée sad
J'ai eu longtemps le même problème avec les mandrake (depuis la 10.1 et la mandriva : pas de prob')
Une solution (chez moi en tout cas...) c'est de débrancher et rebrancher la souris, et hop elle est reconnue (ça marchait aussi avec la mandrake 10.0)...
Je vais regarder comment  ça se passe dans xorg.conf (et par la même occasion je vais essayer de voir comment ça se passe dans le xorg.conf de la version cd...)
Si je trouve une manip' qui marche je repasse un post wink

à plus...

#14 Le 06/06/2005, à 19:05

bodha

Re : tout va bien ,sauf la souris..............minou...minou

sympa ca cool , j'avais mis de coté ubuntu, mais s'il y a une soluce comme ca, j'achete de suite
merci
big_smilecool


Les femmes viennent de Venus. Les hommes mangent des Mars
Mc Solaar

Hors ligne

#15 Le 08/06/2005, à 21:19

forficule

Re : tout va bien ,sauf la souris..............minou...minou

Re bonjour...
j'écris depuis la kubuntu live : ma souris fonctionne au poil, voici un extrait de /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Generic Keyboard"
Driver  "keyboard"
Option  "CoreKeyboard"
Option  "XkbRules" "xorg"
Option  "XkbModel" "pc105"
Option  "XkbLayout" "fr-latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver  "mouse"
Option  "CorePointer"
Option  "Device"  "/dev/input/mice"
Option  "Protocol"  "ImPS/2"
Option  "Emulate3Buttons" "true"
Option  "ZAxisMapping"  "4 5"
EndSection
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option  "HorizScrollDelta" "0"
EndSection

à comparer avec le xorg.conf d'une ubuntu où la souris bloque... j'ai laissé volontairement la partie qui concerne le touchpad car lui aussi fonctionne au poil... Je vais de ce pas faire un petit tour sur ma ubuntu en dur pour voir si ça peut venir de là. Suite des aventures plus tard wink

#16 Le 09/06/2005, à 07:40

cep

Re : tout va bien ,sauf la souris..............minou...minou

Une solution de dépannage provisoire pour la souris, - on n'y pense pas toujours (merci yeremy smile  ) -, est de la brancher en usb lorsqu'il y a un petit adaptateur ps2 qu'il suffit d'enlever au bout de la fiche.

Hors ligne

#17 Le 09/06/2005, à 21:32

forficule

Re : tout va bien ,sauf la souris..............minou...minou

sad oui pour l'adaptateur usb, mais le port usb côté souris de mon portable est cassé, et puis ça m'agace cette souris qui marche avec la version live (ubuntu ou kubuntu hoary) et pas sur la version installée...
Bon, mauvaise nouvelle : mon xorg.conf sur la ubuntu installée est exactement le même que pour la kubuntu, dans le premier cas ma souris ps2 "freeze", je dois la débrancher puis le rebrancher pour que ça marche, dans le deuxième cas, aucun soucis wink
ça peut pas venir de liens symboliques depuis /dev/mouse vers /dev/input/mice ? ou un truc dans le genre ? je ne suis pas assez calé pour voir où ça cloche...
Suite des aventures des souris qui freezent ?

Hors ligne

#18 Le 10/06/2005, à 08:29

cep

Re : tout va bien ,sauf la souris..............minou...minou

forficule a écrit :

ma souris ps2 "freeze", je dois la débrancher puis le rebrancher pour que ça marche, dans le deuxième cas, aucun soucis wink

freeze ? c'est à dire ? elle est reconnue au boot, fonctionne un moment puis blocage ?
Que dit un dmesg ?
Si elle n'est pas du tout reconnue, tu pourrais essayer d'ajouter sur la ligne kernel de ton /boot/grub/menu.lst :
psmouse_noext=1  pour voir si cela peut résoudre le problème.
En principe ce n'est plus nécessaire avec les derniers kernels, mais on ne sait jamais.
Tu peux le faire en éditant ton menu.lst ou au boot en passant en mode édition (esc puis e puis e encore sur la ligne à éditer, là tu ajoutes l'append puis enter pour valider puis b pour booter)

Hors ligne

#19 Le 10/06/2005, à 21:07

forficule

Re : tout va bien ,sauf la souris..............minou...minou

en fait la souris est bloquée au démarrage de l'interface graphique, si je la débranche puis la rebranche elle fonctionne parfaitement... pourquoi ? je ne vois pas, avec la hoary live elle marche parfaitement... dmesg ? je veux bien en faire un, ça consiste en quoi ?

Hors ligne

#20 Le 10/06/2005, à 21:24

cep

Re : tout va bien ,sauf la souris..............minou...minou

forficule a écrit :

dmesg ? je veux bien en faire un, ça consiste en quoi ?

man dmseg :
"dmesg est utilisé pour examiner ou contrôler le tampon des messages du noyau. Le programme aide les utilisateurs à afficher les messages du démarrage de la machine..."

Donc en console, taper dmseg et chercher dans toutes les lignes ce qui a un rapport avec la souris.

Pour avoir une réponse plus concise, mais moins explicite :
dmesg | grep mouse
et
dmesg | grep Mouse

Hors ligne

#21 Le 25/06/2005, à 23:26

forficule

Re : tout va bien ,sauf la souris..............minou...minou

voici ce que donne dmesg
moninvite: # dmesg | grep mouse
mice: PS/2 mouse device common for all mice

ça ne bloque pas du côté de xorg, je pense que ça bloque dans les liens (il y a bien des liens qui sont créés entre les différents devices qui gèrent la souris ?) et la détection... Quoiqu'il en soit, si je débranche la souris et la rebranche, ça marche...
je vais farfouiller dans le répertoire /dev un de ces jours pour voir...
encore merci pour le dmesg wink

Hors ligne

#22 Le 16/10/2005, à 22:03

forficule

Re : tout va bien ,sauf la souris..............minou...minou

smile voici en partie résolu le problème de la souris bloquée : il suffit de passer à breezy wink
Pour info, le problème ne venait pas de xorg.conf (j'ai lancé ubuntu avec le fichier xorg.conf de ma mandriva qui tourne sur le même pc, sans succés... si fgl_glxgears tourne plus vite avec ubuntu d'une trentaine d'images par sec. smile)
J'ai vu au passage de la mise à jour que les modules de gestion usb et de détection automatique étaient tout neufs, je pense que le problème venait de là...
en tout cas maintenant ça marche big_smile

Hors ligne

Haut de page ↑