Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 06/07/2006, à 23:41

xabilon

erreur à l'installation de amule-common

Bonjour tout le monde
J'essaye d'installer amule à partir des dépôts Dapper. J'utilise Synaptic:

Sélectionne le paquet amule, il m'indique amule-common comme dépendance

OK.

J'applique les changements, Synaptic télécharge les 2 paquets, puis au moment de les installer, me sort:

E: /var/cache/apt/archives/amule-common_2.1.0-ubuntu1_i386.deb: le sous-processus pre-installation script a retourné une erreur de sortie d'état 2

amule est installé, mais pas amule-common, je me retrouve donc avec un paquet cassé.

J'essaie d'installer amule-common en ligne de commande (sudo dpkg -i /var/cache/apt/archives/amule-common_2.1.0-1ubuntu_i386.deb)

Voilà le message d'erreur :

(Lecture de la base de données... 89035 fichiers et répertoires déjà installés.)
Dépaquetage de amule-common (à partir de .../amule-common_2.1.0-1ubuntu1_i386.deb) ...
Leaving `diversion of /usr/bin/ed2k to /usr/bin/ed2k.xmule by amule'
dpkg-divert: `diversion of /usr/share/man/man1/ed2k.1.gz to /usr/share/man/man1/ed2k.xmule.1.gz by amule' clashes with `diversion of /usr/share/man/man1/ed2k.1.gz to /usr/share/man/man1/ed2k.xmule.1.gz by amule-utils'
dpkg : erreur de traitement de /var/cache/apt/archives/amule-common_2.1.0-1ubuntu1_i386.deb (--install) :
 le sous-processus pre-installation script a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/amule-common_2.1.0-1ubuntu1_i386.deb

si je fais sudo apt-get install amule-common, j'ai le même message

Comment faire pour installer ce paquet récalcitrant, nécessaire à amule ?

Dernière modification par xabilon (Le 07/07/2006, à 02:08)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#2 Le 08/07/2006, à 16:25

xabilon

Re : erreur à l'installation de amule-common

up ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 08/07/2006, à 17:02

mythrys

Re : erreur à l'installation de amule-common

j'ai déjà eu ca avec xorg je croit (s'étais plus embétant) je pense que c'est une question de paquet corrompu (nettoye le cache de apt) et réessaye.. ou alors essaye de trouver une autre version de amule

Hors ligne

#4 Le 08/07/2006, à 17:03

michel2652

Re : erreur à l'installation de amule-common

Bonjour,

Réparer les paquets cassés dans Synaptic ?

A+

#5 Le 08/07/2006, à 17:17

Smarter

Re : erreur à l'installation de amule-common

essaye de supprimer xmule et de réinstaller amule après

Hors ligne

#6 Le 08/07/2006, à 17:26

michel2652

Re : erreur à l'installation de amule-common

Smarter a écrit :

essaye de supprimer xmule et de réinstaller amule après

Ben, oui faut lire les msg d'erreurs. smile

#7 Le 09/07/2006, à 03:09

xabilon

Re : erreur à l'installation de amule-common

Je n'ai JAMAIS installé xmule !

J'ai fait 'Reparer les paquets cassés' dans Synaptic, tout ce qu'il me propose c'est d'installer amule-common (en ayant nettoyé le cache de apt) ---> retour à la case départ (erreur, etc ...)

J'ai finalement trouvé une version de amule 2.1.1 qui tient en un seul paquet, et qui fonctionne. Mais c'est une version Breezy (je suis sous Dapper), et c'est embêtant pour les futures mises à jour d'amule.

Et puis j'aimerais bien savoir ce qui marche pas avec la version des dépôts ...

Si personne n'a d'idée, tant pis, merci pour votre intérêt.

P.S.: il y a un dépôt avec amule 2.1.3:
deb http://twemu.no-ip.org/apt/amule-testing/dapper/ ./
J'ai exactement le même problème.

Dernière modification par xabilon (Le 09/07/2006, à 17:12)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

Haut de page ↑