Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 17/07/2006, à 18:23

Markand

Comme ça m'enerve ceci

Bonjour

J'essaye d'installer des paquets mais on ne sait trop pourquoi cela donné ça avec les dépôts officiels.

libgnomeui-dev:
 Dépend : libgnome2-dev mais ne doit pas être installé
 Dépend : libbonoboui2-dev mais ne doit pas être installé
 Dépend : libgnomevfs2-dev mais ne doit pas être installé

Comment je peux résoudre ça ?


(EN) Library = (FR) Bibliothèque
Jabber: markand@jabber.fr

Hors ligne

#2 Le 17/07/2006, à 18:27

tshirtman

Re : Comme ça m'enerve ceci

par ce que tu t'apelle mandrake tongue
chez moi pas de pbs... (avec touts dépots ouverts)

 sudo apt-get install libgnomeui-dev
Password:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libart-2.0-dev libavahi-client-dev libavahi-common-dev libavahi-glib-dev
  libbonobo2-dev libbonoboui2-dev libdbus-1-dev libgconf2-dev libgcrypt11-dev
  libgnome-keyring-dev libgnome2-dev libgnomecanvas2-dev libgnomevfs2-dev
  libgnutls-dev libgpg-error-dev libidl-dev libopencdk8-dev liborbit2-dev
  libpopt-dev libtasn1-2-dev
Paquets suggérés :
  libgcrypt11-doc libgnome2-doc libgnomecanvas2-doc libgnomeui-doc
  libgnutls-doc gnutls-bin
Paquets recommandés :
  orbit2
Les NOUVEAUX paquets suivants seront installés :
  libart-2.0-dev libavahi-client-dev libavahi-common-dev libavahi-glib-dev
  libbonobo2-dev libbonoboui2-dev libdbus-1-dev libgconf2-dev libgcrypt11-dev
  libgnome-keyring-dev libgnome2-dev libgnomecanvas2-dev libgnomeui-dev
  libgnomevfs2-dev libgnutls-dev libgpg-error-dev libidl-dev libopencdk8-dev
  liborbit2-dev libpopt-dev libtasn1-2-dev
0 mis à jour, 21 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4074ko dans les archives.
Après dépaquetage, 14,5Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? n
Annulation.

Hors ligne

#3 Le 17/07/2006, à 18:29

mr_pouit

Re : Comme ça m'enerve ceci

Tu as surement activé un dépôt "exotique" qui t'a installé une version spéciale de libcairo2, ou d'une des autres bibliothèques nécessaires pour ce paquet.

Dernière modification par mr_pouit (Le 17/07/2006, à 20:11)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#4 Le 17/07/2006, à 20:05

foch

Re : Comme ça m'enerve ceci

généralement je résoud ce genre de problème en supprimant les paquets incriminés, et en réinstallant le tout !


De retour sous Ubuntu après quelques années sous ArchLinux.

Programme de téléchargement de musique qui ne marche plus vraiment.

Hors ligne

#5 Le 17/07/2006, à 22:15

AlexandreP

Re : Comme ça m'enerve ceci

mmm... je vote pour la réponse de Mr. Pouit (dépôts exotiques activés qui fournissent des versions différentes des bibliothèques concernées).


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#6 Le 17/07/2006, à 22:18

gilir

Re : Comme ça m'enerve ceci

Peut être en utilisant aptitude à la place de apt-get. Dans certains cas, il permet de résoudre des problèmes de dépendances en supprimant les paquets exotiques.

Hors ligne

#7 Le 18/07/2006, à 08:53

Markand

Re : Comme ça m'enerve ceci

voilà mon sources.list

## Dépôts Dapper
deb http://fr.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse

## Dapper-Updates
deb http://fr.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse

## Dépôts Dapper-Securité
deb http://security.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

## Dépôts Backports
deb http://archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu dapper-backports main universe multiverse restricted

## Dépôts Proposed
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-proposed main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-proposed main restricted universe multiverse

## Skype
deb http://download.skype.com/linux/repos/debian/ stable non-free

## Wine
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main

## Wormux
deb http://download.gna.org/wormux/debs dapper/

## Easycam
deb http://blognux.free.fr/debian unstable main

## Amarok
deb http://kubuntu.org/packages/amarok-latest dapper main

## Listen
deb http://theli.free.fr/packages/dapper/ ./

## BMPx
deb http://eros.vlo.gda.pl/~szuwarek/files/linux/bmpx/ dapper/

## PLF
deb http://antesis.freecontrib.org/mirrors/ubuntu/plf/ dapper free non-free
deb-src http://antesis.freecontrib.org/mirrors/ubuntu/plf/ dapper free non-free

## Dépot Tvfreeplayer Dapper
deb http://www.tvfreeplayer.com/linux/ubuntu/dapper/ unstable main

## Cinelerra
deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/mjpegtools ./
deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/i686/ ./

## Gaim 2.0
#deb http://people.ubuntu.com/~seb128/deb ./

## Xgl Compiz et Gset compiz
deb http://xgl.compiz.info dapper main

## Suspend 2
#deb http://dagobah.ucc.asn.au/ubuntu-suspend2 dapper/

libcairo ? il a été mis à jour via XGl je crois


(EN) Library = (FR) Bibliothèque
Jabber: markand@jabber.fr

Hors ligne

#8 Le 18/07/2006, à 08:54

Markand

Re : Comme ça m'enerve ceci

tshirtman a écrit :

par ce que tu t'apelle mandrake tongue
chez moi pas de pbs... (avec touts dépots ouverts)

 sudo apt-get install libgnomeui-dev
Password:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libart-2.0-dev libavahi-client-dev libavahi-common-dev libavahi-glib-dev
  libbonobo2-dev libbonoboui2-dev libdbus-1-dev libgconf2-dev libgcrypt11-dev
  libgnome-keyring-dev libgnome2-dev libgnomecanvas2-dev libgnomevfs2-dev
  libgnutls-dev libgpg-error-dev libidl-dev libopencdk8-dev liborbit2-dev
  libpopt-dev libtasn1-2-dev
Paquets suggérés :
  libgcrypt11-doc libgnome2-doc libgnomecanvas2-doc libgnomeui-doc
  libgnutls-doc gnutls-bin
Paquets recommandés :
  orbit2
Les NOUVEAUX paquets suivants seront installés :
  libart-2.0-dev libavahi-client-dev libavahi-common-dev libavahi-glib-dev
  libbonobo2-dev libbonoboui2-dev libdbus-1-dev libgconf2-dev libgcrypt11-dev
  libgnome-keyring-dev libgnome2-dev libgnomecanvas2-dev libgnomeui-dev
  libgnomevfs2-dev libgnutls-dev libgpg-error-dev libidl-dev libopencdk8-dev
  liborbit2-dev libpopt-dev libtasn1-2-dev
0 mis à jour, 21 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4074ko dans les archives.
Après dépaquetage, 14,5Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? n
Annulation.

Je vois pas le rapport avec mon pseudo ?! roll


(EN) Library = (FR) Bibliothèque
Jabber: markand@jabber.fr

Hors ligne

#9 Le 18/07/2006, à 11:26

tshirtman

Re : Comme ça m'enerve ceci

c'était une boutade, j'espère que tu ne l'as pas mal pris...
au passage je t'ai montré mon résultat pour que tu puisse chercher les pbs de dépendance que tu pourrais avoir...

Hors ligne

#10 Le 18/07/2006, à 17:54

mr_pouit

Re : Comme ça m'enerve ceci

Mandrake a écrit :

voilà mon sources.list

## Xgl Compiz et Gset compiz
deb http://xgl.compiz.info dapper main

libcairo ? il a été mis à jour via XGl je crois

C'est probablement ça la raison : un des paquets dont dépend libgnomeui-dev dépend de libcairo2-dev, et libcairo2-dev dépend de libcairo2. Et il doit donc s'emmeler entre les versions du dépôt xgl et la version officielle dans dapper. smile

(je dis ça avec libcairo2, mais ça revient au même si c'est un autre paquet wink)

Dernière modification par mr_pouit (Le 18/07/2006, à 17:55)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#11 Le 18/07/2006, à 23:51

Markand

Re : Comme ça m'enerve ceci

Même avec le dépôt xgl désactivé fonctionne toujours pas sad


(EN) Library = (FR) Bibliothèque
Jabber: markand@jabber.fr

Hors ligne

#12 Le 19/07/2006, à 05:35

AlexandreP

Re : Comme ça m'enerve ceci

As-tu rechargé le contenu des dépôts après avoir désactivé le dépôt de Xgl ?

$ sudo apt-get update

J'enlèverais aussi les dépôts dapper-proposed.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne