Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 23/07/2006, à 23:51

showlap1

[Resolu] Le pc ne s'éteind pas !

Bonjour à tous,

Je post ce message dans la section hardware sasn vraiment trop savoir si le problème vient de là.

A l'extinction, le pc (un packarbell platinium P3 800mhz) se bloque à "will now halt", et plus rien ne se passe.

Je voulais savoir si quelqu'un connaissait une solution...

Merci !

Dernière modification par showlap1 (Le 24/07/2006, à 20:56)

Hors ligne

#2 Le 24/07/2006, à 00:43

Sorlingues

Re : [Resolu] Le pc ne s'éteind pas !

J'ai un problème similaire ; c'est un bug du noyau répertorié sur le launch pad.

La solution qui a marché chez moi a été de modifier /boot/grub/menu.lst pour ajouter l'option "acpi=force lapic" (sans les guillemets) au noyau utilisé.

Si par exemple ton /boot/grub/menu.lst contient

title           Ubuntu, kernel 2.6.15-26-686
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.15-26-686 root=/dev/hdb1 ro quiet splash
initrd          /boot/initrd.img-2.6.15-26-686
savedefault
boot

tu y remplaces la ligne kernel... par

kernel          /boot/vmlinuz-2.6.15-26-686 root=/dev/hdb1 ro quiet splash acpi=force lapic

Notes :
1/ D'après le rapport de bug, cette solution n'a pas fonctionné chez tout le monde.
2/ Plutôt que de modifier directement la ligne kernel du noyau utilisé, la méthode Debian (utilisée aussi par Ubuntu) voudrait qu'on ne touche pas aux lignes qui sont créées automatiquement, il vaudrait mieux remplacer seulement la ligne

# defoptions=quiet splash

par

# defoptions=quiet splash acpi=force lapic

et demander à grub de modifier lui-même les autres lignes (mais je ne suis plus sûr de savoir comment on fait, de mémoire je dirais "sudo dpkg-reconfigure grub" mais c'est à vérifier.

Hors ligne

#3 Le 24/07/2006, à 07:38

figaro

Re : [Resolu] Le pc ne s'éteind pas !

Sorlingues a écrit :

J'ai un problème similaire ; c'est un bug du noyau répertorié sur le launch pad.

La solution qui a marché chez moi a été de modifier /boot/grub/menu.lst pour ajouter l'option "acpi=force lapic" (sans les guillemets) au noyau utilisé.

Plutôt que de modifier directement la ligne kernel du noyau utilisé, la méthode Debian (utilisée aussi par Ubuntu) voudrait qu'on ne touche pas aux lignes qui sont créées automatiquement, il vaudrait mieux remplacer seulement la ligne

# defoptions=quiet splash

par

# defoptions=quiet splash acpi=force lapic

et demander à grub de modifier lui-même les autres lignes (mais je ne suis plus sûr de savoir comment on fait, de mémoire je dirais "sudo dpkg-reconfigure grub" mais c'est à vérifier.

la commande c'est :

sudo update-grub

Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#4 Le 24/07/2006, à 20:55

showlap1

Re : [Resolu] Le pc ne s'éteind pas !

Ca marche nickel !!:D

merci beaucoup

Dernière modification par showlap1 (Le 24/07/2006, à 20:55)

Hors ligne

#5 Le 25/07/2006, à 00:52

Sorlingues

Re : [Resolu] Le pc ne s'éteind pas !

figaro a écrit :

la commande c'est :

sudo update-grub

Merci pour ce rappel précieux.
Je le copier-collerai 100 fois smile

Hors ligne

#6 Le 13/12/2006, à 17:03

traaf

Re : [Resolu] Le pc ne s'éteind pas !

pareil chez moi

cette soluce ne marche pas,vous en avez pas  une autre en stock?


Vault106, musique libre, enjoy it /!\

Hors ligne

#7 Le 13/12/2006, à 19:41

scorpio810

Re : [Resolu] Le pc ne s'éteind pas !

traaf a écrit :

pareil chez moi

cette soluce ne marche pas,vous en avez pas  une autre en stock?

http://forum.ubuntu-fr.org/viewtopic.php?id=75550


"Le jour où tu découvres le Libre, tu sais que tu ne pourras jamais plus revenir en arrière..."

Hors ligne

#8 Le 13/12/2006, à 21:58

traaf

Re : [Resolu] Le pc ne s'éteind pas !

non plus mad !
c'est une carte mere asus P5GD1 si ca intéresse qqun

Dernière modification par traaf (Le 13/12/2006, à 21:58)


Vault106, musique libre, enjoy it /!\

Hors ligne

#9 Le 15/12/2006, à 12:11

Minneapolis

Re : [Resolu] Le pc ne s'éteind pas !

J'ai trouvé, sur le forum anglais :
Rajouter dans le fichier  /etc/kde3/kdm/kdmrc la ligne suivante :
     TerminateServer=true

Exemple :
[X-:*-Core]
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-nolisten tcp
ServerCmd=/usr/bin/X -br
TerminateServer=true

Ca fonctionne trés bien sur ma bécane

Dernière modification par Minneapolis (Le 15/12/2006, à 12:13)

Hors ligne

#10 Le 15/12/2006, à 20:53

dnz

Re : [Resolu] Le pc ne s'éteind pas !

tu n'aurais pas la meme astuce pour gnome ? pcq moi j'ai gnome et pas KDE merci smile

Hors ligne

#11 Le 18/12/2006, à 14:03

traaf

Re : [Resolu] Le pc ne s'éteind pas !

dnz a écrit :

tu n'aurais pas la meme astuce pour gnome ? pcq moi j'ai gnome et pas KDE merci smile

+1


Vault106, musique libre, enjoy it /!\

Hors ligne

#12 Le 18/12/2006, à 19:56

loudness14

Re : [Resolu] Le pc ne s'éteind pas !

Pour ceux pour qui cela marche pas:

La méthode:

Plutôt que de modifier directement la ligne kernel du noyau utilisé, la méthode Debian (utilisée aussi par Ubuntu) voudrait qu'on ne touche pas aux lignes qui sont créées automatiquement, il vaudrait mieux remplacer seulement la ligne
Code:

# defoptions=quiet splash

par
Code:

# defoptions=quiet splash acpi=force lapic

et demander à grub de modifier lui-même les autres lignes (mais je ne suis plus sûr de savoir comment on fait, de mémoire je dirais "sudo dpkg-reconfigure grub" mais c'est à vérifier.

était pareil pour moi jusqu'à ce que je décomente la ligne:

defoptions=quiet splash acpi=force lapic

Avant de faire "sudo update-grub" wink

Et enfin depuis 4 mois que j'était obligé d'attendre pour appuyer pendant 20 seconde sur le bouton power....:cool:

Hors ligne

#13 Le 19/12/2006, à 10:04

traaf

Re : [Resolu] Le pc ne s'éteind pas !

j'ai toujours lu qu'ele devait rester commentée

ceci dit, ca ne coute rien d'essayer...


Vault106, musique libre, enjoy it /!\

Hors ligne

#14 Le 19/12/2006, à 19:20

loudness14

Re : [Resolu] Le pc ne s'éteind pas !

Moi on ma toujours dit que ce qui était comenté, c'était comme si il n'existait pas... non?

Hors ligne

#15 Le 19/12/2006, à 20:34

kahlil

Re : [Resolu] Le pc ne s'éteind pas !

Je débute, je pensais pareil que toi loudness14,

mais y'a marqué ça dans le menu.lst :

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

  Il ne faut donc pas les décommenter...
Et en effet après l'update grub tu peux vérifier les lignes qui ne sont pas des commentaires sont modifiées pour tous les noyaux.

Je t'avouerais que si ça a marché chez toi je suis tenté, car ça fait 1 mois et demi que j'appuie pendant plusieurs secondes sur le gros bouton pour éteindre mon PC. Le genre de détail qui saoûle ! Mais bon j'ai trop peur de faire des conneries donc j'attends plus d'info.

Vous l'auriez deviné, j'ai le même pb sous ubuntu (donc avec Gnome), et la soluce n'a pas marché pour moi non plus ...

PS   : T'es dans le 14 loudness ?

PS2 : Ca a donné quoi alors traaf ? Ca a marché ?

PS3 : J'ai essayé ça qui ne marche pas non plus (avec un resume sur mon swap) :
http://forum.ubuntu-fr.org/viewtopic.php?id=75550

PS4 : Ne ferait-on pas mieux de poster un nouveau message ou au moins d'enlever Résolu (si tu peux faire ça Showlap1) ?

Dernière modification par kahlil (Le 19/12/2006, à 20:56)

Hors ligne

#16 Le 22/12/2006, à 01:29

Sorlingues

Re : [Resolu] Le pc ne s'éteind pas !

loudness14 a écrit :

Moi on ma toujours dit que ce qui était comenté, c'était comme si il n'existait pas... non?

Quand tu lis un fichier et que tu vois une ligne commentée, c'est qu'elle existe non ?
C'est pareil pour tout programme qui décide après de ce qu'il fait de la ligne commentée : l'ignorer ou non.

Dans le cas de grub, la situation est "compliquée" par debian.

Grub utilise un fichier de configuration (le /boot/grub/menu.lst) dont il ignore les lignes commentées. Quand on installe  ou met à jour le noyau, il faut modifier ce fichier. Heureusement cela se fait automatiquement (par debconf je suppose) mais comment savoir quelles options l'utilisateur veut utiliser (et qu'il faut donc placer dans le nouveau /boot/grub/menu.lst) ?

La méthode utilisée par Debian consiste à placer des méta-données dans le fichier /boot/grub/menu.lst en les commentant de sorte qu'elles ne perturbent pas grub. Quand grub les voit, il les ignore mais quand le système qui doit recréer le /boot/grub/menu.lst après une mise à jour les voit, il sait que lui ne doit pas les ignorer (mais il ignore les lignes précédées de plusieurs #).

Hors ligne

#17 Le 22/09/2007, à 15:10

waterbaby

Re : [Resolu] Le pc ne s'éteind pas !

traaf a écrit :

non plus mad !
c'est une carte mere asus P5GD1 si ca intéresse qqun

salut
j'ai le meme probleme , mon pc ce blok à " will now halt"lorsque je demande de l'eteindre
je possede egalement une asus p5gd

j'ai remarquer que lorsque je desactive dans le bios le mode azalia  ( gestion de la carte son intégré à la CM) le pc s'arrete normalement

traaf pourrais tu me dire si cela et identique pour toi ?

je precise que je suis sous kde feisty mais k'avec gnome feisty j'avais le meme pb ( puisque apprement cela ne viens pas ubuntu mais bien  de la CM


pentium D641 / 1024ddr kingston / nvidia 6600GT / raptor WD36
kUBUNTU  8.04

Les logiciels c'est comme le sexe, c'est meilleur quand c'est libre !!!

Hors ligne

#18 Le 06/03/2008, à 12:19

kahlil

Re : [Resolu] Le pc ne s'éteind pas !

Bonjour,

pour un problème similaire des réglages dans le BIOS ont résolu mon problème...

Hors ligne

#19 Le 20/10/2008, à 21:30

waterbaby

Re : [Resolu] Le pc ne s'éteind pas !

bonjour à tous,

j'ai du dernièrement changer mon alimentation après qu'elle eu sentie le brulé et qu'ele ne voulais plus rien savoir:/

depuis mon pc s'éteint normalement:D

je ne connait pas le rapport entre le pb et ce changement d'alim mais pour moi le pb c'est résolu de cette maniere ( peut etre le signal envoyé par la CM pour couper est-il suffisant pour cette nouvelle alim  ?)


pentium D641 / 1024ddr kingston / nvidia 6600GT / raptor WD36
kUBUNTU  8.04

Les logiciels c'est comme le sexe, c'est meilleur quand c'est libre !!!

Hors ligne

Haut de page ↑