Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/08/2006, à 16:06

Lndil

[Résolu] - Réinstaller Bootloader !

Bonjour @ tous

J vasi essayé de faire cours...

Y a  jours Xp me lache pour un rien (après avoir retiré mon dd externe proprement) et plus moyen de résintaller correctement même après avoir formater (et meme avec précieux conseils des gars HP, enfin bref!)

Je me lance alors sur mon cd live knoppix avec une seule idée en tete... installer linux.. et voila j installe ubuntu sur un DD de Go qui trainait encore et que je met en maitre à ce moment!

Quelle n'est pas ma surprise il y a  jours de voir mon xp se relancer comme si de rien n'était lorsque je replace le DD où il est dessus en maitre !

Quoi qu'il arrive, maintenant que mon ubuntu est sur un dd esclave (hd2.0 ou hdc1... si j ai bien compris!), jen  ai plus le choix au départ pour booter dessus...
J'ai essayé de trouver la réponse moi même... mais non je ne suis pas arrivé à régler le probleme !

Si qq un pouvait m'aider donc a résintaller grib au bon endroit se serait bien sympa, en sachant que je tourne en ce moment grave au cd bootable ubuntu

Merci d'avance

PS: je sais ou est le terminal et j ai qq notion ... mais je reste un nouveau tt de meme ! ^^

#2 Le 19/08/2006, à 16:39

Lndil

Re : [Résolu] - Réinstaller Bootloader !

Je rajoute que j ai essayé le tuto suivant:

Avec Ubuntu ou un Live CD

Note pour le Live CD Ubuntu : le paquet grub n"étant pas installé, vous devez faire :

sudo apt-get install grub

La source du paquet peut provenir d"Internet (si vous avez configuré le réseau) ou d"un CD d"installation d"Ubuntu.

apt-cdrom add /media/cdrom

permet d"ajouter le CD-ROM comme source de paquets.

Sous Ubuntu, ou à partir d"une machine démarrée avec un Live CD, dans un terminal, lancez Grub :

sudo -s

Étapes communes aux deux méthodes

grub --batch

Si vous ne savez pas sur quelle partition se trouvent les fichiers de Grub, entrez à l"invite grub> :

grub> find /boot/grub/stage1

Cette commande vous indiquera la partition sur laquelle sont situés ces fichiers. Imaginons que cette commande nous a fourni (hd0,1) comme réponse. Dans ce cas, il faut entrer :

grub> root (hd0,1)

Remplacez bien entendu (hd0,1) par la partition correspondante. ==> chez moi se serait

L"étape suivante consiste à indiquer à Grub le disque sur lequel il doit (ré)installer le chargeur de système. Si par exemple, on souhaite l"installer sur le disque (hd0):

grub> setup (hd0)
grub> quit

Voilà le travail est fini. Grub est remis d"aplomb !

je rajoute ceci si ca peut aider, résultat de la commande sudo fdisk -l

Disk /dev/hda: 160.0 GB, 160041885696 bytes
240 heads, 63 sectors/track, 20673 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         541     4089928+   b  W95 FAT32
/dev/hda2   *         542       12546    90757800    7  HPFS/NTFS
/dev/hda3           12547       20673    61440120    f  W95 Ext'd (LBA)
/dev/hda5           12547       20673    61440088+   7  HPFS/NTFS

Disk /dev/hdb: 10.2 GB, 10245537792 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        1190     9558643+  83  Linux
/dev/hdb2            1191        1245      441787+   f  W95 Ext'd (LBA)
/dev/hdb5            1191        1245      441756   82  Linux swap / Solaris

#3 Le 19/08/2006, à 17:21

maxfox

Re : [Résolu] - Réinstaller Bootloader !

3 possibilités :

     1. Remettre ton disque "Ubuntu" dans la position où il était quand tu l'as installé, configurer le BIOS pour booter dessus et rajouter une entrée dans le menu.lst de Grub pour windows (Paramètre "map"), ainsi qu'une ligne dans le /boot/grub/device.map pour ton disque Wine. Du fait de tes essais il te faudra peut-être aussi réinstaller Grub sur le MBR de ce disque.

     
     2. Laisser tes disques dans la configuration actuelle et à partir d'un Live CD.

sudo mkdir /media/hdb1
sudo mount /dev/hdb1 -t ext3 /media/hdb1
sudo cp /media/hdb1/etc/fstab  /media/hdb1/etc/fstab_bak
sudo gedit /media/hdb1/etc/fstab

Vérifier/corriger le nom des partitions (/dev/hdxx)

sudo gedit /media/hdb1/boot/grub/menu.lst

et vérifier/corriger ces lignes

# kopt=root=/dev/hdb1
# groot=(hd1,0)
les lignes "root.... (hd1,0) "
les lignes "kernel...  root=/dev/hdb1....  "

Et rajouter une entrée pour Windows aprés la ligne "# This entry automatically added by the Debian installer for a non-linux OS" :
title       Windows NT/2000/XP
root        (hd0,1)
savedefault
makeactive
chainloader +1

sudo gedit /media/hdb1/boot/grub/device.map

(hd0)   /dev/hda
(hd1)   /dev/hdb

Et enfin installer Grub dans le MBR du disque Windows (hd0).


     3. Laisser tes disques dans la configuration actuelle et réinstaller Ubuntu tongue

Dernière modification par maxfox (Le 19/08/2006, à 17:39)

Hors ligne

#4 Le 20/08/2006, à 14:32

Lndil

Re : [Résolu] - Réinstaller Bootloader !

Merci @ toi Maxfox

voici donc ce que j'ai pour la commande sudo gedit /media/hdb1/etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc               /proc           proc    defaults        0       0
/dev/hda1         /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5     none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

Tu me dis : Vérifier/corriger le nom des partitions (/dev/hdxx)
Qu'entends tu par cela ??? tongue

/dev/hda1  deviendrait /dev/hdb1
/dev/hda5         ""         /dev/hdb2
/dev/hdc           ""         /dev/hdb5

C'est ca ?????


Sinon j ai fait le reste des manips.
J attend ta ou une réponse pour relancer la bécane.

Encore merci


Sur Ubuntu depuis 2006

Hors ligne

#5 Le 20/08/2006, à 15:24

maxfox

Re : [Résolu] - Réinstaller Bootloader !

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc               /proc           proc    defaults        0       0
/dev/hdb1         /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb5     none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0


Comme tu as changé la configuration de tes disques, hda est de venu hdb. J'aurais pu être plus explicite avant...

Hors ligne

#6 Le 20/08/2006, à 15:38

Lndil

Re : [Résolu] - Réinstaller Bootloader !

ok merci , j vais essayer (dès qu mon fils arrete de regarder dora ! big_smile) et je te tiens au courant!

merci encore!


Sur Ubuntu depuis 2006

Hors ligne

#7 Le 20/08/2006, à 15:44

Lndil

Re : [Résolu] - Réinstaller Bootloader !

en fait est ce qu'il ya qq chose a changer dans les autres manips que j ai deja effectuées!?


Sur Ubuntu depuis 2006

Hors ligne

#8 Le 20/08/2006, à 15:55

maxfox

Re : [Résolu] - Réinstaller Bootloader !

Ben si tu as fait les modifications convenablement (et si je n'est rien oublié tongue ) non.

Pour vérification, et avant d'installer Grub sur le MBR, tu peux toujours poster les fichiers modifiés (menu.lst, device.map et fstab).

Hors ligne

#9 Le 20/08/2006, à 16:09

Lndil

Re : [Résolu] - Réinstaller Bootloader !

Génial... je boot ubuntu sur mon DD2/esclave... par contre impossible de booter sur xp

voici pour menu.lst

## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hdb1

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title        Ubuntu, kernel 2.6.15-26-amd64-generic
root        (hd1,0)
kernel        /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hdb1 quiet splash
initrd        /boot/initrd.img-2.6.15-26-amd64-generic
savedefault
boot

title        Ubuntu, kernel 2.6.15-26-amd64-generic (recovery mode)
root        (hd0,0)
kernel        /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hda1 ro single
initrd        /boot/initrd.img-2.6.15-26-amd64-generic
boot

title        Ubuntu, memtest86+
root        (hd0,0)
kernel        /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title        Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hdb1

title       Windows NT/2000/XP
root        (hd0,1)
savedefault
makeactive
chainloader +1

Je pense qu'il y a un probleme la à la fin car j ai effacé qq chose par rapport à ce que tu m avait dit de mettre! big_smile (je rajouterai que j ai 3 partition sur le DD contenant xp: hp recovery en "D" et "C"pour xp familly, "L" pour des données perso !)

Voici pour device.map

(hd0)    /dev/hda
(hd1)    /dev/hdb

Voici pour fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdb1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

Dernière modification par Lndil (Le 20/08/2006, à 16:12)


Sur Ubuntu depuis 2006

Hors ligne

#10 Le 20/08/2006, à 16:29

maxfox

Re : [Résolu] - Réinstaller Bootloader !

Les modifications sont en gras :

## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hdb1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title        Ubuntu, kernel 2.6.15-26-amd64-generic
root        (hd1,0)
kernel        /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hdb1 ro quiet splash
initrd        /boot/initrd.img-2.6.15-26-amd64-generic
savedefault
boot

title        Ubuntu, kernel 2.6.15-26-amd64-generic (recovery mode)
root        (hd1,0)
kernel        /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hdb1 ro single
initrd        /boot/initrd.img-2.6.15-26-amd64-generic
boot

title        Ubuntu, memtest86+
root        (hd1,0)
kernel        /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title       Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2

title       Windows NT/2000/XP
root        (hd0,1)
savedefault
makeactive
chainloader +1
boot           ##(normalement inutile)

Essaye avec ça. Si tu n'arrive toujours pas à lancer Windows, le mieux est d'ouvrir un autre sujet avec le message d'erreur, menu.lst et résultat de sudo fdisk -l

EDIT, problème avec balise et oubli

EDIT2, les fichier ont été récupéré à partir d'Ubuntu ou du LiveCD ?

Dernière modification par maxfox (Le 20/08/2006, à 16:55)

Hors ligne

#11 Le 20/08/2006, à 16:57

Lndil

Re : [Résolu] - Réinstaller Bootloader !

re encore moi !

alors quand j essaye d ouvrir avec la commande sudo gedit /media/hdb1/boot/grub/menu.lst
que je sois en root ou non, menu.lst s'ouvre mais rien n'est écrit dedans ..que fais je de faux ?

voila les commandes tapées !

seb@Seb:~$ sudo gedit /media/hdb1/boot/grub/menu.lst
seb@Seb:~$ sudo -s

root@Seb:~#
root@Seb:~#
root@Seb:~# sudo gedit /media/hdb1/boot/grub/menu.lst
root@Seb:~# sudo gedit /media/hdb1/boot/grub/menu.lst


Sur Ubuntu depuis 2006

Hors ligne

#12 Le 20/08/2006, à 17:08

maxfox

Re : [Résolu] - Réinstaller Bootloader !

La commande n'est valable qu'à partir du LiveCD et parceque la partition / a été montée dans le dossier /media/hdb1

À partir d'Ubuntu pour éditer le fichier avec les droits d'administrateur :

Alt+F2 puis : gksudo gedit /boot/grub/menu.lst

Et pour voir le contenu du dossier sans risque, dans un terminal :

cat /boot/grub/menu.lst

Une question avant d'éventuellement ouvrir un autre sujet, le BIOS est configuré pour booter sur quel disque ?

Dernière modification par maxfox (Le 20/08/2006, à 17:09)

Hors ligne

#13 Le 20/08/2006, à 18:47

Lndil

Re : [Résolu] - Réinstaller Bootloader !

le pc boot avec le disque dur maitre où se trouve xp

allez je lance "la bete" pour voir si tout marche... on verra bien


Sur Ubuntu depuis 2006

Hors ligne

#14 Le 20/08/2006, à 19:00

Lndil

Re : [Résolu] - Réinstaller Bootloader !

Bon toujours pas de lancement possible sous xp !

j ai essayé de changer le boot de xp en faisant un edit au départ quand il faut choisir.
j 'ai essayé en enlevant boot           ## , le truc a priori inutile ==> pas de changement!
après j ai changé (hd0,1) par (hd0,0)... pas de résultat non plus !

ah oui il m'écrit erreur 27 !

en attente de tes conseils avisés !

edit 1: que veux dire le "ro" que tu as rajouté à divers endroit!

Dernière modification par Lndil (Le 20/08/2006, à 19:16)


Sur Ubuntu depuis 2006

Hors ligne

#15 Le 20/08/2006, à 19:34

maxfox

Re : [Résolu] - Réinstaller Bootloader !

Là je sèche... hmm

erreur 27 = Unrecognized command

ro = read only

Dans le doute pourrais-tu donner le résultat de ces commandes, histoire d'être sûr que les modifications ont été correctement effectuées :

sudo parted -s /dev/hda print
cat /boot/grub/menu.lst
cat /boot/grub/device.map

Mais à prioris ça devrait être bon... hmm

PS, ##(normalement inutile) était un commentaire, lui était par contre vraiment inutile dans le fichier.

Dernière modification par maxfox (Le 20/08/2006, à 19:35)

Hors ligne

#16 Le 20/08/2006, à 19:48

Lndil

Re : [Résolu] - Réinstaller Bootloader !

sudo parted -s /dev/hda print

Géométrie du disque pour /dev/hda : 0kB - 160GB
Type d'étiquette de disque : msdos
Numéro Début  Fin     Taille  Type      Système de fichiers Drapeaux
1       32kB    4188MB  4188MB  primaire  fat32
2       4188MB  97GB    93GB    primaire  ntfs         amorce
3       97GB    160GB   63GB    étendue               lba
5       97GB    160GB   63GB    logique   ntfs

cat /boot/grub/menu.lst

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default         0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout         10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title         Windows 95/98/NT/2000
# root          (hd0,0)
# makeactive
# chainloader   +1
#
# title         Linux
# root          (hd0,1)
# kernel        /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hdb1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title           Ubuntu, kernel 2.6.15-26-amd64-generic
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hdb1 ro quiet splash
initrd          /boot/initrd.img-2.6.15-26-amd64-generic
savedefault
boot

title           Ubuntu, kernel 2.6.15-26-amd64-generic (recovery mode)
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.15-26-amd64-generic root=/dev/hdb1 ro single
initrd          /boot/initrd.img-2.6.15-26-amd64-generic
boot

title           Ubuntu, memtest86+
root            (hd1,0)
kernel          /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title           Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2

title       Windows NT/2000/XP
root        (hd0,1)
savedefault
makeactive
chainloader +1
boot        ##

cat /boot/grub/device.map

(hd0)   /dev/hda
(hd1)   /dev/hdb

==> le probleme pourrait il venir de mar partition "hp recovery" car j ai lu qq part sur le forum que normalement faudrait pas trop  toucher au MBR à ce niveau la !


Sur Ubuntu depuis 2006

Hors ligne

#17 Le 20/08/2006, à 20:00

maxfox

Re : [Résolu] - Réinstaller Bootloader !

Enlève "boot        ##"

Ensuite, tes essais au prompt de Grub on probablement "décaché" hda1 (la 1ère partition recovery en fat32) :

sudo parted -s /dev/hda set 1 hidden on print

Avec l'option "print" tu auras le résultat de la commande, vérifie qu'hda soit bien marquée "hidden" ou "caché".

Pour le MBR, normalement le tatouage n'empèche pas l'installation de grub, ni le fonctionnement du dualboot, si tant est que ta machine soit "tatouée"...
Mais c'est aussi une des raisons pour laquelle je préfaire la 1ère solution que je t'avais donnée au début.

Dernière modification par maxfox (Le 20/08/2006, à 20:05)

Hors ligne

#18 Le 20/08/2006, à 20:03

cep

Re : [Résolu] - Réinstaller Bootloader !

Bonsoir maxfox et Lndil,

Error 27 vient probablement de boot   ##

Je n'ai pas remonté tout l'historique.

Voir si la partition hda2 est montable et si grub trouve boot.ini et où.

dans le shell grub :   find  /boot.ini   http://forum.ubuntu-fr.org/viewtopic.php?id=6707

Bonne continuation.
cep

Dernière modification par cep (Le 20/08/2006, à 20:05)

Hors ligne

#19 Le 20/08/2006, à 20:04

cep

Re : [Résolu] - Réinstaller Bootloader !

Oups, "scuse" maxfox, je n'avais pas vu ton poste 17.

Byeeeeee

Hors ligne

#20 Le 20/08/2006, à 20:11

maxfox

Re : [Résolu] - Réinstaller Bootloader !

Bonsoir cep

Tes commentaires sont toujours bienvenue...

En mettant # devant le commentaire je pensais qu'ils serait ignoré par Grub dans le cas où Lndil l'aurai effectivement intégré au menu.lst...

En espérant que ce soit effectivement ça le problème.

Hors ligne

#21 Le 20/08/2006, à 20:42

Lndil

Re : [Résolu] - Réinstaller Bootloader !

merci Cep et maxfox (encore une fois ! masi je sais au combien cela (vous) prend du temps!)

bon alors hda1 est bien "caché"

j 'ai suivi lel ien de cep... ca a l air de rejoindre mon probleme est de loin car moi aussi car

grub> find /boot.ini
find /boot.ini
Error 15: File not found

Malheureusement je ne comprend tt ce qui ce dis sur ce post et surtt le montage des DD n'est pas du tt le meme chez moi !

allez j vais rassembler tt mes neurones et j y vais !


EDIT 1:

Alors j ai essayé d'utiliser l'option "map"
j ai édité menu.lst comme cela

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2

title       Windows NT/2000/XP
root        (hd0,1)
map (hd0) (hd1)
map (hd1) (hd0)
savedefault
makeactive
chainloader +1

Puis j ai essayé avec

map (hd1) (hd0)
map (hd0) (hd1)

Dans les 2 cas j ai le mot GRUB qui s'affiche a l infini !!!!


Bon la j vais essayer en éditant comme cela

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1

title       Windows NT/2000/XP
root        (hd0,0)
savedefault
makeactive
chainloader +1

Dernière modification par Lndil (Le 20/08/2006, à 21:04)


Sur Ubuntu depuis 2006

Hors ligne

#22 Le 20/08/2006, à 21:30

Lndil

Re : [Résolu] - Réinstaller Bootloader !

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1

title       Windows NT/2000/XP
root        (hd0,0)
savedefault
makeactive
chainloader +1

me donne grub GEOM error

par contre j ai refait à tt hasard find /boot.ini
résultat ==> (hd0,0)

j vais voir en utilsant l option map si ca sert à qq chose puisque j ai grub geom error

EDIT l option map ni change rien, toujours la meme erreur : Grub GEOM error

Dernière modification par Lndil (Le 20/08/2006, à 21:46)


Sur Ubuntu depuis 2006

Hors ligne

#23 Le 20/08/2006, à 23:15

Lndil

Re : [Résolu] - Réinstaller Bootloader !

Quelqu'un aurait il une moindre idée pour faire avancer mon schmilblick ????

Un bref rappel : Grub est installé et me permet de me lancer sur Ubuntu par contre pas possible pour Xp.
Je rappelle ci dessous les DD en présence et leurs partitions ! (en gras leur fonction pour le 1er!)

Disk /dev/hda: 160.0 GB, 160041885696 bytes
240 heads, 63 sectors/track, 20673 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         541     4089928+   b  W95 FAT32  Une partition de récupération (HP recovery)
/dev/hda2   *         542       12546    90757800    7  HPFS/NTFS La partition où est installé mon merveilleux Xp famillial
/dev/hda3           12547       20673    61440120    f  W95 Ext'd (LBA)
/dev/hda5           12547       20673    61440088+   7  HPFS/NTFS Une partition de données à sauvegarder

Disk /dev/hdb: 10.2 GB, 10245537792 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        1190     9558643+  83  Linux
/dev/hdb2            1191        1245      441787+   f  W95 Ext'd (LBA)
/dev/hdb5            1191        1245      441756   82  Linux swap / Solaris

Le probleme donc !
En éditant menu.lst de différentes façons, avec ou sans l'option map, rien n'a changé (voir posts précédents) et pourtant je pense que Maxfox a bien tt corrigé ...

Alors si vous avez une idée ou que vous avez été dans le cas... UN ENORME MERCI D'AVANCE POUR VOTRE AIDE ! tongue


Sur Ubuntu depuis 2006

Hors ligne

#24 Le 20/08/2006, à 23:32

cep

Re : [Résolu] - Réinstaller Bootloader !

Juste quelques remarques :
- ce (hd0,0) pour boot.ini semble curieux. Si xp a été installé sur hda2 je doute qu'ils aient mis boot.ini sur hda1 ou alors il y a un dual boot avec 98.

- si boot.ini est bien sur hda2 il y a en effet un problème de partitions et hda1 n'est pas interprété.

Vois le site http://www.linux-france.org/article/sys/chargeurs/ix86/grub/grub-manual-fr.html#Commandes%20de%20la%20ligne%20de%20commande%20et%20du%20menu
et les différentes commandes geometry, etc. dans la console de grub.

Ou, autre solution (préférable), avec un cdrom XP tente une réparation du boot avec les recheck, fixboot et compagnie.

Dernière modification par cep (Le 20/08/2006, à 23:33)

Hors ligne

#25 Le 20/08/2006, à 23:39

Lndil

Re : [Résolu] - Réinstaller Bootloader !

bon j vais regarder le lien ...

et après seulement je relancerai pas le cd Xp... je m'en méfie car avec la merde que j ai eu avec cette semaine ca méa calmé et décidé de passer à linux !

merci encore @ vous, cep et maxfox... je vous tiens au courant!

NB: comment je fais pour mettre mon sujet en résolu ??

Dernière modification par Lndil (Le 21/08/2006, à 12:13)


Sur Ubuntu depuis 2006

Hors ligne