Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 28/01/2005, à 12:31

riri

Drivers ATI sur Warthy

Je cherche à installer les drivers ATI sur ma ubuntu amd64, en récupérant le rpm sur le site d'ATI.
Pour faire propre, j'ai voulu convertir le rpm en deb avec alien, mais j'ai une erreur (je vous ai dumpé la sortie d'alien), quelqu'un aurait une idée ?

... la décompression des fichiers ...
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_clean -k
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 |
        xargs -0 -r -i cp -a {} debian/fglrx64-4-3-0
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: format of libfglrx_gamma.1 not recognized
dpkg-shlibdeps: warning: unable to find dependency information for shared library libXext (soname 6, path /usr/X11R6/lib32/libXext.so.6, dependency field Depends)
dpkg-shlibdeps: warning: unable to find dependency information for shared library libX11 (soname 6, path /usr/X11R6/lib32/libX11.so.6, dependency field Depends)
dpkg-shlibdeps: warning: unable to find dependency information for shared library libstdc++ (soname 5, path /usr/lib32/libstdc++.so.5, dependency field Depends)
dpkg-shlibdeps: warning: unable to find dependency information for shared library libX11 (soname 6, path /usr/X11R6/lib32/libX11.so.6, dependency field Depends)
dpkg-shlibdeps: warning: unable to find dependency information for shared library libXext (soname 6, path /usr/X11R6/lib32/libXext.so.6, dependency field Depends)
dh_gencontrol
dpkg-gencontrol: error: current build architecture amd64 does not appear in package's list (x86_64)
dh_gencontrol: command returned error code 65280
make: *** [binary-arch] Erreur 1
        find fglrx64_4_3_0-8.8.25 -type d -exec chmod 755 {} ;
find: fglrx64_4_3_0-8.8.25: Aucun fichier ou répertoire de ce type
        rm -rf fglrx64_4_3_0-8.8.25

Comme on peut le voir, à un moment donné, il cherche x64_64 et ne trouve que amd64 (ou l'inverse :-). Comment cela peut être réglé ?


riri - tulkluteur avertit.
La liberté d'une personne s'arrête où commence celle des autres.

Hors ligne

#2 Le 28/01/2005, à 13:18

riri

Re : Drivers ATI sur Warthy

Je me réponds à moi-même:

Je suis allé plus loin, en regardant le man d'alien.
J'ai lancé
sudo alien --to-deb -g mon.rpm
pour générer la structure du package sans le créer. J'ai ensuite lancé depuis le répertoire de travail la commande
sudo debian/rules binary
comme indiqué dans le man pour générer le package (j'ai fait ça pour bien séparer la décompression de la création).
Et là je retrouve l'erreur. Je regarde l'erreur de près, et je vois qu'il va chercher des dépendances en 32bits [pas bien]. Du coup je vais voir les fameux fichiers à installer, et là grande surprise:
lib = 32bits
lib64 = 64bits
or sur ubuntu :
lib32 = 32bits
lib = 64bits !!
lib64 = lien vers lib !!

J'ai essayé de modifier dans la structure le X11R6 comme ça:
mv lib lib32
mv lib64 lib
(pareil dans le sous-répertoire fglrx64_4_3_0-8.8.25/usr/X11R6)

Mais ça n'a rien changé


riri - tulkluteur avertit.
La liberté d'une personne s'arrête où commence celle des autres.

Hors ligne

#3 Le 28/01/2005, à 13:43

coffee

Re : Drivers ATI sur Warthy

oulah
le bordel pour les drivers ATI
euh tu as vraiment besoin de ces drivers en l'instant? acceleration 3D et sortie télé? car là ça mérite de remonté jusqu'à ATI

Pourrissons leur boite aux lettres lol


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#4 Le 18/02/2005, à 20:12

coffee

Re : Drivers ATI sur Warthy

et avec les nouveaux drivers sortis il y a quelque jours?


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

Haut de page ↑