Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/09/2011, à 22:00

KeeRooL

Portable Sony Vaio Z 2011 (aka VPCZ2)

Assez peu d'informations sont disponibles concernant la compatibilité du portable Sony Vaio Z 2011 (aka VPCZ2) avec Ubuntu (et linux en général).
Je vous propose donc mon retour d'expérience, en espérant que ce sera utile à quelqu'un.

1) Quelques éléments spécifiques à ma configuration matérielle :
- CPU : Intel Core i7-2620M
- RAM : 8 Go
- Disque dur : 128 Go (2 x SSD 64 Go en RAID0)
- Clavier :  AZERTY rétro-éclairé
- Ecran : 1920x1080

Je n'ai pas de module 3G ni le Power Media Dock.

2) Configuration logicielle testée
- Suppression complète de Windows 7
- installation de Kubuntu 11.10 beta1
- partitions root et home en RAID0 logiciel.

3) Installation
3.1) Ceinture et bretelles
J'ai commencé par créer le support de restauration Windows 7 sur clé USB... Au cas où...
Sony fourni un programme qui fait ça très bien. Il faut quand même prévoir 16 Go.

Attention ! Ce portable n'a pas l'air d'être capable de démarrer sur une carte SD.

3.2) Choix du CD d'installation
J'ai testé le live CD "Kubuntu 11.10 beta 1" sans détecter de problème particulier. L'installation doit également fonctionner avec ce CD.
Cela dit, comme je souhaitais monter les disques durs en RAID0, j'ai fait l'installation avec le CD "Kubuntu 11.10 beta 1 alternate".

3.3) Déroulement de l'installation
Attention ! Une connexion filaire à internet vous est indispensable (au moins vraiment très utile).

Les ennuis commencent...
Il faut savoir que l'installation avec le CD "alternate" est un peu plus complexe qu'avec le CD "normal".
Comme si ça ne suffisait pas, l'installation "par défaut" du CD "alternate" plante car il manque le paquet "xserver-xorg-video-ati" dont dépend le paquet "xserver-xorg-video-all".
Il faut donc sélectionner le mode "expert" (dans le menu F6 au démarrage), ce qui permet de déselectionner le paquet "xserver-xorg-video-ati" dans la liste des paquets à installer.

Cela risque de rebuter les plus novices mais ce n'est pas si complexe que ça en fin de compte.
Seules les étapes de partitionnement des disques durs (pour configurer le RAID logiciel) et de sélection des paquets nécessitent de se documenter un minimum.
Pour le reste, les choix par défaut font l'affaire.

3.4) Post-installation
3.4.1) Premier démarrage
Le premier redémarrage est lent (quelques minutes ?) mais il aboutit. Il faut être patient parfois.

3.4.2) Installation des mises à jour
J'ai voulu faire les mises à jour proposées avec l'interface graphique, il doit y en avoir trop car "Muon" (le nouveau gestionnaire de paquets) s'est arrêté de travailler en cours de route.
Aucun message d'erreur, juste une barre d'avancement qui ne progresse plus pendant longtemps.
Je préconise donc de faire la mise à jour dans une console.

3.4.3) Connexion WIFI
J'ai fait l'installation avec un connexion filaire jusqu'à cette étape.
Le module WIFI de ce portable fonctionne très bien sous Kubuntu.
Le problème c'est que le CD "alternate" n'installe pas l'outil de configuration réseau.
Pour cela il faut installer le paquet "plasma-widget-networkmanagement".

4) Bilan
4.1) Ce qui fonctionne "out of the box"
- L'affichage en résolution maximum
- La webcam
- Le réseau filaire
- Le réseau WIFI (il faut quand même installer l'outil de configuration)
- Les touches de volume et de luminosité
- Le clavier rétro-éclairé
- Le pavé tactile (configuration par défaut inhabituelle pour moi : frappe un doigt = clic gauche, frappe deux doigts = bouton du milieu, frappe trois doigts = bouton droit)

4.2) Ce que je n'ai pas encore testé
- La mise en veille/hibernation (j'ai fait l'impasse sur une partition de swap...)
- Le lecteur d'empreinte digitale (c'est un capteur "AuthenTec", il est probablement compatible avec "fprint")
- Les boutons "ASSIST", "WEB" et "VAIO".

4.3) Ce qui ne fonctionne pas
- Mon disque dur externe "Iomega Prestige" quand il est connecté sur le port USB3 (plantage violent du système). Pas de problème sur le port USB2.

Hors ligne

#2 Le 23/09/2011, à 22:09

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Quelques liens utiles :
- http://artifact.gnu-log.net/index.php/L … ies_(2011)
- http://ubuntuforums.org/showthread.php?t=1850544
- http://www.phoronix.com/scan.php?page=a … ower&num=1
- http://bigbrovar.aoizora.org/index.php/ … ntu-11-04/
- http://ubuntuforums.org/showthread.php?p=11286175

Nouveau test avec Kubuntu 11.10 alternate 64 bits en béta 2 :
- L'installation marche sans bidouiller la liste des paquets à installer.
- La mise et veille et l'hibernation fonctionnent.
- Le bouton "WEB" lance le navigateur internet
- Le lecteur d'empreintes digitales ne fonctionne pas avec fprinf.

Dernière modification par KeeRooL (Le 09/10/2011, à 10:36)

Hors ligne

#3 Le 26/09/2011, à 22:36

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut,
Même machine mais l'installation de la 11.04 ne s'est pas bien passées en double boot > grub > no such device
Je pense que c'est à cause du système en raid (détail du boot-info ici http://paste.ubuntu.com/698127/)
Une idée pour une démarche réussie ?
Bonne journée

Dernière modification par nicodup (Le 28/09/2011, à 03:05)

Hors ligne

#4 Le 29/09/2011, à 13:22

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Deux options :
- suis la précédure détaillée ici : http://artifact.gnu-log.net/index.php/L … 1)#install
- supprime le raid du bios et passe en raid software (c'est ce que j'ai fait) en prenant soin de laisser /boot sur une partition non raid

Hors ligne

#5 Le 29/09/2011, à 19:55

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut KeeRooL
Merci de m'avoir répondu.
La manip a l'air un poil velue mais bon.
J'ai passé 3 bonnes heures à réinstaller le pc à partir des dvd de restauration préparer à l'avance (ouf !).
Je viens d'essayer de faire une image du DD avec CloneZilla ; j'ai à nouveau buter sur le pbs de raid.
Comment fait tu pour supprimer le raid du bios et passe en raid software ? avant la procédure de http://artifact.gnu-log.ne je suppose ?
Bonne soirée.

Hors ligne

#6 Le 30/09/2011, à 08:34

malbo

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

KeeRooL,
Sur le modèle concerné, dans la doc j'ai créé une ligne où je donne le lien vers la présente discussion :
http://doc.ubuntu-fr.org/liste_portables_sony#vpc-zxxx
peux-tu vérifier si ce que j'ai mis est correct ? sachant que j'ai retenu que tous les fondamentaux (accès internet en filaire, affichage) sont OK et que le reste est du détail, j'ai considéré que tu n'avais pas de problème d'installation et pas de problème matériel. Si je suis trop optimiste, dis-le.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#7 Le 04/10/2011, à 12:24

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

Salut KeeRooL
Merci de m'avoir répondu.
La manip a l'air un poil velue mais bon.
J'ai passé 3 bonnes heures à réinstaller le pc à partir des dvd de restauration préparer à l'avance (ouf !).
Je viens d'essayer de faire une image du DD avec CloneZilla ; j'ai à nouveau buter sur le pbs de raid.
Comment fait tu pour supprimer le raid du bios et passe en raid software ? avant la procédure de http://artifact.gnu-log.ne je suppose ?
Bonne soirée.

Il faut aller dans le BIOS.
Il y a une option pour afficher l'outil de configuration du raid au démarrage.

Hors ligne

#8 Le 05/10/2011, à 00:35

maxwello

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Bonjour,

moi-même intéressé par ce portable, je suis allé à la SONY boutique près des Champs Elysées à Paris (j'en connais pas d'autres mais des fois que...) pour tripatouiller de la bête. Il faut dire d'abord que t'es reçu comme un roi et on te regarde pas l'air dédaigneux comme dans un Ap...non j'lai pas dit...enfin bref, j'ai demandé à essayer un USB live de la dernière 11.10 beta 2 et pas de problème.. on prend un série Z de la présentation, on file voir les techos et hop on essaie, le tout avec le sourire.  Après, on a pas essayer le dual boot install mais bon, tout était reconnu.
En tout cas, special dedicace à cette boutique 'très chicos" certes mais très accueillante par son personnel avenant.
Voilà. A bientôt quand j'aurais la bête entre les mains !

Hors ligne

#9 Le 06/10/2011, à 00:06

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

;Salut,
J'ai donc supprimé le raid dans le bios et ai ré-installé W7 sur un sdd et mon cher Ubuntu sur l'autre.
Tout fonctionne plutôt bien sauf
- Le lecteur d'empreintes digitales ne fonctionne pas avec fprinf
- Les boutons Assist et Vaio ne produisent aucun effet
- Le bouton web ne lance pas le navigateur mais 20 pages d’accueil lorsqu'il est ouvert
- Le pilote ATI ne va bien non plus ("Il y avait un problème d'initialisation dans l'édition Catalyst Control Center Linux  Il peut provenir du suivant. Aucun pilote graphique ATI n'est installé, ou bien le pilote ATI ne fonctionne pas correctement.
Veuillez installer le pilote ATI approprié à votre matériel ATI, ou configurez avec aticonfig")
- J'ai un écran noir à la reprise de veille, pas encore essayé l'hibernation ; je dois préciser que j'ai modifier grub comme expliquer ici forum ubuntu sony vaio, ce qui me fait un démarrage un peu lent
- le service mysql de xampp ne se lance pas mais c'est hors sujet de cette discussion hmm
Je me serais un peu battu, et ce n'est pas tout à fait fini, mais cette machine est exceptionnelle, je n'ai jamais vu un portable aussi léger et un système aussi rapide.
A+

Dernière modification par nicodup (Le 06/10/2011, à 00:15)

Hors ligne

#10 Le 06/10/2011, à 01:59

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

;Salut,
J'ai donc supprimé le raid dans le bios et ai ré-installé W7 sur un sdd et mon cher Ubuntu sur l'autre.
Tout fonctionne plutôt bien sauf
- Le lecteur d'empreintes digitales ne fonctionne pas avec fprinf
- Les boutons Assist et Vaio ne produisent aucun effet
- Le bouton web ne lance pas le navigateur mais 20 pages d’accueil lorsqu'il est ouvert
- Le pilote ATI ne va bien non plus ("Il y avait un problème d'initialisation dans l'édition Catalyst Control Center Linux  Il peut provenir du suivant. Aucun pilote graphique ATI n'est installé, ou bien le pilote ATI ne fonctionne pas correctement.
Veuillez installer le pilote ATI approprié à votre matériel ATI, ou configurez avec aticonfig")
- J'ai un écran noir à la reprise de veille, pas encore essayé l'hibernation ; je dois préciser que j'ai modifier grub comme expliquer ici forum ubuntu sony vaio, ce qui me fait un démarrage un peu lent
- le service mysql de xampp ne se lance pas mais c'est hors sujet de cette discussion hmm
Je me serais un peu battu, et ce n'est pas tout à fait fini, mais cette machine est exceptionnelle, je n'ai jamais vu un portable aussi léger et un système aussi rapide.
A+

Le pilote ATI c'est pour quoi? Tu as le PMD ?

Hors ligne

#11 Le 06/10/2011, à 17:01

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut,
Pilote graphique FGLRX propriétaire pour ATI/AMD (activé)

Mais un lspci -l me répond

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Sony Corporation Device 9084
    Flags: bus master, fast devsel, latency 0, IRQ 68
    Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at a0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at a000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel modules: i915

et

16:00.0 VGA compatible controller: ATI Technologies Inc Device 6740 (prog-if 00 [VGA controller])
    Subsystem: Sony Corporation Device 9084
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Memory at c0200000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at 5000 [size=256]
    Expansion ROM at c0240000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: fglrx_pci
    Kernel modules: fglrx, radeon

J'ai bien le PMD en version graveur de BR et c'est lui qui met le bazar car lorsque je le retire le pc démarre comme l'éclair roll
En même temps, je perds l'affichage à la mise en veille ou à la déconnexion, je n'ai pas les effets visuels et en retirant le PDM, je n'ai pas de pilotes supplémentaires nécessaires.

On peut dire que mon système n'est pas tout à fait stabilisé sad

Dernière modification par nicodup (Le 06/10/2011, à 18:32)

Hors ligne

#12 Le 07/10/2011, à 08:49

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

En regardant sur le net, j'ai trouvé un bug référencé sur cette carte graphique bugs.launchpad.net
Il est confirmed et Unassigned , c'est pas gagné.
Ceci étant, ça n'a pas de rapport avec mon pbs d'écan noir à la reprise, ni celui du bricolage de grub pour le démarrage, nic celui de l'absence d'effets qui persistent alors que j'ai retiré le pmd hmm
Dans l'état, tous mes espoirs sont fondés sur la sortie de la 11.10

Dernière modification par nicodup (Le 07/10/2011, à 09:08)

Hors ligne

#13 Le 07/10/2011, à 19:22

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

;Salut,
J'ai donc supprimé le raid dans le bios et ai ré-installé W7 sur un sdd et mon cher Ubuntu sur l'autre.
Tout fonctionne plutôt bien sauf
- Le lecteur d'empreintes digitales ne fonctionne pas avec fprinf
- Les boutons Assist et Vaio ne produisent aucun effet
- Le bouton web ne lance pas le navigateur mais 20 pages d’accueil lorsqu'il est ouvert
- Le pilote ATI ne va bien non plus ("Il y avait un problème d'initialisation dans l'édition Catalyst Control Center Linux  Il peut provenir du suivant. Aucun pilote graphique ATI n'est installé, ou bien le pilote ATI ne fonctionne pas correctement.
Veuillez installer le pilote ATI approprié à votre matériel ATI, ou configurez avec aticonfig")
- J'ai un écran noir à la reprise de veille, pas encore essayé l'hibernation ; je dois préciser que j'ai modifier grub comme expliquer ici forum ubuntu sony vaio, ce qui me fait un démarrage un peu lent
- le service mysql de xampp ne se lance pas mais c'est hors sujet de cette discussion hmm
Je me serais un peu battu, et ce n'est pas tout à fait fini, mais cette machine est exceptionnelle, je n'ai jamais vu un portable aussi léger et un système aussi rapide.
A+

Au fait, concernant le raid, je me demande si tu n'as pas la possibilité de créer un volume raid dans le bios qui n'occupe pas l'ensemble des disques.
Ca te permettrait de rester en raid sous windows et de créer le volume raid logiciel pour linux avec l'espace disque restant.
Il faut juste garder une partition primaire non raid pour le filesystem /boot et le swap.
Il n'y a toutefois pas vraiment d'intérêt à mettre le swap en raid.
Il me semble d'ailleurs qu'il existe un driver swapfs pour windows qui permet d'utiliser la partition de swap linux pour le fichier d'échange windows.

En ce qui me concerne, j'ai opté pour un système full linux en raid0. Windows sera installé dans virtualbox, ce qui suffira amplement vu l'usage que j'en ai. Note toutefois que je doute que la restauration windows fonctionne dans une machine virtuelle (la clé de licence OEM ne fonctionne pas il me semble).

Hors ligne

#14 Le 18/10/2011, à 00:43

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut,
J'ai profité de la sortie de la 11.10 pour refaire une installation sans connecter le pmd et cela n'a que peut résolu mes soucis :
* j'ai dû à nouveau inclure nomodset dans grub pour éviter l'écran noir au démarrage
* je n'ai pas les effets dans l'interface graphique (pas de demande de pilotes supplémentaires)
* je perds l'écran à la veille ou à la déconnexion (très chiant)
Je désespère, elle marche tellement vite sad
Un lspci me donne

nicolas@nicolas-Vaio:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
04:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Un coup de main, une piste ?

Dernière modification par nicodup (Le 18/10/2011, à 00:57)

Hors ligne

#15 Le 02/11/2011, à 18:37

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Bonjour,
Quelques nouvelles pour mettre à jour le post
J'ai résolu l'essentiel de mes soucis en installant le kernel 3.1 (https://launchpad.net/~kernel-ppa/+archive/ppa)
Tout fonctionne bien sauf :

    la gestion satisfaisante de la batterie (mais il y a un ajout à faire dans grub que je n'ai pas encore fait))
    la mise en veille et hibernation
    le lecteur d'empreintes digitales
    le PMD (média dock) et sa deuxième carte graphique ATI

J'ai trouvé l'aide nécessaire sur la liste de diffusion sony-vaio-z-series@lists.launchpad.net (https://launchpad.net/~sony-vaio-z-series) ; les membres sont vraiment fort et très disponibles. Anglais indispensable, la liste est internationale.

Hors ligne

#16 Le 08/11/2011, à 13:21

Manolo35

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

Bonjour,
Quelques nouvelles pour mettre à jour le post
J'ai résolu l'essentiel de mes soucis en installant le kernel 3.1 (https://launchpad.net/~kernel-ppa/+archive/ppa)
Tout fonctionne bien sauf :

    la gestion satisfaisante de la batterie (mais il y a un ajout à faire dans grub que je n'ai pas encore fait))
    la mise en veille et hibernation
    le lecteur d'empreintes digitales
    le PMD (média dock) et sa deuxième carte graphique ATI

J'ai trouvé l'aide nécessaire sur la liste de diffusion sony-vaio-z-series@lists.launchpad.net (https://launchpad.net/~sony-vaio-z-series) ; les membres sont vraiment fort et très disponibles. Anglais indispensable, la liste est internationale.

Hello, as tu réussi à faire fonctionner le port VGA pour brancher un écran ou un videoprojecteur et pouvoir régler la résolution ?

Merci,

Manolo

Hors ligne

#17 Le 09/11/2011, à 19:06

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut,

Sans problème aucun.

J'ai par ailleurs modifié grub en ajoutant pcie_aspm i915.i915_enable_rc6=1 et la gestion d'énergie est effectivement meilleure.
Ce week-end je m'attaque au sony-laptop-module et ajouterai ici les résultats.

En passant, j'ai installé gnome shell à la place d'Unity, quel bonheur.
Esthétique, efficace et personnalisable, GS m'a réconcilié avec mon interface.
Merci à www.webupd8.org and www.tux-planet.fr.

Reste à retrouver un écran de veille (à part xscreen-saver qui oblige à des effets qui ne me vont pas) qui me permette de faire défiler mes photos et ça ira bien.

Hors ligne

#18 Le 10/11/2011, à 11:44

Manolo35

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

Salut,

Sans problème aucun.

J'ai par ailleurs modifié grub en ajoutant pcie_aspm i915.i915_enable_rc6=1 et la gestion d'énergie est effectivement meilleure.
Ce week-end je m'attaque au sony-laptop-module et ajouterai ici les résultats.

En passant, j'ai installé gnome shell à la place d'Unity, quel bonheur.
Esthétique, efficace et personnalisable, GS m'a réconcilié avec mon interface.
Merci à www.webupd8.org and www.tux-planet.fr.

Reste à retrouver un écran de veille (à part xscreen-saver qui oblige à des effets qui ne me vont pas) qui me permette de faire défiler mes photos et ça ira bien.

Ok, tu pourrais me rappeler ta version d'ubuntu, du noyau et si tu as installé des pilotes pour la carte graphique ?

Merci,

Manolo

Hors ligne

#19 Le 10/11/2011, à 14:59

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

11.10 + kernel 3.1, pas de pilotes proprio

Hors ligne

#20 Le 10/11/2011, à 15:21

Manolo35

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

nicodup a écrit :

11.10 + kernel 3.1, pas de pilotes proprio

merci. Pourrais tu m'indiquer la marche à suivre pour installer grub2 à la main ? (A partir de l'erreur "no such device" à l'installe), merci!

Hors ligne

#21 Le 17/11/2011, à 00:35

KeeRooL

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Quelques info sur l'augmentation de l'autonomie de ce portable :

J'ai fait plusieurs tests en mesurant la consommation du PC avec PowerTOP 1.13 (Cf. lien sur cette page :https://wiki.ubuntu.com/Kernel/PowerManagement)
Les consommations indiquées correspondent à la moyenne de 6 mesures (ça reste à peu près stable à +/- 0,2 W), la 1ère est exclue car souvent très différente des suivantes.
Tests effectués sous Kubuntu 11.10 64 bits alternate.

- Consommation mesurée avant toute modification : 15,4 W

- Un noyau expérimental vient de sortir mais je ne l'ai pas testé :
https://wiki.ubuntu.com/Kernel/PowerManagement

- paramètres grub :
modifier le fichier /etc/default/grub
ajouter les paramètres "i915.i915_enable_rc6=1 pcie_aspm=force" à la ligne GRUB_CMDLINE_LINUX
--> gain significatif constaté, consommation = 11,3 W

J'ai testé avec les paramètres "i915.i915_enable_fbc=1 i915.lvds_downclock=1" en plus
--> très léger gain constaté, consommation = 11,1 W

- Installation de TLP (https://github.com/linrunner/TLP/wiki/T … Management)
--> étrangement c'est moins bien que sans... Cela dit, avant l'installation la batterie était indiquée comme complètement chargée alors qu'après l'installation et redémarrage elle n'était chargée qu'à 97%. Ca explique peut être l'écart.
Après recharge à 100%, consommation = 12,3 W


En conclusion, je conseille d'ajouter au moins les paramètres ""i915.i915_enable_rc6=1 pcie_aspm=force" dans le fichier de configuration de grub. Ca fait gagner pas loin d'une heure d'autonomie.
Pour ce qui est de TLP, je ne sais pas trop quoi en penser... Quand je le désactive, la consommation monte à 12,8 W. Il est donc intéressant de l'activer une fois installé, mais est-ce une bonne idée de l'installer ? Je n'en suis pas convaincu.

Hors ligne

#22 Le 01/12/2011, à 14:49

nicodup

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Salut,

Je confirme pour i915.i915_enable_rc6=1 pcie_aspm=force

J'ai pour ma part installé  Jupiter et je parviens à plus de 6h d'autonomie en désactivant le wifi et le bluetooth, ainsi qu'en réglant la luminosité au quasi mini.

Hors ligne

#23 Le 02/12/2011, à 02:24

thazun

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Bonjour à tous,

Je viens aussi d'acquérir le vaio Z21. J'ai installé la 11.10 dessus et apparemment presque tout semble fonctionner.
Par contre j'ai essayé d'ajouter "i915.i915_enable_rc6=1 pcie_aspm=force" dans le fichier de configuration de grub pour sauver de la batterie, mais après le sudo update-grub et un redémarrage, j'ai mon écran ou ma carte graphique qui déconnent complètement (clignotements incessants, bandes lumineuses verticales), ce qui fait que je n'arrive plus à rien faire.

Avez vous rencontré ce problème aussi ?
Merci de votre réponse.

Thazun

Hors ligne

#24 Le 02/12/2011, à 10:22

Manolo35

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

thazun a écrit :

Bonjour à tous,

Je viens aussi d'acquérir le vaio Z21. J'ai installé la 11.10 dessus et apparemment presque tout semble fonctionner.
Par contre j'ai essayé d'ajouter "i915.i915_enable_rc6=1 pcie_aspm=force" dans le fichier de configuration de grub pour sauver de la batterie, mais après le sudo update-grub et un redémarrage, j'ai mon écran ou ma carte graphique qui déconnent complètement (clignotements incessants, bandes lumineuses verticales), ce qui fait que je n'arrive plus à rien faire.

Avez vous rencontré ce problème aussi ?
Merci de votre réponse.

Thazun

Bonjour,

Avez vous eu le problème avec grub à l'installation ? Pouvez vous m'indiquer comment avez vous procédé pour l'installer manuellement ?

Merci,

Manolo

Hors ligne

#25 Le 02/12/2011, à 16:00

thazun

Re : Portable Sony Vaio Z 2011 (aka VPCZ2)

Bonjour Manolo,

Avant l'installation, j'ai chargé ubuntu-live de ma clé usb, puis j'ai effacé tout windows, j'ai repartitionné et formaté mon disque dur (que j'ai laissé en RAID0).

Lors de l'installation, j'ai simplement indiqué au programme d'installation de mettre grub sur le volume0 (linux quelquechose ...)

Après redémarrage, presque tout marche "out of the box".

Après, j'ai édité le fichier /etc/default/grub et remplacé la ligne
GRUB_CMDLINE_LINUX=""
par
GRUB_CMDLINE_LINUX="i915.i915_enable_rc6=1 pcie_aspm=force"

Après avoir sauvegardé, j'ai tapé "sudo update-grub" puis redémarré. C'est là que les problèmes ont commencé.

Merci de votre aide.
Thazun

Hors ligne

Haut de page ↑