Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 10/10/2011, à 19:22

Le huttin

Connection internet impossible carte réseau Atheros AR8152

Bonjour à tous,

Déjà merci pour tout ceux qui font vivre la communauté du libre, laissant une échappatoire à cette affreuses fenêtres  quadricolore.

Mon problème le  voici:

Sous Linux depuis deux trois années malgré une une connaissance informatique basique, je me suis vus contraint de faire l'acquisition d'un portable sous Windows, j'ai donc naturellement effectué un dual boot pour profiter de mon OS favoris malgré tout.

Le soucis est que sous ubuntu (10.04) je n'ai aucune connections.

J'ai fait les manip demandé dans le post d 'explication et ça me donne ceci:

josselin@josselin-laptop:~$ sudo lshw -C network
[sudo] password for josselin: 
  *-network UNCLAIMED     
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:d7100000-d7103fff
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR8152 v2.0 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:04:00.0
       version: c1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list
       configuration: latency=0
       resources: memory:d6100000-d613ffff ioport:2000(size=128)
ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:156 errors:0 dropped:0 overruns:0 frame:0
          TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:12208 (12.2 KB)  TX bytes:12208 (12.2 KB)
cat  /etc/network/interfaces
auto lo
iface lo inet loopback
interfaces réseau)
nm-tool

josselin@josselin-laptop:~$ interfaces réseau
interfaces: command not found
josselin@josselin-laptop:~$ nm-tool

NetworkManager Tool

State: disconnected

Voilà tout ce que j'obtiens.

Hors ligne

#2 Le 21/10/2011, à 12:34

Le huttin

Re : Connection internet impossible carte réseau Atheros AR8152

Up personne ne peut m'aider ?

Hors ligne

#3 Le 21/10/2011, à 13:56

Le huttin

Re : Connection internet impossible carte réseau Atheros AR8152

Merci whoies de m'aider.

Alors voila ce que ça donne :

josselin@josselin-laptop:~$ lspci -nn | grep -i net
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8176] (rev 01)
04:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
josselin@josselin-laptop:~$ lsmod
Module                  Size  Used by
binfmt_misc             7960  1 
ppdev                   6375  0 
joydev                 11104  0 
fbcon                  39270  71 
tileblit                2487  1 fbcon
font                    8053  1 fbcon
bitblit                 5811  1 fbcon
softcursor              1565  1 bitblit
vga16fb                12757  1 
vgastate                9857  1 vga16fb
snd_hda_intel          25805  2 
snd_hda_codec          85759  1 snd_hda_intel
snd_hwdep               6924  1 snd_hda_codec
snd_pcm_oss            41394  0 
snd_mixer_oss          16299  1 snd_pcm_oss
snd_pcm                87946  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1782  0 
snd_seq_oss            31191  0 
snd_seq_midi            5829  0 
snd_rawmidi            23420  1 snd_seq_midi
snd_seq_midi_event      7267  2 snd_seq_oss,snd_seq_midi
snd_seq                57481  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23649  2 snd_pcm,snd_seq
snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
nouveau               515227  0 
snd                    71283  15 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ttm                    61007  1 nouveau
uvcvideo               62851  0 
videodev               40518  1 uvcvideo
v4l1_compat            15495  2 uvcvideo,videodev
v4l2_compat_ioctl32    11892  1 videodev
psmouse                65040  0 
serio_raw               4918  0 
soundcore               8052  1 snd
snd_page_alloc          8500  2 snd_hda_intel,snd_pcm
intel_agp              29319  0 
video                  20623  0 
drm_kms_helper         30742  1 nouveau
output                  2503  1 video
drm                   198886  3 nouveau,ttm,drm_kms_helper
i2c_algo_bit            6024  1 nouveau
lp                      9336  0 
parport                37160  2 ppdev,lp
usbhid                 41116  0 
hid                    83888  1 usbhid
ahci                   38030  2 
josselin@josselin-laptop:~$ 

Hors ligne

#4 Le 02/11/2011, à 00:52

kikibelux

Re : Connection internet impossible carte réseau Atheros AR8152

bonjour,

j'ai le même soucis avec une carte de ce nom là.

en utilisant ubuntu 11.10 11.4  cela marche mais pas avec ubuntu 10.10 et tangostudio

J'aimerais savoir comment je peux voir et comparer les modules utilisés par l'une et l'autre afin de voir ce que je dois télécharger....

MERCI


actuelement sur ubuntu 12.04 64b gnome-shell
ex :KDE4.2 Kubuntu 10.04 64b
--------------------------------------------------------------------
Kikibelux issu de  www.loligrub.be  un LUG belge avec de la bière belge et Libre...)

Hors ligne

#5 Le 06/11/2011, à 21:35

Le huttin

Re : Connection internet impossible carte réseau Atheros AR8152

Bonjour,

désolée de n'avoir pas répondue plus tôt.
whoies: je n'ai  pas réussis les manips que tu m'a donné, j'ai donc essayé la dernière versions d'Ubuntu et là j'ai toutes mes connections de dispo donc dans un sens mon problème est réglé.
Sachant que le problème est réglé sur la 11.10 est ce que les solutions serons porté sur la LTS ?

Hors ligne

#6 Le 16/11/2011, à 22:55

Yenim

Re : Connection internet impossible carte réseau Atheros AR8152

Bonjour à tous,
Je suis nouveau sur Ubuntu, et je viens de l'installer sur mon e-pc Asus,

Je n'arrive pas à me connecter sur internet, ni par wifi, ni par câble.
Network manager ne reconnait aucune connexion, alors que je suis actuellement connecté à un mac qui est connecté via wifi à internet.

Donc en faisant quelques recherche sur le net, j'ai trouvé cette discussion.
J'ai fait toute les manips et le modèle de mon Ethernet controller est Atheros Communications AR8152
Vi

Hors ligne

#7 Le 16/11/2011, à 23:04

Yenim

Re : Connection internet impossible carte réseau Atheros AR8152

la suite du message... (Suite à une erreur, j'ai envoyé le message incomplet)

Via la manip suivant " lspci -V" voilà ce qu'on me dit :

02:00.0 Ethernet controller : Atheros Communications AR8152 v2.0 ....
             .....
             .....
             Capabilities : <access denied>

et il en est de même pour mon Network controller.

J'ai ensuite essayer la manip conseiller par WHOIES " /lib/modules/version du noyau/kernel/drivers/net

Et voilà la réponse :

bash : /lib/modules/2.6.32-33-generic/kernel/drivers/net : is a directory

J'ai bien compris qu'il fallait télécharger les firmwares mais je ne comprend pas la réponse de la manip /lib/modules

Merci d'avance,

Hors ligne

#8 Le 17/11/2011, à 21:48

Yenim

Re : Connection internet impossible carte réseau Atheros AR8152

Bonjour,

Désolé de répondre si tard, mais j'étais au bureau toute la journée ...

Merci pour la réponse, et voici les réponses aux configs demandées :

sudo ifconfig - a

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:140 errors:0 dropped:0 overruns:0 frame:0
          TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10960 (10.9 KB)  TX bytes:10960 (10.9 KB)

pan0      Link encap:Ethernet  HWaddr 16:05:a7:6c:05:68 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sudo lshw -C network

  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f9ffc000-f9ffffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR8152 v2.0 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:01:00.0
       version: c1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list
       configuration: latency=0
       resources: memory:f5fc0000-f5ffffff ioport:dc00(size=128)

cat /etc/network/interfaces

auto lo
iface lo inet loopback


nm-tool

NetworkManager Tool

State: disconnected

J'ai fais plusieurs recherche, lesquelles n'ont rien données,

Voilà les liens :

http://forum.ubuntu-fr.org/viewtopic.php?id=420709

http://ubuntuforums.org/showthread.php?p=9449490

Encore merci pour la réponse,

Hors ligne

#9 Le 20/11/2011, à 19:57

Yenim

Re : Connection internet impossible carte réseau Atheros AR8152

Bonsoir,

En fait, je n'ai aucune connexion sur le pc en question, ni filaire, ni wifi.
Je suis actuellement connecté sur un autre pc (plus ancien) sur lequel j'ai aussi installé Ubuntu 10.04 et pour lequel les cartes réseau et wifi fonctionnent très bien.

J'imagine que la "session LiveCD" signifie que je dispose du CD d'installation ???
Ce qui n'est pas le cas, j'ai installé Ubuntu via une clé USB sur Windows.

J'imagine donc que les commandes pour installer le build-essential ne marcheront pas !

A propos du lien pour le téléchargement, je peux éventuellement télécharger les pilotes via un pc qui a une connexion et les installer sur l'autre pc (qui n'a pas de connexion) avec une clé USB ?

Merci pour l'aide,

Hors ligne

#10 Le 29/11/2011, à 22:16

meuh.huem

Re : Connection internet impossible carte réseau Atheros AR8152

Bonjour,

j'ai un problème similaire avec ma carte Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1).
Après plusieurs jours de lutte sans merci, je ne sais plus quoi faire...
Le pb:
- démarrage du pc = tout fonctionne (même trop bien puisque la carte wifi et la carte ethernet obtiennent toutes les deux une connexion différente (deux IP, etc.)
- désactivation de la connection wifi via network manager pour éviter les embrouilles
- la carte ethernet fonctionne un certain temps (entre 10 minutes et plusieurs heures)
- la connexion filaire "saute" (sans raison apparente, si ce n'est pê un download ou un upload via firefox ??)
- impossible alors d'obtenir une IP pour cette carte
=> passage en wifi pour garder une connexion ou redémarrage du pc pour retrouver le filaire...

infos:
> lspci
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
04:00.0 VGA compatible controller: nVidia Corporation Device 0a76 (rev a2)

> uname -r
2.6.35-22-generic-pae
(maverick)

pc: ASUS eeepc 1215N

drivers:
Atheros: wl
Broadcom: atl1c

En installant le noyau 2.6.35-31.62, j'ai perdu la connexion wifi => retour au 35-22-generic-pae, réinstall des drivers, etc.

Des idées ?
Merci,

Meuh

Hors ligne

#11 Le 01/12/2011, à 17:39

meuh.huem

Re : Connection internet impossible carte réseau Atheros AR8152

Hou hou ... ?? Personne ?

Maintenant, même plus de filaire au démarrage... :s

Merci,

Meuh

Hors ligne

#12 Le 05/12/2011, à 22:27

Yenim

Re : Connection internet impossible carte réseau Atheros AR8152

En migrant vers une version plus récente... les cartes réseaux et Ethernet ont des chances d'être reconnue!

Hors ligne

#13 Le 05/12/2011, à 22:47

kikibelux

Re : Connection internet impossible carte réseau Atheros AR8152

oui  je le sais bien,  et c'est fonctionnel sous ubuntu 11.10 mais le hic j'ai un multiboot avec une TangoStudio qui est basé sur 10.04...
pour compiler le drive,  je recherche un meta paquet qui me permettrait de compiler...


actuelement sur ubuntu 12.04 64b gnome-shell
ex :KDE4.2 Kubuntu 10.04 64b
--------------------------------------------------------------------
Kikibelux issu de  www.loligrub.be  un LUG belge avec de la bière belge et Libre...)

Hors ligne

#14 Le 05/12/2011, à 23:27

meuh.huem

Re : Connection internet impossible carte réseau Atheros AR8152

même pb pour moi avec maverick.
Et surtout je ne comprends pas pourquoi "hop, ça marche pis hop, ça marche plus" !!

Hors ligne

#15 Le 06/12/2011, à 16:06

kikibelux

Re : Connection internet impossible carte réseau Atheros AR8152

Pour ma part, j'ai ce problème lorsque je suis sous Tango-Studio
mais c'est Nickel sous Ubuntu 11.10; donc pourrais-je transférer les drives, dans la positive, quels sont les fichiers ?

Dernière modification par kikibelux (Le 06/12/2011, à 20:26)


actuelement sur ubuntu 12.04 64b gnome-shell
ex :KDE4.2 Kubuntu 10.04 64b
--------------------------------------------------------------------
Kikibelux issu de  www.loligrub.be  un LUG belge avec de la bière belge et Libre...)

Hors ligne

#16 Le 15/02/2012, à 23:22

DARsKater

Re : Connection internet impossible carte réseau Atheros AR8152

Perso j'ail le même problème, lorsque je fais ceci :

whois a écrit :

cd "répertoire ou se trouve le fichier wireless-2011-11-16.tar.bz2
tar -xjvf wireless-2011-11-16.tar.bz2
cd compat-wireless-2011-11-16
scripts/driver-select atl1c
make
sudo make install
sudo modprobe atl1c

cela me rétablit le eth0 mais toujours impossible d'avoir le wifi !

Quelqu'un pour m'aider svp ?

Hors ligne

Haut de page ↑