Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 17/10/2011, à 19:29

ubatrime

RME HDSP 9632 sous Ubuntu 11.10

Je suis un utilisateur assez récent d'Ubuntu (11.04 puis 11.10).
J'apprécie, sur un système récent à base d'intel I5, l'excellente reconnaissance des périphériques. Ainsi, pour le son, la sortie HDMI de ma carte vidéo est parfaitement identifiée, de même que le chipset son de ma gigabyte. Malheureusement, il n'en va pas de même pour ma carte son RME HDSP 9632.

Cette carte semble parfaitement reconnue par ubuntu et apparaît dans tous les tests, sauf dans l'utilitaire de configuration du son "réglages du son" (en haut à droite de l'écran) où seules les 2 autres cartes sont reconnues. Mais, surtout, HDSPMIXER, s'il figure bien dans les applications pouvant être lancées dans le tableau de bord, ne produit aucun effet et ne s'affiche pas du tout. Idem si on tente de lancer hdspmixer en mode console. A la différence de hdspconf qui se lance mais sans synchronisation possible.

En fait, pour cette carte, j'ai lu à peu près tout et son contraire mais pas de modus operandi explicite. Ainsi, certains disent que :
- le dernier driver de cette carte ne fonctionnerait pas sous linux
- Ubuntu 11 n'inclurait pas le HDSPmixer qu'il faut installer à part, mais je n'ai pas compris comment
- il faudrait utiliser un module ALSA différent
- ...

Je suis donc preneur d'une expérience d'installation réussie de ce matériel sous UBUNTU 11.04 ou 11.10.

Merci à tous.

Hors ligne

#2 Le 04/12/2011, à 18:19

fcn50

Re : RME HDSP 9632 sous Ubuntu 11.10

Salut ubatrime,

J'ai moi-même une RME 9632 parfaitement fonctionnel sous ubuntu 10.10. Il vrai que ça n'est pas évident quand on y connait rien, j'étais dans la même situation il y a quelques mois!

Cette CS ne peux pas passer par pulseaudio qui est un serveur son pour cartes embarquées que tu as probablement installé d'office avec ubuntu. Tu dois au pire désactiver pulseaudio au mieux le virer et ensuite dans synaptic tu installes: alsa-tools-gui, alsa-firmware-loaders qui sont les éléments indispensables pour la RME. Puis tu auras dans Applications>son et video>HDSPMixer qui le contrôle des piste et volume de la CS. Mais avant il FAUT désactiver pulseaudio et au mieux le virer, ce qui est déjà plus compliqué d'après mes souvenirs. Perso je fais des install minimales pour éviter de devoir me farcir ce genre de complications et mettre uniquement ce qu'il me faut, sinon c'est l'usine à gaz roll

Tiens moi au courant si tu as besoin d'aide.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 10/04/2012, à 08:48

ubatrime

Re : RME HDSP 9632 sous Ubuntu 11.10

En fait j'ai résolu une grande partie des pbs :

1. Le firmware de la carte peut, sans inconvénient, être updaté (154, le dernier). Voilà pour les questions sur ce point : apparemment, inutile de revenir à un vieux firmware, opération au demeurant assez coton (fut à lancer avec Win XP).
2. l'extension 4 entrées analogiques (AO4S), que je possède, interdit chez moi le lancement de HDSPMIXER. Il faut donc la débrancher. Pas glop.
3. Le bon fichier alsa-tools-gui est le 1.0.25-1 ( http://packages.debian.org/sid/i386/als … /download). Ce qui est tout de même mieux que les retours à de vieux frmware, surtout si on utilise aussi la carte avec Windows. Glop.
A installer avec DPKG, en se plaçant dans le bon répertoire : sudo dpkg -i alsa-tools-gui_1.0.25-1_i386.deb

Voilà résolu le mystère du HDSPMIXER absent.

J'ai donc réussi à créer une entrée guitare ; les vu-mètres décollent, mais, dans ARDOUR, je n'ai pas toujours pas de son.
Si quelqu'un a une idée, car Jack est encore mystérieux pour moi. Ainsi, j'ai cru comprendre que Jack doit être lancé et configuré en 1er mais :
- faut-il choisir dans Jack, comme périphériques : "RME Hammersfall HDSP 9632" ou "Hammersfall dsp" ?
- Quelles autres options à cocher ?
- Jack doit-il bien être en maître dans Ardour ?

Voilà, merci et bon courage à tous.

Hors ligne

#4 Le 10/04/2012, à 08:54

ubatrime

Re : RME HDSP 9632 sous Ubuntu 11.10

Ah, oui. Si quelqu'un a pu faire fonctionner la HDSP 9632 en conservant Pulse, merci de le signaler, car la compatibilité entre les deux est aussi une interrogation récurrente.

Hors ligne

#5 Le 06/05/2012, à 19:34

caracala

Re : RME HDSP 9632 sous Ubuntu 11.10

Salut,

effectivement hdspmixer n'est pas fonctionnel sur 11.04, je vérifie d'ailleurs de ce pas si il marche sur la nouvelle 12.04 LTS!

Au sujet de ton AI4S, j'ai rencontré le même problème au début. En fait, c'est l'interface graphique d'hdspmixer qui ne semble pas autoriser à avoir plus de pistes en entrée qu'en sortie!
Pour pouvoir utiliser une des deux extensions de ce type, il faut donc... avoir les deux (AI4S + AO4S)! Et là plus de problème, 16 in et 16 out.

Quelques explications sur jack et ardour, tes "clients en lecture" sortent le son qui provient des entrées physiques (1ere ligne dans hdspmixer), les "clients en ecriture" permettent d'envoyer sur
les playbacks(sorties virtuelles) de la carte, soit la 2eme ligne dans hdspmixer. A toi de router ensuite vers les bonnes sorties physiques.

Dans jack, ce doit normalement etre "RME Hammersfall HDSP 9632", pour les autres reglages : activer temps réel ; priorité à 80 ; périodes/tampon : 2 ; échantillon/période : de 64 à + en fonction de la stabilité ; si tu laisses tout le reste ça devrait fonctionner.

Dans ardour : Jack doit etre maitre seulement si d'autres logiciels (séquenceurs etc.) y sont connectés, sinon pas la peine. N'oublie pas aussi de verifier donc la connexion entre "clients en lecture" dans jack et l'entrée de la piste désirée dans Ardour.

Pour pulseaudio, il fonctionne chez moi et capte seulement les sons du navigateur (flash et autres qui ne sont pas compatibles jack). Il fonctionne avec la puce intégrée qui est paramétrée en digital 48kHz et renvoie en spdif sur la RME (port optique que je n'utilise pas). Comme ça, meme si jack n'est pas lancé, il suffit de re-router directement l'entrée spdif sur ta sortie HP dans hdspmixer. D'autres solutions, logicielles, existent mais sont très peu stables, et chez moi pulse audio fais planter Jack car il est trop lent.

Le site linuxmao.org peut largement t'aider si tu as des soucis de ce genre!

Bon courage

Hors ligne

#6 Le 07/03/2013, à 19:36

ubatrime

Re : RME HDSP 9632 sous Ubuntu 11.10

Pour clore le sujet, voici une config basique simple qui marche bien :

- le cas échéant , débrancher extensions RME (ai4s ou ao4s). Du moins si vous n'avez que l'une ou l'autre.
- Désinstaller Pulseaudio via synaptic
- Taper hdsp dans synaptic et installer les paquets proposés (alsa tools gui et alsa firmware loader)
- Activer sorties analogiques dans hdsp mixer (an1 + 2). Laisser hdspmixer apparent pour vérifier arrivée son.
- Totem (lecteur video fourni avec ubuntu) marche direct pour lecture mp3.

Hors ligne

#7 Le 08/03/2013, à 16:46

fcn50

Re : RME HDSP 9632 sous Ubuntu 11.10

A propos, je me demande comment pourrait-on dimensionner HDSPMIXER suivant les besoins? J'ai un moniteur avec une résolution de 2560x1440 et c'est petit, pouvoir l'agrandir serait sympa!


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#8 Le 08/03/2013, à 18:40

ubatrime

Re : RME HDSP 9632 sous Ubuntu 11.10

Aucune idée, mais Je n'en vois pas trop l'intérêt car il est quand même minimaliste (rien à voir avec celui des dernières RME haut de gamme ou babyface).

Ah oui, placer aussi HDSP en 1ère carte son. Ex avec chipset Intel :
cat /proc/asound/modules (renvoie l'ordre des cartes)

gksudo gedit /etc/modprobe.d/alsa-base.conf
Afin de mettre la carte favorite en premier, il faut changer par exemple :
install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1
en
install sound-slot-1 modprobe snd-card-0
install sound-slot-0 modprobe snd-card-1
Puis à la fin du fichier, rajoutez ces 2 lignes par le nom de vos cartes que cat /proc/asound/modules vous a retourné, en veillant à utiliser des - à la place des _) :
options snd-hdsp index=0
options snd-hda-intel index=1
Puis redémarrez.

Maintenant si quelqu'un a une ruse simple pour conserver Pulseaudio...

Hors ligne

#9 Le 09/03/2013, à 10:21

fcn50

Re : RME HDSP 9632 sous Ubuntu 11.10

ubatrime a écrit :

Aucune idée, mais Je n'en vois pas trop l'intérêt car il est quand même minimaliste

Sur une grande résolution c'est très petit, de le voir en plus grand ne serait pas un luxe, perso. Pour Pulseaudio, pourquoi vouloir le garder? Il ne sert à rien car il ne gère pas cette carte. Si c'est pour pouvoir jouer plusieurs son à la fois, il n'y a pas besoin de serveur son, alsa sait le faire et c'est ton .asoundrc qui détermine cela.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

Haut de page ↑