Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 05/11/2006, à 22:31

mr_pouit

Des logiciels ne sont pas disponibles en paquet ? dites-le !

Ce sujet est la suite de celui-ci : http://forum.ubuntu-fr.org/viewtopic.php?id=8111

Ce sujet va poursuivre le grand projet de pef, qui consistait à regrouper les demandes de paquets pour des programmes pas encore disponibles dans les dépôts.

Ressources : http://doc.ubuntu-fr.org/projets/ecole/ressources smile

Donc un petit rappel du principe :
Si vous connaissez un programme non disponible en paquet (ou en version trop ancienne), il suffit de laisser ici :
    * son nom ;
    * un lien vers le site officiel.
Et il se pourrait que cela change big_smile (intégration dans Ubuntu).

À faire au préalable :
Avant de poster, merci de vérifier que le programme (ou la version) demandé(e) n'est pas déjà disponible en paquet :
    * dans Ubuntu, http://packages.ubuntu.com/<nom_du_paquet> ;
    * dans debian, http://packages.debian.org/<nom_du_paquet>.

Requêtes non valables :
    * Evitez les programmes dont le développement a cessé (depuis 2002 par exemple) : c'est difficile d'obtenir l'aide des développeurs du programme en cas de problème d'empaquetage si le programme n'est plus maintenu. hmm
    * Merci de ne pas poster de demandes de paquets pour des logiciels propriétaires, puisque ce topic est dédié a l'intégration 'officielle' dans Ubuntu.
    * Merci de ne pas poster de demandes telles que "openoffice 2.0.4 dans breezy", pour la bonne raison que ce paquet appartient à la section 'main' et non 'universe', et donc qu'il est du ressort des développeurs Ubuntu, et non des contributeurs de paquets pour Ubuntu Universe. wink
Pour vérifier à quelle section appartient un paquet, vous pouvez utiliser la commande apt-cache madison <nom_du_paquet> :

$ apt-cache madison openoffice.org
openoffice.org | 2.0.4-0ubuntu2 | http://se.archive.ubuntu.com edgy/main Packages
openoffice.org | 2.0.4-0ubuntu2 | http://se.archive.ubuntu.com edgy/main Sources

Pour ceux qui ont eu le courage de lire jusqu'ici, voici la liste des programmes. smile

Version d'Ubuntu où seront les nouveaux paquets : Ubuntu 7.10 "Gutsy Gibbon"

Liste des demandes :

* Paquets en attente dans NEW (validation par un archive-admin)

* Paquets en attente sur REVU (validation par 2 MOTUs)

* Programmes en cours d'empaquetage

* Programmes à empaqueter

---

- est-ce qu'ils sont toujours en cours de travail ?
   * salome - http://www.salome-platform.org/                    guibis
   * opencascade - http://www.opencascade.org/                    guibis
   * code-aster - http://www.code-aster.org/                    guibis
   * bo2k_plugins, bo2k_console - http://www.bo2k.com/software/linux.html    _Enchained
   * xcfa - http://bulin.claude.neuf.fr/xcfa-presentation.html            ptitdav69
   * ToyCars - http://sourceforge.net/projects/toycars/                ptitdav69
   * Laser - http://bookeldor.livejournal.com/                ptitdav69

- à transférer sur LP :
   * freemat - Debian ITP

- paquets rejetés temporairement :
  * tuxguitar - http://www.tuxguitar.com.ar/download.html    Paquet supprimé de debian

Voilà, Lutin et moi essaierons de maintenir ce topic à jour. wink

Dernière mise à jour : 17/04/2007
   * màj de la liste

Dernière modification par mr_pouit (Le 20/04/2007, à 14:06)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#2 Le 05/11/2006, à 22:35

skateinmars

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

xvidcap a deja été packagé non ? (j'arrive plus a le trouver hmm)
Ce soft est aussi un peu obsolète.

Alltray est packagé egalement par un français qui maintenait un depot non-officiel (peut-etre etait-ce asher256)

Hors ligne

#3 Le 05/11/2006, à 23:44

Julian

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Salut,

Serait t-il possible d'intégrer le très bon dvd95 ? wink
Pour rappel, dvd95 permet de faire du dvd9 to dvd5 à l'instar de k9copy, sauf que la qualité finale est bien meilleure.

Voici le lien vers le site officiel:
http://dvd95.sourceforge.net/

Le lien où l'on en parle sur le forum et dans lequel on trouve un paquet pour Dapper et un pour Edgy:
http://forum.ubuntu-fr.org/viewtopic.php?id=64545&p=1

Paquet pour Dapper:
dvd95-1.1p1_i386.deb

Paquet pour Edgy:
dvd95_1.1p1-1_i386_edgy.deb

Ces paquets n'ont pas été créés dans les règles de l'art mais fonctionnent sans problème, et les dépendances sont bien prises en compte avec Gdebi.

Ce serait cool wink

@+
Julian.


julian@jabber.fr

Hors ligne

#4 Le 06/11/2006, à 00:17

hector

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

bonjour,
2 idées:
* le serveur web resin http://www.caucho.com/download/
* le greffon pour avoir eclipse en français: http://download.eclipse.org/eclipse/dow … /index.php

Merci!

Hors ligne

#5 Le 06/11/2006, à 08:32

_Enchained

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

j'ajouterais le logiciel Jext (éditeurs texte en java, que j'apprécie particulièrement)
http://www.jext.org/

#6 Le 06/11/2006, à 08:36

Isaric

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

mr_pouit a écrit :

dans le dépôt d'asher256

C'est des dépôts x86, pas des dépôts AMD 64 sad


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#7 Le 06/11/2006, à 12:03

Isaric

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

XdTV pour AMD 64 tongue

Je ne trouve rien (qui marche) pour faire marcher ma carte tuner en AMD 64, j'utilisais XdTV sur Dapper en x86,
avec le dépôt
## XdTV dapper en x86 (pas encore edgy ni en amd64)
deb http://nicolas.estre.free.fr/ubuntu dapper main
Cela permet d'enregistrer malgré un petit conflit  car il me fallait débrancher la webcam, je crois ! roll

Mais maintenant, je suis passé en configuration AMD 64 hmm et il n'y a plus rien qui marche en TV

Dernière modification par Isaric (Le 06/11/2006, à 12:04)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#8 Le 06/11/2006, à 12:35

Maeda

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Pour dvd95, j'ai fait des paquets pour i386 et amd64 (en suivant le wiki), il me semble que j'ai dû juste omettre un champ dans le fichier control (le champ standards-version). Ils sont disponibles directement sur le site de dvd95.

Si cela peut vous aider wink !

Dernière modification par Maeda (Le 06/11/2006, à 12:37)


[The worst foe lies within the self] | utilisateur 4904 d'Ubuntu | Precise Pangolin 64 bits | Vous avez un Samsung F-480 ? Une RME Digi96/8 PAD ?

Hors ligne

#9 Le 06/11/2006, à 14:55

dawar

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Il me semble qu'on avait parlé de Seamonkey, le successeur de la suite Mozilla. Même dans Feisty on retrouve ce vieux coucou qui n'est plus maintenu par la fondation Mozilla. Seamonkey apporte les nouveautés de Firefox à la suite Mozilla, ça serait peux être une bonne idée de l'empaqueter...

Dans la mesure du possible, évitez les programmes dont le développement a cessé (depuis 2002 par exemple)

La version 1.7 de Mozilla (et dernière version) date de juin...2004.


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#10 Le 06/11/2006, à 15:00

Maximinus

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Bouml - http://bouml.free.fr/
Interface de modélisation UML (par un Français !! cocorico !!)

Au passage, excellente initiative. Il faudrait que j'apprenne à packager correctement...:mad:


L'Anguille...

Hors ligne

#11 Le 06/11/2006, à 15:38

Lestat the vampire

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Pour ma part je dirais
- Xvid 1.1.2 sortie récemment http://www.xvid.org/ (on est toujours à la 1.1.0 du paquet libxvidcore4)
- il serait pas mal aussi de faire un paquet avec une version stable de la branche Xvid 1.2 qui gère le smp (exemple : http://www.koepi.org/xvidcore-1.2.-127-250206.zip)

Hors ligne

#12 Le 06/11/2006, à 15:39

2fast4u

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

L'excellent Zoneminder meriterait bien un ptit paquet. C'est un logiciel de télésurveillance.
Site officiel : http://www.zoneminder.com/

Hors ligne

#13 Le 06/11/2006, à 18:53

shamanphenix

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Ce jeu n'existe pas dans synaptic ?
Je ne l'ai jamais trouvé...

Dernière modification par shamanphenix (Le 06/11/2006, à 18:54)


"Ubuntu". Si tous les gens du monde voulaient bien se tenir par la main... ce serait bien plus facile pour les électrocuter.

What did /home/user/DARTHVADER say to /home/user/DARTHVADER/LUKESKYWALKER ?
I AM YOUR PARENT FOLDER.

Hors ligne

#14 Le 06/11/2006, à 19:03

russose

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

bmpx n'est pas dsipo non plus. Ce lecteur de musique est pas mal wink

http://bmpx.beep-media-player.org/site/BMPx_Homepage


La 3D, c'est pour les grosses machines? Faux, les PDA peuvent aussi utiliser Blender ;)
http://russose.free.fr/BlenderPocket/

Hors ligne

#15 Le 06/11/2006, à 19:32

bruno

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

ManDVD est un frontend en QT pour dvdauthor , un paquet est disponible pour Ubuntu, il faudrait voir avec l'auteur si cela peut être intégré aux dépôts.

En ligne

#16 Le 06/11/2006, à 19:45

thrawn

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Konverter
http://www.kraus.tk/projects/konverter/


Celui qui renonce à devenir meilleur cesse déjà d'être bon.

Hors ligne

#17 Le 06/11/2006, à 20:19

mr_pouit

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Du calme, laissez-nous le temps de faire les paquets tongue
J'ai mis à jour le premier post.

Isaric a écrit :

XdTV pour AMD 64 tongue

Je ne trouve rien (qui marche) pour faire marcher ma carte tuner en AMD 64, j'utilisais XdTV sur Dapper en x86,
avec le dépôt
## XdTV dapper en x86 (pas encore edgy ni en amd64)
deb http://nicolas.estre.free.fr/ubuntu dapper main
Cela permet d'enregistrer malgré un petit conflit  car il me fallait débrancher la webcam, je crois ! roll

Mais maintenant, je suis passé en configuration AMD 64 hmm et il n'y a plus rien qui marche en TV

C'est en cours pour déterminer s'il peut aller dans les plf ou multiverse. https://launchpad.net/products/plf/+bug/59805

Maeda a écrit :

Pour dvd95, j'ai fait des paquets pour i386 et amd64 (en suivant le wiki), il me semble que j'ai dû juste omettre un champ dans le fichier control (le champ standards-version). Ils sont disponibles directement sur le site de dvd95.

Si cela peut vous aider wink !

Merci smile
Malheureusement, ce paquet a les mêmes bugs bizarres que ceux que _Enchained essaie de résoudre (les locales sont installées dans le mauvais dossier, et les CFLAGS utilisés ne sont pas ceux standards de debian je crois).

Maximinus a écrit :

Au passage, excellente initiative. Il faudrait que j'apprenne à packager correctement...:mad:

http://doc.ubuntu-fr.org/projets/paquets wink

Lestat the vampire a écrit :

Pour ma part je dirais
- Xvid 1.1.2 sortie récemment http://www.xvid.org/ (on est toujours à la 1.1.0 du paquet libxvidcore4)
- il serait pas mal aussi de faire un paquet avec une version stable de la branche Xvid 1.2 qui gère le smp (exemple : http://www.koepi.org/xvidcore-1.2.-127-250206.zip)

Xvid c'est un peu délicat : il est maintenu par l'équipe MOTU Media, donc je suis pas sûr qu'on puisse faire grand chose.

bruno a écrit :

ManDVD est un frontend en QT pour dvdauthor , un paquet est disponible pour Ubuntu, il faudrait voir avec l'auteur si cela peut être intégré aux dépôts.

Déjà dans la liste

Dernière modification par mr_pouit (Le 06/11/2006, à 20:21)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#18 Le 06/11/2006, à 21:03

Isaric

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

DVDStyler-1.5b6 avec  wxsvg-1.0b7_1
source code dvdstyler
dvdstyler downloads
pour AMD 64 ??? roll


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#19 Le 06/11/2006, à 21:37

Agrou

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Balazar Brother qui est une sorte de suite à Balazar :

Voici le site du jeu : http://home.gna.org/oomadness/fr/balazar_brother/index.html

Je n'ai jamais réussi à le compiler, mais il a vraiment l'air cool. Ce serai génial s'il était packagé


http://linuxdansmonpc.is-a-geek.com/

« Quoi que tu fasses cela sera insignifiant, mais il est très important que tu le fasses».  Mohandas Gandhi

Hors ligne

#20 Le 07/11/2006, à 12:19

Isaric

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Le nouveau driver webcam de Michel Xhaard
Je vois dans les dépôts (sources) spca5xx-source peut-il y avoir le driver gspcav1-20060925
Et pourquoi pas un .deb d'installation (qui fait automatiquement "sudo ./gspca_build" et pour tous les users ...  roll qui soit compatible l'utilisation d'une carte tuner pour enregistrer avec xdtv sans avoir à débrancher la webcam cool:rolleyes:) ?

Dernière modification par Isaric (Le 07/11/2006, à 12:32)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#21 Le 07/11/2006, à 13:44

roger64

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Xaralx sur Edgy

Bonjour, et merci pour le sacré boulot que vous abattez. smile

Je crois qu'il y a un problème avec le paquet Xaralx sous Edgy. Avec Dapper il marchait sans anicroche.
Ici j'ai un avertissement en console (voir plus bas). Sinon, ensuite le programme a l'air de fonctionner normalement. roll Pouvez-vous éclairer ma lanterne?

roger@roger-laptop:~$ apt-cache search xaralx #
xaralx - Heavyweight vector graphics, illustration and DTP Program
xaralx-examples - Examples of works created by XaraLx
xaralx-svg - SVG (Scalable Vector Graphics) plugin for XaraLX
roger@roger-laptop:~$ apt-cache madison xaralx #
    xaralx | 0.7r1692-2 | http://mir2.ovh.net edgy/multiverse Packages
    xaralx | 0.7r1692-2 | http://mir2.ovh.net edgy/multiverse Sources
roger@roger-laptop:~$ /usr/bin/xaralx

(xaralx:11413): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(xaralx:11413): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(xaralx:11413): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
roger@roger-laptop:~$

avertissement à l'écran

12:35:11: Mailcap file /etc/mailcap, line 59: incomplete entry ignored.
12:35:11: Mailcap file /etc/mailcap, line 60: incomplete entry ignored.


Enfin, j'ai reçu ce mail de launchpad que je ne comprend pas (bon, ça faisait allusion à la version Dapper)

-> Considering  wx2.6-headers (>= 2.6.3)
      Tried versions: 2.6.1.2ubuntu2
   -> Does not satisfy version, not trying

Requires newer wxgtk

** Changed in: dapper-backports (upstream)
       Status: Unconfirmed => Rejected

-- xaralx not in dapper backport https://launchpad.net/bugs/66557

Dernière modification par roger64 (Le 07/11/2006, à 13:45)

Hors ligne

#22 Le 07/11/2006, à 14:00

fmo

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Un pti K9Copy a jours ca pourrait etre sympa aussi, la derniere version dans Edgy est la 1.1.0beta1 alors que la beta2 est dispo.

Merci smile

Un pti lien: http://k9copy.sourceforge.net

Dernière modification par fmo (Le 08/11/2006, à 12:27)


www.terranux.net

Hors ligne

#23 Le 07/11/2006, à 14:22

Maeda

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

mr_pouit a écrit :
Maeda a écrit :

Pour dvd95, j'ai fait des paquets pour i386 et amd64 (en suivant le wiki), il me semble que j'ai dû juste omettre un champ dans le fichier control (le champ standards-version). Ils sont disponibles directement sur le site de dvd95.

Si cela peut vous aider wink !

Merci smile
Malheureusement, ce paquet a les mêmes bugs bizarres que ceux que _Enchained essaie de résoudre (les locales sont installées dans le mauvais dossier, et les CFLAGS utilisés ne sont pas ceux standards de debian je crois).

Ok hmm, est-ce que je dois les faire retirer du site s'ils sont buggés ? En tout cas, bon courage smile !


[The worst foe lies within the self] | utilisateur 4904 d'Ubuntu | Precise Pangolin 64 bits | Vous avez un Samsung F-480 ? Une RME Digi96/8 PAD ?

Hors ligne

#24 Le 08/11/2006, à 06:03

_Enchained

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

J'ai contacté Asher256 pour les paquets de son dépôt (alltray et xvidcap).
Il m'a dit qu'il avait peu de temps pour s'occuper de son dépôt et donc encore moins pour proposer ses paquets à universe.
Mais serait très content de voir ces logiciels dans universe et donc on peut reprendre ses sources (qui sont conformes à la debian policy, ou alors avec peu de retouches à faire).
Il y a checkgmail aussi dans son dépôt que je trouve sympa (je sais pas si déjà proposé)

Hors ligne

#25 Le 08/11/2006, à 10:35

Noxos

Re : Des logiciels ne sont pas disponibles en paquet ? dites-le !

Et linux DC++ wink

Hors ligne

Haut de page ↑