Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/07/2005, à 01:05

sksbir

Installer et configurer exim4...

- J'ai une machine qui s'appelle sun, ou sun.inet

- cette machine possede deux comptes locaux : toto et titi

- j'ai installé mailx, exim4 ,fetchmail et qpopper

Et maintenant, je vous explique ce que je cherche à faire :
titi et toto doivent pouvoir s'écrire sans que les mails aillent faire un tour chez free.
Par contre,les 2 utilisateurs possedent un compte chez free (toto@free.fr), et quand ils écrivent à un tiers, leurs mails doivent bien partir vers smtp.free.fr MAIS, je veux grouper les envois à date fixe. De même, je veux scanner les BAL chez les FAI que sur commande.
Ceci afin d'optimiser les connexions (via réseau téléphonique commuté).

- j'ai configuré exim4 ainsi :
dpkg-reconfigure exim4-config a modifié le fichier
/etc/exim4/update-exim4.conf.conf
Voici son contenu actuel :

dc_eximconfig_configtype='smarthost'
dc_other_hostnames='inet'
dc_local_interfaces='127.0.0.1'
dc_readhost='sun.inet'
dc_relay_domains=''
dc_minimaldns='true'
dc_relay_nets='192.168.10.0/24'
dc_smarthost='smtp.free.fr'
CFILEMODE='644'
dc_use_split_config='false'
dc_hide_mailname='true'
dc_mailname_in_oh='true'

Bon, je reprend en direct live la configuration exim

(root sur la machine)
export LANG=C (c'est pour avoir le truc en anglais, je trouve que c'est plus précis, et ça élimine les problemes de caracteres accentués)
dpkg-reconfigure exim4-config

The Debian exim4 packages can either use a single monolithic file (/etc/exim4/exim4.conf.template) or about 40 small files in /etc/exim4/conf.d/ to generate the final configuration.
The former is better suited for large modifications and is generally more stable, whereas the latter offers a  comfortable way to make smaller modifications but is more fragile and might break if modified extensively.
If you are unsure then you should not use split configuration.                                                  
Split configuration into small files?  <Yes>  <No>

--> no

Select the configuration type that best meets your needs.                                                         
Systems with dynamic IP addresses, including dialup systems, should generally be configured to send outgoing mail to another machine, called a "smart host" for delivery. You can choose to receive mail on such a system; or to have no local mail delivery, except mail for root and postmaster. 
General type of mail configuration: 
- internet site; mail is sent and received directly using SMTP
- mail sent by smarthost; received via SMTP or fetchmail
- mail sent by smarthost; no local mail
- local delivery only; not on a network
- manually convert from handcrafted Exim v3 configuration
- no configuration at this time
<Ok>  <Cancel>

--> j'ai choisi "mail sent by smarthost; received via SMTP or fetchmail"

Your "mail name" is the hostname portion of the address to be shown on outgoing news and mail messages (following the username and @ sign) unless hidden with rewriting.                                                 
This name will also be used by other programs; it should be the single, full domain name (FQDN) from which mail will appear to originate.                                                                                         
This name won't appear on From: lines of outgoing mails if you enable rewriting.                                  
System mail name: 
____________________ 
<Ok>   <Cancel>

--> là, j'ai mis "inet"

Enter a colon-separated list of IP-addresses to listen on.  You need to double the colons in IPv6 addresses (e.g. 5f03::1200::836f::::).                                                                                      
If you leave this value empty, Exim will listen for connections on the SMTP port of all available network interfaces.
If this computer does not receive e-mail directly per SMTP from OTHER hosts, but only from local services like fetchmail or your e-mail program (MUA) talking to localhost you should prohibit external connections to Exim by setting this option to 127.0.0.1 and therefore disabling listening on public network interfaces. 
IP-addresses to listen on for incoming SMTP connections:                                                        
_____________
 <Ok>   <Cancel>

Et je crois que mon soucis vient de là : je n'avais mis précédemment que 127.0.0.1, mais en fait, avec OE, mon serveur reçoit des mails via SMTP directement depuis d'autres machines (celles de mon réseau local)
hop, je tente : 127.0.0.1:192.168.10.0/24

Please enter a list of domains for which this machine should consider itself the final destination, apart from the local hostname (sun) and "localhost".                                                                        
By default all domains will be treated the same; if you want different domain names to be treated differently, you will need to edit the config files afterwards.                                                               
If there are any more, enter them here, separated by colons. You may leave this blank if there are none.
Other destinations for which mail is accepted:                                                                   &#9474;
________________ &#9474;
 <Ok>   <Cancel>

Franchement, là, j'ai rien compris, mais au début, j'avais laissé vide, et quand toto essayais en d'écrire à titi, ça partait vers free.
Après, j'ai mis "inet", et là, les mails locaux ont commencé à circuler.
Donc j'ai toujours pas compris, surtout que c'est la 2eme fois que je mets "inet", alors que quand on regarde le fichier de conf, la valeur inet n'apparait qu'une fois....

Please enter here the networks of local machines for which you accept to relay the mail.                          
This should include a list of all machines that will use us as a smarthost.                                       
If there are any, enter them here, separated by colons. You should use the standard address/length format (e.g. 194.222.242.0/24).                                                                                                
You need to double the colons in IPv6 addresses (e.g. 5f03::1200::836f::::/48)                                    
Machines to relay mail for:
___________
<Ok>    <Cancel>

Là, j'avais déja mis 192.168.10.0/24, mais du coup, ça ne fait pas double emploi avec les IP autorisées au SMTP ??
Si on réfléchit, deux cases plus haut, c'est pour autoriser les mails à arriver depuis les machines de mon réseau local jusqu'au serveur (SMTP), et là, c'est pour avoir une liste des machines qui vont avoir le droit de relayer leurs mails... On pourrait donc sélectionner par l'IP des machines ayant le droit d'écrire, mais seulement en local et pas à l'extérieur.

Enter the hostname of the machine to which outgoing mail is sent.
Refer to /usr/share/doc/exim4-base/README.SMTP-AUTH for notes about setting up SMTP authentication.
Machine handling outgoing mail for this host (smarthost):
___________
<Ok>    <Cancel>

--> smtp.free.fr

The headers of outgoing mail can be rewritten to make it appear to have been generated on a different system, replacing "inet" "localhost" and "inet" in From, Reply-To, Sender and Return-Path.
Hide local mail name in outgoing mail?
<Yes>   <No>

--> là, j'ai mis "yes", mais un peu au pif : l'assistant n'est pas clair : par quoi vat'il remplacer "inet" et  "localhost" au juste ??
[edit]finalement, j'ai remis non, car l'adresse source est configurée dans les comptes OE, donc peu de risque d'erreur.

Since you enabled hiding the local mailname in outgoing mail, you must specify the domain name to use for mail from local users; typically this is the machine on which you normally receive your mail. 
Where will your users read their mail?
Visible domain name for local users:
________
<Ok>   <Cancel>

---> sun.inet (le nom du serveur)

In normal mode of operation Exim makes DNS-lookups at startup, when receiving or delivering message, etc. for logging purposes and to keep the number of hard-coded values in the configuration file small.                   &#9474;
If this were a host without permanent DNS-nameserver-access using Dial-on-Demand this might have the unwanted consequence that starting up exim or running the queue (even with no messages waiting) might trigger a costly dial-up-event.                                                                                                  
Enable this feature if you are using Dial-on-Demand; otherwise, disable it.                                     
Keep number of DNS-queries minimal (Dial-on-Demand)?                                                            
<Yes>   <No>

--> yes (a terme, serveur justement prévu pour etre derriere une ligne RTC.)

Dernière modification par sksbir (Le 13/07/2005, à 13:09)

Hors ligne

#2 Le 12/07/2005, à 01:16

sksbir

Re : Installer et configurer exim4...

Bon, apres la relance du MTA, OE refusait toujours d'envoyer le mail, alors j'ai relancé la configuration d'exim et laissé vide  le champ pour SMTP, (là ou j'avais précédement testé "127.0.0.1:192.168.10.0/24").
Maintenant, ça marche, et c'est iptables qui protège mon serveur en interdisant les connexions entrantes depuis le coté internet...
Mais bon, je creuse pour savoir pq ça ne marche pas.
Un indice permet de savoir si c'est ok sans lancer OE :
netstat -a|grep 25
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN

Et avec la valeur "127.0.0.1:192.168.10.0/24"
netstat -a|grep 25
tcp        0      0 255.255.255.255:25      0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN


[edit du 13/07/2005]

je note quelques liens concernant exim et que j'ai retenu:
Site officiel
Installing and Configuring Exim4
Exim FAQ, section 14 ( DIAL-UP AND ISDN )
Exim 4.40 Specification
Exim4 - SMTP AUTH - Virtual Domain

Ce dernier lien explique clairement comment débuter la configuration, puis une fois dpkg-reconfigure exécuté,

Configuration personnelle:

On vous explique (en gros) comment fonctionne le système exim.

    * A son lancement, le serveur va d'abord lire un modèle : /etc/exim4/exim4.conf.template
    * Il va ensuite le traiter et le resultat est /var/lib/exim4/config.autogenerated.
    * c'est /var/lib/exim4/config.autogenerated qui va être lu appliqué. /var/lib/exim4/config.autogenerated est un fichier de configuration directement applicable.
    * Cependant, si il existe un fichier /etc/exim4/exim4.conf, il aura la priorité sur /var/lib/exim4/config.autogenerated.

Comme je l'ai dit plus haut, /var/lib/exim4/config.autogenerated est un fichier de configuration valide et utilisable, au même titre que /etc/exim4/exim4.conf.

On va donc commencer par copier /var/lib/exim4/config.autogenerated en /etc/exim4/exim4.conf.

Ensuite pour peauffiner notre réglage, on va agir sur /etc/exim4/exim4.conf.

Si on agissait sur /var/lib/exim4/config.autogenerated, le traitement dont je parle au 2ème point écraserait notre /var/lib/exim4/config.autogenerated.

Agir directement sur le modèle /etc/exim4/exim4.conf.template est aussi une solution. Mais pour des raisons qui ne feraient qu'allonger ce document on se passera de cela. On décide tout simplement d'agir sur /etc/exim4/exim4.conf, en le créant si il n'existe pas

C'est donc dans /etc/exim4/exim4.conf que je vais aller bidouiller des trucs comme:
queue_domains = ! *.localnet

[edit] apres quelques recherches sur internet, j'ai trouvé ça.

Et voici donc la configuration qui fonctionne: ajouter ceci en tête du fichier /etc/exim4/exim4.conf

#########
# customisations post configurations
# Queue all none-local domains
queue_domains = ! +local_domains
#####

Dernière modification par sksbir (Le 13/07/2005, à 22:58)

Hors ligne

#3 Le 23/01/2009, à 15:50

adel0778

Re : Installer et configurer exim4...

Merci pour ce tuto.
J aurai aimé trouver une description un peu plus poussée pour le serveur smtp.
Une situation courante est:
* le serveur smtp est avec  une authentification
* le serveur smtp fonctionne avec ssl (465 , 587, ....)
*le nom de la session n'est pas forcement  le nom du login sur le smtp.
peux tu nous fournir plus de details?
Merci

#4 Le 24/01/2009, à 01:17

sksbir

Re : Installer et configurer exim4...

adel0778 a écrit :

Merci pour ce tuto.
J aurai aimé trouver une description un peu plus poussée pour le serveur smtp.
Une situation courante est:
* le serveur smtp est avec  une authentification
* le serveur smtp fonctionne avec ssl (465 , 587, ....)
*le nom de la session n'est pas forcement  le nom du login sur le smtp.
peux tu nous fournir plus de details?
Merci

Salut adel
Je suis désolé, mais en 2005, j'ai arreté ce serveur peu après avoir fait ce tuto car il ne remplissait pas l'objectif que je m'étais fixé à l'époque, c'est à dire optimiser au maximum les connexions internet pour diminuer les temps de connexion au réseau commuté d'une PME.
Je n'ai pas retouché tout ça depuis cette époque.
Amicalement.

Hors ligne

#5 Le 17/02/2009, à 21:43

alex206

Re : Installer et configurer exim4...

un peu de doc que j'ai rédigé sur exim4 :
http://astuces.alexcms.org/serveur_dedie
http://forum.debian-fr.org/viewtopic.php?f=8&t=18425
pour toute question n'hésitez pas

Dernière modification par alex206 (Le 29/10/2009, à 12:05)


Debian stable ya que ça de vrai
http://astuces.alexcms.org

Hors ligne

#6 Le 27/11/2010, à 18:40

Concombre Masqué

Re : Installer et configurer exim4...

Bonjour,

c'est dans ce fil que je trouve ce qui se rapproche le plus de mon problème, alors je tente ma question ...

Pour éviter les long discours, voici la réponse du serveur quand je veux envoyer un mail

local.org est un domaine géré par le serveur à 100% (bind, apache, exim4, ..)
distant.com n'est pas géré par le serveur

$ echo "test envoi " |mail webmaster@distant.com -s "test " -v
LOG: MAIN
  <= michael@local.org U=michael P=local S=379
michael@ns367286:~$ delivering 1PMOfQ-0001MZ-Nj
R: smarthost for webmaster@distant.com
LOG: MAIN
  remote host address is the local host: distant.com
LOG: MAIN
  == webmaster@distant.com R=smarthost defer (-1): remote host address is the local host
LOG: MAIN
  <= <> R=1PMOfQ-0001MZ-Nj U=Debian-exim P=local S=584
LOG: MAIN
  Frozen
delivering 1PMOfQ-0001Mb-Sg
R: smarthost for postmaster@local.org
LOG: MAIN
  remote host address is the local host: local.org
LOG: MAIN
  == postmaster@local.org R=smarthost defer (-1): remote host address is the local host
LOG: MAIN
  Frozen

Comment faire en sorte de pouvoir envoyer des courriels à l'extérieur ? quelle variable modifier/ajouter à exim.conf ?


Edit : après une nuit de sommeil et un peu de lecture, je supprime le fichier /etc/exim4/exim4.conf (créé pour cause de lecture de tuto quelquepart ) et tout fonctionne merveilleusement ! ... désolé du dérangement

Dernière modification par Concombre Masqué (Le 28/11/2010, à 11:40)


Concombre Masqué, 100% Végétal et donc 100% sain

Hors ligne