Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/12/2004, à 02:51

krumli

[Résolu] Problème avec Nvidia GLX

J'avais un problème pour faire fonctionner le driver Nvidia, que j'ai résolue. Ca peut toujours servir à quelqu'un.

Le problème: j'avais bien l'écran blanc Nvidia, X bootait et fonctionnait correctement en 2D mais impossible de lancer une appli 3D car erreur: unable to load GLX .

J'ai testé avec le 2.6.9 de Hoary + tous les packages nvidia ( voir http://gfabio.blog.free.fr/?2004/11/28/92-ubuntu-pilotes-nvidia ) et avec le 2.6.10 + le driver fourni par Nvidia et toujours pareil.

Après recherche et bidouille, j'ai fait le lien suivant:

ln -s /usr/X11R6/lib/modules/extensions/libglx.so /usr/X11R6/lib/modules/extensions/libglx.a

Et ça a marché. Je ne sais pas pourquoi big_smile

Dernière modification par krumli (Le 04/01/2005, à 21:13)

Hors ligne

#2 Le 26/12/2004, à 12:07

MrTom

Re : [Résolu] Problème avec Nvidia GLX

Ah oui merci j'en connais un paquet à qui ça va servir :-D


Modo sur Easynux :D

Hors ligne

#3 Le 29/12/2004, à 01:44

gaaruto.2k80

Re : [Résolu] Problème avec Nvidia GLX

bonjour a tous

je test cette commande ce soir et j'edit pour dire si cela marche
merci krumli !

EDIT :
Nikel ca marche, merci !

Dernière modification par gaaruto.2k80 (Le 30/12/2004, à 15:56)


-= Yama no yoni mieru !!! =-
-= www.easynux.org =-

Hors ligne

#4 Le 04/01/2005, à 14:41

ploum

Re : [Résolu] Problème avec Nvidia GLX

Chez moi, y'a pas de drivers nvidia pour le 2.6.10, y'a pas le restricted module correspondant.

Je suis le seul ?

Hors ligne

#5 Le 04/01/2005, à 14:45

EricDele

Re : [Résolu] Problème avec Nvidia GLX

La dernière fois que j'ai migré sur un noyau plus récent, il m'a fallu attendre 3-4 jours avant que le restricted-module soit dispo pour cette version...

Hors ligne

#6 Le 04/01/2005, à 20:12

krumli

Re : [Résolu] Problème avec Nvidia GLX

le 2.610 est assez recent, on peut supposer que les modules sont en cours de fabrication big_smile

rien ne vaut une bonne vieille compilation de son noyau à la main tongue

Hors ligne

#7 Le 07/01/2005, à 15:33

krumli

Re : [Résolu] Problème avec Nvidia GLX

C'était bel et bien un bug:

xorg (6.8.1-1ubuntu9) hoary; urgency=low

  * Note: This version, and all versions since ubuntu7, are effectively
    6.8.2RC1.
  * #028: Add lib%s.so and %s_drv.so support back, as the nVidia binary driver
    installs libglx.so.  Also eliminate use of regular expressions in
    LoaderListDirs and LoaderGetCanonicalName, which should shave a bit of CPU
    time off.

Hors ligne

#8 Le 10/01/2005, à 20:23

gart

Re : [Résolu] Problème avec Nvidia GLX

Bonjour,
j'ai un problème avec les pilotes nvidia.
J'ai bien sur commencé par une ubuntu stable, puis j'ai mis les dépots pour hoary.
Depuis que je suis avec une noyau 2.6.9 et plus (actuellement en 2.6.10) je n'ai plus les pilotes de disponible.
quand je fais :

sudo apt-get install nvidia-glx nvidia-kernel-common
Aucune version du paquet nvidia-glx n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet nvidia-glx

J'ai surement mal fait le passage de warty en hoary, mais j'avoue ne pas trop savoir quoi exactement.
Quelqu'un aurait une idée pour réussir à installer ce pilote ?

Dernière modification par gart (Le 11/01/2005, à 22:53)


Quidquid latine dictum sit, altum viditur

Hors ligne

#9 Le 11/01/2005, à 10:39

Globule

Re : [Résolu] Problème avec Nvidia GLX

Bonjour,

Comme dit plus haut, il semblerais que le "restrited-module" correspondant à ta version du noyau ne soit pas disponible pour le moment, et indispensable au fonctionnement du driver nvidia. Alors il faut patientez .... smile

Hors ligne

#10 Le 11/01/2005, à 11:12

kil

Re : [Résolu] Problème avec Nvidia GLX

si si c'est dispo... (il y a eu un bug avec la maj du kernel d'hier soir, mais le nouveau de ce matin corrige le problème. je n'ai pas essayé avec Ubuntu 64 sur mon Athlon 64 mais jusqu'à avant hier (en kernel 2.6.10) tout fonctionnait parfaitement...

Hors ligne

#11 Le 11/01/2005, à 13:29

gart

Re : [Résolu] Problème avec Nvidia GLX

Merci pour les réponses.
Hier j'ai fini par l'installer moi-même, en installant les sources du noyau et le pilote NVidia avec l'installeur


Quidquid latine dictum sit, altum viditur

Hors ligne

#12 Le 11/01/2005, à 16:29

kil

Re : [Résolu] Problème avec Nvidia GLX

c'est curieux, je n'ai pas eu à le faire...

packages installés :
nvidia-glx (1.0.6629-ubuntu1)
nvidia-kernel-common (1.0.6629+1)
linux-restricted-modules-2.6.10-386 (2.6.10-3)
linux-restricted-modules-386 (2.6.10.1)
le kernel installé est le 2.6.10-5
à noter que malgré la différence de version, les restricted fonctionnent sur cette version ;-)

par contre, pour télécharger les drivers nvidia, il fallait rajouter universe et/ou multiverse dans les dépots (menu, Catégories, Dépots dans Synaptic)

j'ai même réussi à faire fonctionner l'accélération composite qui fonctionne AVEC GLX (xcompmgr et transset). Cela me permet d'avoir les fenêtres transparentes en temps réelles et les ombres sur les fenêtres (calculé par la carte graphique donc sans ralentissements).

Hors ligne

#13 Le 11/01/2005, à 18:37

gart

Re : [Résolu] Problème avec Nvidia GLX

Bon, en fait j'avais crié victoire trop tôt

glxgears
Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

Du coup, j'ai quand même voulu faire par apt-get et j'ai toujours la même erreur, qui me dis que le paquet n'est pas disponible mais qu'il existe dans la base...
J'ai pourtant fait un

sudo apt-get clean
sudo apt-get update

j'ai ça dans mon sources.list

#sources multimedia par Marillat
deb ftp://ftp.nerim.net/debian-marillat/ testing main

deb http://archive.ubuntu.com/ubuntu/ hoary main

deb http://archive.ubuntu.com/ubuntu/ hoary-security main

deb http://archive.ubuntu.com/ubuntu/ hoary multiverse

deb-src http://archive.ubuntu.com/ubuntu/ hoary main restricted

deb-src http://archive.ubuntu.com/ubuntu/ hoary multiverse

deb-src http://security.ubuntu.com/ubuntu/ hoary-security main restricted

Je ne vois pas trop d'où viens le problème


Quidquid latine dictum sit, altum viditur

Hors ligne

#14 Le 11/01/2005, à 23:10

kil

Re : [Résolu] Problème avec Nvidia GLX

tu n'as pas universe. Je me demande si cela ne vient pas de là...
moi j'ai çà :

deb cdrom:[Ubuntu 4.10 _Warty Warthog_ - Preview i386 Binary-1 (20041020)]/ unstable main restricted


deb http://archive.ubuntu.com/ubuntu/ hoary main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ hoary main restricted universe multiverse

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://archive.ubuntu.com/ubuntu/ warty universe
# deb-src http://archive.ubuntu.com/ubuntu/ warty universe

deb http://security.ubuntu.com/ubuntu/ hoary-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ hoary-security main restricted universe multiverse

Hors ligne

#15 Le 18/01/2005, à 16:27

gart

Re : [Résolu] Problème avec Nvidia GLX

Merci kil, et désolé de répondre avec autant de retard
j'ai modifier mon fichier de sources, et j'ai finalement réussi à installer les pilotes, et du coup aussi deux trois autres trucs qui avaient du mal
J'ai eu quand même un problème, je ne peut pas avoir l'extension "Composite" pour xorg et l'accélération 3D.
Il suffit que je ne charge pas le module, et ça marche néanmoins


Quidquid latine dictum sit, altum viditur

Hors ligne

#16 Le 18/01/2005, à 19:51

kil

Re : [Résolu] Problème avec Nvidia GLX

si si çà marche composite, mais il y a des options a mettre dans le xorg.conf :
voici mon xorg.conf en exemple (une partie seulement ;-)
Section "Device"
        Identifier      "NVIDIA Corporation NVIDIA Default Card"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "RenderAccel"           "yes"
        Option          "NoLogo"                "yes"
        Option          "AllowGLXWithComposite" "yes"

EndSection

Section "Extensions"
        Option  "Composite"     "Enable"
        Option  "RENDER"        "Enable"
EndSection

L'option la plus importante est AllowGLXWithComposite qui permet d'avoir en même temps les accélérations matériels Open GL ET Composite.

Pour activer l'ombrage des fenêtre : xcompmgr -c -C -f -F -o 1.0 -I 0.08
(quelques options que j'aime bien) puis pour mettre une fenêtre transparente, utiliser transset (cliquer sur la fenêtre)

Quelques bugs avec opengl qui reste toujours au premier plan et quelques fenêtres qui s'affichent mal (lorsque l'on quitte gnome, l'écran de fin ne s'affiche pas, il faut faire entrer en aveugle et les fenêtres de prise de controle root sont transparentes, pareil, on tape le mot de passe et entrer, ca marche ), sinon QUE DU BONHEUR ! ;-)

Il faudra peut-être que je pense à écrire un petit topic sur la question...

Hors ligne

#17 Le 18/01/2005, à 20:34

gart

Re : [Résolu] Problème avec Nvidia GLX

Merci, je vais essayer ça le plus vite possible. C'est certainement ce qui me manquait, y'a pas (plus) de raison que ça marche pas, encore merci !


Quidquid latine dictum sit, altum viditur

Hors ligne

#18 Le 01/05/2005, à 15:38

serial

Re : [Résolu] Problème avec Nvidia GLX

Le remplacement du lien libglx.a par un lien vers libglx.so a résolu mon problème !! big_smile

Hors ligne