Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 24/07/2005, à 11:38

szdavid

mplayer sur internet ne joue pas

Salut,

lorsque je veux regarder une vidéo sur firefox, mplayer charge la vidéo (barre bleu qui augmente en bas) mais ne joue rien ; quelqu'un sait comment résoudre ce souci ?

Hors ligne

#2 Le 24/07/2005, à 11:46

coffee

Re : mplayer sur internet ne joue pas

il te faut configurer mplayer

mplayer video.avi marche?

si non, file nous ton /etc/mplayerplug-in.conf et ton /etc/mplayer/mplayer.conf
donne nous aussi ta config video


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#3 Le 24/07/2005, à 11:50

szdavid

Re : mplayer sur internet ne joue pas

c'est une bonne question ; en effet, même les vidéo sur mes disques ne fonctionnent pas ! ! ! (j'utilisais xine)

voici mon /et/mplayerplug-in.conf

#debug=0
#logfile=$HOME/mpp.log
#vo=xv,x11
#ao=arts,esd,oss
#download=1
#dload-dir=$HOME/tmp
#keep-download=0
#noembed=0
#cachesize=256
#use-mimetypes=0
#enable-real=0
#enable-wm=1
#enable-qt=1
#enable-mpeg=1
#enable-ogg=1
#qt-speed=med
#rtsp-use-tcp=0
#nomediacache=0

pour le mplayer.conf

##
## MPlayer config file
##
## This file can be copied to /etc/mplayer.conf and/or ~/.mplayer/config .
## If both exist, the ~/.mplayer/config's settings override the
## /etc/mplayer.conf ones. And, of course command line overrides all.
## The options are the same as in the command line, but they can be specified
## more flexibly here. See below.
##

vo=x11,                 # To specify default video driver (see -vo help for
                        # list)

ao=alsa,                # To specify default audio driver (see -ao help for
                        # list)

fs=no                   # Enlarges movie window to your desktop's size.
                        # Used by drivers: all

vm=no                   # Tries to change to a different videomode
                        # Used by drivers: dga2, x11, sdl

bpp=0                   # Force changing display depth.
                        # Valid settings are: 0, 15, 16, 24, 32
                        # may need 'vm=yes' too.
                        # Used by drivers: fbdev, dga2, svga

zoom=no                 # Enable software scaling (powerful CPU needed)
                        # Used by drivers: svga, aalib

double=yes              # use double-buffering (recommended for xv with
                        # SUB/OSD usage)

# x=800                 # scale movie to <x> pixels width
# y=600                 # scale movie to <y> pixels height

osdlevel=1              # don't display OSD at stratup

monitoraspect=4:3       # standard monitor size, with square pixels
# monitoraspect=16:9    # use this for widescreen monitor! non-square pixels

cache = 1024            # Disk cache 1 MB

##
## Specify your preferred default skin here
## (skins are searched in /usr/share/mplayer/Skin/yourskin
##  and ~/.mplayer/Skin/yourskin)
##

skin = default


##
## Multiple languages are available smile
##
## Hungarian    igen    nem
## English      yes     no
## German       ja      nein
## Spanish      si      no
## Binary       1       0
##
## You can also use spaces and/or tabs.
##

#sound          = 1
#nosound        = nein
#mixer          = /dev/mixer

##
## resample the fonts' alphamap
## 0    plain white fonts
## 0.75 very narrow black outline (default)
## 1    narrow black outline
## 10   bold black outline
##

#ffactor = 0.75

##
## FBdev driver:

# fb = /dev/fb0                         # framebuffer device to use
# fbmode = 640x480-120                  # use this mode (read from fb.modes!)
# fbmodeconfig = /etc/fb.modes          # the fb.modes file

## VESA and FBdev driver: specify your monitor's timings
##
## (see for example /etc/X11/XF86Config for timings!)
## ** CAUTION! IF YOUR DISPLAY DOESN'T SUPPORT AUTOMATICALLY TURNING OFF WHEN
##    OVERDRIVED (AND EVEN IF IT DOES), THIS MAY CAUSE DAMAGE TO YOUR DISPLAY!
##    WE AREN'T RESPONSIBLE, IT'S YOUR DECISION! **
##
## k, K : means multiply by 1000
## m, M : means multiply by 1.000.000
##
# monitor_hfreq = 31.5k-50k,70k         # horizontal frequency range
# monitor_vfreq = 50-90                 # vertical frequency range
# monitor_dotclock = 30M-300M           # dotclock (or pixelclock) range

##
## SDL driver
##

# vo = sdl:aalib        # use SDL video driver by default
                        # use "vo = sdl:aalib" or "vo sdl:dga" and so on,
                        # for specifying SDL subdrivers
# ao = sdl:esd          # use SDL audio driver by default
                        # use "ao = sdl:esd" to use SDL's ESD driver
# noxv = no             # whether to use XVideo hardware acceleration or not
# forcexv = yes         # force XVideo even if not detected

##
## Other (preferred to be default from configfile) switches
##

framedrop=no            # drop frames, when not in sync (slow CPU, videocard,
                        # etc)

#vfm=ffmpeg             # use FFmpeg's libavcodec video codec family
                        # See "mplayer -vfm help" for all available codecs

#bps=yes                # use this method for playing AVIs (if have problems,
                        # try removing this)

# slang= en             # DVD : display english subtitles if available
# alang= en             # DVD : play english audio tracks if available

## This is the correct way to use "subconfig" type options in the
## configuration file. In the command line you use :
## -aop list=resample:fout=44100 , but here it is :
# aop=list=resample:fout=44100

# From Fedora
# the default mpeg audio decoder is currently broken, let's try libmad
# first:
afm=libmad

# get a default OSD font from fontconfig
#fontconfig = yes
#font = "Sans"
#subfont-text-scale = 3

pour la config video :
j'ai une carte ati mobility radeon 9200

Hors ligne

#4 Le 24/07/2005, à 12:51

janno59

Re : mplayer sur internet ne joue pas

Bonjour ,
si tu n'utilise pas mplayer pour tes videos , vire le et installe par l'extension firefox MediaPlayerConnectivity .
Ensuite tu le configure pour que se soit Xine qui lit les stream(wmv,quick,real).
Si le sont est dégueulasse il faut modifier le fichier catalog.cache dans le dossier ~/.xine de ton /home.
Dans le fichier catalog.cache , cherches la ligne :
[/usr/lib/xine/plugins/1.0.0/xineplug_decode_w32dll.so]
et au dessous modifie decoder priority=1 par decoder priority=7.
Moi j'avais 2 lignes [/usr/lib/xine/plugins/1.0.0/xineplug_decode_w32dll.so] à modifier .
Voila je peux tout lire avec un seul lecteur.
A+

Dernière modification par janno59 (Le 24/07/2005, à 12:52)


jean

Hors ligne

#5 Le 24/07/2005, à 13:38

coffee

Re : mplayer sur internet ne joue pas

pour le mplayer.conf

vo=sdl,                 # To specify default video driver (see -vo help for
                        # list)
                            #ou essaye gl si tu as installé le driver fglrx ou radeon

ao=alsa,                # To specify default audio driver (see -ao help for
                        # list)
                            #ou essaye esd sous gnome aussi mais il peut y avoir decalage, oss sinon

ça devrait marcher


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

Haut de page ↑