Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/01/2007, à 16:33

Nicolos

Driver nvidia, hibernation, et mise en veille

Bonjour,

Un nouveau post sur le sujet, (malgré les nombreux autres), qui apportera peut être un peu d'eau au moulin.

Nouveau sous Ubuntu/Edgy, j'utilisais depuis +4 ans les différentes Mandrake/Mandriva.
J'ai été séduit par le CD Edgy, la simplicité de cette distribution, l'ergonomie, et la superbe gestion des périphériques USB. Et également ce support communautaire et documentaire.

Pour en revenir à ce post.
Quelques petits réglages sur cette Edgy, pour que hibernation/veille + driver nvidia fonctionnent à merveille.
Ce, sur un PC de bureau (sis 745), avec une carte graphique un peu ancienne (MX440 / 16Mb).

En quelques points, voici donc à toutes fins utiles les modifs que j'ai effectuées :

Point de départ:
- Kernel : le 2.6.17-10-generic d'origine Edgy, inchangé
- Driver Nvidia : Celui disponible par Synaptic, le 1.0-8776. Pas testé ni encore recompilé de plus récents car fonctionne impec avec ma carte Nvidia.

=> De là, hibernation ou veille provoquaient un freeze/écran noir au resume.

1/ Première modif
Changer le driver agpgart par celui de nvidia. Pour celà, plusieurs petits ajouts à réaliser dans
/etc/X11/xorg.conf, ajout ligne : Option   "NvAGP"  "1"
/etc/modules, ajout ligne : nvidia-agp
/etc/modprobe.d/blacklist, ajout 2 lignes (attention, sis_agp à ajuster en fonction du chipset) :
blacklist sis_agp
blacklist agpgart

Puis reboot, et vérification que c'est bien le driver nvidia qui est chargé :
$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          NVIDIA   <---- Vérifier ceci (plus de AGPGART)
AGP Rate:        4x
Fast Writes:     Disabled
SBA:             Disabled


Là, je me retrouve avec une hibernation OK, mais une mise en veille toujours NOK (Freeze écran noir au redémarrage)

2/ Seconde modif

En consultant les scripts acpi d'hibernation et de veille, je suis alerté par la ligne :
unset POST_VIDEO
qui figure dans le script d'hibernation, mais pas dans celui de mise en veille.
De plus près, cette ligne génère au retour de mise en veille (dans /etc/acpi/resume.d/15-video-post.sh), l'exécution de la commande :
vbetool post
Le man de vbetool alerte bien sur un risque d'instabilité (et bug latent), lors d'un retour de mise en veille, de la commande vbetool post !

J'opte donc pour l'ajout de la ligne :
unset POST_VIDEO
dans le script /etc/acpi/sleep.sh, en ligne 32. (Ce script démarre la mise en veille)
Un extrait de ce script modifié, autour de la ligne ajoutée :

.../...
fi

# Ajout sinon crash on resume. Copie ligne de hibernation.sh
# Unset video posting 
unset POST_VIDEO

# Generic preparation code
. /etc/acpi/prepare.sh

if [ x$DISABLE_DMA = xtrue ] && [ -b /dev/hda ]; then
.../...

Après cette 2nd modif, le mode mise en veille fonctionne maintenant parfaitement !
Argh, il n'avait jamais voulu fonctionner sur mes Mandrake ! big_smile

3/ Dernière petites modifs
Ajouter aussi dans le fichier /etc/default/acpi-support, sur la ligne STOP_SERVICES= , les services qui doivent être arretés avant l'hibernation ou veille, puis redémarrés au resume.
Par exemple, le service athcool (powersaving sur Athlon) qui doit être redémarré au resume :
STOP_SERVICES="mysql athcool"

Hors ligne

#2 Le 04/01/2007, à 22:28

csoler

Re : Driver nvidia, hibernation, et mise en veille

j'ai essaye, i
pour la mise en veille l me dit un truc du genre 'usb external device: could not suspend device 2-16'. Le pb c'est que j'ai pas de device usb externe de branchee la !

Pour l'hibernation, j'ai droit a ca:

Broadcast Message from root@Psilocybe                                          
        (somewhere) at 21:29 ...                                               
                                                                               
The resume partition is not set up. Probably you need to add a                 

'resume=...' option to your kernel command line and reboot. Suspend            

to disk and resume is not possible without a resume partition,                 

please consult the documentation. You can skip this check by setting           

SUSPEND2DISK_SKIP_RESUME_CHECK to 'yes' in the sleep configuration file.

en plus, quand ca revient, j'ai une ligne sur deux qui est noire sur mon ecran (que pour l'hibernation). Ca doit etre un symptome courant.... D'ailleurs, c'est pas facile de tapper un post dans ces conditions ;-)

T'as une idee de ce qu'il se passe ?
Merci pour ton post en tous cas.

Cyril

Dernière modification par csoler (Le 04/01/2007, à 22:33)


Mon projet chou: http://retroshare.sourceforge.net
(Voir aussi la page ubuntu-fr: http://doc.ubuntu-fr.org/retroshare)

Hors ligne

#3 Le 04/01/2007, à 22:35

csoler

Re : Driver nvidia, hibernation, et mise en veille

juste pour m'abonner ;-)


Mon projet chou: http://retroshare.sourceforge.net
(Voir aussi la page ubuntu-fr: http://doc.ubuntu-fr.org/retroshare)

Hors ligne

#4 Le 05/01/2007, à 01:03

did

Re : Driver nvidia, hibernation, et mise en veille

Bonsoir Nicolos,

Grâce à tes trucs j'ai réussit à faire marcher l'hibernation sur mon laptop.

La situation de départ était un peu différent de la tienne, c'est à dire que seule la mise en veille prolongée fonctionnait, mais impossible de sortir correctement de l'hibernation (écran noir).
J'ai donc fait l'inverse de toi, j'ai supprimé unset POST_VIDEO dans mon hibernate.sh, et maintenant tout roule.

Merci à toi wink

Hors ligne

#5 Le 05/01/2007, à 10:09

did

Re : Driver nvidia, hibernation, et mise en veille

Bon sinon, j'essaye de faire marcher la mise en veille avec beryl, car jusqu'à présent si celui-ci est activé, je reste sur un écran noir, ou au mieux un freeze de l'écran de veille au réveil.
Je viens d'essayer de rajouter beryl dans STOP_SERVICES, mais sans résultat.

T'as pas une idée?

Merci

Hors ligne

#6 Le 05/01/2007, à 22:42

Nicolos

Re : Driver nvidia, hibernation, et mise en veille

did a écrit :

Bon sinon, j'essaye de faire marcher la mise en veille avec beryl, car jusqu'à présent si celui-ci est activé, je reste sur un écran noir, ou au mieux un freeze de l'écran de veille au réveil.
Je viens d'essayer de rajouter beryl dans STOP_SERVICES, mais sans résultat.

T'as pas une idée?

Merci

Pour l'instant, je n'ai pas encore installé Beryl, ni encore recompilé les derniers drivers nvidia. En fait, je démarre juste avec Ubuntu, donc installation toute fraiche de Edgy. Si j'ai du nouveau, je posterai.

Avec beryl, ton freeze est pareil en hibernation ou mise en veille ?

Hors ligne

#7 Le 05/01/2007, à 22:48

did

Re : Driver nvidia, hibernation, et mise en veille

Avec beryl, ton freeze est pareil en hibernation ou mise en veille ?

Oui c'est pareil dans les deux cas.

Hors ligne

#8 Le 05/01/2007, à 23:05

Nicolos

Re : Driver nvidia, hibernation, et mise en veille

csoler a écrit :

j'ai essaye, i
pour la mise en veille l me dit un truc du genre 'usb external device: could not suspend device 2-16'. Le pb c'est que j'ai pas de device usb externe de branchee la !

Pour l'hibernation, j'ai droit a ca:

Broadcast Message from root@Psilocybe                                          
        (somewhere) at 21:29 ...                                               
                                                                               
The resume partition is not set up. Probably you need to add a                 

'resume=...' option to your kernel command line and reboot. Suspend            

to disk and resume is not possible without a resume partition,                 

please consult the documentation. You can skip this check by setting           

SUSPEND2DISK_SKIP_RESUME_CHECK to 'yes' in the sleep configuration file.

en plus, quand ca revient, j'ai une ligne sur deux qui est noire sur mon ecran (que pour l'hibernation). Ca doit etre un symptome courant.... D'ailleurs, c'est pas facile de tapper un post dans ces conditions ;-)

T'as une idee de ce qu'il se passe ?
Merci pour ton post en tous cas.

Cyril

Tu es bien sous Edgy ?

Le pb du suspend semble lié à la partition de resume, qui, normallement, est la partition de swap. Donc :
  . Tu as bien une partition de swap, de taille ~ 2xla taille de ta RAM, et ce swap est activé ?
  . Si c'est le cas, l'install et initramfs ont mal détecté et initialisé le swap/resume à l'install. Tu peux donc y remédier :
    * soit en créant (ou vérifie s'il est créé) le fichier /etc/initramfs-tools/conf.d/resume qui doit contenir une ligne de type : RESUME=UUID=<le UUID de ta partition de swap>
    * soit en ajoutant à la ligne kernel= de ton fichier de démarrage Grub (/boot/grub/menu.lst) la commande : resume=/dev/hdaX  ou hdaX est la partition de swap


Pour le pb usb, il semblerait que le hardware ne supporte pas bien la demande de passage en veille. Pour ma part, je fonctionne en acpi S3.
Essaie de voir l'effet de la commande :
$ sudo invoke-rc.d mountdevsubfs.sh stop
puis
$ sudo invoke-rc.d mountdevsubfs.sh start
Y a t-il des messages d'erreur ?
Si pas de messages d'erreur autre que le lien symbolique déjà existant, essaie d'ajouter dans le fichier
/etc/default/acpi-support  dans la variable  STOP_SERVICES=
STOP_SERVICES="mysql mountdevsubfs.sh"
Reteste et reposte

Hors ligne

#9 Le 25/02/2007, à 17:13

postb99

Re : Driver nvidia, hibernation, et mise en veille

Salut,

Pour ce qui est de ta 2e modif Nicolos j'ai trouvé que dans /etc/default/acpi-support il y a une variable nommée POST_VIDEO qui est à true par défaut, et que j'ai mise à false. Ca a l'air de faire la même chose que d'éditer /etc/acpi/sleep.sh wink

Sinon je vois pas la même chose que toi dans /proc, ça m'étonne, alors j'ai cherché un peu dans /sys, je vois que NvAGP n'est pas à 0 donc ça a l'air OK wink

barbara@sirius:~$ cat /proc/driver/nvidia/registry 
VideoMemoryTypeOverride: 1
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0

Euh, Windows 7 + logiciels libres... plus trop de Linux dans ma vie désolée.

Hors ligne

#10 Le 26/02/2007, à 07:43

eln

Re : Driver nvidia, hibernation, et mise en veille

Bonjour

Un grand merci à Nicolos.

J'ai enfin réussi à faire marcher l'hibernation et la mise en veille avec l'accélération graphique d'activée sur une GeForce4 Ti 4200 Go.

Bravo. big_smile

Hors ligne

#11 Le 13/03/2007, à 01:29

Willen

Re : Driver nvidia, hibernation, et mise en veille

Merci Nicolos,
La mise en veille fonctionne maintenant !

Hors ligne

#12 Le 13/03/2007, à 02:30

zit

Re : Driver nvidia, hibernation, et mise en veille

Moi jamais reussi avec ma celebre GeForce4 Ti 4200 Go.
Message d'erreur à la mise en hibernation...
Et j'ai tout essayé mais impossible d'afficher nvidia à la place de agpgart

Hors ligne

#13 Le 13/03/2007, à 21:57

Nicolos

Re : Driver nvidia, hibernation, et mise en veille

zit a écrit :

Et j'ai tout essayé mais impossible d'afficher nvidia à la place de agpgart

Probablement la raison pour laquelle l'hibernation ne fonctionne pas (Quid de la mise en veille ?)

Quel est le message d'erreur d'entrée en hibernation ?
As tu bien blacklisté le driver agpgart ? Tu peux connaitre le driver agp chargé en faisant un :

$ lsmod |grep agp

Quel est le résultat ?

Ensuite, empêcher ce driver de se charger en le blacklistant dans le fichier /etc/modprobe.d/blacklist

Hors ligne

#14 Le 14/03/2007, à 00:34

zit

Re : Driver nvidia, hibernation, et mise en veille

Le message est grosso modo :

[suite de chiffres] PNP : Failed to activate device 00.0C

Et après  la partition swap se casse, obligé de la reformater

oui j'ai bien sur essayé de blacklister avec /etc/modprobe.d/blacklist et xorg.conf mais agpgart se lance quand même.

blacklist sis_agp
blacklist nvidia_agp
blacklist agpgart
blacklist amd64_agp
blacklist agpgart-amd64
lsmod |grep agp
nvidia_agp              9628  1 
agpgart                34888  2 nvidia_agp,nvidia

Cela peut t-il venir de ma carte mère A7N8X-E deluxe? (chipset nforce 2 connu pour être très mauvais...) lol

Hors ligne

#15 Le 19/04/2007, à 23:25

Alain.g

Re : Driver nvidia, hibernation, et mise en veille

Nicolos a écrit :

J'opte donc pour l'ajout de la ligne :
unset POST_VIDEO
dans le script /etc/acpi/sleep.sh, en ligne 32. (Ce script démarre la mise en veille)
Un extrait de ce script modifié, autour de la ligne ajoutée :

.../...
fi

# Ajout sinon crash on resume. Copie ligne de hibernation.sh
# Unset video posting 
unset POST_VIDEO

# Generic preparation code
. /etc/acpi/prepare.sh

if [ x$DISABLE_DMA = xtrue ] && [ -b /dev/hda ]; then
.../...

Après cette 2nd modif, le mode mise en veille fonctionne maintenant parfaitement !
Argh, il n'avait jamais voulu fonctionner sur mes Mandrake ! big_smile

Bonsoir,

cette modif avait très bien fonctionné sous Edgy, mais ce n'est plus le cas sous Feisty, malheureusement !
A la sortie de la mise en veille, j'ai un écran noir et tout est gelé. sad

Dernière modification par Alain.g (Le 19/04/2007, à 23:25)


Xubuntu Karmic !

Hors ligne

#16 Le 29/04/2007, à 22:08

Nicolos

Re : Driver nvidia, hibernation, et mise en veille

Alain.g a écrit :

Bonsoir,

cette modif avait très bien fonctionné sous Edgy, mais ce n'est plus le cas sous Feisty, malheureusement !
A la sortie de la mise en veille, j'ai un écran noir et tout est gelé. sad

Je viens de passer en Feisty depuis ~1h.

Ai commencé par un petit état des lieux, dont, notamment, la mise en veille/hibernation.

Nota : pas encore testé avec compiz.

Brut de fonderie, la mise en veille et l'hibernation ne fonctionnent pas (je rappelle, je suis en graphique nvidia).

C'est normal, car pendant l'upgrade et l'installation des paquets Feisty, un popup est apparu pour demander de mettre en place un nouveau fichier /etc/modprobe.d/blacklist . J'ai répondu oui, donc les précédentes modifications que j'avais ajoutées pour interdire le chargement des drivers sis_agp et agpgart (je suis en chipset sis) n'y étaient plus. Voir le premier post de ce fil.
Confirmé par un :
$ cat /proc/driver/nvidia/agp/status
qui montre le chargement du driver AGPGART au lieu du NVIDIA

Donc je recommence la manip décrite dans le premier post, mais uniquement l'ajout des 2 lignes dans /etc/modprobe.d/blacklist
Nota : le fichier /etc/modules n'a pas été changé lors de l'upgrade, la ligne :
nvidia-agp
y était toujours.

Puis reboot, et retest de la mise en veille et de l'hibernation : cette fois, les 2 sont OK.

En conclusion, sous Feisty, aucune modif dans les fichiers acpi (donc rien touché dans /etc/acpi/sleep.sh).
Le chargement du driver nvidia au lieu du agpart paraît donc fondamentale pour le fonctionnement de la mise en veille et de l'hibernation.

Je vais tester avec compiz et l'activation des effets de bureau, je compléterai dans ce post si besoin.

Hors ligne

#17 Le 14/05/2007, à 15:33

shyalan

Re : Driver nvidia, hibernation, et mise en veille

Bonjour tout le monde, smile

Intéressant Nicolos tes astuces mais pour moi cela ne fonctionne pas !  hmm

Portable HP zd7112 avec carte NVIDIA 5200 GeForce écran 16/9 ème. Je suis sous FEISTY, sous Dapper c'était la même mouise à partir du moment où j'ai installé le driver NVIDIA.

J'ai passé la matinée à regarder tout cela et là je craque !!!  mad Je vais persévérer mais franchement ça me soule. sad

Y a plein de posts un peu partout sur le sujet. Mais c'est tellement spécifique que je crains le pire. En tout cas, il est évident que c'est ce P...... de driver propriétaire NVIDIA (sûrement pareil pour les autres types de carte vidéo) qui fait merder la machine car sans l'installer la veille et l'hibernation fonctionne nickel.

Bref, en tout cas merci à tous d'essayer, à plusieurs on se sent moins seul !!! (n'importe quoi, moi) lol

je continue de chercher ... cool

Shyalan smile

@+


Asus Gamer G55VW - i7 - 16 Go Ram - Nvidia GTX 660M (2Go dédié) - dual boot win8.1-ubuntu 14.04 LTS
- Netbook Asus 1025C Sous Win7-starter ---->dual-boot Kubuntu 12.04 (KDE semble mieux gérer la batterie)

Hors ligne

#18 Le 14/05/2007, à 21:07

Nicolos

Re : Driver nvidia, hibernation, et mise en veille

shyalan a écrit :

Bonjour tout le monde, smile

Portable HP zd7112 avec carte NVIDIA 5200 GeForce écran 16/9 ème. Je suis sous FEISTY, sous Dapper c'était la même mouise à partir du moment où j'ai installé le driver NVIDIA.

Y a plein de posts un peu partout sur le sujet. Mais c'est tellement spécifique que je crains le pire. En tout cas, il est évident que c'est ce P...... de driver propriétaire NVIDIA (sûrement pareil pour les autres types de carte vidéo) qui fait merder la machine car sans l'installer la veille et l'hibernation fonctionne nickel.

@+

Pourrais tu juste poster la nature de ton dysfonctionnement, au moins pour tenter de cibler ce qui pourrait en être la cause ?

Hors ligne

#19 Le 14/05/2007, à 22:58

shyalan

Re : Driver nvidia, hibernation, et mise en veille

Ah oui pardon, je croyais que c'était implicite car c'est la même chose que toi :

si je demande à passer en veille : tout se passe bien, le PC se met en veille correctement mais lorsque j'appuie sur entrée pour en sortir : ECRAN NOIR et puis plus rien ... je suis obligé de redémarrer avec CTRL + ALT + SUPP (si j'ai bien tout compris c'est X qui plante, je connais pas encore tout ...)

J'ai fait tout ce que tu as dis pour FEISTY, ça marchait pas alors j'ai tenté d'ajouter ce qu'il faut dans le sleep.sh mais bon rien n'y a fait.

Remarque : j'ai voulu m'amuser avant de faire ses opérations (durant ces derniers jours) et j'ai installé BERYL, c'est vrai que c'est rigolo tout cela ! Mais bon j'ai du changer des trucs dans xorg.conf. J'aurais peut-être pas du ? Bref peut-être qu'il serait bon que je revienne à un FEISTY tout propre et rééssayer tes manips ? Qu'en penses-tu ?

J'ai lu un truc en anglais sur un post : http://blog.paulbetts.org/index.php/2007/02/11/fixing-software-suspend-hibernate-with-uswsusp-in-ubuntu-feisty-and-edgy/

Mais bon je suis pas très bon en anglais et encore moins en langage informatique, mais ça m'a l'air bizarre ...

Voili voilou, je continue mes recherches ... ou alors j'essaie de réinstaller FEISTY et le garder propre pour tester ou juste récupérer mon xorg.conf.back ben oui on est sous LINUX, suis-je bête ! ???

Chat Haut

Shyalan


Asus Gamer G55VW - i7 - 16 Go Ram - Nvidia GTX 660M (2Go dédié) - dual boot win8.1-ubuntu 14.04 LTS
- Netbook Asus 1025C Sous Win7-starter ---->dual-boot Kubuntu 12.04 (KDE semble mieux gérer la batterie)

Hors ligne

#20 Le 15/05/2007, à 00:05

shyalan

Re : Driver nvidia, hibernation, et mise en veille

Oulala !  EUREKA !!!! Je crois que j'ai trouvé mon info manquante ... ! smile

Youpi Youpi big_smile:D:D

bon je suis allé sur sur ce rapport de bug en lisant un post : https://launchpad.net/ubuntu/+source/acpi-support/+bug/67710

et si vous lisez le dernier message tout en bas de la page, il est dit qu'en installant le paquet xserver-xorg-video-intel le problème est résolu et bien je vous confirme la chose ! c'est résolu pour moi. Par contre ce paquet entraine la suppression de xserver-xorg-videoi810 (un truc comme ça) et je sais pas si c'est important ou pas. voili voilou.

Je ne sais pas si cela fonctionne pour les ATI et autres , je ne sais pas si les manip de Nicolos sont obsolètes ou pas car moi elles sont encore existantes (je ne les ai pas supprimées) ? Je ne sais pas à quoi sert ce paquet, mais ça marche ? en gros, faudrait que je reprenne tout à zéro : feisty propre sans BERYL, etc ... et puis voir ce que cela donne juste en installant ce paquet. cool

Voili voilou ! Comme quoi ...:P

Shyalan wink

PS : je vais pouvoir aller me coucher tranquille ... enfin faut que je teste l'hibernation pour voir quand même ...

OUPS : l'hibernation ne fonctionne pas ... mais bon moi je m'en moque un peu, c'était surtout la veille qui m'intéressait mais bon ... y a un truc à regarder encore

Dernière modification par shyalan (Le 15/05/2007, à 00:09)


Asus Gamer G55VW - i7 - 16 Go Ram - Nvidia GTX 660M (2Go dédié) - dual boot win8.1-ubuntu 14.04 LTS
- Netbook Asus 1025C Sous Win7-starter ---->dual-boot Kubuntu 12.04 (KDE semble mieux gérer la batterie)

Hors ligne

#21 Le 17/05/2007, à 20:03

HKH

Re : Driver nvidia, hibernation, et mise en veille

salut

merci à toi Nicolos.
Ta manip fonctionne aussi pour ma config sous Feisty!
j ai suivi exactement tes modif :Le retour de  La Mise en Veille Prolongéé et de l Hibernation  fonctionnent maintenant!!Plus d ecran noir!!

voila ma config

Feisty 7.04
P4 2.8 Ghz
carte mere Asus
carte graphique Nvidia 7600GS
Driver Proprio Nvidia ( installation manuel car bug du serveur X : http://doc.ubuntu-fr.org/nvidia.run )

Edit:Passage a Hardy ces manipulations sont toujours valable pour ma config avec le driver nvidia des depots

Dernière modification par HKH (Le 04/08/2008, à 12:38)

Hors ligne

#22 Le 28/05/2007, à 10:32

az

Re : Driver nvidia, hibernation, et mise en veille

Nicolos a écrit :

Bonjour,

Un nouveau post sur le sujet, (malgré les nombreux autres), qui apportera peut être un peu d'eau au moulin.

Nouveau sous Ubuntu/Edgy, j'utilisais depuis +4 ans les différentes Mandrake/Mandriva.
J'ai été séduit par le CD Edgy, la simplicité de cette distribution, l'ergonomie, et la superbe gestion des périphériques USB. Et également ce support communautaire et documentaire.

Pour en revenir à ce post.
Quelques petits réglages sur cette Edgy, pour que hibernation/veille + driver nvidia fonctionnent à merveille.
Ce, sur un PC de bureau (sis 745), avec une carte graphique un peu ancienne (MX440 / 16Mb).

En quelques points, voici donc à toutes fins utiles les modifs que j'ai effectuées :

Point de départ:
- Kernel : le 2.6.17-10-generic d'origine Edgy, inchangé
- Driver Nvidia : Celui disponible par Synaptic, le 1.0-8776. Pas testé ni encore recompilé de plus récents car fonctionne impec avec ma carte Nvidia.

=> De là, hibernation ou veille provoquaient un freeze/écran noir au resume.

1/ Première modif
Changer le driver agpgart par celui de nvidia. Pour celà, plusieurs petits ajouts à réaliser dans
/etc/X11/xorg.conf, ajout ligne : Option   "NvAGP"  "1"
/etc/modules, ajout ligne : nvidia-agp
/etc/modprobe.d/blacklist, ajout 2 lignes (attention, sis_agp à ajuster en fonction du chipset) :
blacklist sis_agp
blacklist agpgart

Puis reboot, et vérification que c'est bien le driver nvidia qui est chargé :
$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          NVIDIA   <---- Vérifier ceci (plus de AGPGART)
AGP :        4x
Fast Writes:     Disabled
SBA:             Disabled


Là, je me retrouve avec une hibernation OK, mais une mise en veille toujours NOK (Freeze écran noir au redémarrage)

2/ Seconde modif

En consultant les scripts acpi d'hibernation et de veille, je suis alerté par la ligne :
unset POST_VIDEO
qui figure dans le script d'hibernation, mais pas dans celui de mise en veille.
De plus près, cette ligne génère au retour de mise en veille (dans /etc/acpi/resume.d/15-video-post.sh), l'exécution de la commande :
vbetool post
Le man de vbetool alerte bien sur un risque d'instabilité (et bug latent), lors d'un retour de mise en veille, de la commande vbetool post !

J'opte donc pour l'ajout de la ligne :
unset POST_VIDEO
dans le script /etc/acpi/sleep.sh, en ligne 32. (Ce script démarre la mise en veille)
Un extrait de ce script modifié, autour de la ligne ajoutée :

.../...
fi

# Ajout sinon crash on resume. Copie ligne de hibernation.sh
# Unset video posting 
unset POST_VIDEO

# Generic preparation code
. /etc/acpi/prepare.sh

if [ x$DISABLE_DMA = xtrue ] && [ -b /dev/hda ]; then
.../...

Après cette 2nd modif, le mode mise en veille fonctionne maintenant parfaitement !
Argh, il n'avait jamais voulu fonctionner sur mes Mandrake ! big_smile

3/ Dernière petites modifs
Ajouter aussi dans le fichier /etc/default/acpi-support, sur la ligne STOP_SERVICES= , les services qui doivent être arretés avant l'hibernation ou veille, puis redémarrés au resume.
Par exemple, le service athcool (powersaving sur Athlon) qui doit être redémarré au resume :
STOP_SERVICES="mysql athcool"

Bonjour Nicolos,

Apres toutes ces modifs peut-tu me montrer ce que te donne la commande "lsmod"

Merci.

#23 Le 16/06/2007, à 11:40

Geoffrey

Re : Driver nvidia, hibernation, et mise en veille

zit a écrit :

Moi jamais reussi avec ma celebre GeForce4 Ti 4200 Go.
Message d'erreur à la mise en hibernation...
Et j'ai tout essayé mais impossible d'afficher nvidia à la place de agpgart

Pareil, chez moi AGPGART est lancé meme si je le blacklist, résultat :

$ cat /proc/driver/nvidia/agp/status
Status:          Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem.

Hors ligne

#24 Le 16/06/2007, à 12:03

eln

Re : Driver nvidia, hibernation, et mise en veille

Bonjour

@ Geoffrey

Personnellement et après quelques tests j'ai réussi à faire marcher l'hibernation et la mise en veille sur mon ordi.

lspci
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 Go AGP 8x] (rev a1)

J'ai juste fait ces deux modifications :

/etc/X11/xorg.conf ajout ligne : Option   "NvAGP"  "1"
/etc/modules, ajout ligne : nvidia-agp

agpgart est lancé chez moi aussi mais il n'interfère pas

cat /proc/driver/nvidia/agp/status
Status:          Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem.

Je précise que je suis sur debian 4.0, kde, et installation de kpowersave (surtout le paquet uswsusp)
Pilote nvidia 1.0.8776-4

Si cela peut aider smile

Hors ligne

#25 Le 17/06/2007, à 21:22

golgoth21

Re : Driver nvidia, hibernation, et mise en veille

Je cherche une solution similaire pour une 6800 PCI-E

Ecran noir en sortie de veille.

Si vous avec une solution, merci par avance.

Hors ligne