Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 26/07/2005, à 10:42

Athol

Pas de desktop

Bonjour,

Je viens d'installer ubuntu en suivant scrupuleusement le tuto de http://yekubuntu.free.fr/hoary/index.php,
je précise que je tente cette installation sur un PC qui n'est pas connecté à internet.

L'installation c'est passé comme prévu mais au premier lancement: j'arrive à me loger, je vois l'écran de démarrage de Gnome puis plus rien, je reçois ce message d'erreure :
"Error,    failed to initialize HAL!",
puis au bout d'un moment une fenetre s'ouvre avec à l'intérieur l'icone Desktop mais je n'ai pas les menus Gnome.

Quelqun connait il les raisons de ce problème ainsi que la solution????

Merci par avance,

@+++++

Hors ligne

#2 Le 26/07/2005, à 10:49

Kitty

Re : Pas de desktop

Problème rencontré par d'autres personnes :

http://www.ubuntuforums.org/showthread. … ialize+HAL

Pour contourner le problème : booter avec un CD audio dans le lecteur ???? (bizarre...)

Une autre solution : http://ubuntuforums.org/showthread.php? … ge=2&pp=10

Hors ligne

#3 Le 26/07/2005, à 12:29

Athol

Re : Pas de desktop

Merci pour la réponse,

Effectivement en bootant avec un CD audio dans le lecteur ça a marché, mais ensuite mes lecteurs cd ne sont plus accéssible, je ne peux même pas éjecter le cd audio.

Je vais essayer de voir avec les liens que tu m'as indiqués mais le gros problème c'est que je ne maitrise pas l'anglais .:/

Merci en attendant


@++++++

Hors ligne

#4 Le 26/07/2005, à 14:00

Kitty

Re : Pas de desktop

Après avoir booté, peux-tu mettre à jour tout ton système ?
Le bug aura p'tet été corrigé...

Hors ligne

#5 Le 26/07/2005, à 14:06

Athol

Re : Pas de desktop

Je rappel que je n'ai pas de connexion internet sur cet ordi!

Lorsque je vais dans mises à jour automatiques il me répond que mon ordi est à jour.

Merci
@+++++

Hors ligne

#6 Le 26/07/2005, à 14:13

Kitty

Re : Pas de desktop

Pardon...

bon, je te traduis des astuces trouvées dans les forums en anglais :

Astuce n°1 :
Ajouter

hdc=noprobe hdc=cdrom

dans /boot/grub/menu.lst
à la ligne de chargement du noyau

Astuce n°2 :
booter jusqu'à l'erreur
taper CTRL+ALT+F1
se loguer
taper

sudo killall gdm
sudo gdm

Astuce n°3 :
booter jusqu'à l'erreur
taper CTRL+ALT+F1
se loguer
taper

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
sudo dpkg-reconfigure xserver-xorg

Hors ligne

#7 Le 26/07/2005, à 15:11

Athol

Re : Pas de desktop

Rien à faire,
plus rien ne fonctionne, même avec un cd audio inséré dans le lecteur cdrom.

Je précise que le CD live fonctionne très bien!!!!!!!

Hors ligne

#8 Le 26/07/2005, à 15:12

Kitty

Re : Pas de desktop

Qu'entends-tu par "plus rien ne fonctionne" ?
Ca boot et ça plante ?
Ca ne boot pas ?

Hors ligne

#9 Le 26/07/2005, à 15:28

Athol

Re : Pas de desktop

Ca boot et ça plante.

Hors ligne

#10 Le 26/07/2005, à 15:43

Kitty

Re : Pas de desktop

Et quels les messages ?
Peux-tu faire CTL+ATL+F1 ?

Hors ligne

#11 Le 26/07/2005, à 15:47

Athol

Re : Pas de desktop

J'ai fait exactement tout ce que tu m'as indiqué en commençant par l'astuce 1 puis 2 .....

Je ne comprend pas d'autant plus que le live cd fonctionne très bien

Hors ligne

#12 Le 26/07/2005, à 15:50

Kitty

Re : Pas de desktop

Heu, je me suis mal exprimé. hmm C'était astuce 1 ou bien astuce 2 ou bien astuce 3

Si l'astuce 1 t'empêche complètement de booter, vire là !
Et essaye la 2.

Et si ça marche pas, essaye la 3.

Hors ligne

#13 Le 26/07/2005, à 15:55

Athol

Re : Pas de desktop

J'ai effectué les astuces les unes après les autres,
la 1 n'a rien réglé mais ne m'empèche pas de booter
la 2 idem
la 3 m'a empéché de booter j'ai donc restauré l'ancien fichier en passant par le live cd

Hors ligne

#14 Le 26/07/2005, à 15:56

Kitty

Re : Pas de desktop

OK ! Merci de retour !

Désolé pour ces solutions qui ne fonctionnent pas (j'avais juste traduit ce que j'avais trouvé en anglais...)

Hors ligne

#15 Le 26/07/2005, à 16:02

Athol

Re : Pas de desktop

Pas de problème,

merci d'avoir essayé. Si tu comprends quelques choses voici un autre lien qui doit traiter du sujet mais je ne comprends pas tout.
http://ubuntuforums.org/showthread.php?t=28805&page=2&pp=10

Si tu as le temps.........

Merci tout de même d'avoir essayé

@+++++

Hors ligne

#16 Le 26/07/2005, à 16:27

Kitty

Re : Pas de desktop

Traduction :

1°) modifier le fichier /etc/hdparm.conf (sudo gedit /etc/hdparm.conf) pour commenter les lignes suivantes (ajouter un '#') :

......

#/dev/hdc {
#        dma = on
#}

#/dev/hdd {
#        dma = on
#}

(ici, les lignes sont commentées)

2°) créer le script /etc/init.d/cdroms_dma (sudo gedit /etc/init.d/cdroms_dma)

#! /bin/sh
# /etc/init.d/cdroms_dma
#

# Carry out specific functions when asked to by the system
case "$1" in
  start)
    echo "Enable DMA for /dev/hdc ..."
    hdparm -d 1 /dev/hdc
    sleep 1
    echo "Enable DMA for /dev/hdd ..."
    hdparm -d 1 /dev/hdd
    echo "DONE!"
    ;;
  stop)
    echo "Disable DMA for /dev/hdc ..."
    hdparm -d 0 /dev/hdc
    sleep 1
    echo "Disable DMA for /dev/hdd ..."
    hdparm -d 0 /dev/hdd
    echo "DONE!"
    ;;
  *)
    echo "Usage: /etc/init.d/cdroms_dma {start|stop}"
    exit 1
    ;;
esac

exit 0

Attention, il faut rendre le script excéutable (sudo chmod +x /etc/init.d/cdroms_dma)

3°) ajouter ce script au démarrage/arrêt de l'ordinateur :

sudo update-rc.d cdroms_dma defaults

Explication : on désactive le dma au boot (par le fichier /etc/hdparm.conf), et on le réactive plus tard (une fois que c'est bien booté)

Hors ligne

#17 Le 26/07/2005, à 16:40

Athol

Re : Pas de desktop

Merci pour la traduction, cela va bien m'aider. smile

Je vais essayer tout cela demain matin car je suis obliger de quitter maintenant.:cool:

Merci encore pour tout.

@+++++

Hors ligne

#18 Le 27/07/2005, à 12:32

Athol

Re : Pas de desktop

Bien revenons à nos moutons,

J'ai fait quelques essais et voici mes conclusions:
En fait j'ai un graveur cd Yama en plus de mon lecteur dvd j'ai donc essayé de faire l'astuce n°1 en remplaçant hdc par hdd et là, l'ordi se plante complet pendant le boot j'ai donc annullé cette modif puis j'ai modifié le fichier hdparm.conf pour activer le dma sur hdd ça ne marche pas mieux qu'au début, j'ai donc fini par débrancher mon graveur pour essayer et là, miracle, tout fonctionne.:/:/
J'en conclu donc que c'est mon graveur qui empèchait le desktop de démarrer.
Le problème c'est que je ne voie pas comment me passer de ce graveur.

Si vous avez des idées pour corriger ce problème elles seront les bienvenues.;);)

Merci d'avance

@++++

Hors ligne

#19 Le 27/07/2005, à 12:44

cep

Re : Pas de desktop

Tout semble normal dans les indications renvoyées par le bios ? pas de multiboot sur la machine ?

Essaye de changer la place du graveur sur la nappe, ou de port ou de voir si une autre configuration des cavaliers ne conviendrait pas mieux.

Hors ligne

#20 Le 27/07/2005, à 12:48

Athol

Re : Pas de desktop

J'ai effectivement un multiboot  avec Windows xp

Ce graveur fonctionne très bien sous windows d'ailleur!

Je n'ai pas de message d'erreur......

Hors ligne

#21 Le 28/07/2005, à 18:49

Athol

Re : Pas de desktop

Kitty a écrit :

Traduction :

1°) modifier le fichier /etc/hdparm.conf (sudo gedit /etc/hdparm.conf) pour commenter les lignes suivantes (ajouter un '#') :

......

#/dev/hdc {
#        dma = on
#}


#/dev/hdd {
#        dma = on
#}

(ici, les lignes sont commentées)

2°) créer le script /etc/init.d/cdroms_dma (sudo gedit /etc/init.d/cdroms_dma)

#! /bin/sh
# /etc/init.d/cdroms_dma
#

# Carry out specific functions when asked to by the system
case "$1" in
  start)
    echo "Enable DMA for /dev/hdc ..."
    hdparm -d 1 /dev/hdc
    sleep 1
    echo "Enable DMA for /dev/hdd ..."
    hdparm -d 1 /dev/hdd
    echo "DONE!"
    ;;
  stop)
    echo "Disable DMA for /dev/hdc ..."
    hdparm -d 0 /dev/hdc
    sleep 1
    echo "Disable DMA for /dev/hdd ..."
    hdparm -d 0 /dev/hdd
    echo "DONE!"
    ;;
  *)
    echo "Usage: /etc/init.d/cdroms_dma {start|stop}"
    exit 1
    ;;
esac

exit 0

Attention, il faut rendre le script excéutable (sudo chmod +x /etc/init.d/cdroms_dma)

3°) ajouter ce script au démarrage/arrêt de l'ordinateur :

sudo update-rc.d cdroms_dma defaults

Explication : on désactive le dma au boot (par le fichier /etc/hdparm.conf), et on le réactive plus tard (une fois que c'est bien booté)

Bonjour à tous,

J'ai effectuer tous ces changement et cela ne fonctionne pas au contraire il plante durant le boot au moment de:  "Starting Enterprise Volume Management System..."

Je voudrais donc tout annuler. Comment faire pour retirer cdroms_dma de rc.d ????
ou plus clairement pour annuler:

sudo update-rc.d cdroms_dma defaults


Merci d'avance

@+++++

Hors ligne

#22 Le 29/07/2005, à 09:46

Kitty

Re : Pas de desktop

sudo update-rc.d cdroms_dma remove

Hors ligne

#23 Le 29/07/2005, à 14:21

Athol

Re : Pas de desktop

Merci encore une fois kitty,

Si tu voix une solution pour mon problème ......
Ou bien quelle pourrait en être la cause????

Bye, @+++++++

Hors ligne

Haut de page ↑