Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/01/2007, à 19:56

Eikasia

WIFI Chipset rt61

Bonsoir smile

Contexte : Suite à un gros souci lors du passage à Edgy j'ai du réinstaller Dapper. Un peu dépiter de ne pas goutter à la 6.10 mais surtout très effrayé à l'idée de devoir installer à nouveau pas carte wifi  MSI PC54G3 qui dépend du chipset rt61. Lors de son installation il y a quelques mois j'avais mis plus de trois jours à la dresser et ce, non sans de grosses difficultés. Je vous invite à retrouver mes topics à ce sujet wink mais en gros de gros plantage lors du reboot et impossible d'accéder au bureau sans devoir désinstaller la carte wifi ce qui est plus que fastidieux quand vous faites sans ça 5 ou 6 fois dans une aprem pour tenter de la configurer...

Bref je m'arme de courage, je lance une prière à tous les saints de l'enfer et je me jette à l'eau pour une réinstalle.

Nouvelle installation :
1/ je retourne lire l'article du wiki au sujet du chipset rt61 qui a un peu évolué depuis la dernière fois avec une partie consacré à son installation sur edgy et surtout en fin de page l'ajout de nombreux commentaires qui me rendent très sceptique quant ma possible réinstallation.

2/ Des commentaires font état d'une nouvelle version du pilote RT61_Linux_STA_Drv1.0.4.0.tar.gz pour un pilote RT61_Linux_STA_Drv1.1.0.0.tar.gz et conseille d'éditer le script

3/Premier hic, le lien renvoyant à ce pilote sur le site de ralink est mort mais rien de bien grave on peut le trouver sur cette page : ralink. J'édite le script avec gedit mais avant ça je m'aperçois d'une petite erreur lié au lien mort. En effet, non seulement la version du pilote à changer mais en plus l'url a évolué depuis.
Ainsi ce n'est plus :

http://www.ralinktech.com/drivers/Linux/RT61_Linux_STA_Drv1.0.4.0.tar.gz

mais désormais :

http://www.ralinktech.com/ralink/data/RT61_Linux_STA_Drv1.1.0.0.tar.gz

Voilà une version correcte[12/01/07] du script

4/Petit conseil (mais je demande confirmation) la première fois que j'ai voulu installer cette carte le seul truc qui avait semblé la dresser (désolé pour le champ sémantique mais elle m'avait sacrement fait c****) c'était d'installer network-manager. Pour cette réinstallation le 1° truc que j'ai fait : installer : network-manager et network-manager-gnome et au lieu de passer 3 jours à la configurer en 10 minutes c'etait réglé smile

5/Dernier détail : laisser la connexion en dhcp et oublier l'IP fixe ( je sais c'est rageant). Pour ma première installation l'IP fixe fut impossible à obtenir et aujourd'hui je n'ai pas tenté le coup : pas envie de devoir désinstaller ma carte, reconfigurer les fichiers et la réinstaller. Mais je pense que de toute façon c'est mort pour l'ip fixe. En effet, si c'est réellement network-manager qui permet de configurer la carte wifi c'est en dhcp...

Conclusion : Je suis une un brin pas doué avec la mise en page des wiki d'autant plus que je trouve le wiki d'ubuntu trop peu intuitif (loin de moi l'idée de jeter la pierre à qui que ce soit, le wiki reste un outil merveilleux) pour un plouc comme moi (contrairement au wiki de wikipédia). Tout ça pour dire que si une âme charitable trouve mes remarques pertinentes et veut bien se donner la peine d'en tenir compte pour éditer la page du wiki, je pense que ça pourrait servir à certains (du moins je l'espère) wink En attendant j'ai fait un lien vers ce post et vers une version du script mise à jour [15/01/07]


Merci à vous wink

Dernière modification par Eikasia (Le 18/01/2007, à 21:22)


Ubuntu 12.04 LTS (64 bits) :  boîtier, Textorm 69U6 ; alim, LDLC BG-400 Quality Select 80PLUS Bronze ; cm, Gigabyte GA-F2A75M-D3H ; proc, AMD A8-5600K (3.6 GHz) B E ; ram, Kingston HyperX 4 Go (2x 2Go) DDR3 1600 MHz ; cg, ASUS 210-1GD3-L 1 GB ; dd, Seagate Barracuda 7200.14 SATA 6Gb/s 1 To ; dd, Seagate ST3250624AS ; impri/scan HP PSC 1510.
Ubuntu 12.04 LTS (32 bits) : portable ASUS K53E-SX1254V.

Hors ligne

#2 Le 18/01/2007, à 20:09

DrScholl

Re : WIFI Chipset rt61

Salut
Je suis pas très sûr car gros débutant, mais je viens de lire ceci sur le forum en anglais (le post entier est ) :

(a) Do not use the "Networking" tool (network-admin). You will get a lock-up at boot time at the point where the network interfaces are bieng configured. If you have used the Networking tool, you will have to comment out the entries in the file "/etc/network/interfaces." to do this:

Code:

$ sudo vi /etc/network/interfaces # replace vi with your editor of choice (nano, gedit, kate etc.)

it should look like this:

Code:

auto lo iface lo inet loopback #iface ra0 inet dhcp #wireless-essid xxxx #auto ra0

Hors ligne

#3 Le 20/01/2007, à 11:41

Eikasia

Re : WIFI Chipset rt61

salut

commenter les lignes (c'est à dire mettre une # devant) revient à les rendre inactives. Et en effet le fichier /etc/network/interfaces ne doit conserver que les lignes :

auto lo
iface lo inet loopback

Dernière modification par Eikasia (Le 20/01/2007, à 11:45)


Ubuntu 12.04 LTS (64 bits) :  boîtier, Textorm 69U6 ; alim, LDLC BG-400 Quality Select 80PLUS Bronze ; cm, Gigabyte GA-F2A75M-D3H ; proc, AMD A8-5600K (3.6 GHz) B E ; ram, Kingston HyperX 4 Go (2x 2Go) DDR3 1600 MHz ; cg, ASUS 210-1GD3-L 1 GB ; dd, Seagate Barracuda 7200.14 SATA 6Gb/s 1 To ; dd, Seagate ST3250624AS ; impri/scan HP PSC 1510.
Ubuntu 12.04 LTS (32 bits) : portable ASUS K53E-SX1254V.

Hors ligne

#4 Le 13/02/2007, à 23:24

phil31200

Re : WIFI Chipset rt61

bonjour

je débute sous linux et Ubuntu. J'ai suivi les conseils, parfois avec des difficultés, car je ne savais pas, par exemple, changer les droits d'un fichier, éditer tel autre...

mais bref au terme de 2 jours de combats je suis arrivé à faire fonctionner un portable MSI M670 (rl61 je crois)
big_smile C'est pas simple pour un vrai nocice !! mais ubuntu me botte vraiment et le site et les doc sont supers.

Le souci c'est que le wifi fonctionne seulement sans cryptage !!!  Dès que je mets wep ou wap sur le routeur netgear (fwg114p), je n'arrive plus à établir la liaison. Il est vu, mais la connection ne se fait pas.
J'essaye plein de combinaisons mais franchement je ne comprends pas.

Quelqu'un peut m'aider SVP ?
Merci.

#5 Le 15/02/2007, à 21:09

Eikasia

Re : WIFI Chipset rt61

Salut smile
Si tu souhaites avoir une réponse, tu devrais plutôt ouvrir un topic dédié à ton sujet ds le forum qui correspond, ici tu es dans "trucs et astuces" wink
Bon courage et bonne chance !
PS : je suis pas sûr à 100% ms pour le cryptage en wep ça devrait passer, par contre en wap... c'est plus tendu dirons nous.
PSS : conneXion et pas connection (anglais) : rassure toi, tu n'es pas le seul à faire cette faute et c'est surement pour ça qu'elle m'agace tongue


Ubuntu 12.04 LTS (64 bits) :  boîtier, Textorm 69U6 ; alim, LDLC BG-400 Quality Select 80PLUS Bronze ; cm, Gigabyte GA-F2A75M-D3H ; proc, AMD A8-5600K (3.6 GHz) B E ; ram, Kingston HyperX 4 Go (2x 2Go) DDR3 1600 MHz ; cg, ASUS 210-1GD3-L 1 GB ; dd, Seagate Barracuda 7200.14 SATA 6Gb/s 1 To ; dd, Seagate ST3250624AS ; impri/scan HP PSC 1510.
Ubuntu 12.04 LTS (32 bits) : portable ASUS K53E-SX1254V.

Hors ligne

#6 Le 17/02/2007, à 18:49

rodan

Re : WIFI Chipset rt61

salut,

(chouette, je ne suis pas le seul à être dans le kk smile )

Alors, j'ai pas fini encore et fait plusieurs essais brouillons, mais vite fait au passage
(je reviens quand tout est ok ...)

Dans le script, il doit te manquer un make install après le make all.

Pour le coup de la cle wep, il semble que la syntaxe correcte (pour cette carte) serait
iwconfig ra0 enc 982739827392873298

au lieu de
iwconfig ra0 key 982739827392873298
Tel que configurée par les outils standards: j'ai 2 wifis sur la même machine, dont une qui marche pour comparer.

Je suis arrivé à accrocher ma freebox en wep, mais seulement en redonnant la clé une fois l'if up.
Mais même en éditant interfaces et en changeant "wireless_key" par "wireless_enc", ça marche pas.. et j'ai des soucis au boot.

--
Tout ça sur une pcmcia Hercules HWGPCMCIA-54-V2
Vendor Ralink - Device 0x0301
(qui aurait due marcher en theorie avec le RT2500 de base de la edgy)

#7 Le 17/02/2007, à 20:54

rodan

Re : WIFI Chipset rt61

rodan a écrit :

(je reviens quand tout est ok ...)

Donc, résultat:
Je n'arrive pas à la configurer juste avec network admin (ni wradar,
ni network-manager... et kwifi chose m'a semblé encore moins capable)
Je sens confusément que ça irait mieux si ra0 s'appelait eth2 par exemple... ou wlan0 ??

Il me faut bien éditer le fichier de configuration par défaut:
/etc/Wireless/RT61STA/rt61sta.dat

Et indiquer comme décrit dans le fichier readme :
/tmp/rt61dapper/RT61_Linux_STA_Drv1.1.0.0/Module/readme

au minimum :

* la région, à bien régler suivant le canal sur lequel démarrer
* le canal (ou 0 pour auto, mais faire gaffe à la region...?)
* le type de clé et la valeur de la clé
* l' essid (nom du PA)
* le mode managed

D'ailleurs, au passage c'est pas une bonne idée de bosser dans tmp
s'il est vidé à chaque redémarrage...
remplacer  "/tmp" par "/usr/src" pour garder les trucs intéressants comme
le readme qui explique bien les valeurs des paramètres.

Ensuite, ne pas faire tourner le script comme ça, mais plutôt en copiant/collant...
on voit mieux les erreurs.

J'ai du aussi blacklister l'ancien (ou trop neuf) rt61pci pour pouvoir charger
celui qui marche au boot, comme lu ailleurs:

#echo "#rt61 remplacé en attendant une compile du noyau">>/etc/modprobe.d/blacklist
#echo blacklist rt61pci>>/etc/modprobe.d/blacklist

J'ai donc une connexion qui démarre toute seule en WEP et dhcp, au boot
ou à l'insertion de la pcmcia.
Ca devrait le faire aussi pour une clé WAP (mais j'ai plus le courage de tester là sad )

Je ne suis pas non plus arrivé à faire tourner RaConfig2500 qui devrait pouvoir
faire des choses intéressantes... si j'ai tout compris. Celui de serial-monkey ne veut
rien savoir.
Il faudrait reprendre la compil depuis les sources de ralink (RT2500...) mais ça ne
semble pas bien configuré pour edgy (ou edgy n'a pas des entêtes assez standards ?)
parce que j'ai des erreurs au make de l'outil.


Voilà, j'arrête là: j'ai un truc qui me gèle plus la machine et qui fait son office ;-)

Merci du coup de main.

--
Tout ça sur une pcmcia Hercules HWGPCMCIA-54-V2
Vendor Ralink - Device 0x0301
(qui aurait du marcher en théorie avec le RT2500 de base de la edgy)

Haut de page ↑