Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 28/04/2012, à 20:18

lolovdb

scangear sous ubuntu 12.04 [résolu]

Bonjour à tous,
Je possédais scangear sous ubuntu 10.04 qui me permettait de faire marcher mon scanner CANON MX410 (multifonction).
Depuis que je suis passé à la version 12.04, je n'ai plus scangear et il n’apparaît plus dans les dépôts. Est ce que quelqu'un sait si il est toujours disponible sous ubuntu 12.04 ?
Si non, Est-ce quelqu'un peut me dire comment installer les drivers pour mon scanner .
Merci

Dernière modification par lolovdb (Le 29/04/2012, à 19:06)

Hors ligne

#2 Le 28/04/2012, à 23:37

mohican

Re : scangear sous ubuntu 12.04 [résolu]

as-tu essayé simple scan qui est installé par défaut ?


Pour que Nautilus associe les fichiers html avec leur dossier lié, svp VOTEZ !
mohican, plus tout à fait débutant sur Ubuntu. 3x boot : 12.04 64bits Unity à 95% // 11.10 32b à 0% // Win7 SP1 64b à 5%

Hors ligne

#3 Le 28/04/2012, à 23:49

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

Bonsoir

Le pilote du scanner de la MX410 est disponible sur le site du support de Canon. Vous pouvez utiliser les commandes suivantes pour l'installer :

wget http://files.canon-europe.com/files/soft40871/Software/Linux%20IJ%20Scanner%20Driver%20MX410.tar
tar xvf Linux\ IJ\ Scanner\ Driver\ MX410.tar
tar zxvf scangearmp-mx410series-1.70-1-deb.tar.gz
cd scangearmp-mx410series-1.70-1-deb/
sudo ./install.sh

Hors ligne

#4 Le 29/04/2012, à 09:05

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

demonipuch a écrit :

Bonsoir

Le pilote du scanner de la MX410 est disponible sur le site du support de Canon. Vous pouvez utiliser les commandes suivantes pour l'installer :

wget http://files.canon-europe.com/files/soft40871/Software/Linux%20IJ%20Scanner%20Driver%20MX410.tar
tar xvf Linux\ IJ\ Scanner\ Driver\ MX410.tar
tar zxvf scangearmp-mx410series-1.70-1-deb.tar.gz
cd scangearmp-mx410series-1.70-1-deb/
sudo ./install.sh

Merci pour l'info mais à la commande "sudo ./install.sh", ce message apparait

laurent@lolovdb:~$ wget http://files.canon-europe.com/files/sof … 0MX410.tar
--2012-04-29 08:57:36--  http://files.canon-europe.com/files/sof … 0MX410.tar
Résolution de files.canon-europe.com (files.canon-europe.com)... 217.212.239.26, 217.212.238.225
Connexion vers files.canon-europe.com (files.canon-europe.com)|217.212.239.26|:80... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Longueur: 3123712 (3,0M) [application/x-tar]
Sauvegarde en : «Linux IJ Scanner Driver MX410.tar»

100%[======================================>] 3 123 712   1,52M/s   ds 2,0s   

2012-04-29 08:57:38 (1,52 MB/s) - «Linux IJ Scanner Driver MX410.tar» sauvegardé [3123712/3123712]

laurent@lolovdb:~$ tar xvf Linux\ IJ\ Scanner\ Driver\ MX410.tar
guidemx410series-sd-1.70-1_en.tar.gz
scangearmp-mx410series-1.70-1-deb.tar.gz
scangearmp-mx410series-1.70-1-rpm.tar.gz
laurent@lolovdb:~$ tar zxvf scangearmp-mx410series-1.70-1-deb.tar.gz
scangearmp-mx410series-1.70-1-deb/
scangearmp-mx410series-1.70-1-deb/packages/
scangearmp-mx410series-1.70-1-deb/packages/scangearmp-mx410series_1.70-1_amd64.deb
scangearmp-mx410series-1.70-1-deb/packages/scangearmp-mx410series_1.70-1_i386.deb
scangearmp-mx410series-1.70-1-deb/packages/scangearmp-common_1.70-1_amd64.deb
scangearmp-mx410series-1.70-1-deb/packages/scangearmp-common_1.70-1_i386.deb
scangearmp-mx410series-1.70-1-deb/resources/
scangearmp-mx410series-1.70-1-deb/resources/scanner_ja_utf8.lc
scangearmp-mx410series-1.70-1-deb/resources/scanner_fr_utf8.lc
scangearmp-mx410series-1.70-1-deb/resources/scanner_zh_utf8.lc
scangearmp-mx410series-1.70-1-deb/install.sh
laurent@lolovdb:~$ cd scangearmp-mx410series-1.70-1-deb/
laurent@lolovdb:~/scangearmp-mx410series-1.70-1-deb$ sudo ./install.sh
[sudo] password for laurent:
An error occurred. The package management system cannot be identified.
./install.sh: ligne 337 : [: = : opérateur unaire attendu
==================================================

ScanGear MP Ver.1.70-1 for Linux
Copyright CANON INC. 2007-2011
All Rights Reserved.

==================================================
Une erreur s'est produite. Impossible d'identifier le gestionnaire de paquets.
laurent@lolovdb:~/scangearmp-mx410series-1.70-1-deb$


   Est-ce que cela veut dire que je n'ai pas de gestionnaire de paquet ?
Pour répondre à Mohican, j'ai essayé simplescan mais il ne trouve pas de scanner. (j’avais le même problème sous ubuntu 10.04).

Dernière modification par lolovdb (Le 29/04/2012, à 09:17)

Hors ligne

#5 Le 29/04/2012, à 11:07

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

:)Je viens de résoudre mon problème d’installation
Il y avait RPM et DPKG d'installé dans mon ordinateur d’où le conflit. J'ai désinstallé RPM et l'installation s'est bien déroulé ensuite.

:(Malheureusement, mon scanner n'est toujours pas détecté sous simplescan ou xsane.

J'avoue, je suis perdu

Hors ligne

#6 Le 29/04/2012, à 11:59

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

Pouvez vous vérifier si les paquets sont bien installés? Donnez le retour de la commande suivante :

dpkg -l | grep scangear

Hors ligne

#7 Le 29/04/2012, à 12:15

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

bonjour, voia mon retour:

laurent@lolovdb:~$ dpkg -l | grep scangear
ii  scangearmp-common                             1.70-1                                            ScanGear MP for Linux.
ii  scangearmp-mx410series                        1.70-1                                            ScanGear MP for Linux.
laurent@lolovdb:~$ 

merci

Dernière modification par lolovdb (Le 29/04/2012, à 12:15)

Hors ligne

#8 Le 29/04/2012, à 12:33

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

Ok scangear est bien installé et il faut utiliser ce programme pour numériser vos documents. Il n'est pas possible d'utiliser xsane ou simple-scan (votre scanner n'est pas supporté par SANE).

Vérifiez que vous pouvez scanner en lançant cette commande :

scangearmp

Hors ligne

#9 Le 29/04/2012, à 12:38

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

:)ça marche

Comment je peux lancer scangear sans le terminal

Merci pour les infos

Hors ligne

#10 Le 29/04/2012, à 12:43

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

Ça dépend, voici deux liens vers la doc qui vous seront utiles je pense :
http://doc.ubuntu-fr.org/raccourci-lanceur
http://doc.ubuntu-fr.org/unity_launcher

Hors ligne

#11 Le 29/04/2012, à 13:05

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

sad La méthode ne fonctionne pas car scangear n’apparaît pas avec l'application tableau de bord
me avec l’éditeur de menu cela ne fonctionne pas

Hors ligne

#12 Le 29/04/2012, à 13:27

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

Vous utilisez quelle version d'Ubuntu?

edit : je suis con, la réponse est dans le titre du sujet roll

Consultez cette page de la doc : http://doc.ubuntu-fr.org/unity_launcher

edit 2 : n'ayant pas encore fait de mise à jour de 10.04 vers 12.04, j'ai fais quelques test dans une machine virtuelle.
Pour obtenir un lanceur dans le dash, j'ai procédé comme ceci :
- ouvrez un terminal
- lancez la commande suivante :

gnome-desktop-item-edit ~/.local/share/applications/ --create-new

- dans la fenêtre qui s'ouvre, remplissez les champs : Type: application, Nom: ScanGear, Commande: /usr/bin/scangearmp, Commentaire: Lanceur pour ScanGear.
- modifiez l'icône du lanceur si vous le souhaitez (en cliquant sur la "fusée").
- validez

Désormais vous devriez avoir accès au lanceur en passant par le Dash (tableau de bord).

Dernière modification par demonipuch (Le 29/04/2012, à 14:30)

Hors ligne

#13 Le 29/04/2012, à 19:05

lolovdb

Re : scangear sous ubuntu 12.04 [résolu]

demonipuch a écrit :

edit 2 : n'ayant pas encore fait de mise à jour de 10.04 vers 12.04, j'ai fais quelques test dans une machine virtuelle.
Pour obtenir un lanceur dans le dash, j'ai procédé comme ceci :
- ouvrez un terminal
- lancez la commande suivante :

gnome-desktop-item-edit ~/.local/share/applications/ --create-new

- dans la fenêtre qui s'ouvre, remplissez les champs : Type: application, Nom: ScanGear, Commande: /usr/bin/scangearmp, Commentaire: Lanceur pour ScanGear.
- modifiez l'icône du lanceur si vous le souhaitez (en cliquant sur la "fusée").
- validez

Désormais vous devriez avoir accès au lanceur en passant par le Dash (tableau de bord).

:)Cela marche après avoir installé gnome-panel

Un grand merci

Hors ligne

#14 Le 14/05/2012, à 23:48

Endash

Re : scangear sous ubuntu 12.04 [résolu]

Bonjour,

La même mésaventure m'est arrivée lors du passage de la 11.10 à la 12.04. Je n'ai dû mon salut qu'aux instructions  présentes sur le forum anglophone.

Peut-être pourrait-on mettre à jour la documentation (dans laquelle n'apparaît pas la MX410) ?

Dash


Samsung Series 5 sous Xubuntu 14.04 (64 bits)
Acer Aspire 5738Z sous Xubuntu 13.10 (64 bits)
Acer Aspire 5336 sous Xubuntu 14.04 (32 bits)

Hors ligne

#15 Le 31/05/2012, à 23:24

rich.fournier

Re : scangear sous ubuntu 12.04 [résolu]

Bonjour,
Je viens d'installer une mg5250 sous Precise Pangolin : l'impression fonctionne, l'installation de scangear semble s'être bien passée, mais le scanner n'est pas detecté par scangearmp :

impossible de trouver les scanner disponibles

Pour info j'ai fait :

rfo@debian2:~$ dpkg -l | grep scangear
ii  scangearmp-common                      1.60-1                                  ScanGear MP for Linux.
ii  scangearmp-mg5200series                1.60-1                                  ScanGear MP for Linux.


Merci si vous avez une idée.
Rich

Hors ligne

#16 Le 03/06/2012, à 22:15

rich.fournier

Re : scangear sous ubuntu 12.04 [résolu]

Résolu !!
Excusez-moi, c'était écrit en gros sur le wiki spécifique canon :

    Imprimante allumée, lancez la commande

    lsusb

    dans la ligne de résultat "…Device 002: ID 04a9:1748 CANON..", repérez bien l'ID marque:modèle,
    Éditez le fichier /lib/udev/rules.d/40-libsane.rules avec les droits superutilisateur.
    Ajoutez les deux lignes suivantes à la liste de matériel en les adaptant à votre ID marque:modèle (et en vérifiant qu'elles n'y soient pas déjà) :

    # Canon PIXMA MG5150
    ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1748", ENV{libsane_matched}="yes"

    Sauvegardez le fichier puis redémarrez votre ordinateur.

Hors ligne

#17 Le 01/09/2012, à 08:24

ericb29

Re : scangear sous ubuntu 12.04 [résolu]

rich.fournier a écrit :

Résolu !!
Excusez-moi, c'était écrit en gros sur le wiki spécifique canon :

    Imprimante allumée, lancez la commande

    lsusb

    dans la ligne de résultat "…Device 002: ID 04a9:1748 CANON..", repérez bien l'ID marque:modèle,
    Éditez le fichier /lib/udev/rules.d/40-libsane.rules avec les droits superutilisateur.
    Ajoutez les deux lignes suivantes à la liste de matériel en les adaptant à votre ID marque:modèle (et en vérifiant qu'elles n'y soient pas déjà) :

    # Canon PIXMA MG5150
    ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1748", ENV{libsane_matched}="yes"

    Sauvegardez le fichier puis redémarrez votre ordinateur.


quand je lance la ligne /lib/udev/rules...
il m'indique permission non accordée...

Hors ligne

#18 Le 01/09/2012, à 12:39

demonipuch

Re : scangear sous ubuntu 12.04 [résolu]

rich.fournier a écrit :

Éditez le fichier /lib/udev/rules.d/40-libsane.rules avec les droits superutilisateur.

En ligne de commande :

sudo nano /lib/udev/rules.d/40-libsane.rules

ou graphiquement :

gksudo gedit /lib/udev/rules.d/40-libsane.rules

Hors ligne

#19 Le 20/09/2012, à 00:14

fikfik

Re : scangear sous ubuntu 12.04 [résolu]

Je sais pas si ca peut aider, mais sur ma MG5250, j'ai eu les même problèmes qu'ici décrits après passage sous 12.04 (pardon la fu... bullsh... 12.04) : ca marchait très bien, et ça ne marchait plus ensuite (Impossible de détecter un scanner... gna gna , vérifiez qu'il est bien sous tension et gna gna gna)

J'ai réussi à refaire marcher Scangear en réinstallant la version 1.8 de Scangear à la place de la version 1.6 (elle est notamment dispo pour les modèles MG5300 sur les divers sites de canon)
Ca marche même directement sous Gimp avec cette version de Scangear.

Par contre toujours pas de fonctionnement avec xsane de mon côté.

BrrrGrrr

Dernière modification par fikfik (Le 20/09/2012, à 00:16)

Hors ligne

Haut de page ↑