Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 16/01/2007, à 16:48

bertrand.r

[Résolu] - Gnome partiellement en français

Gnome est à moitié en français et à moitié en anglais.

Ca me soule un peu.

Avant que je réinstalle je me souviens bien qu'il était totalement en français. Vous savez s'il y a un paquet à installer ?

PS : pour ceux qui ont lu mon ancien post j'avais pas fait gaf aux restes des applis wink

Dernière modification par bertrand.r (Le 19/01/2007, à 13:56)

Hors ligne

#2 Le 16/01/2007, à 17:54

eclipse

Re : [Résolu] - Gnome partiellement en français

C'est supèr rare les applications non traduites, pour gnome par défaut hein (aller pas me chercher un soft exotique). j'en connait qu'une ! YELP
Dans une autre mesure, Audacity a du mal avec les accents, mais il est traduit.

A mon avis tu as dû louper quelques choses

#3 Le 16/01/2007, à 18:13

inbox

Re : [Résolu] - Gnome partiellement en français

Menu :
Système -> Administration -> Support linguistique


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#4 Le 16/01/2007, à 18:14

Di@bl@l

Re : [Résolu] - Gnome partiellement en français

un peti resolu !!!

Hors ligne

#5 Le 16/01/2007, à 23:31

bertrand.r

Re : [Résolu] - Gnome partiellement en français

Non mais ça résoud rien le Système -> Administration -> Support linguistique donc non pas de résolu d'ailleur le coup de apt-get install localeconf et dpkg-reconfigure non plus smile

Hors ligne

#6 Le 17/01/2007, à 02:51

Tiennou44

Re : [Résolu] - Gnome partiellement en français

Moi aussi, je viens de m'appercevoir que certains menus et sous-menus de GNOME et tous les menus et sous-menus d'Evolution sont en anglais.

Je suis donc allé dans "Système -> Administration -> Support lingustique" pour voir ce qu'il y avait.

Au lancement de l'application, le système m'a demandé de mettre à jour les packs de langues anglaise et française, ce que j'ai fait. J'ai aussi désélectionné le support de la langue anglaise. La langue française était déjà la langue par défaut.

Après redémarrage de la session GNOME, cela a remis les menus et sous-menus de GNOME en français, mais n'a rien changé pour Evolution, et peut-être pour d'autres applis.

J'ai donc jeté un coup d'oeil dans l'historique des paquets installés par Synaptic. Je me suis rendu compte que les "language-packs" anglais et français avaient été mis à jour avec une version plus récente hier, le 16 janvier (2007).

Je suppose donc les packs de langue française qui ont été mis à jour ne contiennent plus le support du français pour Evolution.

Est-ce que je me trompe ?
Quelqu'un d'autre a-t-il remarqué cela ?
Y a-t-il une solution pour retrouver les menus et sous-menus dans Evolution en langue française ? Ou bien faut-il attendre une nouvelle mise à jour des packs de langue française ?

Hors ligne

#7 Le 17/01/2007, à 02:58

Tiennou44

Re : [Résolu] - Gnome partiellement en français

Je précise que je suis sous Dapper.

Hors ligne

#8 Le 17/01/2007, à 03:01

bertrand.r

Re : [Résolu] - Gnome partiellement en français

Hmm Tiennou44 il me semble avoir vu cette mise à jour passer (à vrai dire je met à jour sans faire gaf donc voila ce qui arrive). Surement une merde à ce niveau en effet (dapper pour moi aussi). Le mieux serait qu'on attende je pense.

Hors ligne

#9 Le 17/01/2007, à 03:56

Tiennou44

Re : [Résolu] - Gnome partiellement en français

En utilisant un prog en perl, l'interpréteur perl m'a inscrit sur la console que les variables d'environnement suivantes avec leur valeur n'étaient pas présentes :

LANGUAGE="fr_FR:fr:en_GB:en"
LC_ALL=(unset)
LANG="fr"

Faut-il mettre les déclarations dans le fichier .bashrc situé dans son home directory ? ou bien y a-t-il un emplacement particulier (sous /etc par exemple) où il faut le mettre ?

Quand les déclarations de ces variables d'environnement sont faites dans le .bashrc situé dans son répertoire perso, est-ce que GNOME les voit et les prend en compte ? (a priori non, car je l'ai fait et cela n'a rien changé pour Evolution)

Finalement, est-ce que cela peut avoir une incidence sur la localisation de GNOME et de ses applis ?

Hors ligne

#10 Le 17/01/2007, à 07:19

bertrand.r

Re : [Résolu] - Gnome partiellement en français

Je sais pas si c'est dans ce fichier mais j'avais fait des recherche sur le forum pour un problème similaire et j'ai regénéré les locales ça change rien.

Hors ligne

#11 Le 17/01/2007, à 10:59

tof63

Re : [Résolu] - Gnome partiellement en français

Depuis hier, j'avais le même problème.

Dans système, entre autres, au lieu d'avoir "a propos de moi", j'avais "about me" et plein de petit truc comme ça.

Je suis allé dans support linguistique qui m'a dit de réinstaller des paquets (en français et en anglais) du style ....... kde-en.deb.

Ce que j'ai fait. puis j'y suis retourné et j'ai décoché "l'anglais". Valider.
Ctrl Alt Backspace

Au redémarrage, mes menus étaient en français.
ça à donc marché.

A+


Quad Core Q8600 | ubuntu 11.10

Hors ligne

#12 Le 17/01/2007, à 11:09

oswald-p

Re : [Résolu] - Gnome partiellement en français

Oui, visiblement il y'a un problème avec des mises à  jour effectuées hier sous Dapper.
J'ai le même problème ici: Evolution avec les menus en anglais, Gnome avec des menus en français et en anglais hmm bonjour le Long Terme Support....

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#13 Le 17/01/2007, à 11:45

jipers

Re : [Résolu] - Gnome partiellement en français

bonjour,

même problème juste après la mise a jour d'hier...
français et anglais mélangé un peu partout big_smile

ça fait la troisieme mise à jour foireuse pour moi lol

m'enfin l'pingouin l'est sympa quand même wink

edit:
après décochage "anglais" et "francais" puis recochage "francais" et redémarrage, tout es rentré dans l'ordre.

Dernière modification par jipers (Le 17/01/2007, à 11:56)

Hors ligne

#14 Le 17/01/2007, à 16:23

webatou

Re : [Résolu] - Gnome partiellement en français

Effectivement, après avoir décoché toutes les langues, avoir appliqué et re-coché le français uniquement, ça repasse tout en français.

Pour une LTS ça fait désordre quand même sad


Linux Ubuntu 8/04

Hors ligne

#15 Le 17/01/2007, à 16:42

figaro

Re : [Résolu] - Gnome partiellement en français

Sauf la petite fenêtre de fermeture qui reste en anglais ! sad
C'est du reste comme cela que j'ai été alerté de ce gentil petit bug....
Pour l'instant le problème n'existe que sous dapper, espérons qu'ils ne le transposent pas sous edgy... smile

Dernière modification par figaro (Le 17/01/2007, à 17:03)


Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#16 Le 17/01/2007, à 17:34

Schbler

Re : [Résolu] - Gnome partiellement en français

Ouf !! J'ai eu peur que mes manipulations de néophite aient donné ces menus franco-anglais. J'ai décoché l'anglais dans le Support Linguistique puis un bon vieux Ctrl Alt Backspace (comme quoi l'anglais sert encore), et les menus ont meilleure allure, sauf, comme le signale figaro, lors de la fermeture. Mais là, on le fait généralement sans même lire le texte ....


Plus tu pédales moins fort, moins tu avances plus vite

Hors ligne

#17 Le 17/01/2007, à 18:31

jiceel

Re : [Résolu] - Gnome partiellement en français

Avec l'astuce de webatou tout repasse en Français y compris la fenêtre de fermeture.
C'est vrai que pour une version que j'ai choisi pour sa fiabilité, il faudrai pas que ça devienne une habitude.

Dernière modification par jiceel (Le 17/01/2007, à 18:32)


Ubuntu 12.04 LTS 64 sur AMD 2x4600 Nvidia 7600GS 3go DDR2

Hors ligne

#18 Le 17/01/2007, à 19:00

figaro

Re : [Résolu] - Gnome partiellement en français

Oui je viens de le faire sur mon portable qui est sous dapper.
Le seul truc c'est quand les fichiers ont été supprimés puis réinstallés, il n'y a plus de choix de langue par défaut, ni d'option appliquer ni fermer ni valider ne pas s'affoler il faut alors fermer la fenêtre avec la croix de fermeture.
Quand on relance l'option français apparaît alors, on valide, on relance X et tout va bien. smile


Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#19 Le 17/01/2007, à 19:42

webatou

Re : [Résolu] - Gnome partiellement en français

jiceel a écrit :

Avec l'astuce de webatou tout repasse en Français

Remettons les choses à leur place, c'est l'astuce de jipers wink


Linux Ubuntu 8/04

Hors ligne

#20 Le 17/01/2007, à 21:40

romario

Re : [Résolu] - Gnome partiellement en français

même problème ici sur dapper après la MAJ des langues
résolu par l'astuce de "webatou-jipers" wink
(décocher les deux langues anglais et français, appliquer, recocher français, appliquer, redémarrer, sélectionner français par défaut)

merci !

Hors ligne

#21 Le 18/01/2007, à 00:26

Math

Re : [Résolu] - Gnome partiellement en français

oui, j'ai mis à jour hier aussi ma dapper : y'avais des packets de langue et j'étais étonné qu'il y ait des updates... et effectivement, j'ai un gnome partiellement en anglais (Dapper aussi)

Commit Log for Tue Jan 16 19:43:06 2007


Les paquets suivant ont été mis à jour :
language-pack-en (1:6.06+20061004) to 1:6.06+20061130
language-pack-fr (1:6.06+20061003) to 1:6.06+20061201
language-pack-gnome-en (1:6.06+20060927) to 1:6.06+20061205
language-pack-gnome-fr (1:6.06+20061004) to 1:6.06+20061202
language-pack-kde-en (1:6.06+20061004) to 1:6.06+20061201
language-pack-kde-fr (1:6.06+20061003) to 1:6.06+20061130

Hors ligne

#22 Le 18/01/2007, à 06:41

bruno-Kaledonie

Re : [Résolu] - Gnome partiellement en français

Salut à tous,

J'ai résolut le problème en suisvant ce post :

http://forum.ubuntu-fr.org/viewtopic.php?id=89738

tongue

Merci à la communauté

Hors ligne

#23 Le 18/01/2007, à 19:45

Bazoo

Re : [Résolu] - Gnome partiellement en français

Meme problème, résolut grâce à votre aide, merci wink
Par contre c'est vrai que ça fait un peu désordre pour une LTS... M'enfin bon c'est déja pardonné.

A+

Hors ligne

#24 Le 18/01/2007, à 21:53

frez

Re : [Résolu] - Gnome partiellement en français

Salut moi aussi j'ai eu le meme probleme sad merci c'est résolu wink

Hors ligne

#25 Le 18/01/2007, à 22:02

Bacchux

Re : [Résolu] - Gnome partiellement en français

Bonsoir,

figaro a écrit :

Le seul truc c'est quand les fichiers ont été supprimés puis réinstallés, il n'y a plus de choix de langue par défaut, ni d'option appliquer ni fermer ni valider ne pas s'affoler il faut alors fermer la fenêtre avec la croix de fermeture.
Quand on relance l'option français apparaît alors, on valide, on relance X et tout va bien. smile

Pour moi, relancer X (par Alt-Ctrl-BackSpace) n'a pas suffi. Pire, les applications ne se lançaient plus et plus rien ne réagissait. J'ai dû éteindre l'ordi à la sauvage. Au lancement suivant, tout était rentré dans l'ordre.
Cela dit, étant débutant, j'ai eu quelques difficultés à m'y retrouver. Donc je récapitule la procédure que j'ai appliquée, en suivant les conseils donnés par tous ci-dessus :
J'ai :
1/ Fait Système > Administration > Support linguistique
2/ Décoché toutes les langues, puis cliqué sur Appliquer
3/ Recoché Français, cliqué Appliquer
4/ Fermé la fenêtre du support linguistique avec la petite croix en haut à droite
5/ Recommencé Système > Administration > Support linguistique
6/ Choisi Français comme langue par défaut
7/ Validé
8/ Tout fermé et redémarré complètement
9/ Refait Système > Administration > Support linguistique
10/ Coché l'anglais (en laissant bien sûr la langue par défaut sur Français)
11/ Validé.

Voilà tout est bien en Français, y compris la fenêtre de fermeture.

Merci à tous.
(ce post pourrait être passé en résolu, ça aiderait ceux qui cherchent la solution)


Beatux qui prodest quibus potest
Atelier linux (Ubuntu et Suse)

Hors ligne