Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 01/08/2005, à 09:46

szdavid

[Résolu] Installation e17 : erreur pour e17genmenu

Salut,

j'essaie d'installer e17genmenu et lorsque je fais le configure, j'ai ce message d'erreur :

checking for Ecore_File.h... no
configure: error: No Ecore_File.h !

Une idée ?

Hors ligne

#2 Le 01/08/2005, à 10:05

patgrysli

Re : [Résolu] Installation e17 : erreur pour e17genmenu

Tu as essaye comme ici?  http://planet.ubuntu-fr.org/

Hors ligne

#3 Le 01/08/2005, à 10:09

szdavid

Re : [Résolu] Installation e17 : erreur pour e17genmenu

c'est justement de là que je viens  :-(

Hors ligne

#4 Le 01/08/2005, à 10:22

patgrysli

Re : [Résolu] Installation e17 : erreur pour e17genmenu

un coup dans l eau tongue

Hors ligne

#5 Le 01/08/2005, à 10:25

szdavid

Re : [Résolu] Installation e17 : erreur pour e17genmenu

Ok, il y a un certain nombre de librairies à installer (je mettrai cela en commentaire sur le tutorial)

maintenant, j'ai ce message :

checking checking for Gnome... no
checking checking For Gnome 1.0... ./configure: line 7792: gnome-config: command not found
no
Gnome portions of e17genmenu will not be built

Hors ligne

#6 Le 01/08/2005, à 10:48

benohite

Re : [Résolu] Installation e17 : erreur pour e17genmenu

Bonjour,

ben@speedy:~$ apt-file search gnome-config
gnome-dev-doc: usr/share/doc/gnome-dev-doc/html/gnome/gnome-gnome-config.html
libgnome-dev: usr/bin/gnome-config
libgnome-dev: usr/include/gnome-1.0/libgnome/gnome-config.h
libgnome-dev: usr/share/man/man1/gnome-config.1.gz
libgnome2-dev: usr/include/libgnome-2.0/libgnome/gnome-config.h
libgnome2-doc: usr/share/doc/libgnome2-doc/html/libgnome-gnome-config.html
libgnome2-ruby: usr/share/doc/libgnome2-ruby/examples/gnome-config.rb.gz

Je te suggererai donc d'installer libgnome-dev


Ben


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#7 Le 01/08/2005, à 10:54

szdavid

Re : [Résolu] Installation e17 : erreur pour e17genmenu

c'était bien ça.
Alors, a priori, ça configure (j'en suis même pas sur)

Je fais make

make  all-recursive
make[1]: entrant dans le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2 »
Making all in icons
make[2]: entrant dans le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2/icons »
make[2]: Rien à faire pour « all ».
make[2]: quittant le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2/icons »
Making all in src
make[2]: entrant dans le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2/src »
gcc     -o e17genmenu  global.o eap.o icons.o order.o categories.o parse.o menus.o sort.o e17genmenu.o -L/usr/lib -lecore -lecore_job -lecore_x -lecore_evas -lecore_con -lecore_ipc -lecore_txt -lecore_fb -lecore_config -lecore_file -L/usr/lib -lcurl -lidn -lssl -lcrypto -ldl -lssl -lcrypto -ldl -lz -L/usr/lib -leet -lz -ljpeg -lm -L/usr/lib -levas -L/usr/lib -leet -lz -ljpeg -L/usr/lib -lengrave -L/usr/lib -lecore -lecore_job -lecore_x -lecore_evas -lecore_con -lecore_ipc -lecore_txt -lecore_fb -lecore_config -lecore_file -L/usr/lib -lcurl -lidn -lssl -lcrypto -ldl -lssl -lcrypto -ldl -lz -L/usr/lib -leet -lz -ljpeg -lm -L/usr/lib -levas -lm
/usr/bin/ld: ne peut trouver -lcurl
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [e17genmenu] Erreur 1
make[2]: quittant le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/szdavid/Desktop/e17genmenu-2.0.2 »
make: *** [all] Erreur 2

A priori, le problème viendrait d'un truc curl ; j'ai donc installé tclcurl mais ce n'était pas ça...

Grr...

Hors ligne

#8 Le 01/08/2005, à 11:14

benohite

Re : [Résolu] Installation e17 : erreur pour e17genmenu

Bon là je vais me faire taper sur les doigts (à raison d'ailleurs) mais tant pis.
j'ai regardé sur le site du projet et il y a un rpm en téléchargement, tu poourrais peut-être le prendre et faire un alien derrière (non pas taper svp) smile


Ben


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#9 Le 01/08/2005, à 11:53

Osku

Re : [Résolu] Installation e17 : erreur pour e17genmenu

une réponse a été posté sur le site de Play par Lalu:
"J'ajouterais qu'il faut avoir libcurl3-dev et libengrave0-dev et e17genmenu se compile comme un charme"


Fasten your seat belt while seated
Carac ordi / Bug n°1 /
Du libre et du sport

Hors ligne

#10 Le 01/08/2005, à 12:02

benohite

Re : [Résolu] Installation e17 : erreur pour e17genmenu

szdavid a écrit :

Salut,

j'essaie d'installer e17genmenu et lorsque je fais le configure, j'ai ce message d'erreur :

checking for Ecore_File.h... no
configure: error: No Ecore_File.h !

Pouurais-tu indiquer comment tu as résolu ce problème.

Merci

Ben


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#11 Le 01/08/2005, à 12:43

szdavid

Re : [Résolu] Installation e17 : erreur pour e17genmenu

regarde les commentaires de ce post (jusqu'au dernier)

http://gfabio.blog.free.fr/index.php?2005/08/01/69-ubuntu-hoary-installer-e17

Hors ligne

Haut de page ↑