Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 24/01/2007, à 23:19

bertrand38

[résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Après bien des déboires (voir : http://forum.ubuntu-fr.org/viewtopic.php?id=91139)
je ne peux ni installer ni désinstaller openoffice. Synaptic me demande de réparer les paquets
cassés mais il refuse de les réinstaller. Comment supprimer les paquets cassés sans avoir à les
réinstaller ?
le message est le suivant :
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Impossible de verrouiller le répertoire de téléchargement
Merci.

Dernière modification par bertrand38 (Le 15/02/2007, à 20:55)


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

#2 Le 25/01/2007, à 00:12

renaud.guilhou

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Je sais que tu es en 64bits si j'ai bien compris
mais regarde il m'est arrivé un souci de ce genre ici

et je l'ai résolu avec

sudo aptitude install  openoffice.org
sudo apt-get update

essaye des fois que...:rolleyes:

Hors ligne

#3 Le 25/01/2007, à 00:41

halucard22

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

peut-etre qu'un simplte apt-get -f install devrait suffire. Ca vérifie l'intégrité des paquets installés.


"Un homme peut être pauvre mais s'il a un but dans la vie et s'efforce de l'atteindre alors il est grand." - Choe Bendal

Hors ligne

#4 Le 25/01/2007, à 10:05

renaud.guilhou

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Pour moi, cela n'avait pas suffit big_smile

Hors ligne

#5 Le 25/01/2007, à 21:52

bertrand38

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Eh ben même avec aptitude ça ne marche pas :
j'ai fait : sudo aptitude install  openoffice.org

et la console donne :

dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-core_2.0.2 -2ubuntu12.2-1_amd64.deb (--unpack) :
paquets en conflit - openoffice.org-core non installé
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/openoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org  :
openoffice.org dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.

je suis vraiment coincé de chez coincé ....


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

#6 Le 26/01/2007, à 21:48

renaud.guilhou

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

En fait, il me semble que tu as le meme problème que moi mais en version 64bit lol

moi, j'ai réussi mais ca tiens du coup de chance wink

essaye peut etre en trouvant la paquet en question openoffice.org-core.deb et installe-le par un double clic des fois que

Hors ligne

#7 Le 29/01/2007, à 22:55

bertrand38

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

j'avance, j'ai désinstallé tout ce qui concerne openoffice avec synaptic.
En fait, la première fois, il gueule, je lui redemande la désinstall et là, ça marche.
Mais, quand je réinstalle, j'ai toujours un problème de conflit avec le paquet
openoffice-core.


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

#8 Le 09/02/2007, à 12:04

bruno

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Peut-tu essayer cette suite de commandes :

sudo aptitude purge openoffice.org openoffice.org-core

Attention ne valide pas si cela te propose de supprimer tout un tas d'autres paquets !

sudo aptitude update
sudo aptitude upgrade
sudo aptitude install openoffice.org openoffice.org-core

Hors ligne

#9 Le 13/02/2007, à 00:07

bertrand38

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

comme j'avais réussi à désinstaller complètement OO, la commande purge n'a rien fait de nouveau.
J'ai ensuite suivi tes conseils mais le
"sudo aptitude install openoffice.org openoffice.org-core"
ne s'est pas bien passé :

Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/openoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org  :
openoffice.org dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -impress :
openoffice.org-impress dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-impress (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -base :
openoffice.org-base dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-base (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -math :
openoffice.org-math dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-math (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -draw :
openoffice.org-draw dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-draw (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -calc :
openoffice.org-calc dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-calc (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -common :
openoffice.org-common dépend de openoffice.org-core (>> 2.0.2) | openoffice.org -core-experimental (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
  Paquet openoffice.org-core-experimental n'est pas installé.
dpkg : erreur de traitement de openoffice.org-common (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -writer :
openoffice.org-writer dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-writer (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -java-common :
openoffice.org-java-common dépend de openoffice.org-common (>> 2.0.2) ; cependa nt :
  Paquet openoffice.org-common n'est pas encore configuré.
dpkg : erreur de traitement de openoffice.org-java-common (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org -l10n-en-us :
openoffice.org-l10n-en-us dépend de openoffice.org-common (>= 2.0.2) | language -support-en ; cependant :
  Paquet openoffice.org-common n'est pas encore configuré.
  Paquet language-support-en n'est pas installé.
openoffice.org-l10n-en-us dépend de openoffice.org-common (<< 2.0.3) | language -support-en ; cependant :
  Paquet openoffice.org-common n'est pas encore configuré.
  Paquet language-support-en n'est pas installé.
dpkg : erreur de traitement de openoffice.org-l10n-en-us (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
openoffice.org
openoffice.org-impress
openoffice.org-base
openoffice.org-math
openoffice.org-draw
openoffice.org-calc
openoffice.org-common
openoffice.org-writer
openoffice.org-java-common
openoffice.org-l10n-en-us


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

#10 Le 13/02/2007, à 00:18

bruno

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Essaie avec :

sudo aptitude dist-upgrade

et ensuite

sudo aptitude install openoffice.org

Hors ligne

#11 Le 14/02/2007, à 19:57

bertrand38

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Bon ben en fait ça n'a rien changé , j'étais à jour : le aptitude dist-upgrade a donné ça :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Donc, j'ai toujours la même erreur :
dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb (--unpack) :
paquets en conflit - openoffice.org-core non installé
Sélection du paquet openoffice.org-writer précédemment désélectionné.
Dépaquetage de openoffice.org-writer (à partir de .../openoffice.org-writer_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org-calc précédemment désélectionné.
Dépaquetage de openoffice.org-calc (à partir de .../openoffice.org-calc_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org-draw précédemment désélectionné.
Dépaquetage de openoffice.org-draw (à partir de .../openoffice.org-draw_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org-impress précédemment désélectionné.
Dépaquetage de openoffice.org-impress (à partir de .../openoffice.org-impress_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org-math précédemment désélectionné.
Dépaquetage de openoffice.org-math (à partir de .../openoffice.org-math_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org-base précédemment désélectionné.
Dépaquetage de openoffice.org-base (à partir de .../openoffice.org-base_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Sélection du paquet openoffice.org précédemment désélectionné.
Dépaquetage de openoffice.org (à partir de .../openoffice.org_2.0.2-2ubuntu12.2-1_amd64.deb) ...
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/openoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org :
openoffice.org dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-impress :
openoffice.org-impress dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-impress (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-base :
openoffice.org-base dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-base (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-math :
openoffice.org-math dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-math (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-draw :
openoffice.org-draw dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-draw (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-calc :
openoffice.org-calc dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-calc (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-common :
openoffice.org-common dépend de openoffice.org-core (>> 2.0.2) | openoffice.org-core-experimental (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
  Paquet openoffice.org-core-experimental n'est pas installé.
dpkg : erreur de traitement de openoffice.org-common (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-writer :
openoffice.org-writer dépend de openoffice.org-core (>> 2.0.2) ; cependant :
  Paquet openoffice.org-core n'est pas installé.
dpkg : erreur de traitement de openoffice.org-writer (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-java-common :
openoffice.org-java-common dépend de openoffice.org-common (>> 2.0.2) ; cependant :
  Paquet openoffice.org-common n'est pas encore configuré.
dpkg : erreur de traitement de openoffice.org-java-common (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de openoffice.org-l10n-en-us :
openoffice.org-l10n-en-us dépend de openoffice.org-common (>= 2.0.2) | language-support-en ; cependant :
  Paquet openoffice.org-common n'est pas encore configuré.
  Paquet language-support-en n'est pas installé.
openoffice.org-l10n-en-us dépend de openoffice.org-common (<< 2.0.3) | language-support-en ; cependant :
  Paquet openoffice.org-common n'est pas encore configuré.
  Paquet language-support-en n'est pas installé.
dpkg : erreur de traitement de openoffice.org-l10n-en-us (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
openoffice.org
openoffice.org-impress
openoffice.org-base
openoffice.org-math
openoffice.org-draw
openoffice.org-calc
openoffice.org-common
openoffice.org-writer
openoffice.org-java-common
openoffice.org-l10n-en-us


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

#12 Le 15/02/2007, à 14:07

bruno

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

C'est curieux ce problèmes de dépendances, bon au point ou cela en est, il faut essayer de forcer l'installation du paquet qui semble poser problème :

sudo dpkg -i --force-all /var/cache/apt/archives/openoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb

si ça passe on peut tenter une installation "normale" du reste :

sudo aptitude install openoffice.org

Hors ligne

#13 Le 15/02/2007, à 20:55

bertrand38

Re : [résolu] Aïe, impossible d'installer ou de désinstaller openoffice

Super ça marche impec !!!!
J'ai tapé ce que tu m'as suggéré :

sudo dpkg -i --force-all /var/cache/apt/archives/op enoffice.org-core_2.0.2-2ubuntu12.2-1_amd64.deb

Et là il a un peu gueulé : morceau choisi :
[...]
dpkg : openoffice.org-core : problèmes de dépendances, mais configuration comme demandé :
openoffice.org-core dépend de openoffice.org-common (>> 2.0.2) ; cependant :
  Paquet openoffice.org-common n'est pas installé.
openoffice.org-core dépend de openoffice.org-l10n-en-us (>> 2.0.2) | openoffice.org-l10n-2.0.2 ; cependant :
  Paquet openoffice.org-l10n-en-us n'est pas installé.
  Paquet openoffice.org-l10n-2.0.2 n'est pas installé.
openoffice.org-core dépend de openoffice.org-java-common (>> 2.0.2) ; cependant :
  Paquet openoffice.org-java-common n'est pas installé.
Paramétrage de openoffice.org-core (2.0.2-2ubuntu12.2-1) ...
[...]

Bon, là j'ouvre synaptic et le paquet openoffice.org-java-common est cassé. Je lui demande (gentillement
quand même, je le sens susceptible) de réparer. Puis, j'installe via synaptic le paquet openoffice.org et là
miracle tout fonctionne !!!!

Merci beaucoup de m'avoir tiré de cette galère !


Il ne peut y avoir révolution que là où il y a conscience (Jaurès).

Hors ligne

Haut de page ↑