Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 14/05/2012, à 03:38

naughtyjah

[Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

EDIT DU 22/05/2012 : Pour ceusses qui auraient la flemme de lire le post dans son ensemble

À l'heure actuelle lightdm, l'écran de connexion par défaut d'ubuntu, bugue si votre dossier /home a été chiffré ou s'il est chiffré. (pour le chiffrage voir ecryptfs )

Le bug sur launchpad est ici

Si vous souhaitez contourner le problème, et garder un écran de connexion, la solution est d'installer gdm à la place et de le choisir comme écran de connexion.

sudo apt-get install gdm

ou

sudo aptitude install gdm

------------------------------------------

Bonjour,

C'est un peu bourrin comme méthode mais je voulais localiser le problème, à défaut de le comprendre ou de le régler, avant de poster.

Je fais une installation propre de la LTS en formatant le / .

Juste après l'installation, suite au login, la session se lance normalement. Tout va pour le mieux.

Je fais les mises à jour. Je redémarre. Après le login, XFCE semble bloqué.

Seul le fond d'écran apparaît avec le curseur de la souris. Ce dernier bouge mais n'a aucune action au clic.

30 à 40 secondes plus tard - La session se lance normalement.

Je ne vais pas épiloguer mais en refaisant une installation propre, j'ai fait les mises à jours petit à petit pour voir quel(s) paquet(s) serai(en)t à l'origine du problème.

Il y n'en reste que six - Tous ont trait au paquet network-manager et aux bibliothèques qui lui sont associées :

Mises à jours recommandées

network-related Giomodules for Glib
glib-networking
network-related Giomodules for Glib data files
glib-networking-common
network-related Giomodules for Glib D-BUS services
glib-networking-services
network management framework (Glib shared library)
libnm-glib4
network management framework (shared library)
libnm-util2
network management framework (daemon and userspace tools)
network-manager

Je ne suis pas suffisamment calé pour savoir de quoi il en retourne.

Pour le moment, j'ai bloqué les versions de ces paquets.

Si une bonne âme avait une idée.

Merci d'avance.

XUBUNTU 12.04 - AMD 64.

Dernière modification par naughtyjah (Le 22/05/2012, à 10:04)

#2 Le 14/05/2012, à 07:44

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Salut,

Oui j'ai une idée: virer NM et faire sans cet oignon qui doit mouliner pour trouver ta connexion, pour plus d'info, #122 à 149:

http://forum.ubuntu-fr.org/viewtopic.php?id=883751&p=5


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 14/05/2012, à 09:25

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Vu !!!

Merci faucon50.

Je vais tester et je te tiens au jus dans la soirée.

@ + tard

#4 Le 14/05/2012, à 10:08

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Ca roule, si tu as un soucis n'hésite pas.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#5 Le 14/05/2012, à 21:00

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Merci pour toutes les infos faucon50 !!! smile

Tu proposes un élégante solution de contournement pour network-manager c'est vrai.

Mais, par acquis de conscience, après avoir viré network-manager (qui vire également network-manager-gnome) et configuré mon  adresse ip en statique en éditant

/etc/network/interfaces

, j'ai débloqué les versions des librairies pour test.

Après un bel

 apt-get upgrade

Le freeze a réapparut.

Je vais mes renseigner en amont pour savoir ce que font/contiennent ces autres paquets.

Je te ferais un retour.

@ plus.

Dernière modification par naughtyjah (Le 14/05/2012, à 21:02)

#6 Le 15/05/2012, à 07:28

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

naughtyjah a écrit :

Je vais mes renseigner en amont pour savoir ce que font/contiennent ces autres paquets.

Quels paquets as-tu mis à jours exactement? Bon, tu as au moins ciblé d'où ça vient mais suivant quels paquets, tu n'en a peut-être pas besoin?!

Chez moi, installés: glib-networking, glib-networking-common, glib-networking-services

Non installés: libnm-glib, libnm-util2, network-manager


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#7 Le 15/05/2012, à 12:27

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

En fait j'ai mis à jour les paquets :

glib-networking glib-networking-common glib-networking-services libnm-util2 libnm-glib4

Je viens de virer libnm-util2 et libnm-glib4 qui ne sont effectivement pas nécessaires pour se connecter.

Donc le ou les coupables sont :

glib-networking glib-networking-common glib-networking-services

Symptômes supplémentaires que je viens de découvrir: Écran noir au changement de session puis rien. De même pour le reboot.

Je suis obligé de passer en tty1 pour faire un

sudo reboot

Après il n'y a pas grand chose comme info sur la page ubuntu

Mais il y a eu des changements dans ce paquet entre Oneiric  et Precise.

Je vais tenter un downgrade pour voir si ça résout le problème.

Dernière modification par naughtyjah (Le 15/05/2012, à 12:27)

#8 Le 15/05/2012, à 13:31

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Gagné !

Il s'agît bien de

glib-networking glib-networking-common et glib-networking-services

J'ai suivi cette documentation en anglais

J'ai installé aptitude (je ne sais pas si c'est vraiment nécessaire)

sudo apt-get install aptitude

J'ai mis à jour la liste des paquets

sudo aptitude -y update  

Puis j'ai affiché les informations de glib-networking glib-networking-common glib-networking-services et les versions disponibles

apt-cache show glib-networking
apt-cache show glib-networking-common
apt-cache show glib-networking-services

La version actuelle de ces paquets : 2.32.1-1ubuntu1
La version antérieure de ces paquets : 2.32.1-1

J'ai downgradé ces trois paquets de la version 2.32.1-1ubuntu1 vers la version 2.32.1-1 en tapant la commande :

sudo aptitude install glib-networking=2.32.1-1 glib-networking-common=2.32.1-1 glib-networking-services=2.32.1-1

Après j'ai bloqué les versions en suivant la doc ubuntu

Avec ces versions des paquets tout fonctionne normalement, ouverture, fermeture de session, reboot.

Ça n'explique toujours pas pourquoi la session se bloque avec les nouveaux paquets mais déjà ça permet de retomber sur ses pattes en attendant.

Edit :

J'ai oublié une chose qui peut avoir son importance

lspci |grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Dernière modification par naughtyjah (Le 15/05/2012, à 15:34)

#9 Le 15/05/2012, à 15:48

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Concernant aptitude il est installé d'office me semble-t-il? La différence avec apt-get c'est qu'aptitude installe les dépendances nécessaires avec. Pour la version des paquet, je suis en 2.32.1-1ubuntu1 et pas de soucis et voilà mon lspci:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

La différence est (rev 02)>(rev 06) chez toi...

Cette crotte de realtek pose des problèmes depuis un moment, si tu veux tu peux essayer d'installer le pilote proprio realtek, voici le lien du comment au #14:

https://bugs.launchpad.net/ubuntu/+sour … bug/573259

C'était pour Maverick 10.10 mais essaye. Dans le lien realtek section linux prend le premier pilote 8.030.00 .Moi je n'en ai plus besoin, ça marche d'office! N'oublie pas après install du realtek de blacklister le 8169!

Pour l'écran noir, tu es sur quel CG et quel pilote?

Dernière modification par faucon50 (Le 15/05/2012, à 21:19)


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#10 Le 15/05/2012, à 16:01

The Uploader

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Non, aptitude ne fait pas partie de l'installation de base de Xubuntu depuis plusieurs versions (je crois bien que c'est pareil pour Ubuntu).


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#11 Le 15/05/2012, à 16:35

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

The Uploader a écrit :

Non, aptitude ne fait pas partie de l'installation de base de Xubuntu depuis plusieurs versions (je crois bien que c'est pareil pour Ubuntu)

Ah bon...je dois vraiment avoir un système exotique mais peut-être aptitude installé chez moi du fait de la version serveur de base?

Dernière modification par faucon50 (Le 15/05/2012, à 21:44)


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#12 Le 15/05/2012, à 16:45

The Uploader

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Ben j'me trompe peut-être mais sur mes deux dernières et seules installations de Xubuntu 12.04 j'ai du installer aptitude. Et c'est pas la première fois.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#13 Le 15/05/2012, à 18:32

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Merci pour toutes ces infos et pour ton aide faucon50 !!! wink

Je vais faire les manips pour la carte réseau un peu plus tard et je te ferai un retour.

En ce qui concerne, l'écran noir..eh, eh, eh, big_smile A pu écran noir !

Tout était lié aux paquets glib-networking et ses deux compères que ce soit pour l'ouverture de session, le reboot ou la fermeture de session.

Enfin, si ça t'intéresse voici ma config :

Carte mère :

Asus M4A89TD Pro socket AM3

Processeur :

AMD Phenom(tm) II X6 1090T

Disques durs :

OCZ-AGILITY2 120 Gio
ATA WDC WD10EALS-00Z x2
ATA WDC WD15EARS-00Z   
ATA WDC WD5000AAKS-OOZ

Carte Graphique

Radeon HD 5700 Series 1Gio

Carte son

Creative Labs CA0106 Soundblaster

Ram

4 Gio

@ plus tard.

#14 Le 15/05/2012, à 20:51

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Bravo faucon50 !!! smile

En plein dans le mille. cool

J'ai suivi tes conseils en compilant le pilote realtek r8168-8.030.00.

J'ai débloqué les paquets

glib-networking glib-networking-common glib-networking-services

Je les ai mis à jour.

Tout fonctionne à merveille !

Donc, pour résumer :

Si vous avez ces symptômes ou un de ces symptômes:

  • Ouverture de session retardée et freeze de XFCE pendant 35 à 40 secondes

  • Écran noir à la fermeture de session

  • Écran noir au reboot

Et que vous avez comme contrôleur réseau un :

RTL8111/8168B PCI Express Gigabit Ethernet controller

Il est possible que ça vienne du pilote moisi de votre contrôleur.

Connaitre la carte réseau (ou le contrôleur réseau) :

lspci |grep Ethernet

Installer les paquets de base pour compiler :

sudo apt-get install build-essential fakeroot checkinstall

Récupérer le pilote r8168-8.030.00 depuis le site de realtek

wget ftp://WebUser:AxPL9s3k@95.130.192.218/cn/nic/r8168-8.030.00.tar.bz2

(wget téléchargera le .tar dans votre dossier personnel /home/$user)
ou  aller directement sur le site pour télécharger le pilote dans le dossier de votre choix.

Aller dans le dossier où le pilote a été téléchargé :

cd home/$user

ou

cd /*le dossier choisi pour le téléchargement du pilote*/

Décompresser l'archive du pilote :

tar vjxf r8168-8.030.00.tar.bz2

Aller dans le dossier r8168-8.030.00

cd /r8168-8.030.00

Lancer le script de compilation en tant que root ou sudo :

Soit

sudo su

rentrer son mot de passe puis lancer le script

./autorun.sh

Soit

sudo ./autorun.sh

puis rentrer son mot de passe pour lancer le script

Blacklister le pilote moisi :

gksudo leafpad /etc/modprobe.d/blacklist-network.conf

ou

gksudo gedit /etc/modprobe.d/blacklist-network.conf

et ajouter dans le fichier

blacklist r8169

Et encore merci faucon50 big_smile

16-05-12 : procédure éditée suite à la remarque de PengouinPdt.

Dernière modification par naughtyjah (Le 16/05/2012, à 12:12)

#15 Le 15/05/2012, à 21:15

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Magnifique...Magnifique big_smile Je suis content d'avoir pu te fournir les clefs de la résolution...Super chouette cool Je vois que nous avons le même Phenom ène lol Va faire un tour dans le fil "comment accélérer xubuntu" que je t'ai mis en lien pour virer cet oignon de network-manager, histoire de virer et d'améliorer le bidule... big_smile

Extra pour le [résolu], en espérant que ça en aidera d'autres. wink

P.S. Hors sujet: Je vois tes DD...Regarde si tu n'as ce problème avec ces WD: http://forum.ubuntu-fr.org/viewtopic.php?id=403064


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#16 Le 15/05/2012, à 23:10

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Merci énormément faucon50 !

Effectivement, pour certains de mes disques durs, je fais parti des malchanceux. roll

Je vais donc agir.

En ce qui concerne l'optimisation, ça fait longtemps que je n'avais pas "mis les mains dans le cambouis" faute de temps mais je vais m'atteler à la tâche.

Je vais aussi jeter un œil sur vos retours d'expérience quant à XFCE 4.10.

A bientôt sur les différents posts. smile

Dernière modification par naughtyjah (Le 15/05/2012, à 23:11)

#17 Le 16/05/2012, à 07:23

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Y'a pas de quoi smile Bon flashage avec ces DD à la gomme WD et à bientôt. wink


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#18 Le 16/05/2012, à 09:04

PengouinPdt

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

J'ai ce même phénomène ... et, ce depuis le fait d'avoir basculé de 11.10 à 12.04.
Mais, je n'arrivais pas à trouvé, quoi, ni comment l'expliquer !!!

À la différence j'ai cette carte réseau :

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)

Ce n'est pas le modèle RTL8111/8168B, mais RTL8101E/RTL8102E.

Je vais tester le pilote "officiel" !

Hors ligne

#19 Le 16/05/2012, à 09:46

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Essaye, t'as rien à perdre! Ces oignons de realtek de mes deux... roll


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#20 Le 16/05/2012, à 09:54

PengouinPdt

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

J'y suis ...
Alors, il a fallu que je m'y reprenne par deux fois !
En effet, lors de la première fois, la compil a freezé la machine. Freeze Total !

Pour info, je n'avais pas de fichier /etc/modprobe.d/blacklist-network.conf ; je l'ai donc créée et blacklisté le r8169.
La seconde fois, aprés avoir redémarrée ma station, j'ai basculé en tty1, arrêté Lightdm ; j'ai dû supprimé le répertoire r8101 - des erreurs s'affichaient.... puis décompressait à nouveau l'archive, et activait l'autorun - ahhh, oui, au fait, le faire en mode sudo - ce que ne précise pas naughtyjah !

Puis, au reboot suivant, après vérification, je fonctionne bien sur le r8101. (dans mon cas !)

Hors ligne

#21 Le 16/05/2012, à 10:17

fcn50

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

PengouinPdt a écrit :

Pour info, je n'avais pas de fichier /etc/modprobe.d/blacklist-network.conf ; je l'ai donc créée et blacklisté le r8169.

Y'avait pas besoin de le créer, tu aurais aussi pu le blacklister /etc/modprobe.d/blacklist.conf, peu importe. Mais pas oublier le sudo update-initramfs -u après avoir blacklister un module.

PengouinPdt a écrit :

oui, au fait, le faire en mode sudo - ce que ne précise pas naughtyjah !

C'est le cas pour tous les pilotes proprio en général et il y aussi le readme dans le dossier du pilote. wink

PengouinPdt a écrit :

Puis, au reboot suivant, après vérification, je fonctionne bien sur le r8101. (dans mon cas !)

Y'a plus qu'a espérer. smile


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#22 Le 16/05/2012, à 12:07

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Désolé, PengouinPdt, j'ai bien marqué qu'il fallait lancer le script ./autorun en tant que root ou sudo mais c'est vrai que c'est mal indiqué

Lancer le script de compilation (en tant que root ou sudo)

./autorun.sh

Je corrige.

#23 Le 18/05/2012, à 05:05

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Hop,

Je fais une dernière fois remonter le sujet.

La solution trouvée n'a malheureusement pas fonctionné longtemps.

Les problèmes de freeze au boot, etc...sont réapparus après deux reboots.

J'ai voulu en avoir le cœur net et j'ai consulté les fichiers contenus dans

/var/log/

puis j'ai trouvé dans

/var/log/lightdm

un fichier log où il y avait cette ligne :

WARNING: Could not call SetLanguage: GDBus.Error:org.freedesktop.Accounts.Error.Failed: not access to HOME yet so language not saved

Ce qui m'a amené ici.

Il s'avère que lightdm bugue quand le dossier /home est crypté ou a été crypté.

Ce qui est mon cas.

En attendant, j'ai installé gdm et tout est revenu dans l'ordre.

J'avoue ne pas comprendre comment les manips faites avec faucon50 ont pu avoir brièvement une influence sur ce bug.

Voilà.

#24 Le 19/05/2012, à 11:00

PengouinPdt

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Perso, j'ai remarqué que depuis que j'ai mis nautilus, l'ouverture de session redevenait correcte.

Là, encore, va comprendre ... ???

Hors ligne

#25 Le 19/05/2012, à 13:50

naughtyjah

Re : [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Et tu as gardé lightdm comme écran de connexion ?

Tu as juste remplacé Thunar par Nautilus ou tu as fait d'autres changements ?

  • Accueil
  • » Forum
  • » XFCE
  • » [Résolu] Xubuntu 12.04 XFCE freeze 40 secondes lancement session

Haut de page ↑