Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 11/02/2007, à 21:36

teke

[résolu] caractère en console ok, pas en terminal

Bonjour,

Cela fait un peu plus de trois heures que je cherche... et là  j'en peux plus...

Lorsque je lance gvim je n'ai pas de soucis(1), lorsque je lance vim dans une console gnome, je n'ai pas de soucis non plus. Par contre lorsque je lance vim dans un terminal (ctrl+alt+F1) j'ai des soucis... les caractères accentués me paraissent sous la forme de deux caractères or-normes...

Mes locales :

$ locale
LANG=fr_CH.UTF-8
LANGUAGE=fr_CH:fr_FR:fr:en_GB:en
LC_CTYPE="fr_CH.UTF-8"
LC_NUMERIC="fr_CH.UTF-8"
LC_TIME="fr_CH.UTF-8"
LC_COLLATE="fr_CH.UTF-8"
LC_MONETARY="fr_CH.UTF-8"
LC_MESSAGES="fr_CH.UTF-8"
LC_PAPER="fr_CH.UTF-8"
LC_NAME="fr_CH.UTF-8"
LC_ADDRESS="fr_CH.UTF-8"
LC_TELEPHONE="fr_CH.UTF-8"
LC_MEASUREMENT="fr_CH.UTF-8"
LC_IDENTIFICATION="fr_CH.UTF-8"
LC_ALL=
$ echo $LANG
fr_CH.UTF-8

Un tout tout gros merci aux à¢mes miséricordieuses qui pourraient me donner un coup de main.

Dernière modification par teke (Le 28/01/2008, à 23:23)

Hors ligne

#2 Le 12/02/2007, à 18:07

yohann

Re : [résolu] caractère en console ok, pas en terminal

salut, je sais pas précisment ce qu'il faut faire mais en tout cas ton problème est "normal", puisque a partir du moment ou tu à lancé gnome, tu utilise xorg.conf pour gérer le clavier et l'écran alors qu'en mode text, ces option sont gérés par d'autres fichiers, mais je sais plus lesquels malheureusement, et je suis pas chez moi mais en déplacement chez un client donc je peut pas les retrouver tout de suite.

en tout cas, si tu ne le savais pas déja:
inutile de torturer ton xorg.conf, il n'y est pour rien.

bonne chance, à +


j.vachez, le génie du net | Soirées jeux sur Lyon | 441
++++++++++[>+++++++>++++++++++>+++<<<-]>++.>+.+++++++
..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.

Hors ligne

#3 Le 12/02/2007, à 18:46

itsmokes

Re : [résolu] caractère en console ok, pas en terminal

Salut.
En mode ttyi, (alt+ctrl+Fi) tu tapes :
/usr/bin/unicode_start
et après ça roule smile
EDIT : ou bien sudo /usr/bin/unicode_start s'il y a des pbs de permission

Dernière modification par itsmokes (Le 12/02/2007, à 18:51)

Hors ligne

#4 Le 12/02/2007, à 20:49

teke

Re : [résolu] caractère en console ok, pas en terminal

Merci mille fois... cela fonctionne impeccables...
Quelle joie de pouvoir utiliser vim de cette manière... je le trouve plus lisible en terminal.

Hors ligne

#5 Le 13/02/2007, à 19:57

itsmokes

Re : [résolu] caractère en console ok, pas en terminal

De rien smile
Pour ne pas avoir à taper la commande à chaque passage en mode vt tu peux rajouter dans le .bash_profile du répertoire personnel :

if [ -f /usr/bin/unicode_start ]; then
    sudo /usr/bin/unicode_start
fi

là ça devient totomatique big_smile

Hors ligne

#6 Le 14/02/2007, à 15:39

teke

Re : [résolu] caractère en console ok, pas en terminal

Merci encore... c'est efficace et plus agréable à travailler

Hors ligne

#7 Le 28/11/2007, à 10:30

teke

Re : [résolu] caractère en console ok, pas en terminal

Bonjour, je ressuscite se fil car la solution à  bien fonctionné pendant un un certains temp, mais maintenant que je suis sous gutsy je n'ai de nouveau plus d'accent en mode terminal (tty).

La solution apportée ici me renvoie maintenant la réponse :
unicode_start : already in utf-8

Mais je n'ai pas d'accent en terminal... avec l'usage que je fais du terminal... (notamment le courrier électronique)  c'est vraiment très très pénible...

Quelque'un peut-il m'aider sur ce coup là  ?

Hors ligne

#8 Le 28/11/2007, à 12:22

LinuFin

Re : [résolu] caractère en console ok, pas en terminal

Bonjour,

J'suis pas un pro, donc il faut vérifier tout ce que je dis.
J'ai eu un problème similaire : visiblement pas la même configuration clavier utilisée sous Gnome et sous les tty. Mon clavier était en configuration fr sous Gnome et sur la console lancée sous Gnome. Par contre, il était en us sur tty et au login (la fenêtre d'ouverture de session Gnome qui était pourtant bien en langue française...).
Contrairement à  ce qu'affirme le message #2 de ce fil, le problème venait de mon xorg.conf ! En effet, dans celui-ci, mon clavier était déclaré en us. Je l'ai remis en fr et mon problème a été résolu, tant en tty que sur la fenêtre d'ouverture de session.

J'espère t'avoir aidé.

Hors ligne

#9 Le 28/11/2007, à 12:44

teke

Re : [résolu] caractère en console ok, pas en terminal

Merci beaucoup pour ta réponse,

Alors le fichier xorg est en ordre (ch et le variant à  fr)

Mais à  petit coup de grep je suis arrivé au fichier "/var/lib/locales/supported.d/local" qui contenait :

fr_CH.UTF-8 UTF-8
en.UTF-8 UTF-8

J'ai supprimé cette deuxième ligne et rebooté, mais sans résultat.

Je me demande si la chose ne peut pas provenir de mon .bashrc, je le poste au cas o๠:

  1 [ -z "$PS1" ] && return
  2 export HISTCONTROL=ignoredups
  3 export HISTCONTROL=ignoreboth
  4 shopt -s checkwinsize
  5 [ -x /usr/bin/lesspipe ] && eval "$(lesspipe)"
  6 if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
  7     debian_chroot=$(cat /etc/debian_chroot)
  8 fi
  9 case "$TERM" in
 10 xterm-color)
 11     PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
 12     ;;
 13 *)
 14     PS1='\!$ '
 15     ;;
 16 esac
 17 case "$TERM" in
 18 xterm*|rxvt*)
 19     PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD/$HOME/~}\007"'
 20     ;;
 21 *)
 22     ;;
 23 esac
 24 if [ -f ~/.bash_aliases ]; then
 25     . ~/.bash_aliases
 26 fi
 27 if [ "$TERM" != "dumb" ]; then
 28     eval "`dircolors -b`"
 29     alias ls='ls --color=auto'
 30 fi
 31 if [ -f /etc/bash_completion ]; then
 32     . /etc/bash_completion
 33 fi

Mais je ne vois pas trop...

Hors ligne

#10 Le 28/11/2007, à 13:10

edouardj

Re : [résolu] caractère en console ok, pas en terminal

salut,

bon et bien moi c'est pareil et ça fait 2 jours que j'essaye de trouver ça.... Elle commence à  me gonfler gusty!!
Alors voilà  o๠j'en suis: au boulot on a une appli sur un serveur qu'on doit intérrogé avec un tty. Sous Dapper pour avoir l'apparence correct avec les accents etc je devais changer les locales comme la plupart des gens. Je faisais comme ceci:

Dapper:

cat /etc/environment
LANG="fr_FR"
LANGUAGE="fr_FR:fr"

Je supprime tous dans /var/lib/locales/supported.d./en et local
et je rajoute ceci dans le fr:

cat /var/lib/locales/supported.d/local 
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15
fr_FR.UTF-8 UTF-8

Puis je fais :

sudo locale-gen  (ou dpkg-reconfigure locales)

un reboot et c'était bon... Maintenant sous Gusty c'est le bordel...P'tain à  chaque version y a un truc qui change. C'est fou comme ils veulent se compliquer la vie et rendre fou les gens. Bref...

Gusty: je fais la même chose que Dapper, sauf que je rajoute:

sudo rm /etc/default/locale

afin de supprimer ce fichier qui prend le dessus sur /etc/environment

Mais ça ne change rien à  notre problème d'accents. D'ailleurs je ne sais pas si vous avez remarquez mais le e accent grave est pris alors que l'autre non....

On arrive à  faire quelque chose temporairement avec:

sudo dpkg-reconfigure console-setup

on laisse les choix par défaut (je suis en ISO-8859-1) et après validation il fait un:

setting up console font and keymap

et là  ça va MAIS si je reviens sous Gnome ben pouff tout est reperdu! Faudrait que je trouve ce qui est lancé

rem: je n'ai pas encore essayé cette commande: unicode_start
rem: sous feisty ça marche comme pour dappper

Dernière modification par edouardj (Le 28/11/2007, à 13:11)

Hors ligne

#11 Le 28/11/2007, à 13:26

edouardj

Re : [résolu] caractère en console ok, pas en terminal

une autre remarque:

si laisse ou pas l'option du noyau :locale=fr_FR  ça ne change rie au problème.

Hors ligne

#12 Le 28/11/2007, à 13:49

teke

Re : [résolu] caractère en console ok, pas en terminal

bien venue au club...
perso, j'y trouve de moins en moins mon compte... tout les six mois je passe un trentaines d'heures à  rechercher les solutions au même problèmes (terminaux, carte graphique, double écran, wifi,...) car à  chaque fois les solutions trouvées ne fonctionnent plus...

Très honnêtement, je suis vraiment découragé... je me dis qu'avec le temps que j'y ai passé ces trois ans, j'aurais largement eu le temps d'apprendre à  maà®triser gentoo ou autre...

je crois que j'ai trouvé mon occupation pour les vacances d'été 2008...

Est-ce que quelqu'un à  réussi à  faire fonctionner le teminal correctement ?
1) l'accentuation.
2) la taille de l'affichage (le vga=xxx ne fonctionne plus du tout)

Hors ligne

#13 Le 28/11/2007, à 14:13

edouardj

Re : [résolu] caractère en console ok, pas en terminal

tiens j'ai aussi un prob sur la taille de la police...
Sur ce cà´té là  je ne connais pas grand chose mais je pense que ça doit être du cà´té de l'initram du noyau...

Hors ligne

#14 Le 28/11/2007, à 14:59

teke

Re : [résolu] caractère en console ok, pas en terminal

d'o๠le vga=xxx que l'on mettait dans le grub et qui a toujours super bien fonctionné jusqu'à  la Gutsy....

C'est ce que l'on appelle de framebuffer sauf erreur...

Hors ligne

#15 Le 28/11/2007, à 15:23

edouardj

Re : [résolu] caractère en console ok, pas en terminal

non moi je ne rajoutais pas d'option au boot pour la police...

Bon j'ai résolu le problème: tu fais comme j'ai noté pour Gusty, puis un

sudo dpkg-reconfigure locales

et j'ai choisi ISO-8859-1 + Police en VGA et taille 16 (au lieu de Fix). Une fois rebooté je retrouve bien les mm tty que sous Dapper. Ouffffffff
J'espère que ça marchera aussi pour toi.

Hors ligne

#16 Le 28/11/2007, à 18:50

teke

Re : [résolu] caractère en console ok, pas en terminal

Effectivement, il y a un très net mieux perso j'ai :

Sauvegarde des fichiers touchés :

sudo mkdir /root/locale-bck
sudo cp -a /etc/environment /root/locale-bck/environment
sudo cp -a /var/lib/locales/supported.d /root/locale-bck/
sudo cp -a /etc/default/locale /root/locale-bck/locale
sudo cp -a /boot/initrd.img-2.6.22-14-generic /root/locale-bck/

# le nom de ce dernier fichier peut changer tab pour trouver le bon

Modification des fichiers :

sudo echo -e 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANG="fr_CH"
LANGUAGE="fr_CH:fr"'\
> /etc/environment
sudo echo 'fr_CH.UTF-8 UTF-8' > /var/lib/locales/supported.d/local
sudo rm /etc/default/locale
sudo dpkg-reconfigure console-setup
sudo dpkg-reconfigure locales

Pour la dernière commande on choisi ce qui est logique et coule de source...
puis
  UTF-8 ensuite
et
  # latin1 et latin5 : langues de l'Europe de l'ouest et turc
et
  Terminus
et
  14

puis tout fonctionne.

Enfin presque, car en fait j'ai toujours le problème de taille, bien que j'aie essayé toutes les tailles de caractères données...


--
EDIT
ouai... mais bon... au troisième démarrage les lettres accentuées on de nouveau disparut. enfin ils sont maintenant remplacés par des caractères cabalistiques....

Dernière modification par teke (Le 28/11/2007, à 19:35)

Hors ligne

#17 Le 04/01/2008, à 17:41

teke

Re : [résolu] caractère en console ok, pas en terminal

Mwouais... c'est vraiment du grand n'importe quoi... J'ai maintenant installé gutsy sur 72 machines différentes... et je n'ai pas eu une seule et unique installation qui s'est passée sans que je doive bidouiller pour que ça fonctionne...

Mais bon, la sur mon asus F9S, que j'ai réinstallé, la procédure indiquée ci dessus ne fonctionne plus...

Avant j'avais mes terminaux qui "débordaient" vers le bas : les x dernières lignes étaient en dessous de l'écran... très pratique...

Maintenant, comment faire fonctionner le framebuffer ? jusqu'à  gutsy ça fonctionnait bien... mais plus maintenant...

Hors ligne

#18 Le 04/01/2008, à 18:25

teke

Re : [résolu] caractère en console ok, pas en terminal

En fait c'est maintenant résolut avec la page :
http://doc.ubuntu-fr.org/tutoriel/comment_activer_le_framebuffer

Hors ligne

#19 Le 13/04/2008, à 17:21

Beebop

Re : [résolu] caractère en console ok, pas en terminal

Bonjour,

Est ce que vous avez résolu votre problématique de caractère ? Car pour moi, aprés avoir résolu celle de la résolution basse des session tty, j'ai depuis cette problèmatique. Pour les consoles c ok. En suivant vos étapes je me retrouve avec des caratéres balistiques (je ne dis pas que c'est de votre faute....).

:mad:C'est vraiment la poisse cette histoire: se prendre la tete pour récupérer un disque avec ses données ça vaut le coup ou régler des probs de sécurité ou je ne sais quoi encore, mais pour ce type de problème, ça ne devrait pas exister, à moins de changer de nationalité, de faire un lavage de cerveau et ne causer qu'en anglais et à ce moment là effectivement on passe sur une autre table de caratère et on se prend la tete...Mais purée!  Je l'ai installé en francais l'Ubuntu quoi ! Je suis en pétard de voir  qu'on perd autant de temps avec ce gendre de conn....Et c'est réellement difficile de trouver des tutos ou autres. Enfin bref le coup de gueule n'est pas le propos de mon post. Très mauvais points pour Ubuntu. Désolé de vous parler de windows, mais j'ai rencontré ce type de prob très très rarement et certainement pas aprés une installation. Le mode console ou terminal selon comment on se logue ne m'a jamais causé de soucis comme ca. mad

Merci de m'indiquer les fichiers à éditer et à poster pour repérer une merdouille..
Beebop

Dernière modification par Beebop (Le 14/04/2008, à 02:33)


NetBook Acer Aspire 0ne - Seven Pro / Karmic

Hors ligne

#20 Le 13/04/2008, à 19:53

teke

Re : [résolu] caractère en console ok, pas en terminal

Je compatis...

En fait... le problème était résolu... Puis il y eu une mise à jour du noyau qui à tout cassé... j'ai baissé les bras... je me suis dit que j'attends la prochaine mise à jour majeur, et si ce n'est pas résolu, je passe à gentoo...

Hors ligne

#21 Le 13/04/2008, à 21:39

Beebop

Re : [résolu] caractère en console ok, pas en terminal

He ben.....je suis vraiment étonné...
Je commencai à penser (voir à regretter mon coup de gueule) qu'il y avait une éventuelle incompatibilité avec mon pc portable, mais tu es bien avec un système différent que le mien..
Bon, ben je verrai avec un pot pour voir s'il a une idée sur cet prob..
Et ce qui m'étonne bcp également ce sont les résultats des recherches sur google ou sur les forums qui sont très maigre, mais très maigre... Je m'attendai à me faire tirer les oreilles pour absence de recherche, mais non...

J'avoue  quand meme que j'étais pas mal pommé dans la fenetre du réglage des parametres avec sudo dpkg-reconfigure console-setup.  Ce qui m'étonne, c'est que lorsque mes session était en basse résolution, je n'ai pas aperçu cette problématique de table de caractère...Je pense que tu peux me le confirmer.... Si confirmation, il y a donc un lien de cause à effet. Je n'ai pas non p lus remarquer cette situation en mode safe....Cette partie je pourrai la vérifer....MAIS, mon soucis c'est que suite au différente manip on est passé de caractères manquant ou erroné(on avait uniquement les accent graves ou aïgue ko à des affichages balistiques comme tu disais. Donc, on peut se poser la question si on n'a pas rajouté un peu plus de prob.

Question subsidiaire :
Est ce que c'est reconnu comme un bug ou non? Si oui je laisse tombé en attendant (ou non) la mise à jour, sinon ben je me casserai la tête encore quelque temps.   
Est ce que tu pourrais enlever le résolu afin de pouvoir le réactualiser ?
Merci pour ta compassion teke wink

Dernière modification par Beebop (Le 13/04/2008, à 22:19)


NetBook Acer Aspire 0ne - Seven Pro / Karmic

Hors ligne

#22 Le 14/04/2008, à 02:19

Beebop

Re : [résolu] caractère en console ok, pas en terminal

En suivant ton script ca a marché pour moi...

 Je précise deux trois choses : 
sudo echo -e 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANG="fr_CH" # ici je me suis retrouver avec quote> en début de ligne et j'ai tout de meme continuer comme si de rien je le précise pour ceux qui se poserait des question.
LANGUAGE="fr_CH:fr"'\ # toujours avec quote> aprés cette ligne le quote disparait
> /etc/environment # aprés ça on revient avec un prompt normal
sudo echo 'fr_CH.UTF-8 UTF-8' > /var/lib/locales/supported.d/local  # ici j'ai recontré un prob de permission meme avec "sudo" j'ai pu le modifier en l'éditant avec Kwrite en admin et j'ai repris la suite
sudo rm /etc/default/locale
sudo dpkg-reconfigure console-setup
sudo dpkg-reconfigure locales

Dans le prog "dpkg-reconfigure console-setup" aprés quelques parametre du clavier qu'on laisse par defaut :
on met  
  UTF-8 ensuite 
et
  # latin1 et latin5 : langues de l'Europe de l'ouest et turc
et
  Terminus >>>>ici j'ai plutôt mis en vga (mais ca n'influence pas l'encodage)
et
  14
et reboot # j'ajoute cette ligne car il me semblait nécessaire de le faire (habitude windows :rolleyes:

tout est ok et il faut évidemment ensuite rajouter les modif concernant le frame buffer afin d'avoir un résolution convenable dans les session tty (si ca été fait avant, c'était mon cas, ca ne pose pas de problème
.
Je vais me le mettre de coté vite fait bien  fait..
Merci à vous deux d'avoir exposé cette problématique et sa résolution....Dommage qu'elle n'a été que provisoire pour toi teke

Bon ben laisse le resolu....
Ce serait bien de mettre cette solution en évidence quelque part avec les mot clés qui vont avec :
encodage de caractère - tty - shell - terminal. Non ?  Par ce que ca était vraiment galère à trouver...J'y ai passé tout mon dimanche..Héhéhé

Merci encore


NetBook Acer Aspire 0ne - Seven Pro / Karmic

Hors ligne

#23 Le 14/04/2008, à 02:42

Beebop

Re : [résolu] caractère en console ok, pas en terminal

Je reviens encore juste pour une question :

Tu dis que le problème est revenu aprés une mise à jour du noyau...Est ce que ca voudrait dire que cette manip reste inefficace ?

Une petite doc sur l'encodage de caractère uft-8 "man utf-8 (7) - Un encodage Unicode multi-octets compatible ASCII." http://pwet.fr/man/linux/conventions/utf_8.

Dernière modification par Beebop (Le 14/04/2008, à 02:50)


NetBook Acer Aspire 0ne - Seven Pro / Karmic

Hors ligne

#24 Le 14/04/2008, à 07:52

teke

Re : [résolu] caractère en console ok, pas en terminal

Pour moi c'est bien la mise à jour qui a fait revenir le problème. La solution qui à très bien fonctionné sur une douzaine de machine différentes ne fonctionnait plus après cette mise à jour.

De guère lasse... j'ai laissé tombé. Je suis passé à debian sur ma propre machine, et aucun soucis du même type... je vais tenter une installation de hardy... on verra...

Hors ligne

Haut de page ↑