Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/02/2007, à 03:32

messirekarl

[Abandonné] Druide Antidote Rx v3 sur amd64

Bonjour!

Je viens d'acheter le logiciel d'aide à la rédaction Antidote Rx v3 (Druide Informatique) et je suis incapable de l'installer sur mon portable, un Turion64.  Le message d'erreur me dit que les paquets sont "i386" et non pas "amd64".  J'ai cherché sur le net des indices, sans trouver.

Est-il possible de l'installer tout de même, ou dois-je installer Ubuntu 6.10 en 32 bits et perdre l'intérêt d'avoir acheté un 64 bits?  Quelqu'un a-t-il/elle réussi à se l'installer?  On m'a dit qu'un 64 bits pouvait lire le 32 mais pas l'inverse... est-ce vrai?

Merci

Dernière modification par messirekarl (Le 26/03/2007, à 04:16)

Hors ligne

#2 Le 12/02/2007, à 06:56

scorpio810

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

sudo dpkg --force-architecture -i tonsoft.deb

"Le jour où tu découvres le Libre, tu sais que tu ne pourras jamais plus revenir en arrière..."

Hors ligne

#3 Le 12/02/2007, à 07:45

messirekarl

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Merci Scorpio,

Cependant, je n'ai pas de .deb.  C'est un fichier autoexécutable (?) qui fait l'installation pour moi.

Normalement, je l'appelle ainsi sur un i386:

sudo ./Installe_Antidote_RX

puis il me demande si je veux utiliser l'installation RPM ou DPKG...  Je choisi DPKG, et c'est là que je reçois les messages d'erreurs (mauvaise architecture).  J'ai essayé de rajouter --force-architecture à la ligne, mais c'est sans succès.  C'est où et comment que je dois lui dire de forcer l'installation sur amd64?

Merci

Hors ligne

#4 Le 12/02/2007, à 13:59

Béryl

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Bonjour,
Tu devrais te renseigner directement chez Druide. Ils sont très réactifs.

Hors ligne

#5 Le 12/02/2007, à 15:58

scorpio810

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

essaye le forcage de l'installation de tous les debs

sudo dpkg --force-architecture -i ****.deb

Dernière modification par scorpio810 (Le 12/02/2007, à 15:58)


"Le jour où tu découvres le Libre, tu sais que tu ne pourras jamais plus revenir en arrière..."

Hors ligne

#6 Le 12/02/2007, à 21:48

Ansuz

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Salut messirekarl,

Personnellement, j'ai réussi à installer Antidote RX_v3 sur mon Edgy 6.10 mais en 32 bits...(Pentium III)
Voir ici:
http://forum.ubuntu-fr.org/viewtopic.php?id=93761
Pour ce qui est de processeur en 64 bits, je ne sais pas...
Ce qui m'a posé le plus de souci, c'est l'intégration à OpenOffice!


"Mieux vaut ne rien savoir que beaucoup savoir à moitié !"  Friedrich Nietzsche

Hors ligne

#7 Le 06/09/2007, à 01:11

francois008

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

J'ai le même problème, mais avec la Version 4 d'antidote.

Le problème, c'est que le paquet .deb n'est pas accessible.
Il semble être décompressé quand je clique "Terminer", puis supprimé juste avant de nous afficher l'erreur.

Si je prend le path indiqué dans l'erreur:

dpkg : erreur de traitement de /tmp/antidote_6.4.7000-1_i386.deb (--install) :
 l'architecture du paquet (i386) ne correspond pas à celle du système (amd64)
Des erreurs ont été rencontrées pendant l'exécution :
 /tmp/antidote_6.4.7000-1_i386.deb

Et que j'essaie :

sudo dpkg --force-architecture -i /tmp/antidote_6.4.7000-1_i386.deb

Ca me dit:

dpkg : erreur de traitement de /tmp/antidote_6.4.7000-1_i386.deb (--install) :
ne peut pas accéder à l'archive: Aucun fichier ou répertoire de ce type
Des erreurs ont été rencontrées pendant l'exécution :
/tmp/antidote_6.4.7000-1_i386.deb

Dernière modification par francois008 (Le 06/09/2007, à 01:24)

Hors ligne

#8 Le 06/01/2008, à 15:58

gagarine

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Hello,

Quelqu'un ayant une machine 32bit ne pourrait poster le paquet? Ca doit être faisable en stopant le processus d'installation au bon moment une fois le paquet créer... (en passant simplement par le moniteur système).

Pas question d'acheter antidote si je ne suis pas certain que ça fonctionne en 64bit.


http://www.wiki.neverlandlab.net/

Hors ligne

#9 Le 30/03/2008, à 12:32

Edouard GAULUE

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Pour installer la version 64 bits d'Antidote ce n'est pas compliqué (du moins sur 7.10).

Il faut déjà installer le pkg ia32-libs pour faire tourner les applis 32 bits simples.

aptitude install ia32-libs

Ensuite tu ajoutes dans /etc/dpkg/dpkg.cfg la ligne :

force-architecture

Puis, tu fais ton install standard d'Antidote.

Pour le passage en v6, il pointe sur 2 librairies dont le nom diffère entre fedora et ubuntu/debian. Suffit de créer les liens qui vont bien dans /usr/lib32/ :

ln -s libcrypto.so.0.9.8 libcrypto.so.6
ln -s libssl.so.0.9.8 libssl.so.6

Bien entendu, tu peux retirer le force-architecture dans dpkg.cfg après.

A l'heure actuelle ça marche sauf que l'application ne se lance pas directement depuis thunderbird, firefox...

J'investigue...

#10 Le 31/03/2008, à 02:21

Edouard GAULUE

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

La suite...

Je n'arrive pas à trouver d'information sur la possibilité d'executer des extensions 32 bits sur du mozilla like 64 bits. J'ai cherché autour de nspluginwrapper mais sans succès : (i) ce n'est pas un plugin mais une extension et (ii) je récupère un message d'incompatibilité NPAPI.

Je pense toutefois que le problème vient de là.

Antidote 32 bits tourne très bien sur mon Gusty AMD64 mais les applications tierces n'arrivent pas à le lancer ce qui limite considérablement son intérêt.

Druide ne fournit pas de plugins 64 bits. Aller ! S'il vous plait faite quelque chose : le monde linux est très souvent sous 64 bits. On veut juste les plugins pas tout le programme ! Ou alors juste un peu d'info sur ces plugins pour vous aidez à les ré-écrire.

Si vous avez d'autres idées...

#11 Le 31/03/2008, à 02:29

yurek

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

le monde linux est très souvent sous 64 bits

ca c'est pas vrai.
tu devrais commencer pas ouvrir le script Installe_Antidote_RX avec un editeur de texte pour voir ce qui s'y passe. Dommage que c'est propriétaire.

Dernière modification par yurek (Le 31/03/2008, à 02:31)


http://doc.ubuntu-fr.org/installation/debutants
http://doc.ubuntu-fr.org/diagnostic
http://doc.ubuntu-fr.org/diagnostic_outils
http://doc.ubuntu-fr.org/reflexe_ubunteros

Hors ligne

#12 Le 01/04/2008, à 23:18

Edouard GAULUE

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Suite et fin.

L'extension firefox, thunderbird est en XPCOM (avec librairies compilées en 32 bits). Je ne suis pas expert des extensions XPCOM et je n'ai pas trouvé de logiciel équivalent à nspluginwrapper permettant de les faire tourner en 32 bits à partir d'une application 64 bits.

Donc pas de solution sauf à réécrire un truc vu qu'Antidote fournit une API.

J'ai posé la question a Druide qui ma répondu qu'ils y travaillaient, plus précisément, à une compatibilité ubuntu 64 bits. J'en déduis qu'ils travaillent sur un ensemble compilé en 64 bits et pas seulement sur les plugins.

J'espère qu'il seront prêt pour la 8.04. Sinon c'est dommage, on avait juste besoin des plugins revus puisque qu'Antidote fonctionne très bien en 32 bits sous ubuntu 64 bits.

En tout cas j'arrête là mes recherches et je vais attendre.

#13 Le 15/05/2008, à 23:05

Hibountu

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Bon, s'il ne manque que les plugins, moi ça me va, je passe en 64 bits.  Le logiciel inclus son propre éditeur, c'est moins pratique, mais ça fera d'ici une version 64 bits native.


Un journal d'actualité internationale qui voit loin : www.lepanoptique.com

Hors ligne

#14 Le 13/08/2008, à 12:06

Jeff1

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Comme beaucoup, après des heures passées à réussir l'install d'Antidote sur un AMD 64 bits (avec Hardy Heron), impossible de réussir à le lancer dans OpenOffice (aucune message d'erreur, il ne se passe rien). J'ai fait appel au support technique : je viens de recevoir la réponse suivante de Druide Informatique :

Les intégrations que nous distribuons avec Antidote RX sont 32 bits uniquement. Bien qu'Ubuntu 64 soit capable d'exécuter une application 32 bits telle qu'Antidote, une application 64 bits (OpenOffice.org par exemple) n'arrivera pas à charger une librairie 32 bits. Par conséquent, l'intégration d'Antidote dans OpenOffice.org ne fonctionnera pas sur un système 64 bits.

Je leur ai répondu d'étudier les avantages de la GPL : la solution aurait déjà était trouvée !

Hors ligne

#15 Le 18/08/2008, à 04:14

Das Letzte Einhorn

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

La raison pourquoi il ne charge pas Jeff1 je l'ai expliquée ici : http://forum.ubuntu-fr.org/viewtopic.php?id=241055

Il semble que c'est à nouveau un problème de lien entre les librairies. Cependant, je ne sais pas quelle commande il faut écrire après "ln -s" pour changer ca. Est-ce qu'Édouard aurait une solution?

Hors ligne

#16 Le 23/09/2008, à 20:04

belcirelk

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Il y a un utilisateur qui l'utilise avec du 64 bits ici :

http://forums.gentoo.org/viewtopic-t-526679-highlight-antidote.html

Hors ligne

#17 Le 30/09/2008, à 21:46

Jean-François Gagnon

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Salut Belcirelk

J'ai tenté sa méthode et ça ne fonctionne pas.

cd /usr/lib/openoffice/program/
sudo rm libstdc++.so.6
sudo ln -s /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6 libstdc++.so.6

Sinon  titoucha dit que "sur un système 64bits il faut utiliser la version Openoffice-bin pour que ça fonctionne et pas la version compilée."

Est-ce que c'est normal que je ne trouve pas la version bin de Ooo? Sinon, est-ce qu'il serait possible d'installer Ooo en 32 bits pour qu'il soit compatible avec Antitode?

Dernière modification par Jean-François Gagnon (Le 30/09/2008, à 21:47)

Hors ligne

#18 Le 23/07/2009, à 19:01

M4d3L

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

J'ai fait un petit tutoriel très simple pour installer Antidote sur ubuntu 9.04 64bit

http://www.m4d3l-network.com/2009/07/22/installer-le-druide-antidote-sur-ubuntu/

Mais j'ai le meme probleme. ne fonctionne pas sur openoffice ni firefox sinon en native sa marche #1.

#19 Le 20/01/2010, à 07:04

dlebon13

Re : [Abandonné] Druide Antidote Rx v3 sur amd64

Salut,
J’ai ce message quand je tente en sudo de faire la màj de Antidote RX7 vers RX8 sur Karmic 64 bit; « error while loading shared libraries: libbz2.so.1: cannot open shared object file: No such file or directory » (libbz2 est installée). L’installation de RX7 s’étant, elle, déroulée sans erreur. Si vous avez une idée, merci de m’aider.:(

Hors ligne

Haut de page ↑