Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 24/07/2012, à 15:46

pti-jean

[Résolu] Thunderbird et liens http av option "-no-remote"

Bonjour,

Quand j’exécute Thunderbird avec l'option  "-no-remote", et que je souhaite ouvrir un lien http, j'ai ce message: "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

C'est quoi le problème ?
Comme lui dire d'ouvrir les liens http ?

(J'ai trouvé la solution d'ouvrir Thunderbird avec l'option "-no-remote", pour avoir plusieurs fenêtres Thunderbird en même temps (cad 2)... une pour chaque profils!)

JM

Dernière modification par pti-jean (Le 05/10/2012, à 12:02)


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#2 Le 24/07/2012, à 18:08

Vu

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Bonjour,

Il y a t-il une session Firefox d'ouverte lors de l'apparition de ce message ?? ou un processus firefox en cours ?? (que tu peux voir en tapant top dans un terminal ou en passant par le moniteur système).

Dernière modification par Vu (Le 24/07/2012, à 18:09)


Ubuntu 12.04

Hors ligne

#3 Le 24/07/2012, à 20:45

pti-jean

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Oui, effectivement y-a firefox de lancé...
Mais, à moment donner, y-a toujours un firefox de lancé, avec plein de liens que je suis en train d'utiliser!

Donc oui, j'ai fais un test, est avec firefox éteint, quand je clique sur le lien http dans Thunderbird, il se lance bien avec le lien dedans.

Mais, cela ne résout pas le problème... et même cela le complique... car:
J'ai th1... Thunderbird lancé normalement...
J'ai th2... Thunderbird lancé comme:    thunderbird -P bidule -no-remote

Si firefox est arrêté, dans les 2 cas... cad th1 et th2... firefox démarre avec le lien dedans, quand on clique sur le http dans Thunderbird.
Si firefox est démarré... th1 lance les liens dans firefox... th2, affiche le message d'erreur et ne lance pas le lien.
Si firefox est démarré par un lien dans th1... th2, affiche le message d'erreur et ne lance pas le lien, tendis-que th1 lance bien les liens dans ff.
Si firefox est démarré par un lien dans th2... th1, affiche le message d'erreur et ne lance pas le lien, tendis-que th2 lance bien les liens dans ff.

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#4 Le 24/07/2012, à 23:59

pti-jean

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

En fait j'ai raconté des bêtises, car j'avais pas testé à fond le truc...

Je reprend...

J'ai donc:
th1: Thunderbird lancé normalement...
th2: Thunderbird lancé avec la cmd:    thunderbird -P bidule -no-remote

Si firefox est arrêté:
* clic sur un lien http dans th1, exécute firefox avec le lien... puis:
  ~ un autre clic sur un lien http dans th1, ouvre le lien dans un nouvel onglet
  ~ un clic sur un lien http dans th2, affiche le message d'erreur et ne lance pas le lien
* clic sur un lien http dans th2, exécute firefox avec le lien... puis:
  ~ un clic sur un lien http dans th2, affiche le message d'erreur et ne lance pas le lien
  ~ un clic sur un lien http dans th1, affiche le message d'erreur et ne lance pas le lien
Si firefox est démarré par le raccourcie normal du menu:
* clic sur un lien http dans th1, ouvre le lien dans un nouvel onglet
* clic sur un lien http dans th2, affiche le message d'erreur et ne lance pas le lien

Donc, visiblement, l'option "-no-remote" impose par défaut que le lien va s'ouvrir en démarrant firefox... et si firefox, est déjà démarré, j'ai doit au message d'erreur! Ce qui n'est pas le cas, quand Thunderbird est démarré normalement... puisque dans ce cas, les liens sont ouverts dans de nouveaux onglets!

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#5 Le 29/08/2012, à 13:03

pti-jean

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Bonjour,

Même problème avec l"extension ProfilSwitcher... le profil démarrer à partir du premiers, n'ouvre par les liens dans (de nouvelles onglets dans) Firefox.

Mon but est quand-même d'avoir mes 2 profils d'ouverts en même temps!

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#6 Le 05/10/2012, à 12:02

pti-jean

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Bonjour,

Alors que je copiai les liens manuellement dans firefox à cause du problème ; je viens de faire un clic sur un lien dans Thunderbird et je constate que ça fonctionne...

Merci donc à la communauté, qui même si elle ne m'a pas répondu directement a corrigé le problème (de souvenir, c'est la deuxième fois que je vie ce genre d'expérience ;-)

@+

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#7 Le 05/10/2012, à 14:14

Vu

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Il faut dire que ta question tape bien dans les coins. Quand il y a pas de réponses (moi je n'en avait pas) il faut trouver un forum plus pointu:
http://www.geckozone.org/forum/


Ubuntu 12.04

Hors ligne

#8 Le 07/10/2012, à 18:28

pti-jean

Re : [Résolu] Thunderbird et liens http av option "-no-remote"

Pas de soucis Vu... si je disais ça, c'était pas négatif... en tous cas je préfère que l'on ne me dise rien, et qu'un beau jour j'ai la bonne surprise de m'apercevoir que c'est corrigé... que l'on me mène en bateau et que je n'obtienne rien! wink

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

Haut de page ↑