Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/10/2005, à 13:30

yanshee

Breezy: sérieux problèmes au démarrage de Gnome

Bonjour à tous,

Voilà, je viens de passer d'Hoary à Breezy, et j'ai un énorme problème avec Gnome: quand j'arrives sur l'écran de login, je me logges normalement, il commence le démarrage de gnome, avec la bannièere de chargement et la p'tite musique, et puis boum, il redémarre Gnome et me ramènes à l'écran de login. Je ne sais vraiment pas quoi faire,parce que je suis un pauvre petit débutant qui n'y connaît pas encore grand-chose... hmm

J'arrives à me logger en terminal safe fail ( et à lancer firefox, d'où je vous écrit..), mais impossible de se logger sur le bureau, même en safe mode...

Concernant ma migration, j'ai eu quelques problèmes à la faire directement d'internet, j'ai donc pompé le CD de Breezy, et fait une update à partir du CD (en modifiant toutefois mon sources.list et en remplaçant tous les hoary par breezy... comme indiqué dans le Wiki). Je me suis inspiré de ce post pour ma migration: http://forum.ubuntu-fr.org/viewtopic.php?id=15677
Synaptic m'a fait des problèmes en disant qu'il ne trouvait pas certains serveurs(problèmes avec les serveurs belges ?!), mais je me suis dit que ce ne devait pas être grave vu que j'avais rajouté le cd de breezy dans mes dépôts.

Voilà, aidez-moi s'il vous plaît, j'ai des tas de documents à récupérer, je n'ai donc aucune envie de reformater et faire une install clean de breezy qui me ferait perdre tous mes documents. Je n'ai vraiment aucune idée de ce qu'il faut faire, alors si un "gourou" wink pouvait se pencher sur mon cas ce serait formidable !

merci d'avance pour toutes les réponses et l'aide que vous pourrez m'apporter. smile

Hors ligne

#2 Le 20/10/2005, à 13:34

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

hum.

sudo dpkg-reconfigure gdm

(mais je doute que ça fonctionne)

Donc, trouvons d'abord la cause:  qu'as-tu comme messages d'erreur dans ~/.xsession-errors

?


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 20/10/2005, à 14:15

Desintegr

Re : Breezy: sérieux problèmes au démarrage de Gnome

Je pense que le problème vient des fichiers de configuration de GNOME.

Pour tester rapidement si le problème vient de là, le plus simple est de créer un nouvel utilisateur (par exemple nommé « test ») en console avec la commande « adduser », puis de lancer une session GNOME avec ce nouvel utilisateur.
Si tout fonctionne correctement avec l'utilisateur « test », cela signifie bien qu'il y a bien un problème avec ta configuration personnelle de GNOME.

Il faudra alors sûrement supprimer toute la configuration de GNOME pour repartir « proprement ».
Quels sont les types de documents importants ? Mails/Agenda/Carnet d'adresse dans Evolution ? Document OpenOffice ou autres ? Ils ne seront peut-être pas touché par une remise à zéro de la configuration de GNOME.

Sinon comme le dit laurent, il doit y avoir quelques informations supplémentaires dans le fichier ~/.xsession-errors


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#4 Le 20/10/2005, à 14:19

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Salut, et merci pour ta réponse !

Bon, j'ai essayé la commande sudo dpkg-reconfigure gdm, mais cela n'a rien changé comme tu le prévoyais. A quoi sert cette commande (j'ai envie d'apprendre en même temps... wink ) ? à réinstaller gnome ?
Voici ce qu'il y a dans le fichier .xsession-errors (j'ai tout recopié à la main, le copier/coller ne semble pas fonctionné, alors j'espère ne pas avoir fait d'erreurs dans mon recopiage...):

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running:/usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "var/lib/gdm/ :0.XServers" -h "" -l ":0" "yanshee"
/etc/gdm/Xsession: Beginning session setup...
_Ice TransTransNoListen: unable to find transprot: tcp
_IceTransmkdir: ERROR: euid !=0, directory /dev/X will not be created
_IceTransmkdir: ERROR: cannot create /dev/X
_IceTransPTSOpenServer: mkdir (/dev/X) failed, errno=13
_IceTransOpen: transport open failed for pts/MEPHISTO:
_IceTransMakeAllCOTSServerListeners: failed to open listener for pts
_IceTransISCOpenServer: protocol is not supported by a ISC connection
_IceTransOpen: transport open failed for isc/MEPHISTO:
_IceTransMakeAllCOTSServerListeners: failed to open listener for isc
_IceTransSCOOpenServer: protocol is not supported by a SCO connection
_IceTransOpen: transport open failed for sco/MEPHISTO:
_IceTransMakeAllCOTSServerListeners: failed to open listener for sco
SESSIONMANAGER: unix/MEPHISTO:/tmp/ .ICE-unix/8908
gnome-session:fatal IO error 104(connexion ré-initialisée par le correspondant) on X server:0.0.

Voilà, c'est toujours aussi incompréhensible pour moi...
L'erreur viendrait-elle plutôt du serveur X que de gnome ?

encore merci de ton attention...

Hors ligne

#5 Le 20/10/2005, à 14:29

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Salut Desintegr,

je viens de tester en ajoutant un utilisateur test comme tu me le conseillais, mais je rencontre exactement le même problème en me loggant sur ce compte test: écran de chargement, puis retour à l'écran de login. sad
Concernant les documents que je dois impérativement conservés, il s'agit de travaux réalisés avec Gimp, Inkscape et Wings3D, des mails, des photos, des MP3,... je pourrais peut-être les déplacer dans un autre répertoire hors de mon répertoire home afin de les protéger, serait-ce une solution ?

encore merci pour l'aide les gars ! wink

Hors ligne

#6 Le 20/10/2005, à 14:30

Desintegr

Re : Breezy: sérieux problèmes au démarrage de Gnome

Hum, d'après le test avec le nouvel utilisateur, le problème semble plus compliqué.


Je ne pense pas que ça fonctionne (comme l'utilisateur « test » ne fonctionne pas non plus )mais tu peux toujours essayer.
Essaye de renommer ton fichier ~/.ICEauthority en ~/.ICEauthority.bak, puis essaye de relancer ta session GNOME.

Si ça fonctionne, tu pourras supprimer le fichier ~/.ICEauthority.bak

Dernière modification par Desintegr (Le 20/10/2005, à 14:32)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#7 Le 20/10/2005, à 14:39

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

voilà, je viens d'essayer en renommant le fichier en bak, mais cela n'a toujours rien changé... sad

Hors ligne

#8 Le 20/10/2005, à 15:53

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

Bon, c'est problématique, tout ça.

gdm= le gestionnaire de display de gnome (gnome display manager), c'est l'écran de connexion qui lance gnome en gros

Je n'arrive pas à voir où se situe l'erreur.... Te rappelles-tu de tes dernières manip avant l'apparition du problème.

Un problème de droits, il me semble, à cause de cette ligne-ci:
_IceTransmkdir: ERROR: euid !=0, directory /dev/X will not be created
_IceTransmkdir: ERROR: cannot create /dev/X
_IceTransPTSOpenServer: mkdir (/dev/X) failed, errno=13

ce qui me laisse perplexe. Le test du nouvel user ayant foiré, ça ne vient pas de ta config...

Comprends pas trop, quelqu'un a une idée?


Laurent, petit belge explorant la banquise

Hors ligne

#9 Le 20/10/2005, à 16:16

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Ben, mais dernières manip, ça a été de faire ma migration via synaptic, une fois qu'il a eu terminé, il restait encore une librairie qu'il n'avait pas updaté, je l'ai donc updaté, il l'a désinstallée puis réinstallée, ensuite j'ai fermé synaptic, puis j'ai redémarré le PC (en bon ancien utilisateur de windows, je me suis dit qu'il fallait sans doute le faire, peut-être à tort...), et c'est là que mes problèmes ont commencé... sad

Lors de la migration, il m'a demandé pour remplacé 2 fichiers, j'ai dit oui, ne sachant que répondre, j'ai dit oui, mais j'ai néanmoins conservé une copie de ces fichiers avant qu'il les remplace, il y avait notamment le fichier profiles.xlm, et l'autre je ne me souviens plus de son nom pour l'instant. Cela peut peut-être aidé... hmm

Hors ligne

#10 Le 20/10/2005, à 16:21

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

non, ne t'inquiète pas, y'a pas de mal à première vue.

Bon, si tu n'as pas peur de faire péter ta bande passante:

1. sudo gedit /etc/apt/sources.list
2. tu mets ça dedans:

deb http://archive.ubuntu.com/ubuntu breezy main restricted
deb-src http://archive.ubuntu.com/ubuntu breezy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu breezy-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu breezy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team

deb http://archive.ubuntu.com/ubuntu breezy universe multiverse
deb-src http://archive.ubuntu.com/ubuntu breezy universe multiverse

## Security Updates
deb http://security.ubuntu.com/ubuntu breezy-security main restricted
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted

deb http://security.ubuntu.com/ubuntu breezy-security universe multiverse
deb-src http://security.ubuntu.com/ubuntu breezy-security universe multiverse

## Skype
deb http://download.skype.com/linux/repos/debian/ stable non-free

## Hoary Extras (because Breezy Extras are not curently available)
#deb http://ubuntu-backports.mirrormax.net/ hoary-extras main universe multiverse restricted

## Officials Backports
## deb http://archive.ubuntu.com/ubuntu breezy-backports main universe multiverse restricted

## Backports
## deb http://ubuntu-backports.mirrormax.net/ breezy-backports main universe multiverse restricted
## deb http://ubuntu-backports.mirrormax.net/ breezy-backports-staging main universe multiverse restricted
## deb http://ubuntu-backports.mirrormax.net/ breezy-extras-staging main universe multiverse restricted

## dépots plf
deb http://antesis.freecontrib.org/mirrors/ubuntu/plf/ breezy free non-free
deb-src http://antesis.freecontrib.org/mirrors/ubuntu/plf/ breezy free non-free

3. sudo apt-get update
4. sudo apt-get install --reinstall ubuntu-desktop

C'est un peu radical, mais je vois pas vraiment d'où vient le prob...


Laurent, petit belge explorant la banquise

Hors ligne

#11 Le 20/10/2005, à 16:29

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

ok, merci pour le sources.list, je vais essayer ça de suite, mais juste deux petites questions:
1/ dois-je remplacer mon fichier sources.list par celui que tu viens de me donner, ou juste ajouter les dépôts au fichier existant?
2/Si c'est un problème de création de directory, ne puis-je pas la créer moi-même, et ensuite utiliser la commande sudo dpkg-reconfigure gdm? (je sais c'est une idée sans doute naive, mais j'y connais pas grand-choses...)

PS: si je réinstalles avec ton sources.list, va-t-il détruire mes documents ? yikes

Dernière modification par yanshee (Le 20/10/2005, à 16:35)

Hors ligne

#12 Le 20/10/2005, à 16:46

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

Salut,

oui, tu peux toujours essayer mais je n'y crois pas du tout, étant donné que tout ce qui a dans /dev est recréé à chaque démarrage, tu aurais toujours le meme problème. Essaye quand meme:

sudo mkdir /dev/X

et lance ta session gnome (gdm est hors de cause, maintenant, je pense)

Pour le sources.list, remplace le contenu. Tes documents resteront intacts, seuls les programmes seront upgradés. a ce sujet, lors de l'upgrade, tu as bien fait:

sudo apt-get update
sudo apt-get dist-upgrade

?


Laurent, petit belge explorant la banquise

Hors ligne

#13 Le 20/10/2005, à 17:10

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Bon,

concernant ta dernière question sur le apt-get, oui ça a dû être fait, je suis passé par synaptic (d'après mes souvenirs...).

Sinon, je donc remplacé mon sources.list par le tien, j'ai fait 3. sudo apt-get update
4. sudo apt-get install --reinstall ubuntu-desktop

et là, j'ai eu une erreur qui dit:

dépendances non satisfaites: ubuntu-desktop: dépend: x-window-system-core mais ne sera pas installé
E:paquets défectueux

lorsque j'ai fait le apt-get update, il est allé me chercher quelques trucs, mais pas grand-choses, l'erreur c'est produite apràs avoir lancer le apt-get install. Cela semble donc être un problème avec le serveur X (enfin d'après ce que j'en déduis...)

PS: j'ai gravé le CD de breezy aussi, je ne sais pas s'il peut être d'une utilité quelconque dans ce cas-ci... hmm

Hors ligne

#14 Le 20/10/2005, à 17:12

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

t'as connection au net fonctionne correctement? Tu n'as pas un proxy?

que donne précisément le

sudo apt-get update
?


Laurent, petit belge explorant la banquise

Hors ligne

#15 Le 20/10/2005, à 17:55

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

pour ma connexion web, oui elle a l'air de fonctionner correctement (vu que c'est par elle que j'utilises pour aller sur ce forum), et non je ne suis pas derrière un proxy, mon PC est connecté directement au modem.

Pour le apt-get, je l'ai relancé, et il m'a donné une erreur:

W: GPG error: http://archive.ubuntu.com breezy-updates Release: Les signatures suivantes étaient invalides: BADSIG 40976EAF437DO5B5 Ubuntu Archive Automatic Signing Key

W: Vous pouvez lancer "apt-get update" pour corriger ces problèmes.

J'ai donc relancé apt-get comme suggéré, et là il ne m'a plus affiché d'erreur, j'ai donc ré-essayer install --reinstall, mais là le problème est toujours présent. hmm

(encore merci pour ton aide...)

Hors ligne

#16 Le 20/10/2005, à 18:08

laurent

Re : Breezy: sérieux problèmes au démarrage de Gnome

sudo apt-get install x-window-system-core

?


Laurent, petit belge explorant la banquise

Hors ligne

#17 Le 20/10/2005, à 18:28

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Je viens d'essayer, il m'a fait 2-3 erreurs lors de l'install, je l'ai refait une seconde fois, et là il m'a dit que la version la plus récente était déjà installée. J'ai redémarré, mais toujours rien... hmm
Je commences à décourager... sad

Hors ligne

#18 Le 20/10/2005, à 22:22

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

J'ai trouvé le problème !!! mais j'arrive pas à le solutionner... hmm

Voilà, en fait j'ai fait une installation fraîche de breezy(reformatage et tout, après avoir déplacer mes documents par l'intermédiaire d'une misérable clé usb de 256Mo...). Tout se lance à merveille, et je me dis, première chose à faire, refaire fonctionner mes deux écrans. Alors je reprends mon ancien fichier xorg.conf que j'avais sauvé, je regardes comment j'ai fait la première fois, je recopie les lignes adéquates, je redémarre gnome, et la fenêtre de login apparaît sur mon deuxième écran. Super,je me dis, jusqu'à ce que je me logges... Le problème ressurgit, il m'éjectes et me renvoit à l'écran de login. Le problème doit donc venir de là, mais je ne vois pas trop pourquoi cela ne fonctionne plus si cela à fonctionné sous hoary... (désolé de ne pas avoir pensé à mentionner que j'utilisais deux écrans et deux cartes graphiques... roll ). Je suis revenu au xorg.conf initial, et là plus de problèmes, mais je n'ai qu'un écran...

voici le xorg modifié (partie concernant les écrans uniquement):

#CARTES---------------->

Section "Device"
    Identifier    "s3virge"
    Driver        "s3virge"
    BusID        "PCI:0:10:0"
        # Uncomment following option if you see a big white block
        # instead of the cursor!
        #    Option      "sw_cursor"
        Option      "DPMS"
EndSection

Section "Device"
        Identifier  "FX5600"
        VendorName  "Creative"
        BoardName   "Unknown"
        BusID       "1:0:0"
        Driver      "nvidia"
        # Uncomment following option if you see a big white block
        # instead of the cursor!
        #    Option      "sw_cursor"
        Option      "DPMS"
EndSection

#ECRANS----------------->

Section "Monitor"
    Identifier    "HIT14"
        VendorName     "HIT"
        ModelName      "14pouces"
    Option        "DPMS"
    HorizSync    28-49
    VertRefresh    43-72
EndSection

Section "Monitor"
        Identifier     "Philips19"
        VendorName     "Philips"
        ModelName      "Philips 109E5"
    Option           "DPMS"
        HorizSync    30-92
        VertRefresh     50-160
EndSection

#SCREEN------------------>

Section "Screen"
        Identifier "Principal"
        Device      "FX5600"
        Monitor     "Philips19"
        DefaultDepth 24
        Subsection "Display"
            Depth       8
            Modes       "1280x1024" "1024x768" "800x600" "640x400"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes       "1280x1024" "1024x768" "800x600" "640x400"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       24
            Modes       "1280x1024" "1024x768" "800x600" "640x400"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       32
            Modes       "1280x1024" "1024x768" "800x600" "640x400"
            ViewPort    0 0
        EndSubsection
EndSection

Section "Screen"
    Identifier    "Second"
    Device        "s3virge"
    Monitor        "HIT14"
    DefaultDepth    16
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "ServerLayout"
        Screen     "Principal"
        Screen     "Second" LeftOf "Principal"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice "cursor" "!SendCoreEvents"
        InputDevice "stylus" "!SendCoreEvents"
    InputDevice "eraser" "!SendCoreEvents"#"AlwaysCore"
EndSection

Section "DRI"
    Mode    0666
EndSection

Voilà, j'espère que quelqu'un saura m'aider... (problème de drivers nvidia ??)

Hors ligne

#19 Le 21/10/2005, à 06:58

Desintegr

Re : Breezy: sérieux problèmes au démarrage de Gnome

Commence par vérifier si les busID sont corrects avec « lspci | grep VGA ».
Ensuite teste avec le driver « nv » à la place de « nvidia ».
Essaye aussi de nous fournir le contenu de /var/log/Xorg.0.log juste après un plantage.

Sinon ta configuration semble bonne.

Fais un test tout simple, coupe gdm et lance X tout seul (avec la commande X), normalement tu devrais avoir un affichage sur tes deux écrans, et la souris devrait passer d'un écran à un autre.


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#20 Le 21/10/2005, à 22:30

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Hello !
désolé de pas avoir donné de nouvelles plus tôt... roll
bref, alors, je n'ai pas encore essayer de remplacer le driver nvidia du xorg.conf par le nv. Par contre, j'ai testé la commande  lspci | grep VGA, et il m'a retourné deux chaines (une par carte): 0000:00:0a:0 pour la S3virge, et 0000:01:00.0 pour la geforce. Ca ne ressemble pas au format utilisé dans le busID de xorg (BusID       "1:0:0"), est-ce que ce sont bien les bus ? sinon, j'ai coupé gdm, et fais startx dans la console, et comme tu le dis, j'ai l'affichage sur les deux écrans, et la souris qui passe de l'un à l'autre, tout est comme si de rien n'était.

Je ne sais pas poster pour l'instant le fichier Xorg.0.log, parce que je suis dans la session sous X, et que je l'avais sauvé sur mon bureau dans la session terminal, mais là, il n'apparaît pas sur mon bureau... hmm Je tâcherai de le poster dès que possible, et je vais tester avec le driver nv...

PS: j'ai lu quelque part dans mes nombreuses recherches, que le driver nv "diminuait" les possibilités de la carte 3D, est-ce vrai ?

Re-PS: j'ai retrouvé le fichier log de xorg, (j'etais loggé sur le desktop de root...:rolleyes:), mais il est assez énorme, je postes quand même le contenu, ou seulement certaines parties ?

Dernière modification par yanshee (Le 21/10/2005, à 22:37)

Hors ligne

#21 Le 21/10/2005, à 22:45

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Ok, je viens de tester avec le driver nv, et cela fonctionne sans problèmes (apparents...). Alors, j'utilises ce driver, ou c'est juste un bon signe, et il faut continuer pour installer le nvidia ? neutral

Hors ligne

#22 Le 21/10/2005, à 23:01

Desintegr

Re : Breezy: sérieux problèmes au démarrage de Gnome

Si tu n'utilises pas les fonctions 3D (OpenGL) de ta carte graphique, tu peux tout à fait garder le driver « nv ».


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#23 Le 21/10/2005, à 23:06

yanshee

Re : Breezy: sérieux problèmes au démarrage de Gnome

Euh, ben non je les utilise, donc je dois faire tourner le driver nvidia...:/

Hors ligne

#24 Le 21/10/2005, à 23:17

Desintegr

Re : Breezy: sérieux problèmes au démarrage de Gnome

Pour installer les drivers Nvidia, il faut (ré)installer les paquets « nvidia-glx » et « nvidia-kernel-common ».

Puis lancer la commande : « sudo nvidia-glx-config enable ».

Mais le problème vient peut-être de là.


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

Haut de page ↑