Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 29/09/2012, à 22:54

Ne-ux

[Résolu] Problème installation ubuntu G75VW

Bonjour,

J'ai récemment acheté un pc portable asus G75V, core i7-3610QM, Nvidia GeForce GTX 670M, 6Gb de RAM, avec Windows 7 fourni.
Je voulais donc installer linux en dual boot. Comme c'est la première fois que j'installe linux, je me suis aidé de tutos.
J'ai donc lancé l'installation par usb. Ainsi après avoir choisit de démarrer sur la clé dans le BIOS, un écran violet avec deux symboles blancs en bas apparait ( jusque la c'est normal si j'ai bien compris) et après il y a un écran noir avec des lignes de commandes blanches qui défillent; jusqu'à ce que les lignes s'arrêtent de défiler et que l'écran ne change pas. Au bout de cinq minutes j'essaye alors de voir si l'ordi répond mais aucune action sur le clavier n'a le moindre effet .
J'ai essayé avec la version ubuntu-12.04.1-desktop-amd64 et ubuntu-secure-remix-12.04.1-64bits et à chaque fois le processus d'installation s'arrête après avoir cherché les hub usb et afficher l'action " switching to clocksover".

J'ai aussi essayé d'installer debian qui est installable par le réseau du campus mais là après le menu d'installation, il affirme ne pas connaitre le driver pour ma carte réseau.

Je voulais du coup savoir si cela signifiait que mon système ne permet simplement pas d'installer une version de linux (ce qui est gênant), ou bien quels sont les réglages à effectuer pour réussir l'installation.

Merci d'avance.

Dernière modification par Ne-ux (Le 17/10/2012, à 18:43)

Hors ligne

#2 Le 01/10/2012, à 11:26

malbo

Re : [Résolu] Problème installation ubuntu G75VW

Déjà, tu peux utiliser l'option nomodeset comme expliqué dans ce post : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p8087381
La doc propose la même chose (mais en moins détaillé que mon post) : http://doc.ubuntu-fr.org/kernel#modifie … ssion-live

Si cette option nomodeset ne suffit pas, essaie l'option acpi=off qui est présentée dans la doc ci-dessus. C'est une option détestable parce qu'elle désactive l'acpi ce qui est une action lourde mais dans certains cas, avec les PC récents, c'est la seule façon d'arriver à démarrer sur Ubuntu.

Dernière modification par malbo (Le 01/10/2012, à 11:31)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#3 Le 01/10/2012, à 18:41

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Salut
Merci de ta réponse.
D'accord, je vais essayer.
Je te tiens au courant du résultat.

Merci encore.
A bientôt

Dernière modification par Ne-ux (Le 01/10/2012, à 18:45)

Hors ligne

#4 Le 01/10/2012, à 21:18

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Re-bonjour.
Comme tu me l'avais conseillé j'ai coché nomodeset et j'arrive à lancer le live-usb.
Par contre juste à la fin du chargement, à coté de la barre s'affiche :"[nombres] asus can't find DTS"
Mais sinon le live-usb semble fonctionner correctement, le son marche, internet ...
Par contre la résolution d'écran est pas adaptée et je peux pas la changer mais ça doit être dû au fait que c'est qu'une version usb.
Mais bon cette étape est passée.
Merci de ton aide, je te dirais si tout c'est bien passé pour l'installation.
Encore merci et à bientôt.

Hors ligne

#5 Le 05/10/2012, à 22:34

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Salut
J'aurais besoin d'un conseil s'il vous plait.

          Une fois sur le live-usb d'ubuntu , je lance l'installation et en suivant les tutos disponibles pour réaliser un dual-boot, je choisis "autre" pour le partitionnement du disque, j'arrive à la fenêtre, décrivant les disques durs, qui me demande de choisir "le périphérique ou sera installé le programme de démarrage". J'ai donc chercher à identifié les différentes partitions proposées.
Je peux installer ce programme sur:

/dev/sda1 en fat 32 qui correspond à la partition du système EFI
/dev/sda3 en ntfs qui correspond au disque OS de Windows 7
/dev/sda4 en ntfs qui doit correspondre au disque DATA pour Windows
/dev/sda5 Windows Recovery Envirronment
/dev/sdb qui doit être donc ma clé usb

/dev/sda2 est une partition où je ne sais pas ce qu'il y a dessus et qui n'est pas proposée pour le programme de démarrage.

              J'ai donc cherché à comprendre dans la documentation à quoi correspondait l'EFI. Et je me suis demandé si je ne devais pas lancer la clé USB en mode UEFI.
J'obtiens alors cet écran : http://doc.ubuntu-fr.org/lib/exe/fetch. … 132006.png.
Je choisi de lancer le live-usb et là j'ai un écran noir avec seulement une bande de l'écran violet d'ubuntu tout en bas de l'écran et puis des traits multicolores sur l'écran noir. Visiblement l'ordinateur est réactif à mes commandes car quand j'utilise les flèches du clavier, les traits changent de couleur, puis après l'ordi s'éteint au bout de quelques minutes.

Voila donc ma question était de savoir si je dois installer linux de façon classique, et du coup quel périphérique je dois choisir pour le programme de démarrage ? Ou alors si je dois lancer la version UEFI et du coup comment faire pour qu'il m'affiche quelque chose ?

Merci d'avance à bientôt .

Dernière modification par Ne-ux (Le 06/10/2012, à 09:55)

Hors ligne

#6 Le 08/10/2012, à 07:32

malbo

Re : [Résolu] Problème installation ubuntu G75VW

Ne-ux a écrit :

Comme tu me l'avais conseillé j'ai coché nomodeset et j'arrive à lancer le live-usb

Depuis la session live, je te prie de répondre à cette demande (Boot-Info) : http://doc.ubuntu-fr.org/tutoriel/boot-info


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#7 Le 08/10/2012, à 20:46

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Hors ligne

#8 Le 08/10/2012, à 21:01

malbo

Re : [Résolu] Problème installation ubuntu G75VW

Ne-ux a écrit :

Et je me suis demandé si je ne devais pas lancer la clé USB en mode UEFI.
J'obtiens alors cet écran : http://doc.ubuntu-fr.org/lib/exe/fetch. … 132006.png.

Quand tu obtiens cet écran, tu sélectionnes la première ligne du menu Grub (try Ubuntu without installing), mais ensuite au lieu d'appuyer sur la touche Entrée, tu appuies sur la touche e, tu ajoutes nomodeset juste après quiet spash comme indiqué là : http://images.maketecheasier.com/2009/1 … b-entr.png
puis tu valides par Ctrl + x ou F10
Et c'est depuis une session démarré comme ça (en EFI) que tu installes Ubuntu. Quant au périphérique pour installer le programme de démarrage, laisse ce qui est par défaut. On s'en fout parce ce que l'installateur n'utilise pas ce qui est sélectionné dans ce champ.

Dernière modification par malbo (Le 08/10/2012, à 21:02)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#9 Le 08/10/2012, à 22:03

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Merci de ta réponse
Juste pour le programme de démarrage, il me semble que par défaut c'est la clé /sdb donc je le met juste sur le sda/

Hors ligne

#10 Le 09/10/2012, à 07:40

malbo

Re : [Résolu] Problème installation ubuntu G75VW

Ne-ux a écrit :

Juste pour le programme de démarrage, il me semble que par défaut c'est la clé /sdb donc je le met juste sur le sda/

Je ne sais pas si c'est utile mais tu as raison de prendre cette précaution.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#11 Le 09/10/2012, à 19:19

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Salut,

Avant de partitionner, je voulais vérifier que je vais bien faire les bonnes manips.
Je réduit /sda4 pour faire de la place pour linux.
Sur le nouvel espace libre, je crée 4 partitions primaires. Une pour la racine, une pour le swap, une pour home et une EFI.

Je voulais aussi savoir si je dois en faire une autre pour un espace d'échanger de documents avec windows ou s'il vaut mieux que j'utilise le la sda4 qui sera encore le Datade windows en ntfs ?

Merci d'avance.

Dernière modification par Ne-ux (Le 09/10/2012, à 19:57)

Hors ligne

#12 Le 09/10/2012, à 20:15

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

c'est la partition Windows (sda3) qu'il faudrait réduire (via les outils Windows) de 300Go à 70Go. Cela permettra de placer les fichiers de boot d'Ubuntu (/boot contenu dans /) en début de disque.
Et pas besoin de créer une 2e partition EFI, Ubuntu utilisera la partition EFi existante (sda1).

Vous avez actuellement:

1      1049kB  211MB  210MB   fat32        EFI system partition          boot
2      211MB   345MB  134MB                Microsoft reserved partition  msftres
3      345MB   300GB  300GB   ntfs         Basic data partition
4      300GB   723GB  423GB   ntfs         Basic data partition
5      723GB   750GB  26.8GB  ntfs         Basic data partition          hidden, diag

je vous recommande de faire ceci:

1      1049kB  211MB  210MB   fat32        EFI system partition          boot
2      211MB   345MB  134MB                Microsoft reserved partition  msftres
3      345MB   70GB  70GB   ntfs         Basic data partition
4   Partition / d'Ubuntu, en EXT4,  20Go
5    Partition SWAP , de la taille de votre SWAP (quelques Go)
6    votre partition /home, en EXT4 (environ 200Go)
7      300GB   723GB  423GB   ntfs         Basic data partition
8      723GB   750GB  26.8GB  ntfs         Basic data partition          hidden, diag

Dernière modification par YannUbuntu (Le 09/10/2012, à 20:16)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#13 Le 09/10/2012, à 20:22

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

D'accord

Je fais comme cela.

Merci beaucoup.

Hors ligne

#14 Le 10/10/2012, à 19:21

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Bonjour,
Désolé encore une fois,
mais la partition data de Windows sera elle accessible pour Ubuntu ?
Parce que je ne peut pas réduire sda3 à moins de 175 Go avec les outils windows.

Je pensais donc passer la partition /home de Ubuntu à 90 Go ( ce qui peut être faible), simplement je voulais savoir si je pourrais utiliser Data pour stocker des données ou installer des logiciels même si elle est en ntfs .

Merci.

Hors ligne

#15 Le 10/10/2012, à 19:54

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

Toutes les partitions Windows (NTFS) sont accessibles en lecture& ecriture par Ubuntu.

Ne surtout pas mettre /home ni root (/) en NTFS.

Le but final de la manoeuvre c'est de faire en sorte que la partition root (/) soit ENTIEREMENT contenue dans les 100 premiers Go du disque. Donc pas le choix, il faut reduire sda3.
Windows refuse de reduire à moins de 175Go car vous ne l'avez pas vidée.

Il faut :
1) faire de la place dans la partition sda3 (actuellement il y a 150Go de donnees dedans, il faut qu'il y en ait 70Go ou moins si possible)
2) si possible defragmenter Windows
3) Reduire sda3 à 70Go


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#16 Le 10/10/2012, à 20:13

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

D'accord merci,
Désolé, j'ai oublier de préciser que j'avais vidé le maximum de données possibles :
C: espace utilisé ~ 65.3 Go
    espace libre ~ 214 Go

J'ai défragmenté le disque.
Maintenant je vais dans  Gestion des disques -> Réduire le volume :
Taille totale en Mo avant réduction : 286161
Espace de Réduction disponible (en Mo): 115490
Quantité d'espace à réduire en Mo: x
Taille totale après réduction ( en Mo): 286161-x

Hors ligne

#17 Le 10/10/2012, à 20:58

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

tant pis alors, on croise les doigts pour que ça fonctionne quand même. Ca devrait donner ce partitionnement:

1      1049kB  211MB  210MB   fat32        EFI system partition          boot
2      211MB   345MB  134MB                Microsoft reserved partition  msftres
3      345MB   175GB  175GB   ntfs         Basic data partition
4   Partition / d'Ubuntu, en EXT4,  20Go
5    Partition SWAP , de la taille de votre SWAP (quelques Go)
6    votre partition /home, en EXT4 (environ 95Go)
7      300GB   723GB  423GB   ntfs         Basic data partition
8      723GB   750GB  26.8GB  ntfs         Basic data partition          hidden, diag

Dernière modification par YannUbuntu (Le 10/10/2012, à 20:59)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#18 Le 10/10/2012, à 21:05

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Ok je teste,
je vous donnerais les résultats.
Dans le pire des cas je peux augmenter le volume de C: à son état d'origine ?

Hors ligne

#19 Le 10/10/2012, à 23:35

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Bon alors la mauvaise puis la mauvaise nouvelle.

Donc j'installe ubuntu tout comme les tutos.

L'ordi redémarre, je retire la clé. J'arrive sur le Grub je choisi Ubuntu, et là l'écran violet charge le logo Ubunto et quand le barre de chargement apparait, l'écran devient noir en parti (et j'ai les mêmes bug graphiques que quand je tapais pas "nomodeset" après "quiet spash" pour le boot-USB.) cecei accompagné d'une bruit court comme celui que l'on a quand on arrive sur le bureau Unity pour charger la session.

J'essaye de démarrer windows 7 loader : j'obtiens un message : "erreur: invalid EFI file path"
Je lance recovery windows: pareil : "erreur: unkown command 'drivemap' "
                                                         "erreur: invalid EFI file path"


Je lance la version de récupération de Ubuntu:

Menu de récupération (état du système de fichier lecture seule)

resume                       reprendre démarrage normal
clean                          essayer de libérer de l'espace
dpbg                           réparer les paquets cassés
failsurfex                     démarrer en mode graphique sans échec
grub                            mettre à jour le chargeur d'amorçage GRUB
network                       activer la prise en charge par le réseau
root                             passer sur une console administrateur
system-summary         rapport d'état du système

                                        <OK>

J'ai d'abord testé "failsurfex", un message me dit que ma carte graphique et mon écran fonctionnent mal, puis il m'est proposer de configurer le système ou de démarrer en graphique sans échec et d'autres option. Je choisi graphique sans échec: une barre de chargement apparait mais déja remplie, je peux juste appuyer sur valider et je retourne sous le menu de recupération.

Je prends "resume", le message suivant apparait :

           Vous allez maintenant quitter le mode de récupération et continuer une séquence de démarrage. Veuillez noter que certains pilotes graphiques nécessitent un démarrage totalement graphique et ne peuvent donc pas redémarrer  depuis le mode de réstauration
            Dans ce cas, redémarrer simplement depuis l'écran de connexion et effectuez un démarrage normal.
                                                                                                                           <OK>

Puis lignes de codes qui défillent et j'arrive sur Unity pour ouvrir ma session.

Voila, je relancerais "failsurfex" plus tard pour mieux décrire les fenêtres visibles. Avez vous une idée de la raison du problème pour le chargement d'Ubuntu?
Mais il faudrait surtout que je trouve un moyen de ressusciter Windows, sinon :s

Merci d'avance et puis merci pour votre aide jusqu'à présent.

Dernière modification par Ne-ux (Le 11/10/2012, à 00:29)

Hors ligne

#20 Le 11/10/2012, à 00:33

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

comme vous aviez besoin de nomodeset en session-live, vous en aurez besoin aussi en session installée. Pour l'ajouter:

Boot-Repair --> Options avancées --> onglet Options de GRUB --> cocher "Ajouter une options de kernel: nomodeset" --> Appliquer
Nous indiquer la nouvelle URL svp.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 11/10/2012, à 08:18

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Voilà:
http://paste.ubuntu.com/1272643/

Pour le réglage du BIOS, comme indiquer à la fin du message. Je dois quand même redémarrer l'ordi ?

Dernière modification par Ne-ux (Le 11/10/2012, à 08:21)

Hors ligne

#22 Le 11/10/2012, à 11:43

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

oui


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#23 Le 11/10/2012, à 13:29

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Bon alors j'ai redémarrer l'ordinateur, je suis allé dans BIOS option de boot,
j'ai pas trouver le fichier comme il est nommé dans le rapport mais l'option 1 était ubuntu.

Sous gnub, je sélectionne ubuntu, ça marche.
Si je sélectionne Windows ça marche, je peux jouer et tout, donc cool.

Par contre, je voulais savoir en quoi consiste l'option nomodeset, parce que j'ai lu sur la doc mais j'ai pas bien compris.  Comment ça marche ? Puis-je jouer sous ubuntu ou la carte graphique ne fonctionne pas ?
Ah et autre question comment passé le format de l'écran de 1024x768 (4:3), sous linux, en 1920x1080 (16:9) comme j'ai sous Windows car ça ne m'est pas proposé dans Paramètres système -> Affichage .

Voilà , merci de votre aide

Dernière modification par Ne-ux (Le 11/10/2012, à 13:48)

Hors ligne

#24 Le 11/10/2012, à 13:58

YannUbuntu

Re : [Résolu] Problème installation ubuntu G75VW

L'option nomodeset désactive des fonctionnalités du noyau Linux, donc ça risque de ne pas exploiter complètement ta carte graphique.

Maintenant l'important c'est de remonter un maximum d'infos aux développeurs Linux, afin qu'ils améliorent le support de ton PC.

Pour cela:
1) creer ton compte Launchpad: http://doc.ubuntu-fr.org/launchpad#creer_votre_compte
2) te connecter à ton compte sur https://launchpad.net/
3) depuis ton Ubuntu installée, ouvrir un terminal (Ctrl+Alt+T) et saisir la commande suivante:

ubuntu-bug kernel

Appuyer sur entrée;
Cela va collecter des infos sur ton système, puis ouvrir un page internet, attendre son chargement complet.
4) Dans le champ "Summary", saisir: "Nomodeset required on asus G75V", cliquer sur "Continue"
5) Dans le champ "Further information", saisir "Nomodeset option is required to boot Ubuntu 12.04.1 on asus G75V laptop (core i7-3610QM, Nvidia GeForce GTX 670M, 6GB RAM, with preinstalled Windows 7)", puis cliquer sur "Submit bug report" en bas de la page.
6) Noter l'URL du rapport de bug créé, et nous l'indiquer svp.

Dernière modification par YannUbuntu (Le 11/10/2012, à 13:58)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#25 Le 11/10/2012, à 14:17

Ne-ux

Re : [Résolu] Problème installation ubuntu G75VW

Ok,

Bon j'ai lancé la commande, la collecte des informations se lance, puis s'arrête et une fenêtre s'ouvre en m'annonçant que le paquet kernel n'existe pas .
Faut t'il que je l'installe du coup ? Et si oui comment  ?

Juste pour savoir, je risque pas d'abîmer mon matériel, en utilisant ubuntu là? Faut-il que j'essaye de ne pas trop le solliciter, donc éviter vidéo et jeu ? Ou bien c'est juste que j'exploite pas au max des capacités ? Mais ubuntu est-il fonctionnel ?

Merci d'avance

Dernière modification par Ne-ux (Le 11/10/2012, à 22:54)

Hors ligne

Haut de page ↑