Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 13/10/2012, à 16:07

ouftimondju

[ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour,

j'ai intégré - manière de logotype - une image créée avec le Gimp dans la page d'accueil de mon site ( CMS WordPress ). La couleur de fond de celle-ci est identique, et pour cause, à celle du support : #1F1F1F.

Dans le cours de mon processus de validation OS et navigateurs, je me suis aperçu que Firefox ( 16.0.1 ) rendait une hexa #242424 dont je me demande bien d'où elle sort.

Capture d'écran, avec Iron au-dessus et Firefox en-dessous :

1350139092.png

Curieusement, il semble que cette lubie ne se produise que chez moi. J'ai vérifié avec IceCat : même problème. Ce qui est ennuyeux, bien évidemment, puisque je ne peux plus me fier à Ffx pour vérifier mon site sous Ffx...

Quelqu'un aurait une idée ?

Le site est ici : http://www.patrickgermain.eu et, par la même occasion, toute remarque afférant à d'autres domaines de validation serait bienvenue ( par message privé, pour ne pas sortir du sujet ici ).

Merci d'avance !

Dernière modification par ouftimondju (Le 19/10/2012, à 19:33)


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#2 Le 13/10/2012, à 17:03

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour

ouftimondju a écrit :

Dans le cours de mon processus de validation OS et navigateurs, je me suis aperçu que Firefox ( 16.0.1 ) rendait une hexa #242424 dont je me demande bien d'où elle sort.

Je l'ai pas trouvé ! hmm


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#3 Le 13/10/2012, à 17:30

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Merci.
... ben oui... et jusque-là personne d'autre que moi ne la trouve. Ce qui m'arrange bien, côté site, puisque tout semble donc correct.
Mais côté navigateur, il y a quand-même un solide gremlin chez moi et ça m'arrangerait de savoir dans quel coin il se niche smile


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#4 Le 13/10/2012, à 23:38

Vu

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour,
Je reproduis.
J'ai le cadre (l'image du bas) sur FF16.0.1 Ubuntu 12.04.1 x86_64, le mode sans échec ne change rien à l'affaire. Le problème persiste avec FF 19.0a1.
Es-ce la même chose avec FF sous Windows ??

Le cadre n'apparaît pas dans Epiphany 3.4.1, Opera 12.02, Chromium 20.0.1132.47

Dernière modification par Vu (Le 13/10/2012, à 23:56)


Ubuntu 12.04

Hors ligne

#5 Le 14/10/2012, à 11:45

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour

ouftimondju a écrit :

Ce qui est ennuyeux, bien évidemment, puisque je ne peux plus me fier à Ffx pour vérifier mon site sous Ffx...

D'abord une chose, Firefox n'invente rien. Ce que l'on voit se trouve dans la conception de ton site. Au contraire ce qui est inquiétant, c'est de pas voir les défauts ! (ou les détails, quand t-il le faudrait).

Donc il faut que tu vois cela du côté développement web...avec l'aide d'un site dédié. (Perso, je suis pas un expert en développement web tongue mais quelques-un pas ici : http://www.geckozone.org/forum/viewforum.php?f=8 )

Et sur la quasi-totalité de mes Firefox (3.6* encore présent..., 15*, 16*, 17*, 18* et 19*) et autres navigateurs (IE8, IE9, Epiphany, Chromium, Midori et SeaMonkey , je ne vois pas ce cadre.
Vérifications effectuées sous Ubuntu 10.04, XP, Vista, Linux Mint.
Seulement sous Fedora 14, avec Fx 15* et 16*, j'ai vu ce cadre !.. roll

Dernière modification par Bob49 (Le 14/10/2012, à 11:58)


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#6 Le 14/10/2012, à 11:56

lool_lauris

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Salut,

Dans Firefox, ouvre un onglet, dans la barre d'adresse tape : about:config > Promets > dans le champ filtre copie et colle ceci :

gfx.color_management.enablev4

Passe la valeur à true

Vérifie ici si les couleurs sont correctes => http://www.color.org/version4html.xalter


Ne rien lâcher, les utopies d'aujourd'hui seront la réalité de demain !
------------------------------------------------------------------------------------------------
Soutenez le Libre => http://www.april.org/

Hors ligne

#7 Le 14/10/2012, à 12:07

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

lool_lauris a écrit :
gfx.color_management.enablev4

Passe la valeur à true

Perso, j'ai Firefox 16* qui à la préférence en true (depuis longtemps) et pour les versions en développement, elle est en false. Mais le résultat est le même au niveau de l'affichage de la page.

Dernière modification par Bob49 (Le 14/10/2012, à 12:08)


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#8 Le 14/10/2012, à 13:02

lool_lauris

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Salut Bob,

Bob49 a écrit :
lool_lauris a écrit :
gfx.color_management.enablev4

Passe la valeur à true

Perso, j'ai Firefox 16* qui à la préférence en true (depuis longtemps) et pour les versions en développement, elle est en false. Mais le résultat est le même au niveau de l'affichage de la page.

En fait, toi tu n'as pas le problème !
Ce qui serait surtout intéressant ce serait le retour de ouftimondju ... smile


Ne rien lâcher, les utopies d'aujourd'hui seront la réalité de demain !
------------------------------------------------------------------------------------------------
Soutenez le Libre => http://www.april.org/

Hors ligne

#9 Le 14/10/2012, à 13:06

maman

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

salut,
il y avait un souci avec libcairo2, il fût un temps. Les png avaient un rendu tout pourri. Donc, essaie de passer ton image "logod-gimpmetalf" en .jpg pour voir si c'est mieux.

@+

Dernière modification par maman (Le 14/10/2012, à 13:06)


90% of teens today would die if Facebook was completely destroyed. If you are one of the 10% that would be laughing, copy and paste this to your signature.

Hors ligne

#10 Le 14/10/2012, à 13:49

Vu

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

lool_lauris a écrit :

Salut,

Dans Firefox, ouvre un onglet, dans la barre d'adresse tape : about:config > Promets > dans le champ filtre copie et colle ceci :

gfx.color_management.enablev4

Passe la valeur à true

Vérifie ici si les couleurs sont correctes => http://www.color.org/version4html.xalter

Je viens de faire l'opération sur Firefox 16.0.1 et après un redémarrage, j'ai tester le site qui me confirme que cela fonctionne.
Pour tant le cadre est toujours là, même après un CTRL +F5


Ubuntu 12.04

Hors ligne

#11 Le 19/10/2012, à 19:08

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Désolé de n'avoir pas répondu : je m'y attelle de ce pas !


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#12 Le 19/10/2012, à 19:16

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Vu a écrit :
lool_lauris a écrit :

Salut,

Dans Firefox, ouvre un onglet, dans la barre d'adresse tape : about:config > Promets > dans le champ filtre copie et colle ceci :

gfx.color_management.enablev4

Passe la valeur à true

Vérifie ici si les couleurs sont correctes => http://www.color.org/version4html.xalter

Je viens de faire l'opération sur Firefox 16.0.1 et après un redémarrage, j'ai tester le site qui me confirme que cela fonctionne.
Pour tant le cadre est toujours là, même après un CTRL +F5

Voilà, c'est fait et j'ai le même résultat :

The system supports these ICC version 4 and version 2 profiles

malgré quoi cette bizarrerie subsiste, sur le site.


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#13 Le 19/10/2012, à 19:32

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

maman a écrit :

salut,
il y avait un souci avec libcairo2, il fût un temps. Les png avaient un rendu tout pourri. Donc, essaie de passer ton image "logod-gimpmetalf" en .jpg pour voir si c'est mieux.

@+

Bingo ! Je viens d'effectuer le changement et ça ne pose plus aucun problème.

Grand merci à toi

ainsi qu'à Vu, Bob49 et lool_lauris : mille excuses encore pour le retard de mes réponses...


PS : il serait peut-être utile de signaler ce problème ? Si oui : où dois-je poster ?

Dernière modification par ouftimondju (Le 19/10/2012, à 19:37)


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#14 Le 20/10/2012, à 06:19

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour

ouftimondju a écrit :
maman a écrit :

salut,
il y avait un souci avec libcairo2, il fût un temps. Les png avaient un rendu tout pourri. Donc, essaie de passer ton image "logod-gimpmetalf" en .jpg pour voir si c'est mieux.

@+

Bingo ! Je viens d'effectuer le changement et ça ne pose plus aucun problème.

Pour Fedora ou je vois ce problème, la version n'est plus maintenue depuis un an...je suis tout de même étonné d'avoir ce problème ! Étant donné que Lucid à eu la dernière mise à jour de ce paquet en Juin 2010....
De toute façon, il faut que je passe à la dernière de Fedora, ça devrait régler le problème... smile


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#15 Le 20/10/2012, à 08:50

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour !

Bob49 a écrit :

je suis tout de même étonné d'avoir ce problème !

... ça ne m'étonne pas ;)

Cette curieuse lecture d'un format, pourtant ouvert, n'est pas uniforme de la part de versions récentes et mises à jour. Il serait quand-même intéressant de comprendre ce qui se passe et où ça se passe, car en fait la lecture des autres images .png se passe très bien : il a fallu que je sois "le nez dessus" pour m'apercevoir de cette anomalie, et le nombre de personnes s'étant penchées sur le problème à ma demande n'est pas énorme. Il n'est donc pas impossible que ce soit plus répandu que ça en a l'air. Vicieux, si ça se met, le gremlin :)

N'étant pas assez outillé en anglais ( ni techniquement, du reste ) pour soumettre le problème moi-même dans launchpad ou ailleurs j'ai posté dans le "forum des bugs".

Voili,voilou : bon week-end et merci encore


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#16 Le 20/10/2012, à 13:51

Vu

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

ouftimondju a écrit :

j'ai posté dans le "forum des bugs".

Le forum francophone qui pourrait t'aider pour Firefox est http://www.geckozone.org/forum/

Si un bug ouvert ou s'il en existe un, poste le aussi ici pour notre curiosité.


Ubuntu 12.04

Hors ligne

#17 Le 20/10/2012, à 15:59

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Vu a écrit :

Si un bug ouvert ou s'il en existe un, poste le aussi ici pour notre curiosité.

Voilà, je crois que j'ai trouvé. En tout cas ça marche chez moi : http://www.geckozone.org/forum/viewtopi … ng#p537484

Il s'agit donc de mettre, dans about:config, la clé gfx.color_management.mode à 0 conformément à la solution proposée par teoli2003 sur Geckozone.

Reste à voir si ça fonctionne pour tout le monde. Il n'y a pas de raison, mais sait-on jamais, et ça confirmera la validité de cette solution.


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#18 Le 20/10/2012, à 16:24

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonjour

Pour moi cette préférence est en 2 ! ... je vérifirais sous Fedora, histoire de savoir tout de même...

D'ailleurs sur 2, c'est par défaut... http://kb.mozillazine.org/Gfx.color_management.enabled


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#19 Le 20/10/2012, à 16:39

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Effectivement : c'était en 2 chez moi aussi.


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#20 Le 20/10/2012, à 17:37

Bob49

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

@ ouftimondju, comme tu t'es inscrit sur Geckozone, je te laisse rectifier ton lien, car il est mauvais smile


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#21 Le 20/10/2012, à 17:56

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

... 'core abusé des chicons au gratin, moi... 'plus de mon âge...

Merci ;)


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

#22 Le 20/10/2012, à 19:01

Vu

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Chez moi aussi en 2. Résolu en passant à 0.

Grâce cette information,  j'ai trouvé un bug de mai 2011 sur launchpad:
https://bugs.launchpad.net/ubuntu/+sour … bug/787824

Et sur bugzilla, j'en ai trouvé 4:
2008: https://bugzilla.mozilla.org/show_bug.cgi?id=456017
2010: https://bugzilla.mozilla.org/show_bug.cgi?id=621474
2012: https://bugzilla.mozilla.org/show_bug.cgi?id=756877
2012: https://bugzilla.mozilla.org/show_bug.cgi?id=781156

Dans le Bug 456017, il y a en un qui demande carrément si on ne devrait pas ajouter la non résolution du bug (Won't FIX=ne sera pas résolu car  .... les développeurs précisant le point de désaccord) puisque depuis 2008, le problème persiste.

SI quelqu'un a une explication sur les tenants et aboutissants de l'histoire, en français si possible: car les explications anglaises n'ont pas dissipées le brouillard chez moi.


Ubuntu 12.04

Hors ligne

#23 Le 20/10/2012, à 21:15

ouftimondju

Re : [ Résolu ] Firefox : rendu de couleurs fantaisiste

Bonsoir,

j'ai essayé de faire un peu le ménage avec mes moyens limités en vocabulaire technique : réserve d'usage, donc.

En gros, ça tourne en rond dans le genre "la poule ou l'œuf ?" et on en revient systématiquement à la "solution 0".

La référence au "WONTFIX" du message 456017 est une supposition du gars qui revient à la charge après s'être fait un rien planter là : "Il semblerait que tu aies un mauvais profil de couleurs sur ton système", quelques années plus tôt.

Il semblerait que tu aies un mauvais profil de couleurs sur ton système.

Qu'y puis-je ? gfx.color_management.display_profile est à sa valeur par défaut, qui est la chaîne vide. D'un autre côté ( = OTOH), désactiver le CMS ( en donnant à gfx.color_management.mode une valeur zéro ) semble rendre des couleurs correctes partout, donc apparemment je dois le laisser désactivé, ou y a-t-il des effets indésirables à craindre en agissant ainsi ?

gfx.color_management.mode est toujours à zéro, sans aucune séquelle si loin que je puisse en juger (AFAICT) Je n'ai pas testé récemment si le bug est toujours présent si je fais un "Reset" et que je redémarre mais je suppose que, après tout ce temps ( sans réponse), il est WONTFIX ?

Ce qui serait effectivement dans la ligne de la mise en garde ( Caveat ) : "Sans un moniteur correctement calibré et un profil de couleurs correct, la gestion des couleurs peut effectivement empirer." que l'on trouve ici http://kb.mozillazine.org/Gfx.color_management.enabled et qui porte précisément sur gfx.color_management.mode.

Mais cet avertissement est placé après l'explication des valeurs 1-2-0. Que faut-il en déduire ?

Car au-delà je dois avouer que my tailor n'est pas riche assez pour suivre celui des développeurs :)

Côté Launchpad Ubuntu je lis comme toi que le problème a été ré-ouvert fin 2011 parce que récurrent, mais je constate que quelqu'un vient de relancer sur base du souci qui fait l'objet de ce fil. Merci à lui, soit-dit en passant.

Wait and see, donc, comme ils disent.

... et si je crains ne t'avoir pas été très utile, au moins cette petite promenade sur les liens l'aura-t-elle été à my tailor ;)


Xubuntu 12.04 (precise) - Xfce 4.10 / HP G5230be : Intel Celeron CPU E3400 @ 2.60GHz - VGA compatible Intel 4 Chipset integrated graphics controller ( rev 03 ) - DD ATA Hitachi HDS72103 298GiB (320GB)
( ... et un bon plat de chicons au gratin... )

Hors ligne

Haut de page ↑