Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 28/10/2012, à 11:42

YAUNHIC

[Résolu] Impossible d'installer Wine

Bonjour,

Avant de poster ici, j'ai regardé diverses réponses concernant ce problème, mais j'avoue que je suis un peu perdu...

Je ne suis pas pressé, je veux installer Wine pour pouvoir utiliser quelques petits logiciels normalement "utilisables" par Windows, donc pas d'urgences wink

Voici les messages d'erreurs :

Installation via les dépôts officiels :

1351416623.jpg

Via la console :

sudo apt-get install wine
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
wine : Dépend: wine1.4 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Quelques captures :


Gestionnaire de paquets synaptic :

1351415888.jpg


Sources de logiciels :

1351416249.jpg


Commande "cat /etc/apt/sources.list" :

# deb cdrom:[Xubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120817.3)]/ dists/precise/main/binary-i386/

# deb cdrom:[Xubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120817.3)]/ dists/precise/multiverse/binary-i386/
# deb cdrom:[Xubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120817.3)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Xubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120817.3)]/ dists/precise/universe/binary-i386/
# deb cdrom:[Xubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120817.3)]/ precise main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse #Added by software-properties

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main


Merci pour vos réponses wink

Dernière modification par YAUNHIC (Le 30/10/2012, à 12:36)

Hors ligne

#2 Le 28/10/2012, à 12:20

PPdM

Re : [Résolu] Impossible d'installer Wine

Salut
laisse tomber ces vielles procédures et utilise plutôt PlayOnLinux

Dernière modification par pierguiard (Le 28/10/2012, à 12:21)

Hors ligne

#3 Le 28/10/2012, à 12:56

GP974

Re : [Résolu] Impossible d'installer Wine

bonjour

essaie de mettre a  jour la liste des paquet et ton système au passage ça peut corriger les problèmes de dependance

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install wine

Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

#4 Le 29/10/2012, à 20:00

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Bonsoir,

@ Pierguiard : Ça ne marche pas non plus, même message d'erreur sad

@ GP974 : Pareil, il n'y-a rien à faire...

Ça se complique on dirait.

Salut.

Hors ligne

#5 Le 29/10/2012, à 20:02

PPdM

Re : [Résolu] Impossible d'installer Wine

Que dit

sudo apt-get update && sudo apt-get dist-upgrade

Hors ligne

#6 Le 29/10/2012, à 20:06

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Re,

Voilà le résultat de la commande "sudo apt-get update && sudo apt-get dist-upgrade" :

Ign http://security.ubuntu.com precise-security InRelease
Atteint http://security.ubuntu.com precise-security Release.gpg               
Ign http://extras.ubuntu.com precise InRelease                                 
Ign http://ppa.launchpad.net precise InRelease                                 
Ign http://ppa.launchpad.net precise InRelease                                 
Ign http://ppa.launchpad.net precise InRelease                                 
Ign http://fr.archive.ubuntu.com precise InRelease                             
Ign http://fr.archive.ubuntu.com precise-backports InRelease                   
Atteint http://security.ubuntu.com precise-security Release                   
Atteint http://extras.ubuntu.com precise Release.gpg                           
Atteint http://ppa.launchpad.net precise Release.gpg                           
Atteint http://ppa.launchpad.net precise Release.gpg                           
Atteint http://extras.ubuntu.com precise Release                               
Atteint http://fr.archive.ubuntu.com precise Release.gpg                       
Atteint http://security.ubuntu.com precise-security/restricted Sources         
Atteint http://fr.archive.ubuntu.com precise-backports Release.gpg             
Atteint http://security.ubuntu.com precise-security/main Sources               
Atteint http://security.ubuntu.com precise-security/multiverse Sources         
Atteint http://security.ubuntu.com precise-security/universe Sources           
Atteint http://security.ubuntu.com precise-security/main amd64 Packages       
Atteint http://security.ubuntu.com precise-security/restricted amd64 Packages 
Atteint http://security.ubuntu.com precise-security/universe amd64 Packages   
Atteint http://security.ubuntu.com precise-security/multiverse amd64 Packages 
Atteint http://security.ubuntu.com precise-security/main i386 Packages         
Atteint http://security.ubuntu.com precise-security/restricted i386 Packages   
Atteint http://security.ubuntu.com precise-security/universe i386 Packages     
Atteint http://fr.archive.ubuntu.com precise Release                           
Atteint http://security.ubuntu.com precise-security/multiverse i386 Packages   
Atteint http://fr.archive.ubuntu.com precise-backports Release                 
Atteint http://fr.archive.ubuntu.com precise/restricted Sources               
Atteint http://fr.archive.ubuntu.com precise/main Sources                     
Atteint http://fr.archive.ubuntu.com precise/multiverse Sources               
Atteint http://fr.archive.ubuntu.com precise/universe Sources                 
Atteint http://fr.archive.ubuntu.com precise/main amd64 Packages               
Atteint http://fr.archive.ubuntu.com precise/restricted amd64 Packages         
Atteint http://fr.archive.ubuntu.com precise/universe amd64 Packages           
Atteint http://fr.archive.ubuntu.com precise/multiverse amd64 Packages         
Atteint http://fr.archive.ubuntu.com precise/main i386 Packages               
Atteint http://fr.archive.ubuntu.com precise/restricted i386 Packages         
Atteint http://fr.archive.ubuntu.com precise/universe i386 Packages           
Atteint http://fr.archive.ubuntu.com precise/multiverse i386 Packages         
Atteint http://fr.archive.ubuntu.com precise/main TranslationIndex             
Atteint http://fr.archive.ubuntu.com precise/multiverse TranslationIndex       
Atteint http://fr.archive.ubuntu.com precise/restricted TranslationIndex       
Atteint http://fr.archive.ubuntu.com precise/universe TranslationIndex         
Atteint http://fr.archive.ubuntu.com precise-backports/main Sources           
Atteint http://fr.archive.ubuntu.com precise-backports/restricted Sources     
Atteint http://fr.archive.ubuntu.com precise-backports/universe Sources       
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse Sources     
Atteint http://fr.archive.ubuntu.com precise-backports/main amd64 Packages     
Atteint http://fr.archive.ubuntu.com precise-backports/restricted amd64 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/universe amd64 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse amd64 Packages
Atteint http://security.ubuntu.com precise-security/main TranslationIndex     
Atteint http://fr.archive.ubuntu.com precise-backports/main i386 Packages     
Atteint http://fr.archive.ubuntu.com precise-backports/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/universe i386 Packages 
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/main TranslationIndex   
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/restricted TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/universe TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/main Translation-fr_FR           
Atteint http://fr.archive.ubuntu.com precise/main Translation-fr               
Atteint http://security.ubuntu.com precise-security/multiverse TranslationIndex
Atteint http://security.ubuntu.com precise-security/restricted TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/main Translation-en               
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-fr_FR     
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-fr         
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-en         
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-fr_FR     
Atteint http://security.ubuntu.com precise-security/universe TranslationIndex 
Atteint http://security.ubuntu.com precise-security/main Translation-en       
Atteint http://security.ubuntu.com precise-security/multiverse Translation-en 
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-fr         
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-en         
Atteint http://fr.archive.ubuntu.com precise/universe Translation-fr_FR       
Atteint http://fr.archive.ubuntu.com precise/universe Translation-fr           
Atteint http://fr.archive.ubuntu.com precise/universe Translation-en           
Atteint http://security.ubuntu.com precise-security/restricted Translation-en 
Atteint http://fr.archive.ubuntu.com precise-backports/main Translation-en     
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/universe Translation-en
Atteint http://security.ubuntu.com precise-security/universe Translation-en   
Atteint http://extras.ubuntu.com precise/main Sources                         
Atteint http://extras.ubuntu.com precise/main amd64 Packages           
Atteint http://extras.ubuntu.com precise/main i386 Packages
Atteint http://ppa.launchpad.net precise Release.gpg                   
Ign http://extras.ubuntu.com precise/main TranslationIndex             
Atteint http://ppa.launchpad.net precise Release
Atteint http://ppa.launchpad.net precise Release                               
Atteint http://ppa.launchpad.net precise Release                               
Atteint http://ppa.launchpad.net precise/main Sources                         
Atteint http://ppa.launchpad.net precise/main amd64 Packages           
Atteint http://ppa.launchpad.net precise/main i386 Packages           
Ign http://ppa.launchpad.net precise/main TranslationIndex             
Atteint http://ppa.launchpad.net precise/main Sources                 
Atteint http://ppa.launchpad.net precise/main amd64 Packages           
Atteint http://ppa.launchpad.net precise/main i386 Packages           
Ign http://ppa.launchpad.net precise/main TranslationIndex             
Atteint http://ppa.launchpad.net precise/main Sources                 
Atteint http://ppa.launchpad.net precise/main amd64 Packages           
Atteint http://ppa.launchpad.net precise/main i386 Packages           
Ign http://ppa.launchpad.net precise/main TranslationIndex             
Ign http://extras.ubuntu.com precise/main Translation-fr_FR           
Ign http://extras.ubuntu.com precise/main Translation-fr               
Ign http://extras.ubuntu.com precise/main Translation-en               
Ign http://ppa.launchpad.net precise/main Translation-fr_FR           
Ign http://ppa.launchpad.net precise/main Translation-fr
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-fr_FR
Ign http://ppa.launchpad.net precise/main Translation-fr
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-fr_FR
Ign http://ppa.launchpad.net precise/main Translation-fr
Ign http://ppa.launchpad.net precise/main Translation-en
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Merci wink

Hors ligne

#7 Le 29/10/2012, à 20:10

PPdM

Re : [Résolu] Impossible d'installer Wine

Bon a priori il n'y a pas d'erreur dans tes sources.
Tu a fais comment pour installer POL ?

Hors ligne

#8 Le 29/10/2012, à 20:12

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Via la logithèque.

Hors ligne

#9 Le 29/10/2012, à 20:16

PPdM

Re : [Résolu] Impossible d'installer Wine

Essayes comme ça

wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -
sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

Mais avant

sudo apt-get autoremove

Dernière modification par pierguiard (Le 29/10/2012, à 20:17)

Hors ligne

#10 Le 29/10/2012, à 20:26

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Re,


Pour les commandes suivantes :

sudo apt-get autoremove

wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -

sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list

sudo apt-get update

sudo apt-get install playonlinux

Résultat :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
playonlinux : Dépend: wine ou
                        wine-stable mais il n'est pas installable ou
                        wine-unstable mais il n'est pas installable
               Dépend: python-wxgtk2.8 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#11 Le 29/10/2012, à 20:54

PPdM

Re : [Résolu] Impossible d'installer Wine

Salut visiblement tu as des paquets cassés
lance Synaptic, si tu ne l'a pas

sudo apt-get install synaptic 

Lance le  et dans >édition>> réparer les paquets cassés

Hors ligne

#12 Le 30/10/2012, à 09:36

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Bonjour,

Le gestionnaire de paquets synaptic ne trouve aucun paquets cassés (aucune action)
Dans mon premier message j'avais mis une capture de la liste des paquets pour wine (Xubuntu 12.04 en 64bits)
1351415888.jpg

Salut.

Hors ligne

#13 Le 30/10/2012, à 10:38

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Re,

J'y suis enfin arrivé !

Aux vues des erreurs affichées lors de nos tentatives d'installations de "Play on Linux" (à préférer à Wine "seul" si j'ai bien compris) j'en ai déduit qu'il-y avait des problèmes avec certains paquets indispensables pour l'installation du logiciel ; ces paquets étaient manquants (et non pas "cassés" comme l'indiquait les messages d'erreurs) et, ne pouvaient pas être installés car, je cite :
"Les paquets suivants contiennent des dépendances non satisfaites" et "Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »"

J'ai donc coché dans "Sources de logiciels/Mises à jour" "Mises à jour recommandées"
Ce qui doit signifier (à confirmer) que les MAJ proposées, tiennent compte des logiciels/programmes déjà installées sur le PC et, améliorent la stabilité/sécurité de ceux-ci (les "MAJ suggérées" sont décochées pour ne pas installer des choses dont je n'ai pas besoin)

1351584977.jpg

J'ai pu ensuite installer "Play on Linux" via la logithèque sans plus de problème.


Question 1 : Pensez-vous que je puisses maintenant décocher cette option "Mises à jour recommandées" (quitte à la cocher de nouveau plus tard en cas de problèmes) ou dois-je le laisser tel quel pour de futures installations ?

Question 2 : Ou puis-je trouver l'historique par date des MAJ ?

J'attends un peu avant de passer ce sujet en "résolu"

@+

Dernière modification par YAUNHIC (Le 30/10/2012, à 10:57)

Hors ligne

#14 Le 30/10/2012, à 11:51

alca94

Re : [Résolu] Impossible d'installer Wine

Bonjour
Non laisser comme ça ,d'ailleurs ça aurait dû être comme ça dés le départ

Question 1 : Pensez-vous que je puisses maintenant décocher cette option "Mises à jour recommandées" (quitte à la cocher de nouveau plus tard en cas de problèmes) ou dois-je le laisser tel quel pour de futures installations ?

Dans la logithèque -----> Historique (il y a plusieurs onglets )

Question 2 : Ou puis-je trouver l'historique par date des MAJ ?

Voici comment c'est régler chez moi
1351590924.png
1351590993.png
1351591036.png

Dernière modification par alca94 (Le 30/10/2012, à 11:57)

En ligne

#15 Le 30/10/2012, à 12:36

YAUNHIC

Re : [Résolu] Impossible d'installer Wine

Bonjour,

Merci pour ces infos, les problèmes venaient donc du fait que je n'avais pas coché ces MAJ recommandées...
OK pour l'historique des MAJ wink

Bonne journée à tous et toutes !

@+

Hors ligne

Haut de page ↑