Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/11/2012, à 00:52

@rtix41

DNS tunneling avec dns2tcp

Bonjour à tous,

Dans un esprit de challenge personnel et pour progresser un peu en réseau, j'ai voulu tenter la réalisation d'un dns tunneling. En ayant suivi plusieurs tutos, j'ai installé le soft dns2tcp qui me paraissait le plus simple à mettre en place. Mais après plusieurs jours de tests infructueux, il m'est toujours impossible de faire fonctionner le serveur :

sudo dns2tcpd -d 3 -f ~/.dns2tcpdrc
23:24:09 : Debug options.c:97   Add resource ssh:127.0.0.1 port 22
23:24:09 : Debug socket.c:55    Listening on 0.0.0.0:53 for domain dns2tcp.mondomaine.fr
Error socket.c:107 bind error

J'ai un domaine ovh (on va dire mondomaine.fr), sur lequel j'ai créé un NS record vers mon serveur connecté à internet (de type : dns2tcp    IN   NS monserveur.no-ip.org.).
Voici le contenu de mon fichier de configuration .dns2tcpdrc :

listen = 0.0.0.0
port = 53
user=nobody
chroot = /var/empty/dns2tcp/
pid_file = /var/run/dns2tcp.pid
domain = dns2tcp.mondomaine.fr
resources = ssh:127.0.0.1:22

J'ai déjà pensé à la redirection UDP du port 53 de ma livebox vers mon serveur.

Je suis encore débutant en réseau, et il y a donc peut-être quelque chose d'évident que j'ai oubliée de faire.
D'où pensez-vous que vienne mon erreur ?
Merci d'avance smile .

Hors ligne

#2 Le 20/11/2012, à 23:25

@rtix41

Re : DNS tunneling avec dns2tcp

C'est bon, j'ai réussi ! En faisant des manipulations pour tenter de comprendre le protocole DNS, j'avais installé bind9 que j'avais oublié de désinstallé. Il écoutait donc constamment sur le port 53... Une désinstallation et ça a marché.
Désolé pour le dérangement, à bientôt !

Hors ligne

Haut de page ↑