Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/11/2012, à 23:59

Pik-O-paT

[Résolu] Minecraft : plantage après login

Bonjour,

Récemment j'ai voulu tester Minecraft sous Xubuntu (12.10). J'ai la version de java suivante (commande java -version)

java version "1.7.0_09"
OpenJDK Runtime Environment (IcedTea7 2.3.3) (7u9-2.3.3-0ubuntu1~12.10.1)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

Lorsque je lance mon Minecraft, je peux me loguer mais cependant après un cours chargement voici le message d'erreur.

      Minecraft has crashed!      
      ----------------------      

Minecraft has stopped running because it encountered a problem; Failed to start game

A full error report has been saved to /home/valentin/.minecraft/crash-reports/crash-2012-11-21_23.49.13-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(



--- BEGIN ERROR REPORT 96aa9892 --------
Full report at:
/home/valentin/.minecraft/crash-reports/crash-2012-11-21_23.49.13-client.txt
Please show that file to Mojang, NOT just this screen!

Generated 21/11/12 23:49

-- System Details --
Details:
	Minecraft Version: 1.4.5
	Operating System: Linux (amd64) version 3.5.0-18-generic
	Java Version: 1.7.0_09, Oracle Corporation
	Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 30835008 bytes (29 MB) / 60751872 bytes (57 MB) up to 902299648 bytes (860 MB)
	JVM Flags: 0 total; 
	AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
	Suspicious classes: No suspicious classes found.
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	LWJGL: 2.4.2
	OpenGL: ~~ERROR~~ NullPointerException: null
	Is Modded: Probably not. Jar signature remains and client brand is untouched.
	Type: Client (map_client.txt)
	Texture Pack: ~~ERROR~~ NullPointerException: null
	Profiler Position: N/A (disabled)
	Vec3 Pool Size: ~~ERROR~~ NullPointerException: null[failed to get system properties (java.lang.NullPointerException)]


org.lwjgl.LWJGLException: Could not init GLX
	at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
	at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:52)
	at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:684)
	at org.lwjgl.opengl.Display.create(Display.java:854)
	at org.lwjgl.opengl.Display.create(Display.java:784)
	at org.lwjgl.opengl.Display.create(Display.java:765)
	at net.minecraft.client.Minecraft.a(SourceFile:232)
	at net.minecraft.client.Minecraft.run(SourceFile:515)
	at java.lang.Thread.run(Thread.java:722)
--- END ERROR REPORT 543cc56d ----------

Opengl était expressément nommé j'ai essayé de voir si les pilotes de ma carte Nvidia avais un problème. La commande lspci | grep VGA me donne :

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520MX] (rev a1)

J'ai bien le pilote nvidia-current 304.51.really.304.43-0ubuntu1. Cependant lorsque je fais nvidia-setting, j'ai un message d'erreur me conseillant de lancer en root nvidia-xconfig. Ce que je fais et... ça change rien. Voici la réponse à la commande sudo nvidia-xconfig :

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

Si pouvait me donner un petit coup de pouce pour que je puisse comprendre un peu mieux. Ça serait pas de refus.

Merci par avance

Dernière modification par Pik-O-paT (Le 22/11/2012, à 15:21)


Epook-Epeek

Hors ligne

#2 Le 22/11/2012, à 08:57

leold

Re : [Résolu] Minecraft : plantage après login

hello
en se qui concerne ta carte graphique tu as la technologie optimus
http://doc.ubuntu-fr.org/nvidia_optimus
http://forum.ubuntu-fr.org/viewtopic.php?id=565321
donc tu dois pas installer les drivers NVIDIA par la methode classic.
et apres lancer les programmes qui demande pas mal de ressources avec la commande optirun (mais je te laisse decouvrir cela tout seul )
en se qui concerne minecraft, je suis pas arrivé a le faire tourner avec le java d'adobe (oracle java 7 ou 8), par contre il tourne tres bien avec le openJDK
regarde si chez toi cela marche et tien nous au courant

Hors ligne

#3 Le 22/11/2012, à 14:04

Pik-O-paT

Re : [Résolu] Minecraft : plantage après login

Merci beaucoup, un collègue de bureau est arrivé au même constat. Je teste ça ce soir ou demain et je vous fais savoir !

Encore une fois merci !


Epook-Epeek

Hors ligne

#4 Le 22/11/2012, à 15:20

Pik-O-paT

Re : [Résolu] Minecraft : plantage après login

Ça fonctionne ! Merci beaucoup ! Effectivement ça change tout ! Je passe le message en résolu !


Epook-Epeek

Hors ligne

Haut de page ↑