Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 11/11/2011, à 09:35

ursu

Problème de "root" pour accès disque dur [Résolu]

Bonjour à tous!

Récemment, mon disque dur "sdg1" n'accepte plus l'apport de fichier; je regarde ses propriétés et
remarque qu'il est mis en "root" (Permissions: propriétaire et groupe)
Je trouve dans un forum une commande :

"sudo ls -la /media/sdg1"

qui me le confirme, puis une seconde:

"sudo chown   -R   utilisateur:utilisateur  /media/sdg1"

qui, dans un premier temps va me régler le problème (l'accès est devenu possible!)
Enfin, hier, je me rends compte que sdg1 est de nouveau en "root", mais maintenant, la seconde commande n'est plus efficace... .
Que faire???
Merci pour vos réponses...,
L'Ursu_

Dernière modification par ursu (Le 12/11/2011, à 13:52)

Hors ligne

#2 Le 11/11/2011, à 15:16

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

Bonjour ursu,

postes le résultat de

cat /etc/fstab

SOPI

Hors ligne

#3 Le 11/11/2011, à 17:44

ursu

Re : Problème de "root" pour accès disque dur [Résolu]

Re- à tous,
Salute f.x0!

Voici le résultat de la commande conseillée:

ursu@HP:~$ cat /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc    proc    nodev,noexec,nosuid    0    0
#Entry for /dev/sdf1 :
UUID=aa31f404-d241-4437-8327-97ed71f91325    /    ext4    errors=remount-ro    0    1
#Entry for /dev/sda2 :
UUID=4a26a3f8-22d0-4da0-b4be-97845898da9a    /media/sda2    ext4    defaults0    0
#Entry for /dev/sdg1 :
UUID=4B0C54965D37B0EC    /media/sdg1    ntfs    defaults,nls=utf8,umask=0222    00
#Entry for /dev/sdg2 :
UUID=476be8a5-d81f-4146-a55c-8fdcb0b26208    /media/sdg2    ext4    defaults0    0
#Entry for /dev/sdf5 :
UUID=51bc808f-0d6b-453b-ad84-3dabe305c8a2    none    swap    sw    0    0
UUID=32113771-7bdf-493a-b261-8ee13b474120    none    swap    sw    0    0
192.168.1.3:/home/Partage /media/Partage nfs rw 0 0

Merci à toi...,
L'Ursu_

Hors ligne

#4 Le 11/11/2011, à 17:59

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

Essaies de modifier ton fichier /etc/fstab comme ceci

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc    proc    nodev,noexec,nosuid    0    0
#Entry for /dev/sdf1 :
UUID=aa31f404-d241-4437-8327-97ed71f91325     /                      ext4    errors=remount-ro         0    1
#Entry for /dev/sda2 :
UUID=4a26a3f8-22d0-4da0-b4be-97845898da9a    /media/sda2   ext4    defaults                          0     0
#Entry for /dev/sdg1 :
UUID=4B0C54965D37B0EC                                     /media/sdg1    ntfs     defaults,utf8,umask=0    0    0
#Entry for /dev/sdg2 :
UUID=476be8a5-d81f-4146-a55c-8fdcb0b26208    /media/sdg2     ext4   defaults                           0    0
#Entry for /dev/sdf5 :
UUID=51bc808f-0d6b-453b-ad84-3dabe305c8a2   none                swap  sw                                    0    0
UUID=32113771-7bdf-493a-b261-8ee13b474120   none                swap  sw                                    0    0
192.168.1.3:/home/Partage /media/Partage                                     nfs      rw                                    0    0

Dernière modification par f.x0 (Le 11/11/2011, à 17:59)


SOPI

Hors ligne

#5 Le 11/11/2011, à 19:16

JLK

Re : Problème de "root" pour accès disque dur [Résolu]

En lisant le fstab d'ursu, je remarque que /dev/sdf5 a deux UUID. Ça vient d'où, ça ? Ou bien il y a deux partitions d'échange ?

Dernière modification par JLK (Le 11/11/2011, à 19:19)

Hors ligne

#6 Le 12/11/2011, à 01:06

ursu

Re : Problème de "root" pour accès disque dur [Résolu]

Bonsoir à tous!

Merci de votre aide... .

à f.x0: j'ai édité /etc/fstab comme tu me l'as conseillé, mais pas de changement sur les droits de sdg1... .
à JLK: j'avais en effet deux swap, sur deux disques différents, c'est pas vraiment logique?
D'autant plus que je viens de supprimer la seconde et que les deux UUID perdurent dans le fstab!
Voilà, bonne nuit,
L'Ursu_

Hors ligne

#7 Le 12/11/2011, à 01:15

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

Essaies

sudo chmod 777 /media/sdg1

SOPI

Hors ligne

#8 Le 12/11/2011, à 02:49

JLK

Re : Problème de "root" pour accès disque dur [Résolu]

ursu a écrit :

Bonsoir à tous!

Merci de votre aide... .

à f.x0: j'ai édité /etc/fstab comme tu me l'as conseillé, mais pas de changement sur les droits de sdg1... .
à JLK: j'avais en effet deux swap, sur deux disques différents, c'est pas vraiment logique?
D'autant plus que je viens de supprimer la seconde et que les deux UUID perdurent dans le fstab!
Voilà, bonne nuit,
L'Ursu_

J'ai vu quelque part qu'il était possible d'utiliser plusieurs partitions swap (avec un ordre d'utilisation, je pense).
A mon avis, deux partitions swap, ça fait un peu beaucoup, à moins pour des raisons spécifiques.

Hors ligne

#9 Le 12/11/2011, à 10:03

ursu

Re : Problème de "root" pour accès disque dur [Résolu]

Bonjour à tous!

Salute f.x0 et JLK!

Commande tapée, pas de changement sur les droits, mais je peux importer et exporter avec le DD
(ça avance!)
Par contre, le doublage des UUID se répète désormais avec mon sda2 (j'ai formaté mon deuxième DD, Win XP +
une partition FSX):

#Entry for /dev/sda2 :
UUID=164F1F9E2B72D108    /media/FSX_divers    ntfs    defaults,nls=utf8,umask=0222    0    0
UUID=4a26a3f8-22d0-4da0-b4be-97845898da9a    /media/sda2    ext4    defaults    0    0

De plus, ce volume est bien en NTFS et non en ext4 comme ça apparaît sur le second UUID;
coïncidence (?), ce volume n'arrive pas à se monter au démarrage (touche "S" ou "M")
Est-ce que je dois supprimer cette ligne erronée?
Enfin, pour la swap, elle est notée "sdf5", alors qu'elle apparaît dans tous les gestionnaires de disque comme "sdb5"
(logique vu qu'elle est la swap du disque "sdb")
Un peu obscur tout ça pour moi!
Merci encore,
L'Ursu_

Hors ligne

#10 Le 12/11/2011, à 12:34

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

Bizarre en effet
postes le retour de

sudo fdisk -lu
sudo blkid
mount -l
cat cat /etc/fstab

SOPI

Hors ligne

#11 Le 12/11/2011, à 13:16

ursu

Re : Problème de "root" pour accès disque dur [Résolu]

Re-

Pour info, au dernier reboot, je n'ai plus la main sur sdg1... .
Voici les commandes demandées:

ursu@HP:~$ sudo fdisk -lu
[sudo] password for ursu: 

Disque /dev/sda: 500.1 Go, 500107862016 octets
255 têtes, 63 secteurs/piste, 60801 cylindres, total 976773168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x0002b3da

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *          63   193518989    96759463+   7  HPFS/NTFS
/dev/sda2       193518990   976768064   391624537+   7  HPFS/NTFS

Disque /dev/sdf: 1000.2 Go, 1000204886016 octets
255 têtes, 63 secteurs/piste, 121601 cylindres, total 1953525168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x0004438d

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdf1   *        2048  1933594623   966796288   83  Linux
/dev/sdf2      1933596670  1953523711     9963521    5  Etendue
/dev/sdf5      1933596672  1953523711     9963520   82  Linux swap / Solaris

Disque /dev/sdg: 2000.4 Go, 2000398934016 octets
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x00084106

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdg1              63  3071997494  1535998716    7  HPFS/NTFS
/dev/sdg2      3071997495  3907024064   417513285   83  Linux
ursu@HP:~$ sudo blkid
/dev/sda1: UUID="7A50D07150D0361B" TYPE="ntfs" 
/dev/sda2: LABEL="FSX-divers" UUID="164F1F9E2B72D108" TYPE="ntfs" 
/dev/sdf1: UUID="aa31f404-d241-4437-8327-97ed71f91325" TYPE="ext4" 
/dev/sdf5: UUID="51bc808f-0d6b-453b-ad84-3dabe305c8a2" TYPE="swap" 
/dev/sdg1: UUID="4B0C54965D37B0EC" TYPE="ntfs" 
/dev/sdg2: UUID="476be8a5-d81f-4146-a55c-8fdcb0b26208" TYPE="ext4" 
ursu@HP:~$ mount -l
/dev/sdf1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
/dev/sda1 on /media/sda1 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sdg1 on /media/sdg1 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sdg2 on /media/sdg2 type ext4 (rw,commit=0)
/dev/sda2 on /media/FSX_divers type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions) [FSX-divers]
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
gvfs-fuse-daemon on /home/ursu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ursu)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
ursu@HP:~$ cat cat /etc/fstab
cat: cat: Aucun fichier ou dossier de ce type
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc    proc    nodev,noexec,nosuid    0    0
#Entry for /dev/sdf1 :
UUID=aa31f404-d241-4437-8327-97ed71f91325    /    ext4    errors=remount-ro    0    1
#Entry for /dev/sda1 :
UUID=7A50D07150D0361B    /media/sda1    ntfs    defaults,nls=utf8,umask=0222    00
#Entry for /dev/sdg1 :
UUID=4B0C54965D37B0EC    /media/sdg1    ntfs    defaults,nls=utf8,umask=0222    00
#Entry for /dev/sdg2 :
UUID=476be8a5-d81f-4146-a55c-8fdcb0b26208    /media/sdg2    ext4    defaults0    0
#Entry for /dev/sda2 :
UUID=164F1F9E2B72D108    /media/FSX_divers    ntfs    defaults,nls=utf8,umask=0222    0    0
#Entry for /dev/sdf5 :
UUID=51bc808f-0d6b-453b-ad84-3dabe305c8a2    none    swap    sw    0    0
UUID=32113771-7bdf-493a-b261-8ee13b474120    none    swap    sw    0    0
192.168.1.3:/home/Partage    /media/Partage    nfs    rw    0    0


ursu@HP:~$ 

Si j'en crois la commande "sudo blkid", le vrai UUID de "sdf5" est le premier annoncé (commençant par "51bc..".) donc
je peux supprimer le second ?(c'est ce que j'ai fait avec le second UUID de "sda2" avant ton post)
Merci encore,
L'Ursu_

Hors ligne

#12 Le 12/11/2011, à 13:26

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

OK pour supprimer

UUID=32113771-7bdf-493a-b261-8ee13b474120    none    swap    sw    0    0

SOPI

Hors ligne

#13 Le 12/11/2011, à 13:31

f.x0

Re : Problème de "root" pour accès disque dur [Résolu]

Pour tes droits en écriture,
essaies d'installer l'outil de configuration NTFS disponible dans la logithèque.

Puis actives les droits en écriture en lançant outil de configuration NTFS


SOPI

Hors ligne

#14 Le 12/11/2011, à 13:51

ursu

Re : Problème de "root" pour accès disque dur [Résolu]

Re-

J'ai supprimé l'UUID en question... .
L'installation de l'outil de configuration NTFS m'a permis de pouvoir écrire sur toutes mes partitions NTFS,
le reboot me l'a confirmé... . (la commande "sudo ls -la /media/sdg1" me laisse "sdg1" en root, mais j'y ai accès, alors...)
Merci à toi, f.x0, je peux édité le post "Résolu"... .
Amicalement,
L'Ursu_

Hors ligne

#15 Le 22/11/2012, à 16:48

maestroom

Re : Problème de "root" pour accès disque dur [Résolu]

Merci f.x0 l'outil de configuration NTFS ma permis de régé mon problème sur un de mes disque dur il était en root.. et je ne pouvais plus modifier n'y créé de dossier smile


CM: Asus M2N-E sli /cpu: Amd phenom 9550E quad core /carte graphique: nvidia GTS 250 /os: Ubuntu 13.04 "" 64 bits avec dual boot windows 8/ vmware : Windows 7

Hors ligne

Haut de page ↑