Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 11/01/2008, à 10:37

Emalice

[Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Bonjour.

Combien d'entre vous on passé deux heures de film à  toucher la souris toutes les 10 minutes parce que l'économiseur d'écran se met en route ?

Combien d'entre vous se sont arrachés les cheveux en constatant que tous les paramètres de l'économiseur sont pourtant bien réglés ?

Combien d'entre vous ont pleuré en ne trouvant nulle part sur les forums LA petite astuce qui permet de contourner ce problème ?

Réjouissez vous, la solution et simple. Il faut juste aller rajouter quelques lignes dans le xorg.conf voici la procédure.

N'oubliez pas de respecter la casse (majuscules/minuscules)

à‰tape 1 : copie de sauvegarde du xorg.conf

Dans la console, tapez :

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

à‰tape 2 : modification du xorg.conf

Toujours dans la console, tapez :

 sudo gedit /etc/X11/xorg.conf

Rajoutez à  la fin du fichier les lignes suivantes (un copié/collé devrait faire l'affaire)

Section "ServerFlags"
# other options can go here
        Option  "BlankTime"             "0"
        Option  "StandbyTime"           "0"
        Option  "SuspendTime"           "0"
        Option  "OffTime"               "0"
EndSection

Sauvegardez le fichier.

à‰tape 3 : Redémarrez le serveur X

Soit vous redémarrez carrément le pc, soit vous faites [Ctrl]+[Alt]+[Retour arrière(backspace)]


En cas de crise

Si vous avez un problème majeur d'affichage, vous pouvez revenir à  la version précédente de xorg.conf en tapant dans la console :

 sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

Normalement maintenant vous pouvez regarder vos vidéos sans aucun souci. Votre économiseur d'écran fonctionnera toujours tel que vous l'avez paramétré, sans pour autant s'inviter grossièrement à  regarder des films avec vous...

#2 Le 11/01/2008, à 10:59

yohann

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

merci pour l'astuce, j'atait exactement dans le cas que tu décris au début du post...


j.vachez, le génie du net | Soirées jeux sur Lyon | 441
++++++++++[>+++++++>++++++++++>+++<<<-]>++.>+.+++++++
..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.

Hors ligne

#3 Le 11/01/2008, à 11:17

Emalice

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Hé hé hé, mais de rien.

J'ai passé beaucoup de temps à  chercher une solution à  ce problème, et vu tout ce que j'ai vu sur beaucoup de fora (pluriel de forum, pour les non latinistes) je pense qu' énormément de gens rencontrent ce problème. Ce qui m'a décidé à  écrire ce post...

Heureux d'avoir pu donner un coup de main à  la communauté.


Mieux vaux mobiliser son intelligence sur des conneries que sa connerie sur des choses intelligentes.
Devise Shadok.

Hors ligne

#4 Le 11/01/2008, à 21:50

Skippy le Grand Gourou

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Je m'inscris au sujet, en espérant que quelqu'un fasse un up un jour o๠je serai devant le portable de ma copine... big_smile


Mais quand vont-ils tous se taire ?? (De l'indécence médiatique et de sa justification des crimes violents)
Touristes africains, vous n'êtes pas les bienvenus en France.
 

Hors ligne

#5 Le 20/01/2008, à 19:33

Vysserk3

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Je viens de mettre ces options dans le Xorg.conf, et c'est toujours pareil lors de la lecture avec smplayer (un front-end pour mplayer), l'économiseur d'écran de Gnome se lance au bout du temps indiqué dans les préférences...

Hors ligne

#6 Le 20/01/2008, à 19:43

Malizor

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

J'avais trouvé dans je sais plus quel topic qu'il fallait taper ça dans un terminal:

xset -display :0 s off -dpms

Pour éviter de faire la même manip à chaque fois il faut le rajouter dans "sessions"

Avantage: ici on ne modifie pas de Xorg.conf et vue que c'est sauvegarder dans le home ya pas besoin de refaire la manip après une réintallation!
En tous cas chez moi j'ai plus jamais eu ce problème!


Je recherche un stagiaire pour faire du dev Python sur GNU/Linux en région Parisienne. Contactez moi par MP si intéressé !


« Vous prouver que j'ai raison serait admettre que je puisse avoir tort. »  -  Beaumarchais  ← Le premier troll ?

Hors ligne

#7 Le 20/01/2008, à 21:41

Vysserk3

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Bon en fait pour mon problème, c'est parce que j'utilisais gnome-screensaver. Il faut utiliser xscreensaver wink

Hors ligne

#8 Le 10/11/2011, à 16:50

hibou7

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

@Mailzor
Merci beaucoup, ça marche!
Si jamais tu suis encore cette discussion: comment m'y prendre pour rajouter cette ligne dans "Sessions".

Ou encore: comment apprendre ou se trouvent les différentes parties du Système Ubuntu?

Merci d'avance  smile


Ubuntisan paisible et souvent nocturne sur un ordinosaure du 2e millénaire.
Xubuntu 14.04.1 LTS | CPU Pentium 4, 2.80GHz | CG ATI Radeon RV 100QY | RAM 2 Gio 
Les tutos video d'Alexis Madrzejewski: http://www.tutoriels-video.fr/category/tutoriel-video/
Si GNU/Linux ne répond plus: le redémarrer proprement avec:  Alt + SysRq + REISUB

Hors ligne

#9 Le 11/11/2011, à 01:41

Matsjö

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Salut hibou7

Tu est tjs sur 11.04 ?
Dans ce cas tu ouvre avec les droits le fichier /etc/gdm/init/Default
La tu coipe ces deux lignes juste avant le exit 0
     xset s off
     xset -dpms
Tu sauvegarde, et la ton economiseur d'ecran ne t'embete plus(desactive au demarrage de l'ordi)

Ps j'ai mis un racouci sur mon tableau de bord, afin d'acceder rapidement a la remise en
route de l'economiseur si j'en ai besion (Etant sur un poste fixe, c'est bien souvent que j'eteint
carrement mon ecran).

Sur mon portable, j'ai un dual boot Xubuntu 11.10-64 et bodhil. Pour ts les deux, je me suis contente
de mettre un racourci sur le bureau afin d'activer ou non l'economiseur, sans rien modifie d'autre et cela marche tres bien.
A+ wink


Important ... Je crois:
http://www.laquadrature.net/fr/acta
http://www.libraboot.org/
Because the best thing in life is Freedom

Hors ligne

#10 Le 11/11/2011, à 12:00

coucou123

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Salut Matsjö,

Ton raccourci sur le bureau, c'est pour t'envoyer dans les préférences de gnome-screensaver ?


Precise Pangolin 64bits
Lucid Lynx 64bits

Hors ligne

#11 Le 11/11/2011, à 13:12

Matsjö

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Salut coucou123

Yep, c'est cela meme, cela te permet d'activer ou non ton economiseur d'ecran qui n'a d'economie que le nom big_smile
Si tu veux vraiment preserver ta batterie, il faut se brancher sur ecran vide.

A+ wink


Important ... Je crois:
http://www.laquadrature.net/fr/acta
http://www.libraboot.org/
Because the best thing in life is Freedom

Hors ligne

#12 Le 06/03/2012, à 11:19

Jacs

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Ben moi j'ai juste mis l'applet d'inhibition du gestionnaire d'énergie 2.30.0 sur mon tableau de bord (clic droit sur le tableau de bord puis ajouter au tableau de bord)
http://www.gnome.org/projects/gnome-power-manager/

Hors ligne

#13 Le 11/05/2012, à 07:21

nesthib

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Je profite du déterrage pour ajouter une petite astuce honteusement bidouillée dans la lignée de XKCD.

while true; do xte "mousermove 0 1" ; xte "mousermove 0 -1" ; sleep 2m ; done

qui bougera le pointeur de la souris d'un pixel aller/retour toutes les deux minutes.

À mettre en alias dans son .bashrc wink


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#14 Le 20/11/2012, à 10:35

fcn50

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Salut,

Je rajoute mon grain de sel... Pour m'éviter l'installation d'un économiseur d'écran (xscreensaver ou autres) tout en ayant cette fonction, je met ceci dans xorg.conf ("4" = 4 minutes):

Section "ServerFlags"
    Option        "standby time" "4"
    Option        "suspend time" "4"
    Option        "off time" "4"
EndSection

Et pour désactiver lors des vidéos, dans un terminal et le tour est joué:

xset -dpms

xset s off

xset s noblank

Pour réactiver l'économiseur:

xset +dpms

xset s on

xset s blank


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#15 Le 21/11/2012, à 23:44

snipe2004

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

nesthib a écrit :

Je profite du déterrage pour ajouter une petite astuce honteusement bidouillée dans la lignée de XKCD.

while true; do xte "mousermove 0 1" ; xte "mousermove 0 -1" ; sleep 2m ; done

qui bougera le pointeur de la souris d'un pixel aller/retour toutes les deux minutes.

À mettre en alias dans son .bashrc wink

Y a plus de .bashrc sur GnomeShell 3.6? L'extension Caffeine qui est censée permettre de couper la mise en veille ne fonctionne pas chez moi, et cette astuce me semble géniale big_smile

Et comme mon xorg.conf est horrible car Optimus est là, chabalabala, je préfère pas y toucher :s


MEDION AKOYA P7624 (MD 98921)
Processeur Intel Core™ i5-2430M 2,40 GHz (Turbo Boost 2,0 jusqu‘à 3,0 GHz, 3 Mo Intel Smart Cache, Intel Hyper-Threading)
NVIDIA GeForce GT630M DirectX 11 (1024 Mo de mémoire, sortie numérique audio/vidéo HDMI et Optimus) + Intel Centrino Advanced-N 1030 (Bluetooth 3.0 intégré)
Ubuntu 13.10

Hors ligne

#16 Le 21/11/2012, à 23:54

VPCL

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

Bonsoir à tous,
sous XFCE, c'est tout simple:
_ gestionnaire de paramètres
_ économiseur d' écran
_ Mode:"Désactiver l' économiseur d'écran"

Bonne soirée, VPCL.

Hors ligne

#17 Le 23/11/2012, à 10:59

fcn50

Re : [Tuto] Bloquer l'économiseur d'écran pendant la lecture des vidéos

snipe2004 a écrit :

Et comme mon xorg.conf est horrible car Optimus est là, chabalabala, je préfère pas y toucher :s

C'est pas la section "ServerFlags" qui va changer le prix du beurre et c'est pas irréversible...

Concernant Xfce que j'utilise aussi, tout est plus simple avec cet environnement mais les goûts et les couleurs... Perso j'ai même pas xscreensaver qui sert pas à grand chose alors qu'on peux s'en passer, un paquet en moins c'est un problème potentiel en moins. big_smile


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

Haut de page ↑