Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/11/2012, à 19:16

abelthorne

[résolu] MySQL ne démarre pas tout seul (Raspberry Pi)

Bonsoir,
Je vais peut-être me faire taper sur les doigts, mon problème n'étant pas sous Ubuntu mais sous Raspbian (Debian sur Raspberry Pi). Mais étant donné que le système est à peu près identique pour ce qui est des fonctionnaités serveur, je me permets de poster ici au cas où...

Sur mon Pi, j'ai installé Apache + PHP + MySQL. Tout fonctionne bien à un détail près : MySQL ne se lance pas tout seul au démarrage. Je suis obligé de me connecter à la machine pour le lancer manuellement via sudo service mysql start
Quelqu'un a déjà rencontré un problème similaire sur une distro Linux et aurait une idée de ce que je dois vérifier pour voir d'où vient le problème ?

Dernière modification par abelthorne (Le 26/11/2012, à 20:15)

Hors ligne

#2 Le 26/11/2012, à 19:44

pires57

Re : [résolu] MySQL ne démarre pas tout seul (Raspberry Pi)

update-rc.d mysql defaults

tente cela et dis moi si cela fonctionne.

Dernière modification par pires57 (Le 26/11/2012, à 19:45)


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

#3 Le 26/11/2012, à 20:04

abelthorne

Re : [résolu] MySQL ne démarre pas tout seul (Raspberry Pi)

Non, ça ne change rien.

EDIT : je viens de jeter un coup d'œil au syslog et j'ai ça :

Nov 26 20:02:17 raspbmc mysqld_safe: Starting mysqld daemon with databases from /var/lib/mysql
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [Note] Plugin 'FEDERATED' is disabled.
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: The InnoDB memory heap is disabled
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Mutexes and rw_locks use GCC atomic builtins
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Compressed tables use zlib 1.2.7
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Using Linux native AIO
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Initializing buffer pool, size = 128.0M
Nov 26 20:02:18 raspbmc mysqld: InnoDB: mmap(135987200 bytes) failed; errno 12
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Completed initialization of buffer pool
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 InnoDB: Fatal error: cannot allocate memory for the buffer pool
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [ERROR] Plugin 'InnoDB' init function returned error.
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [ERROR] Unknown/unsupported storage engine: InnoDB
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [ERROR] Aborting
Nov 26 20:02:18 raspbmc mysqld: 
Nov 26 20:02:18 raspbmc mysqld: 121126 20:02:18 [Note] /usr/sbin/mysqld: Shutdown complete
Nov 26 20:02:18 raspbmc mysqld: 
Nov 26 20:02:18 raspbmc mysqld_safe: mysqld from pid file /var/run/mysqld/mysqld.pid ended
Nov 26 20:03:00 raspbmc /etc/init.d/mysql[1254]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' 
resulted in
Nov 26 20:03:00 raspbmc /etc/init.d/mysql[1254]: #007/usr/bin/mysqladmin: connect to server at 'localhost' failed
Nov 26 20:03:00 raspbmc /etc/init.d/mysql[1254]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock
' (2)'
Nov 26 20:03:00 raspbmc /etc/init.d/mysql[1254]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
Nov 26 20:03:00 raspbmc /etc/init.d/mysql[1254]:

Manque de mémoire ?

EDIT : bingo. Trouvé une solution sur ce thread : http://www.raspberrypi.org/phpBB3/viewt … 28&t=19277
Depuis MySQL 5.5 il attribue par défaut un buffer de 128 Mo, ce qui est un peu trop pour le Pi. En le réglant à 8 Mo, MySQL se lance bien.

Dernière modification par abelthorne (Le 26/11/2012, à 20:14)

Hors ligne

Haut de page ↑