Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 02/12/2012, à 16:25

lesiteduhtml

Apache2 et .htaccess

Salut à tous :),
Je possède un serveur virtuel avec apache2 installé. J'ai modifié un peux le fichier default d'apache pour qu'il redirige les sous-domaines et vouant enlevé le multiviewer j'ai supprimé ce qui le concerné.
Mais maintenant je voudrai placer un .htaccess pour faire les redirections des errerus 404, 500 ...
Sauf que mon apache en le reconnais pas.
J'aimerai qu'il le reconnaisse, voici le contenu de mon fichier default ( bien sur j'ai enlevé les vrai url ^^ ) :

<VirtualHost *:80>
        ServerName forum.monsite.fr
 ServerAdmin webmaster@localhost

        DocumentRoot /var/www/forum
        <Directory />
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        <Directory /var/www/forum>
                Options -Indexes -FollowSymLinks
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:80>
        ServerName www.monsite.fr
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        <Directory /var/www/>
                Options -Indexes -FollowSymLinks
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>
        ServerName monsite.fr
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        <Directory /var/www/>
                Options -Indexes -FollowSymLinks
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Voilà, j'espère que vous pourrais m'aider :)
Amicalement
Jérôme

Hors ligne

#2 Le 02/12/2012, à 18:47

Haleth

Re : Apache2 et .htaccess

L'utilisation des htaccess ralenti grandement les performances du serveur
Place donc la valeur AllowOverride à None, et rajoute ceci pour les 404 & co (par exemple):

ErrorDocument 404 http://machin.truc/bidule.html
ErrorDocument 500 /500.html

Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#3 Le 02/12/2012, à 20:47

tiramiseb

Re : Apache2 et .htaccess

Ouaip j'allais dire la même chose : vu que tu as accès directement à la config d'Apache, n'utilise pas les htaccess !

(htaccess permet juste d'outrepasser les réglages par défaut du serveur, il n'y a rien que tu peux faire dans un htaccess que tu ne puisse pas faire dans la config d'apache directement)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 06/12/2012, à 13:29

lesiteduhtml

Re : Apache2 et .htaccess

D'accord,
Merci beaucoup à vous deux smile
Bonne journée
Amicalement
Jérôme

Hors ligne

Haut de page ↑