Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 18/12/2012, à 17:27

jeanjules

boot CD impossible après installation en dual-boot

Bonjour,
Mon vieux PC qui tournait avec Lucid a rendu l'âme. J'ai acheté un portable Samsung sur lequel était installé Windows 8. J'ai installé 12.04 et j'ai voulu garder windows, pour voir ...  avec l'intention de tout réinstaller ensuite en ne gardant que Ubuntu (mes derniers contacts avec MS dataient de Windows 98).
J'ai eu un peu de mal à accéder au BIOS pour désactiver boot secure puis l'installation d'Ubuntu s'est déroulée normalement. Tout marche très bien sous 12.04.
Mais maintenant je voudrais refaire une installation claire avec une partition /home et sans Windows, mais impossible de booter à nouveau sur le CD. Je n'arrive plus non plus à accéder au BIOS ni à booter sur une clé USB.
Serais-je condamné à cohabiter avec Windows et à ne plus utiliser la moitié du disque dur ?
Je n'aimerais mieux pas et je remercie d'avance tous les spécialistes pour leur aide.

Hors ligne

#2 Le 18/12/2012, à 18:59

malbo

Re : boot CD impossible après installation en dual-boot

jeanjules a écrit :

Je n'arrive plus non plus à accéder au BIOS

Cette inquiétante situation me fait rapprocher ton cas de ce bug : https://bugs.launchpad.net/ubuntu-cdimage/+bug/1040557
On y voit que des ordis de marque Samsung se sont retrouvés avec un Bios hors d'usage après des tentatives plus ou moins avancées d'installation de Ubuntu


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#3 Le 18/12/2012, à 22:48

jeanjules

Re : boot CD impossible après installation en dual-boot

Merci de ta réponse, inquiétante aussi mais très utile car je m’apprêtais à supprimer les partitions Windows avec Gparted pour les utiliser avec Ubuntu. Mais alors le système risque de ne plus redémarrer et si le Bios est endommagé ...
Est-ce que tu penses qu'il y a une solution ?

Hors ligne

#4 Le 18/12/2012, à 23:04

jeanjules

Re : boot CD impossible après installation en dual-boot

Une précision : c'est un portable Samsung NP350E7C. Je ne connais pas la version du Bios. Quand j'ai installé 12.04 il a booté sur un CD après que j'aie désactivé boot secure et choisi (à la place de UEFI) : UEFI et Legacy (ou Bios et Legacy je ne sais plus très bien).

Hors ligne

#5 Le 19/12/2012, à 06:51

malbo

Re : boot CD impossible après installation en dual-boot

Dans le commentaire #23 du rapport de bug dont j'ai parlé dans le post #2, on voit qu'il existe la possibilité de faire ce qu'on appelle un "Clear Cmos", c'est à dire une action qui permet de remettre le Bios dans sa configuration originale (comme il était quand tu l'as reçu). Tu ne peux pas continuer à vivre avec un accès au Bios impossible. Donc soit tu retournes l'appareil au fabricant pour qu'il fasse la réparation, soit tu fais le "Clear Cmos" toi-même après t'être renseigné sur un forum Samsung (si ça existe) ou tu le fais faire par quelqu'un qui s'y connaît ou par un réparateur.

Edit : si on en croit le commentaire #23, il suffirait d'enlever la batterie et d'enlever la pile CMOS qui doit ressembler à ça : http://www.laptopparts101.com/wp-conten … 60x420.jpg
Tu laisses reposer comme ça (sans batterie et sans pile CMOS) toute la nuit. Au matin, tu remets la pile CMOS et la batterie et tu devrais constater que tu as retrouvé l'usage de ton Bios.

Dernière modification par malbo (Le 19/12/2012, à 07:14)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#6 Le 19/12/2012, à 10:53

jeanjules

Re : boot CD impossible après installation en dual-boot

Salut,
Merci pour tous ces renseignements. La solution qui consiste à faire un "clear Cmos" (je ne connaissais pas) est rassurante mais pour cela je vais plutôt demander à un technicien du magasin qui m'a vendu la machine. Je pense qu'après, outre l'accès au BIOS retrouvé, j'aurai à nouveau la possibilité de booter sur un CD ou une clé.
Dès que ça sera fait, je posterai le résultat dans cette discussion.

Hors ligne

#7 Le 19/12/2012, à 11:02

malbo

Re : boot CD impossible après installation en dual-boot

jeanjules a écrit :

je vais plutôt demander à un technicien du magasin qui m'a vendu la machine.

S'il accepte de faire l'opération devant toi, ce serait bien utile : quand on peut voir une fois quelqu'un faire l'opération, en général ça donne confiance pour le faire soi-même si le "drame" se reproduit.

S'agissant du "Clear Cmos", l'opération - correctement décrite à mon avis - est désignée par "effacement CMOS" dans cet extrait de Wikipedia : http://fr.wikipedia.org/wiki/Flashage_d … erclocking
Et tu peux constater qu'il est dit que majoritairement, c'est l'enlèvement de la pile qui permet de réaliser cet effacement. En pratique, il faut quand même enlever la batterie et enlever la pile (les deux) pour réaliser l'opération.

Dernière modification par malbo (Le 19/12/2012, à 11:17)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#8 Le 20/12/2012, à 11:14

jeanjules

Re : boot CD impossible après installation en dual-boot

Salut,
Bon ça marche.
Avant de demander l'aide d'un technicien, j'ai enlevé la batterie pendant quelques heures. Au démarrage suivant j'ai pu accéder au BIOS, booter sur le CD Ubuntu 12.04 et faire une installation claire (sans Windows). 
Je ne suis pas certain que le fait d"enlever la batterie ait réglé le problème puisqu'il aurait fallu aussi enlever la pile pour faire un effacement CMOS. J'ai peut-être simplement pressé plus vite F2 (aussitôt après avoir pressé le bouton d'allumage car avec une partition Windows l'affichage des choix de Grub arrive très vite après le démarrage).
Je te remercie tous les renseignements sur le BIOS et l'opération "clear CMOS" et j'espère que cela pourra être utile à d'autres lecteurs.

Hors ligne

#9 Le 20/12/2012, à 11:54

malbo

Re : boot CD impossible après installation en dual-boot

jeanjules a écrit :

Je ne suis pas certain que le fait d"enlever la batterie ait réglé le problème puisqu'il aurait fallu aussi enlever la pile pour faire un effacement CMOS.

Ton expérience est très intéressante parce qu'elle révèle qu'il n'est pas nécessaire d'enlever la pile CMOS pour retrouver l'accès au Bios. L'explication doit être que le bug de Ubuntu (qui est toujours bien vivant : voir comment #69) met la carte-mère dans un état bien merdique : le fait de démarrer une session Ubuntu, que ce soit en session live (ou que ce soit en session d'un Ubuntu installé sur le disque dur) doit mettre la carte-mère dans un état électrique particulier qui empêche d'avoir accès au Bios ultérieurement. La seule façon de retrouver l'accès au Bios est de mettre hors tension la carte-mère pour faire disparaître cet état électrique indésirable : c'est ce que tu as réalisé en enlevant la batterie.

D'autre part, tu dis avoir fait "une installation claire (sans Windows)". Jolie formule mais ce serait bien de préciser si tu as installé Ubuntu en mode EFI ou pas. Pour le savoir, depuis ta session Ubuntu, il faut juste copier la ligne suivante et la coller dans un terminal (je l'ai piqué ici) :

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

Puis valider la commande par la touche Entrée pour voir le résultat obtenu.
Chez moi (j'ai Ubuntu installé en mode Bios), ça donne logiquement " Session non-EFI" comme résultat, Peux-tu poster ce que tu obtiens ?

Dernière modification par malbo (Le 20/12/2012, à 12:17)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#10 Le 21/12/2012, à 00:39

jeanjules

Re : boot CD impossible après installation en dual-boot

J'ai la réponse :

Session non-EFI

J'ai du faire une installation BIOS mais je ne le savais pas. C'est peut-être à cause du choix "EFI et Legacy" au lieu de "EFI" dans le BIOS ?

Hors ligne

#11 Le 21/12/2012, à 07:17

malbo

Re : boot CD impossible après installation en dual-boot

Il y a une explication si le liveCD que tu as utilisé est une version Francophone de Ubuntu 12.04 : en effet, ces versions francophones merdiques ne permettent pas de faire une installation en mode EFI comme expliqué là : http://doc.ubuntu-fr.org/efi#versions_d … n_mode_efi
Il aurait fallu utiliser un support live (liveCD ou liveUSB) d'installation réalisé à partir du fichier ubuntu-12.04.1-desktop-amd64.iso téléchargeable ici : http://releases.ubuntu.com/precise/ubun … -amd64.iso

Dernière modification par malbo (Le 21/12/2012, à 07:18)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

Haut de page ↑