Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 22/12/2012, à 19:41

JNic

[RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Bonjour à tous,

Je viens de passer la journée sur ce problème. J'ai consulté ici et ailleurs de nombreux forums sans jamais trouver de réponse satisfaisante. Si toutefois, je n'ai pas assez cherché, je serais ravi d'être redirigé vers un post plus ancien!

Le problème:

J'ai installé sur le pc d'un ami (Asus Eee PC) Ubuntu 12.10 via une clé USB. L'installation s'est passée sans soucis notable (juste eu besoin de créé manuellement une partition swap et ext4). Une fois l'installation terminée, je redémarre. Et là rien. Enfin pas vraiment. Un écran noir appairait avec le message d'erreur suivant:  "Reboot and select proper boot device". Je me suis naturellement assuré que dans le menu du bios j'avais bien le HD de sélectionner au démarrage.

J'ai tout de suite pensé à un problème de GRUB. Je m'attendais à avoir à rebooter avec la clé pour voir apparaître enfin le menu du dual boot (c'est arrivé à un ami). Au lieu de cela, je ne peux uniquement lancer une version d'essai ou installer à nouveau. Je ne peux donc plus booter ni sur linux ni sur windows...

Ce que j'ai fait:

  1. J'ai tenté de modifier le grub de la version de linux fraichement installée: j'ai commenté la ligne

    GRUB_HIDDEN_TIMEOUT=0

    . Sans succès.

    J'ai également tenté boot-repair. Cette fois-ci l'erreur annoncée est la suivante

    Please create a BIOS-Boot partition

    .

Voili voilou... C'est grave docteur? Plus sérieusement, j'ai épuisé l'ensemble de mes idées et atteint (et même dépassé) mes connaissances en la matière. Est-ce que vous auriez des suggestions?

Merci d'avance!!

Ju

Dernière modification par JNic (Le 24/12/2012, à 11:48)

Hors ligne

#2 Le 22/12/2012, à 20:21

Maisondouf

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Redémarre un USB et suis ce tuto pour qu'on ait plus d'info http://doc.ubuntu-fr.org/tutoriel/boot-info


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 23/12/2012, à 15:54

JNic

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Salut!

Merci de t'intéresser à mon problème. Vu le nombre de posts dans cette section du forum, je craignais que le mien passe inaperçu!

Voici le log de boot-repair:
http://paste.ubuntu.com/1459500/

Ju

Hors ligne

#4 Le 23/12/2012, à 16:02

JNic

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Une petite précision qui peut avoir son utilité:

Depuis le live USB je peux voir un disque de monté sur lequel Ubuntu est installé. Ce qui est étonnant c'est que ce disque est beaucoup trop gros. Il couvre également les différentes partition Windows (principales et données). D'ailleurs je ne vois nul part les données Windows.

Ju

Hors ligne

#5 Le 23/12/2012, à 16:18

Maisondouf

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

La première info importante, c'est qu'il n'y a pas de boot dans le mbr du disque

=> No boot loader is installed in the MBR of /dev/sda.

Donc il ne peut pas démarrer.

La deuxième (moins réjouissante) c'est que Ubuntu a effectivement pris tout le disque et que ton Windows a disparu.

Pour tout de même avoir un PC qui démarrera, lances ces commandes à partir du LIve:

sudo mount /dev/sda2 /mnt
sudo grub-install --root-directory=/mnt /dev/sda
sudo umount /dev/sda2

Ça devrait démarrer dans ton bel Ubuntu tout neuf.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#6 Le 23/12/2012, à 16:38

JNic

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Eh ben tant pis pour windows...

Je viens de tester les commandes suggeree:

ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt /dev/sda
/usr/sbin/grub-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-bios-setup: error: will not proceed with blocklists.

Je ne suis pa sur que ce message soit tres encourageant.

Ju

Hors ligne

#7 Le 23/12/2012, à 23:44

Maisondouf

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Effectivement, alors il faut passer par gparted (toujours en Live) et mettre le drapeaux 'boot' sur /dev/sda2 en espérant que grub est dans le premier secteur de /dev/sda2.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#8 Le 24/12/2012, à 11:46

JNic

Re : [RESOLU] Problème boot - ASUS Eee PC - 12.10 / W7 (Grub)

Maisondouf,

Merci beaucoup pour ton aide. Le problème est résolu. Je n'ai finalement pas eu besoin de ton dernier conseil. Par acquis de conscience j'ai rebooté après avoir tenté l'installation du grub. Et ça a marché!

Bref, tout est bien qui finis bien.

Maintenant je me pose toujours la question: qu'est-ce que j'ai fait de travers pour que la partition Windows est sautée...  J'ai ma petite idée sur la question. Lors du choix de la partition j'avais comme choix sda et sda2 (la partition nouvellement créée en ext4). J'ai hésité un peu, et j'ai finalement opté pour le premier en me disant peut-etre à tord qu'il fallait que les deux OS cohabitent au même "niveau".. Bref, j'aurais du me documenter un peu plus! L'ignorance n'est pas une excuse.

Merci encore,

et joyeux Noël!

Ju

Dernière modification par JNic (Le 24/12/2012, à 11:49)

Hors ligne

Haut de page ↑