Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/12/2012, à 23:36

flolm

Openvpn sur Kimsufi

Bonsoir à tous,

J'ai depuis peu un serveur dédié Kimsufi (mKS 2G), le premier de la gamme des Kimsufi.

Je voudrais que mon serveur passe par un serveur vpn. Je me suis donc orienté vers activpn qui est très bon dans ce domaine modération: merci d'éviter ce genre d'information qui pourrait s'apparenter à du spam

J'ai reçu mes informations de connexion par email.
Jusque là tout va bien...
Je me connecte à mon serveur dédié en SSH, j'installe openvpn (aptitude install openvpn)

Je copie dans /etc/openvpn mon ca.crt que j'ai reçu par email de la part de actiVPN et mon autre fichier nommé "netherland.ovpn". (J'ai choisi le serveur VPN au Pays-Bas).

A la suite de ça (je pense que je n'ai plus grand chose à faire à part établir la connexion <-- dites-moi si je me trompe)

Sur mon serveur je me rends dans le dossier openvpn : cd /etc/openvpn
et je lance la connexion : openvpn netherland.ovpn

A ce moment là, on me demande de m'identifier. Je renseigne donc mes identifiants reçu par email de la part d'actiVPN.

Ensuite je pense que la connexion se fait, je perd la main en SSH et impossible de me reconnecter, dû surement à ma nouvelle adresse IP.

Je vous ai fais une capture d'écran pour voir ce qu'il se passe au moment ou je rentre mes informations de connexion.
Voir ici

Je ne connais pas ma nouvelle IP et donc à chaque fois je dois réinstaller completement mon serveur.

Je me suis peut-être trompé dans les étapes à la connexion sur un serveur VPN...je ne sais plus quoi faire...aidez-moi SVP


Je vous remercie par avance.

Cordialement.

Flolm

Dernière modification par ljere (Le 27/12/2012, à 09:51)

Hors ligne

#2 Le 27/12/2012, à 04:23

Maisondouf

Re : Openvpn sur Kimsufi

Je ne comprends pas pourquoi tu as pris un abonnement à un VPN externe pour connecter ton serveur.
Tu peux pas le connecter directement depuis ton PC ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 27/12/2012, à 08:06

tiramiseb

Re : Openvpn sur Kimsufi

C'est normal que tu te fasses "jeter" : tu changes la configuration réseau de ton serveur et du coup il passe par le VPN pour communiquer avec "le reste du monde". C'est le fonctionnement normal du VPN. Si tu veux que ton serveur utilise son interface réseau classique avec son adresse IP publique chez OVH, il ne faut pas le configurer en client VPN...

Et quand tu perds la connexion de cette manière, pas besoin de réinstaller !!! Au pire il devait suffire de redémarrer.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

Haut de page ↑