Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#26 Le 28/12/2012, à 00:15

tiramiseb

Re : Contrôle parental avec squid et squidguard

Et dans les logs de Squid ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#27 Le 28/12/2012, à 00:30

lorrinux

Re : Contrôle parental avec squid et squidguard

Rien dans les logs. Je veux dire que quand je rajoute des lignes avec proxy_auth ... required, il n'y a plus de mises à jour des logs lors des tentatives de connexion, comme si squid n'était pas sollicité.

Hors ligne

#28 Le 28/12/2012, à 00:40

tiramiseb

Re : Contrôle parental avec squid et squidguard

Étrange. Là je vais dormir, j'y réfléchirai demain.

Si quelqu'un d'autre qui passe par là a une idée, qu'il ne se gêne pas !


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#29 Le 28/12/2012, à 00:44

lorrinux

Re : Contrôle parental avec squid et squidguard

Pareil, bonne nuit !

Hors ligne

#30 Le 28/12/2012, à 10:10

tiramiseb

Re : Contrôle parental avec squid et squidguard

Quand tu mets "autre chose que http_access allow all", es-tu sûr que ta syntaxe est correcte ? Squid démarre-t-il bien ? Si Squid est arrêté pour cause d'erreur de syntaxe dans la configuration, c'est normal qu'il ne réponde pas et qu'il n'écrive rien dans les logs...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#31 Le 28/12/2012, à 10:41

lorrinux

Re : Contrôle parental avec squid et squidguard

Bon alors, j'ai redécomposé comme au début en débranchant SquidGuard. Il n'y a donc que Squid qui fonctionne pour l'instant.
A l'origine, dans le fichier de config, j'ai

http_access allow all

et la navigation fonctionne bien.
Si je remplace pour voir par

http_access deny all

le navigateur affiche une page bien explicite "vous n'êtes pas autorisés bla bla bla ..." et les logs montrent bien les tentatives de connexion aux sites avec NONE après les URL (au lieu de DIRECT quand la navigation est autorisée).
Si je mets une des deux lignes suivantes ou les deux ensemble

acl parent proxy_auth REQUIRED
http_access allow parent

j'ai le message d'erreur (approximatif) "FF est configuré pour utiliser un proxy mais celui-ci refuse les connexions" et plus rien n'est écrit dans les logs.

Hors ligne

#32 Le 28/12/2012, à 10:47

tiramiseb

Re : Contrôle parental avec squid et squidguard

Et Squid est-il bien démarré ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#33 Le 28/12/2012, à 10:54

tiramiseb

Re : Contrôle parental avec squid et squidguard

As-tu défini auth_param ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#34 Le 28/12/2012, à 22:45

lorrinux

Re : Contrôle parental avec squid et squidguard

Je n'ai pas pu répondre car j'étais absent toute la journée.
Je suis entrain de faire des manips en tenant compte de tes remarques. Je crois que tu m'as mis sur la bonne voie, je fais un retour dès que j'ai qqch de concret.

Hors ligne

#35 Le 30/12/2012, à 19:40

lorrinux

Re : Contrôle parental avec squid et squidguard

Bon, je patine.
Je mets

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/passwd

acl parent proxy_auth REQUIRED

ce qui permet de naviguer.
Par contre, dès que je branche squidguard, la connexion échoue. Je ne sais pas comment le configurer correctement.

Hors ligne

#36 Le 31/12/2012, à 10:31

tiramiseb

Re : Contrôle parental avec squid et squidguard

Sans plus de détails on ne peut pas t'aider.
- configuration de SquidGuard
- manipulation(s) effectuée(s)
- logs de Squid
- toute autre information intéressante...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#37 Le 31/12/2012, à 14:38

lorrinux

Re : Contrôle parental avec squid et squidguard

Désolé, j'étais fatigué.

Il y a deux comptes installés sur la machine : parent et enfant.

Je commence par Squid tout seul et je m'occupe uniquement de parent pour le moment.

Ceci fonctionne :

http_access allow all

Ceci ne fonctionne pas :

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/passwd
acl parent proxy_auth REQUIRED
http_access allow parent

et affiche la boite d'authentification "le proxy demande un nom d'utilisateur et un mot de passe". Je renseigne les champs, je me fais jeter. Je finis par annuler et j'obtiens la page "ERROR, cache accès interdit".
Rien dans access.log mais ceci dans cache.log :

2012/12/31 10:54:56| Starting Squid Cache version 3.1.19 for i686-pc-linux-gnu...
2012/12/31 10:54:56| Process ID 3275
2012/12/31 10:54:56| With 65535 file descriptors available
2012/12/31 10:54:56| Initializing IP Cache...
2012/12/31 10:54:56| DNS Socket created at [::], FD 5
2012/12/31 10:54:56| DNS Socket created at 0.0.0.0, FD 6
2012/12/31 10:54:56| Adding nameserver 127.0.0.1 from /etc/resolv.conf
2012/12/31 10:54:56| helperOpenServers: Starting 5/5 'ncsa_auth' processes
2012/12/31 10:54:56| Unlinkd pipe opened on FD 21
2012/12/31 10:54:56| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2012/12/31 10:54:56| Store logging disabled
2012/12/31 10:54:56| Swap maxSize 0 + 262144 KB, estimated 20164 objects
2012/12/31 10:54:56| Target number of buckets: 1008
2012/12/31 10:54:56| Using 8192 Store buckets
2012/12/31 10:54:56| Max Mem  size: 262144 KB
2012/12/31 10:54:56| Max Swap size: 0 KB
2012/12/31 10:54:56| Using Least Load store dir selection
2012/12/31 10:54:56| Current Directory is /
2012/12/31 10:54:56| Loaded Icons.
2012/12/31 10:54:56| Accepting  intercepted HTTP connections at 0.0.0.0:3128, FD 22.
2012/12/31 10:54:56| HTCP Disabled.
2012/12/31 10:54:56| Squid plugin modules loaded: 0
2012/12/31 10:54:56| Adaptation support is off.
2012/12/31 10:54:56| Ready to serve requests.
2012/12/31 10:54:57| storeLateRelease: released 0 objects
2012/12/31 10:55:38| IpIntercept.cc(137) NetfilterInterception:  NF getsockopt(SO_ORIGINAL_DST) failed on FD 8: (92) Protocol not available

J'essaie donc ceci (qui fonctionne avec Squid seul)

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/passwd
acl parent proxy_auth REQUIRED
http_access allow all

et je branche SquidGuard :

Toutes les configurations suivantes de SquidGuard font que le navigateur mouline indéfiniment
1.

acl {
	default {
		pass	 all
		redirect http://admin.foo.bar.de/cgi-bin/blocked.cgi?clientaddr=%a&clientname=%n&clientuser=%i&clientgroup=%s&targetgroup=%t&url=%u
	}
}

2.

acl {
	parent {
		pass all
	}	
	default {
		pass	 all
		redirect http://admin.foo.bar.de/cgi-bin/blocked.cgi?clientaddr=%a&clientname=%n&clientuser=%i&clientgroup=%s&targetgroup=%t&url=%u
	}
}

3.

src parent {
	user parent
}
acl {
	parent {
		pass all
	}	
	default {
		pass	 all
		redirect http://admin.foo.bar.de/cgi-bin/blocked.cgi?clientaddr=%a&clientname=%n&clientuser=%i&clientgroup=%s&targetgroup=%t&url=%u
	}
}

4.

src admin {
	user parent
}
acl {
	admin {
		pass all
	}	
	default {
		pass	 all
		redirect http://admin.foo.bar.de/cgi-bin/blocked.cgi?clientaddr=%a&clientname=%n&clientuser=%i&clientgroup=%s&targetgroup=%t&url=%u
	}
}

Hors ligne

#38 Le 01/01/2013, à 21:47

tiramiseb

Re : Contrôle parental avec squid et squidguard

Il faudrait que je me replonge dans la doc et que j'installe Squid et SquidGuard pour faire des tests et comprendre, mais je n'ai pas le temps de faire ça, désolé...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#39 Le 02/01/2013, à 11:55

lorrinux

Re : Contrôle parental avec squid et squidguard

Merci quand-même pour ton aide.

Hors ligne

#40 Le 02/01/2013, à 12:03

tiramiseb

Re : Contrôle parental avec squid et squidguard

Je suis sûr que tu n'es pas loin du but.
Peut-être un problème de syntaxe dans la configuration.

Bon courage !


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

Haut de page ↑