Contenu | Rechercher | Menus

Annonce

Les adresses laposte.net ne permettent pas de recevoir nos emails. Vous êtes invité à changer d'adresse dans vos paramètres de compte à votre prochaine connexion.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 28/12/2012, à 23:46

wario4

GRUB Windows : no such device

Bonjour à tous !

Je viens de découvrir l'expérience Linux, c'est vraiment super ! Par contre j'ai fait plein de manip qui m'ont mené à réinstaller Linux et là je me trouve avec un problème que je ne comprends pas.

Pour résumer :
1/ J'ai 2 DD du coup j'ai laissé Windows sur le premier DD (qui llboot par défaut) et Ubuntu sur le deuxième. Ca me permettait de démarrer Windows par défaut et de démarrer Ubuntu quand je le voulais en allant dans le BIOS. Du coup, pas de bootloader par défaut, juste quand je lance Ubuntu sur mon DD2.

2/ J'essaye d'installer GNOME Shell, et je rencontre quelques problèmes (comme la logithèque qui crash à chaque ouverture), et je finis par faire une énorme connerie :

sudo apt-get remove gnome*

Oui, bon... du coup Ubuntu ne fait plus rien vu que tout se supprime, je me trouve obligé de réinstaller Ubuntu. Je relance donc mon CD Ubuntu 12.10, choisis l'option "Réinstaller Ubuntu (sans le supprimer)" et lance l'install.

3/ Une fois ceci fait, je redémarre, et là, bizarrement, le bootloader d'Ubuntu se lance (sur mon DD1 qui boote par défaut, alors qu'il n'y a normalement aucune trace de Linux...)

4/ Me retrouvant avec un Ubuntu en mauvaise forme (incapable de repérer la résolution de mon écran etc), je formate complètement ma partition Linux et réinstalle totalement Ubuntu.

5/ Maintenant, nickel pour Ubuntu, seulement quand je démarre l'ordi normalement, j'ai l'impression que GRUB se lance, mais ne détecte rien. Du coup j'ai droit à un écran de ce type :
grub
Et là je ne peux plus rien faire.
Du coup pour démarrer Windows, je dois booter sur mon DD2, et lancer le loader Windows depuis le bootloader d'Ubuntu...

Une idée pour régler ce problème ?

Merci !

Hors ligne

#2 Le 29/12/2012, à 06:54

malbo

Re : GRUB Windows : no such device

Il faut réinstaller le chargeur d'amorçage de Windows dans le MBR du disque Windows (alors qu'actuellement c'est le chargeur d'amorçage de Grub qui se trouve là). La doc suivante peut t'aider : http://doc.ubuntu-fr.org/comment_recupe … ion_ubuntu
Pour Windows 7, parmi les instructions suivantes :

     Sélectionnez votre langue, ouvrez l'invite de commande et lancez les commandes suivantes1) :

chkdsk C: /f
bootrec /FixBoot
Bcdboot C:\windows
bootrec /RebuildBcd

Alternative:

c:
bootsect /nt60

S'il s'agit de rétablir un boot windows sans passer par le menu grub lancez aussi la commande suivante (vous n'aurez alors plus accès à Ubuntu) :

bootrec /FixMbr

Tu n'appliques pas les commandes du début (inutile dans ton cas), tu ne fais que la dernière commande (c'est elle qui fait la réparation qui te concerne) :

 bootrec /FixMbr

Si cette réparation "ciblée" (puisqu'on sait où est le problème) ne fonctionne pas, fais la réparation automatique par ton CD de réparation Windows 7. Au lieu de sélectionner l'invite de commande comme dans la réparation ciblée, il faut alors sélectionner "Réparation du démarrage"

Dernière modification par malbo (Le 29/12/2012, à 07:06)

En ligne

#3 Le 29/12/2012, à 13:35

wario4

Re : GRUB Windows : no such device

Ca a fonctionné, merci beaucoup !

Hors ligne