Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 08/01/2013, à 12:55

pingster

Problème avec mon Touchpad seulement sous ma session

Bonjour !

Mon Touchpad ne marche pas, mais seulement sous ma session...Peut-être que avant que je crée un nouvel utilisateur, vous pourriez m'aider...

- Mon ordinateur est un Acer Aspire 5738 DG
-Il tourne sous Precise (12.04) 32 bit Kernel Linux 3.2.0-35-generic-pae

J'ai une touche pour activer/désactiver le touchpad, elle réagit bien, et j'ai même un symbole en haut à droite qui me montre que mon touchpad est activé/désactivé, mais ça ne change rien au problème, mon touchpad ne réagit toujours pas.

Des idées ?

Merci d'avance

Hors ligne

#2 Le 08/01/2013, à 17:08

stevens4c

Re : Problème avec mon Touchpad seulement sous ma session

etrange.
que te renvois la commande suivante

xinput list

Hors ligne

#3 Le 08/01/2013, à 17:47

webfil

Re : Problème avec mon Touchpad seulement sous ma session

Bonjour,

Ma session souffre du même problème. Étrangement l'utilisateur invité peut profiter des merveilles du touchpad, mais pas mézigue.

J'ai bien essayé tout ce qui se trouve sur cette page et sur divers forum, mais rien n'y fait. Pourtant, xinput renvoie bel et bien un touchpad.

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ DualPoint Stick                         	id=12	[slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                       	id=9	[slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint TouchPad        	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Video Bus                               	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=10	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=13	[slave  keyboard (3)]

Mon xorg.conf contient ceci seulement :

Section "InputClass"
        Identifier "enable synaptics SHMConfig"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
EndSection

Touchpad-indicator ne réussit pas à maîtriser l'activation et la désactivation du touchpad (il reste coi, le gros X sur son symbole dans la barre des tâches, peu importe si je lui demande l'activation ou la désactivation).

Synclient -m me rend ceci, peu importe l'intervalle donnée.

    time     x    y   z f  w  l r u d m     multi  gl gm gr gdx gdy
   0.000   946  956 117 1  0  0 0 0 0 0  00000000

Mon matos :
Dell Inspiron 1545
Ubuntu 12.04.1 LTS 32 bits
Noyau 3.2.0-35-generic-pae
J'ai une souris USB générique que j'ai payé 3$ pour palier temporairement au problème, mais elle arrive en fin de vie utile.

Dernière modification par webfil (Le 08/01/2013, à 17:50)

Hors ligne

#4 Le 08/01/2013, à 19:52

stevens4c

Re : Problème avec mon Touchpad seulement sous ma session

et synclient te renvoi quoi

Hors ligne

#5 Le 08/01/2013, à 20:25

pingster

Re : Problème avec mon Touchpad seulement sous ma session

Le mien me répond ça :

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ 2.4G Wireless Optical Mouse             	id=9	[slave  pointer  (2)]
⎜   ↳ PS/2 Mouse                              	id=12	[slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ Video WebCam                            	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]

Pareil pour la session invité ça marche bien...

Dernière modification par pingster (Le 08/01/2013, à 20:27)

Hors ligne

#6 Le 09/01/2013, à 05:27

webfil

Re : Problème avec mon Touchpad seulement sous ma session

Synclient renvoie ceci :

Parameter settings:
    LeftEdge                = 299
    RightEdge               = 1701
    TopEdge                 = 209
    BottomEdge              = 1191
    FingerLow               = 12
    FingerHigh              = 15
    FingerPress             = 128
    MaxTapTime              = 180
    MaxTapMove              = 107
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 141
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 48
    HorizScrollDelta        = 48
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0819336
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 15
    EdgeMotionMaxZ          = 80
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 195
    EdgeMotionUseAlways     = 0
    TouchpadOff             = 2
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 100
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 15
    PressureMotionMaxZ      = 80
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 12
    VertHysteresis          = 12

Hors ligne

#7 Le 09/01/2013, à 19:41

stevens4c

Re : Problème avec mon Touchpad seulement sous ma session

as tu essayé de mettre la valeur de touchpadoff à 0

Hors ligne

#8 Le 09/01/2013, à 23:45

webfil

Re : Problème avec mon Touchpad seulement sous ma session

Oui, ça n'a pas fonctionné avec touchpadoff.

J'ai essayé les commandes suivantes avec modprobe

modprobe -r psmouse
modprobe psmouse proto=imps

Problème résolu ; je l'ai enregistré dans /etc/rc.local

Hors ligne

Haut de page ↑