Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 13/01/2013, à 21:04

joejoe

[RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Hello everybody !

J'ai un souci avec la luminosité de mon écran. En fait, je peux la modifier "virtuellement", c'est-à-dire qu'à partir des raccourcis ou des réglages je peux faire changer la barre de luminosité, mais ça n'a aucun effet réel sur l'écran !!

Je tourne sous Precise Pangolin avec le bureau Unity (pas certain xd)

joe@joe:~$ lsb_release -idc
Distributor ID:	Ubuntu
Description:	Ubuntu 12.04.1 LTS
Codename:	precise

Modèle du pc :

Packard Bell SJV70_HR Base Board Version
Serial number (motherboard) : Base Board Serial Number
SKU Number :
Bios version : V1.11
Date : 5/24/2011

J'ai remarqué que c'est un problème récurrent mais je ne trouve pas de solution.

Quelqu'un peut-il m'aider ?


Solution :

Modifier les deux dernières lignes de son fichier Grub en :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

Et ajouter la ligne suivante dans votre fichier xorg.conf, dans la section Device :

sudo gedit /etc/X11/xorg.conf
Option "RegistryDwords" "EnableBrightnessControl=1"

Dernière modification par joejoe (Le 26/01/2013, à 23:30)

Hors ligne

#2 Le 13/01/2013, à 21:21

michel_04

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Bonjour,

Quel portable ?

A+

Hors ligne

#3 Le 13/01/2013, à 21:47

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Un packard bell mais je ne connais pas le modèle. Dessous c'est inscrit P7YS0.

Y a-t-il un moyen de connaître le modèle ?

Hors ligne

#4 Le 14/01/2013, à 17:04

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Le voici !

Packard Bell SJV70_HR Base Board Version
Serial number (motherboard) : Base Board Serial Number
SKU Number :
Bios version : V1.11
Date : 5/24/2011

Hors ligne

#5 Le 17/01/2013, à 01:01

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

petit up ! smile

Hors ligne

#6 Le 21/01/2013, à 19:51

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Personne n'a la même config ? xd

Hors ligne

#7 Le 21/01/2013, à 20:07

ginette

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

c'est un modèle avec 2 cartes graphiques ?
si oui c'est quoi ?

#8 Le 22/01/2013, à 01:20

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Ce n'est pas sans mal que j'ai pu trouvé, même hardinfo ne me donne pas mes cartes graphiques !! Et effectivement MES cartes graphiques, car j'en ai deux (je ne savais même pas que ça se faisait) :

joe@joe:~$ sudo lspci -vnn | egrep "VGA|3D|Display"
[sudo] password for joe: 
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] [1002:6741] (prog-if 00 [VGA controller])

Et ceci :

joe@joe:~$ grep /drivers/ /var/log/Xorg.0.log
[    27.261] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    27.262] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    27.262] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    27.264] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

Est-ce suffisant ou y a-t-il autre chose que je puisse faire ?

Dernière modification par joejoe (Le 22/01/2013, à 01:22)

Hors ligne

#9 Le 22/01/2013, à 10:57

michel_04

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Bonjour,

joejoe a écrit :

Ce n'est pas sans mal que j'ai pu trouvé, même hardinfo ne me donne pas mes cartes graphiques !! Et effectivement MES cartes graphiques, car j'en ai deux (je ne savais même pas que ça se faisait) :

joe@joe:~$ sudo lspci -vnn | egrep "VGA|3D|Display"
[sudo] password for joe: 
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] [1002:6741] (prog-if 00 [VGA controller])

Voir ce post [SOLUTION] AMD/Intel Graphiques Commutables

A+

Hors ligne

#10 Le 22/01/2013, à 16:31

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Merci, je crois avoir réussi la mise à jour des drivers (en suivant la procédure indiquée sur wikipédia : http://wiki.cchtml.com/index.php/Ubuntu … 7s_site.29

(j'avais suivi celle du topic en premier mais je ne pouvais plus accéder au mode graphique xd, j'ai donc fait un back-up et fais comme indiqué sur le wiki)

Ensuite j'ai suivi la procédure indiquée dans le topic mais je ne peux toujours pas régler la luminosité :s

D'autres propositions ?

Hors ligne

#11 Le 22/01/2013, à 23:39

FoXv89

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

La plupart des gens utilise Xbacklight mais chez moi ça n'a pas marché (au cas ou)

sudo apt-get install xbacklight


xbacklight =50    #règle la luminosité à 50 %.
xbacklight +10    #augmente la luminosité de 10 %.
xbacklight -10    #diminue la luminosité de 10 %.

Ou sinon en "trichant" essayes

xrandr --output LVDS --brightness 0.80

Ça change le constraste et c'est déjà ça


J'espére avoir pu t'aider du haut de ma toute petite expérience sous Linux

Dernière modification par FoXv89 (Le 23/01/2013, à 01:05)

Hors ligne

#12 Le 23/01/2013, à 00:59

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Et non, j'avais déjà essayé tout ça. Je viens de réessayer mais ça ne fonctionne toujours pas...

Hors ligne

#13 Le 23/01/2013, à 01:06

FoXv89

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Yapluka coller une feuille de papier calque sur l'écran lol

Hors ligne

#14 Le 23/01/2013, à 10:23

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Pas si bête ^^

Mais il existe peut être autre chose xd

Hors ligne

#15 Le 23/01/2013, à 12:07

alca94

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

En ligne

#16 Le 23/01/2013, à 19:35

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Bonjour,

Merci pour ces liens, apparement il y en a un susceptible de fonctionner. Il faudrait que je modifie mon fichier xorg.conf, mais je ne sais pas lequel.

xorg.conf    original         back-up           ou           failsafe     ?

La ligne a ajouté dedans est la suivante :

Option "RegistryDwords" "EnableBrightnessControl=1"

Dois-je la copier telle quelle ? ou faut-il que je retire les guillemets ? (ce n'est pas préciser)

Ensuite il faut modifier le grub :

GRUB_CMDLINE_LINUX=""
en
GRUB_CMDLINE_LINUX="acpi_osi=Linux"


Je vais tester cette option dés que j'aurai confirmation, je garde espoir car les utilisateurs l'ayant testé ont réglé leur problème, avec des configs différentes apparemment.

Merci encore !

Hors ligne

#17 Le 25/01/2013, à 14:03

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Aller, un petit up, ce post s'approche de sa résolution ! ^^

Hors ligne

#18 Le 25/01/2013, à 15:02

PlapPlop

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

La modification de xorg.conf n'a pas marché ?

Hors ligne

#19 Le 25/01/2013, à 15:18

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

J'ai 3 fichiers xorg.conf ! Justement avant de tester j'aimerai savoir lequel modifié, voir post #16   smile

Hors ligne

#20 Le 25/01/2013, à 15:27

PlapPlop

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Fais-le dans le fichier xorg.conf original. Et il faut laisser la ligne telle quelle.

Dernière modification par PlapPlop (Le 25/01/2013, à 15:28)

Hors ligne

#21 Le 25/01/2013, à 15:28

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Dac, merci pour ta réponse super rapide car je venais de tester dans la back up et ça n'a pas marché xd

Je teste ça vite fait et je reviens.

Dans ce xorg il n'y avait qu'un commentaire :  # NOXORGCONFEXISTED: No X.org configuration file existed when this backup was created.

J'ai ajouté la ligne, je redémarre pour voir.

Dernière modification par joejoe (Le 25/01/2013, à 15:31)

Hors ligne

#22 Le 25/01/2013, à 15:34

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Et non, cette solution n'a pas fonctionné... sad

Je suis bon pour la feuille de calque je crois xd

Hors ligne

#23 Le 25/01/2013, à 15:37

PlapPlop

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Supprime xorg.conf. Dans ton fichier xorg.conf.backup, tu devrais avoir une section Device section. Colle la ligne en question dans cette section, renomme xorg.conf.backup en xorg.conf et redémarre.

Hors ligne

#24 Le 25/01/2013, à 16:05

joejoe

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Oh my god écran noir au démarrage ! Plus rien ! Que faire !? Les boules !!! Xd

Hors ligne

#25 Le 25/01/2013, à 16:13

PlapPlop

Re : [RESOLU] Attention les yeux ! Réglage de la luminosité impossible

Sérieusement ? Mince... Désolé. Bon il faut que tu renommes ce xorg.conf en xorg.conf.backup histoire de récupérer un écran déjà. En recovery mode du coup...

Et une fois que ce sera fait, poste le contenu de xorg.conf.backup ici.

Encore désolé pour cette manip.

Dernière modification par PlapPlop (Le 25/01/2013, à 16:14)

Hors ligne

Haut de page ↑